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1. LusoCAD 2025 Introduction and Installation

1.1. LusoCAD 2025 Introduction

LusoCAD 2025 elevates performance to a new level with Hardware Acceleration and other improvements on a series of features,
significantly enhances the design experience. Exciting new features, including Parametric Constraints, BIM Data Editing, and
Voice Annotation, etc., further enrich functionality. What’s more, compatibility has been expanded with the addition of Python
support, empowering more robust customization and automation. Without further ado, let's explore these exciting updates!

1.2. System Requirement

Before installing LusoCAD, please confirm whether the specifications of your PC meet the following requirements:

®  (0S (Operating System)

Windows 11

Windows 10 version 1507 or higher: Home, Professional, Education, and Enterprise (LTSC and Windows 10 S are not
supported)

Windows 8.1 (with Update 2919355): Core, Professional, and Enterprise

Windows 7 SP1 (with latest Windows Updates): Home Premium, Professional, Enterprise, Ultimate

Windows Server 2016: Standard and Datacenter

Windows Server 2019: Standard and Datacenter

Windows Server 2022: Essentials, Standard, Datacenter

Note: Because LusoCAD and related tools are developed and compiled with visual studio 2017, in order to ensure the normal
operation of the software, the operating system needs to be able to install the environment package of visual studio 2017 normally.

e (PU
1.6 GHz processor (2 GHz or faster Multi-core processor recommended)

® RAM
2GB (8GB recommended or higher)

®  (Graphics Card
1 GB GPU (2 GB GPU recommended or higher)

®  Hard Disk
The system and installation disk need more than 1 GB of space. (10 GB recommended or higher)
To improve performance, it is recommended that the software be installed and stored on a solid-state drive (SSD).

®  Display Resolution
1024800 or above; LusoCAD will work best at a resolution of HD and 4K resolution.
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©®  Additional Requirement

Administrator rights are required to install LusoCAD and license tools.

NET Framework 4.8 or above (Only for custom software development).

The network license server and all workstations running applications that rely on network licenses must support the TCP/IP
protocol.

1.3. LusoCAD 2025 Installation

Users can visit www.luso-cad.com to download LusoCAD 2025 to your computer or server.

LusoCAD 2025 Install Wizard will guide the user to install the software in the operating system completely and successfully.

Please follow the steps below to install LusoCAD 2025:

1. Double-click the executable file downloaded and the LusoCAD Install Wizard dialog box will pop up.

LusoCAD 2025

C:\Program Files\IGENMAT\LusoCAD2025

. Agree to LusoCAD software



http://www.luso-cad.com/
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2.

3.

Click Browse | button and choose the destination path where setup will install the files.

LusoCAD 2025

. Agree to LusoCAD software

Click LusoCAD Install Wizard > Options, users can select or deselect the VBA feature according to your need. You can also
read the System Requirements and Activation Mode of LusoCAD.

LusoCAD 2025

’ ,
System Requirementa mwe

C:\Program Files\IGENMAI\LusoCAD2025

B Agree to LusoCAD software
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4. Read the License Agreement and Privacy Policy, and check Agree to LusoCAD License Agreement and Privacy Policy.

LusoCAD 2025

ystem Requirements & Agk

C:\Program Files\IGENMAI\LusoCAD2025

[l Agree to LusoCAD software

5. Click Install button to continue the installation.

LusoCAD 2025

System Requirements " Ak

C:\Program Files\IGENMAI\LusoCAD2025

. Agree to LusoCAD software
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6. You just need to wait for a few minutes for the Overall Progress.

Full Compatibility

Native DWG support, fully compatible in command, menu, APl and operating habits.

Installing LusoCAD and Help...

7. Then you will see the workspace selection window. Select your favorite workspace and click the Next button.

Please select your favourite workspace

2D Drafting LusoCAD Classic

Next
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8. Click Finish button to exit the wizard. The LusoCAD wizard has successiully installed LusoCAD 2025.

LusoCAD 2025
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2. Starting up LusoCAD 2025

2.1. The User Interface

You can enjoy working at LusoCAD 2025 in different ways. You can display and rearrange elements like the toolbars, display the
command bar, switch between workspaces, change the interface themes and enable the status bar. The toolbars and command
bar can also be floated anywhere on the screen or docked as well.

@ R=nb
File  Edit
i

Home

Line ~ Polyline

Draw ©

Drawing1* X+

21.1.  Quick Access Toolbar

Display the frequently used tools like: New, Open, Save, Undo, Redo, Save As, Plot, Plot Preview and Help. Moreover, you can
customize it (adding more commands from the drop-down button) or show it bellow/above the ribbon.

Customize Quick Access Toolbar
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2.1.2.  Workspace

2.1.21.  Workspace Switching

Switch between workspaces (2D Drafting and LusoCAD Classic). What' more, LusoCAD 2025 provides many color themes,
such as LusoCAD, Lightblue, Blue, Black, Sliver and Aqua, you can choose your favorite color theme directly.

= BB B & & - 4 <20 0mafting

Home Insert Annotation 2D

Drawing1 +

2.1.22. Workspace Command

The WORKSPACE command allows you to create, modify and save workspaces current. You can customize LusoCAD ribbon or
classic workspace to suit interface environment needs much easier.

Workspaces are sets of menus, toolbars, palettes, and ribbon control panels that are grouped and organized so that you can
work in a custom, task-oriented drawing environment. When you use a workspace, only the menus, toolbars, and palettes that
are relevant to a task are displayed. In addition, a workspace may automatically display the ribbon, a special palette with task-
specific control panels. You can easily switch between workspaces. The following task-based workspaces are already defined in
LusoCAD: 2D Drafting and LusoCAD Classic.

LusoCAD 2025 Plus - [Drawing1*]
Draw

Mesh
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If you execute WORKSPACE command, the following prompts are displayed:

Set Current; Sets a current workspace.
Save As: Saves a current interface configuration as a workspace.

Edit: Opens the Customize User Interface dialog box, Customize tab, where you can make modifications to a workspace.

(@ Customize User Interface o x
¢4 Elements Cu @y Workspace G 1 == Transfer
Customization List: A Properties _
Al Customizstion Fils &8 B
\3@ GCAD E General
= Quick Access Toolbars Name
3 Ribbon Display Mame:
B Toolbars Filename
T Menus
Shortcut Menus
-[[E] Quick Properties
- Keyboard Shortcuts
{1 Double Click Actions
{9 Mouse Buttons
egecy
artial Customization Files
Command List: A
Ao S ——
Command Source @
0 EXPRESS
3 Point GCAD
1428 30 Adjust Clip Planes GEAD
3D Adjust Distance GCAD
9 30 Alian GEAD
1% 3D Anay GCAD
| 3D Constrained Orbit GCAD
3D Continuous Orbit GCAD
3D Fly GCAD
- 3D Free Orbit GCAD
8 30 Miror GCAD Command
1. 3D Move GLAD
13D Orbit GLAD
< 30 Osnap Settings., GCAD
.30 Pan GCAD v
Apely Cancel ¢
@ Workspace Settings X
Workspace
My Workspace = 2D Drafting v
Menu Display and Order
Rename: Renames a workspace. Move U
LusoCAD Classic
Delete: Deletes a workspace. Move Down
Settings: Opens the Workspace Settings dialog box, which controls the display, menu
order, and Save settings of a workspace.
When Switching Workspaces

21.3.  Menu Bar

(® Do not save changes to workspace
(O Automatically save workspace changes

Cancel

The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it you can find the
follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Text, Dimension, Modify, Window, Application, Help, Express

and Collaboration.
FEERE

Edit

= 20 Drafting - =

File View |nsert Format Tools Draw  Text

Home Insert Annotation 3D Surface Mesh

m O as v

Dimension

Layout

ﬂ === Table

Text

Modify
View Manage

/- Leader ~
¥ Linear ~

Annotation ~

Window

-
N

Layer
Properties

Application Help Express Collabora

Export EIM Application
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21.31. Menus and Shortcut Menus

You can use any of the option on the Menus from the menu bar at the top of the Fle ‘ii SRR LS R L G DEE
In !

drawing area. Choose one of the follong methods to use a menu:

- On the menu bar, click a menu name to choose the menu or to expand a list of
options.

- Press Alt and the key for the underlined letter in the menu name to open the
corresponding menu item list and then choose menu items from it. For example,
to edit the drawing file, press <Alt-+E> to open the Edit menu.

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you right click an object, status
bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut menu depend on what you clicked.

21.3.2. Shortcuts Customize

A faster way to invoke a command is customize its shortcut. The @ shortcuts Customize X
CUSTACC command allows you to customize, delete or modify Name Button Source A =
existing command shortcuts. To access this command, go through Seapsae SRCT GCAD "
Command Line CTRL+9 GCAD Modify
the menu bar, under tools, select customize and choose Shortcuts Copy Clip CTRL4C GCAD
) ] ] ] Copy with Base P... SHIFT+CT... GCAD Delete
Customize. After that, the shortcut customize window will pop up. CTRL++ CTRL+H GCAD
X . CTRL+R CTRL+R GCAD
As you can see, there is a list of shortcuts command that you can cut CTRL#X GCAD
. . L. I DesignCenter CTRL+2 GCAD
gasily modify, delete or even make a new one over an existing one. ®exit CTRL4O GoAD
.- Hyperlink. .. CTRLH GCAD
(P Customize Command X Magnifier CTRL+E GCAD
Mew... CTRL-HM GCAD
Command Command properties
Search Command list: E Command ~ Open... CTRL+O GCAD
Tags l Paste CTRL+V GCAD
All commands only | Mew Macro SM=S{f S{and S(>5( [ Paste as Block SHIFT+CT...  GCAD
Command Name ! Command Line Plot... CTRL+P GCAD
romes Rt oo
E Advanced QuickCalc CTRL+5 GCAD v
HIDE COMMARND LINE Hement 1D ID_CmdLine - —— s -
UNDEFINE COMMAND = [ o .
Largz image RCDATA_32_COM Cancel
Small image RCDATA_16_COM "
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If you want to create a new one, just click the New button and the customize command
window will pop up. Then you can search the command or select one from the
command list. For example, you can input “command line” and then select the
requested command. Notice that it will display the command properties by selecting the
requested command at the right side of the window. After selecting the command, press
OK.

Then the set shortcut window will pop up. You can input the desired keyword(s). For
example, you can set the shortcuts SHIFT+D. If you want to delete a created shortcut
command, invoke the command CUSTACC and then select the delete button from the
Shortcut Customize window.

@ Shortcuts Customize

MName

Clean Screen

mmand Line
Copy Clip
Copy with Base P...
CTRL+H

CTRL+R
Cut

I DesignCenter

) Ext

. Hyperlink...
Magnifier
New...
Open...

I Paste

[ Paste as Block
Plot...
Properties
QuickCalc

Button
CTRL+D

CTRL+C
SHIFT+CT...
CTRL+H
CTRL+R
CTRL+%
CTRL+2
CTRL+Q
CTRL+K
CTRL+E
CTRLHM
CTRL+O
CTRL+Y
SHIFT+CT...
CTRL+P
CTRL+1
CTRL+3

Source
GCAD

Modify

Delete

Cancel

@ Set Shortcuts =

Command:

Command Line

Set Shortcuts

2.1.4.  The Ribbon

The ribbon consists of several panels, which are organized into each tab according to their task label. The tools and controls in
gach panel are also available in toolbars and dialog boxes.

Panel Tab Expandable panel Expandable tools button

Tab: The ribbon is structured by tabs. Every tab BB & & - A -oaftng
displays a series of panels with its own tools T*“nr;:tatx;i
(commands or thumbnails) easier to select or pick. o

Panel: The panel shows the most used tools. Some - e -
thumbnails have an expandable tools button that can Annotstion 3D Surface
be expanded in a drop-down method. In addition, i . Ii' Bl
most of panels at home tab have an expandable panel = A g 5 ¢

that shows up more commands related.

Modify ~

Mesh

Layout
=2z Table

- Leader ~

it
[ Linear -

Annotation «
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Expandable Panel: The expandable panel is located at the bottom of the panel. If you click at the bottom of
the panel, more commands related will be displayed.

@ Center, Radius

(/) center, Diameter

Expandable Tools Button: Some thumbnails (tools or commands
at the panel) have an expandable tools button that can be
expanded in a drop-down method. If you click this button, all the
related tools will be displayed.

Concentric

) 2 Point

I
( ) 3roint
./

( 1 Tan, Tan, Radius

2.1.5.  Appearance () on Ton, Tan

You can manage the interface’s theme plus show/display toolbars, menu bar, file tabs and status bar.

& ToolBar x> .

[ Dimension A
[ Draw

[ Draw Order

[Jinsert

e T T elsorsion WM Eores dopttie e Layout

?.39. C = é : : (——wae TN vl EMudrfy
casiudalon ol KUK el v o m 2 ™ e 2 o g G Moy I

[]Properties

[Layer

[5tyle

Closnap

[ Refedit

[JReference

[]Render

[IMadeling

[[]50lid Editing

["15tandard Annotation A

Heb

irst point: *Cancel*

Model  Layoutl | Layout2 H#f b D4 =W

2.1.6. Drawing Area

Your drawings are displayed in the drawing window.
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2.1.7.  Toolbars

Toolbars partially contain buttons that start commands. When you move your mouse or pointing device over a toolbar button,

the tooltip displays the name of the button.

The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well
as Microsoft Office standard commands such as New, Open, and Save. LusoCAD 2025 classic workspace initially displays
several toolbars by default:

- Draw toolbar i/ /7200rQ0
- Draw order toolbar

- Modify toolbar S D
- Properties toolbar
- layer toolbar

- Style toolbar

- Standard toolbar

21.71. Displaying and Hiding Toolbars

LusoCAD 2025 provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can also move
and dock toolbars. To choose which toolbars to display:

1. Execute TOOLBAR command or select the TOOLBARS option from the drop-down list under Appearance button (at top right
of the interface) to open the Toolbar dialog box.

2. Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK.

@“::5:—.' *

[ Dimension ~
Draw e
[ Draw Order ] “ Eh E’h ﬁ & & n a
Insert

[ Layout

] Modiy I

[(]Propetties

[CLayer

[15tvle

ZlosNAP

[JRefedi

[]Reference

[]Render

[IModeling

[]Selid Editing

["1Standard Annotation &

QK Help 1 0
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To make floated a horizontal docked toolbar, just click and

hold the left side of it and drag around the place you need.

To make floated a vertical docked toolbar, just click and hold

the top of it and drag around. To dock any toolbar, just double-click at the left side of it.

2.1.7.2. Starting Commands Using Toolbars

To start a command from a toolbar, click a
command button and respond to the prompts.

Revision Cloud (REVCLOUD) |

2.1.8.  User Coordinate System (UCS)

The icon indicates the orientation of the drawing in two-dimensional space.

Model Llayoutl | Layout2 | 4

2.1.9.  Model Space and Layout Space tabs

Click a tab to switch between the drawing of your model and a printed layout.

4 AREASUM SAMPLE FOR DEMO.dwg x < AREASUM SAMPLE FOR DEMO.dwg

Baseball Field
Area summatory

Baseball Field

4 4 » ¥ ‘ Model [ Layoutl M4 » w4 Model » Layoutl

11
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2.1.10. Command Window

The command bar is a dockable window in which you can type commands and view prompts and other program messages. You
can move the command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to change the number of lines of text it
displays. You can dock the command bar at the top or bottom of the drawing.

Command: CIRCLE

Specify center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric]:

2.1.10.1.  Enter Commands on the Command Line

Command Line *
) Command: circ 0
Type the full command on the command line and press ENTER or coecty serte port for cicle o [37/28 T/ Arc/Mukiplel-osnap
. . . . Resuming CIRCLE d.
SPACEBAR, or right-click on your pointing device to start the o ecty conte port or il or [3P/2P T/ PecMukil Carce (1]

. . Command: “Cancel” -
command. Some commands also have abbreviated names (aliases). Command[SPLINE | PR
2.1.10.2.  Specify Command Options
Once you have entered a command on the command line, it Ak .

. . . . \Specify center point for circle or [3P/2P/Ttr/Arc/Muttiple]:'osnap 0
displays a set of options or a dialog box. To choose a different +>Resuming CIRCLE command.

\Specify certer point for circle or [3P/2P./Ttr/Arc/Muttiple]: Cancel®

option, enter one of the options in the brackets (either uppercase Command: “Cancel" |
ICommand: SPLINE -

or lowercase letter is OK), and then press ENTER or SPACEBAR. [Specty frt poirt of [Obict] O | e

21.10.3.  Execute, Repeat and Cancel Commands

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names have been
entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To
cancel a command in progress, press ESC.

2.1.10.4.  Nesting a Command

To use a command inside an active command, type an apostrophe before you type the command. For example, you turn on the
object snap while you are drawing a circle, thus you can setup Object snap
mode before continuing drawing.

() Drafting Settings X

Snap and Grid  Polar Tracking  Object Snap  Dynamic Input  Quick Properties M *|*

Object Snap On (F3) [] Object Snap Tracking On (F11)
Object Snap modes
Command: circle>Specify center point for circle or [3P/2P/Tir (tan tan O B ot # DOipalel Sokct A
. 2y [ Midpaint 0y [dinsertion Clear Al
radius)]: ‘osnap & Heaie b ClPependedar
[] Geometric Center 75 [Tangent
= Command: CIRCLE % [INode = [Nearest
, pecify center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric] . osnap & [Quadeant [[] Apparent intersection
= Model  layoutl | Layout2 | - 3¢ [ Intersection o [ Distance from Endpoint

=[] Extension - []Divide  Segments

1) Totrack from an Osnap point. pause over the point whi ina
% command. Atracking vector appears when you move the cursor. To.

(Setup object snap mode as Center in Draft Settings dialog, and then close
the dialog to go on performing CIRCLE command) elp kin paves vt pont agen

Optirs.. Cancel Helo

12
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2.1.10.5.  Enter System Variables on the Command Line

System variables are available for controlling
how certain commands work. For example, Command: GRIDMODE

GRIDMODE is used to control the grid status Bhiaiee o it
ON or OFF.

Specify insertion point: *Cancel*

2.1.10.6.  Using LusoCAD Text Window

() gead Text Window o X

The LusoCAD Text Window displays a history of the carcte A A
Commands and prompts |SSU9d SlnCG yOU Started the i nter point for circle o \rc/Multiple/Concentric]: *Cancel®
current session of LusoCAD.

y center point for circle or [3P/2P/Ttr/Arc/Multiple/Concentric]

To display or close the LusoCAD Text Window press F2.

To view entries in the LusoCAD Text Window, just drag the
scroll bars or use the Up (1) and Down (|) arrows to
display previously used commands.

nter point for circle or [ \re/Multiple/Concantric]

2.1.10.7.  Switch Dialog Boxes and Command Line

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the
command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as
well:

- ATTDIA controls whether INSERT uses a dialog box for attribute value entry.

- EXPERT controls whether certain warning dialog boxes are displayed.

- FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is set to 1,
OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompt on the command line. Even when
you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (~) at the first prompt.

2.1.10.8.  Dynamic Input @ Drafing Setings x
Snap andl Gid | Polar Tracking ObiectSnap | Dynamic Input Guick Propertes | Magnier [

The "Dynamic input" box is a floating window which appears near bRzt I e el e et

the cross cursor. It provides a convenient method for users to m  ma—

input commands or system variables dynamically and display

the index information. Type a command using the dynamic input, e e

it displays a list of all the commands whose prefix matches what Dynamic Prompis

Show command prompting and

command input near the crosshairs

Show Dynamic Input Tooltip near the
crosshairs

you've typed plus it will display all their icons making easier to
recognize them at glance. When creating and editing objects, the
dynamic dimension can guide you to draw precisely. What's
more, the dynamic input displays all options of a command and
could select them in different methods. o oK el ey

[ Automatically ENTER when the
keyword is Matched

Drafting Tooltip Appearance...

LusoCAD 2025 supports the functions of Dimension Input, vertical Dynamic Prompts list and independent Pointer Input boxes,

it provides easier-to-use experience and improves design efficiency.
13
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e Independent Pointer Input Boxes

Pointer Input boxes for length, angle and coordinates, etc. are displayed independently, making it more convenient for users to
input different values by simply switching between the boxes using the TAB key.

ecify next point or

367.1005

e  Dynamic Dimension Input

When creating and editing objects, data such as length, angle, radius, etc., are displayed in the form of dimensions, which are
dynamically changing as the mouse cursor is being moved. With the help of the independent Pointer Input boxes, users are
now able to input dimensional data and execute design operations more efficiently.

pecify next point or

e \Vertical Dynamic Prompts List

Dynamic Prompts List are now displayed vertically by default in LusoCAD 2025, which allows users to see all the prompts at
once, it simplifies drawing operations. Horizontal prompts list could still be activated by using system variable DYNLISTSTYLE.

Specify first corner point or 2867.3719)g 501.9349
Chamfer
Elevation

Fillet

#® Thickness
Width
Oblique

14
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211, Status Br B N/
¥ DYNF1Z) 9
2 souarn

Display information such as the current cursor coordinates, Snap, Grid, - m”

Ortho, Polar, Osnap, Otrack and other settings. In addition to displaying e

information, the status bar is a quick way to access many features. You =

can click status bar items to make changes and right click items to
display short cut menus that allow you more choices. By default, the
status bar is shown as the picture below:

I~ COORDS(FE)

¥ Quick Properties

[ -
_ .

Tray S

The status bar icon also can be shown as text button, right click

Enabled

v Uselcon

on one of the icons of the status bar, uncheck the "Use Icon"

option and you will get another method to show the status bar.

Settings...
Gl e A l:lv AT

2.1.12. Properties Palette

You can modify the value or properties of object(s) you wanted in each column. The Properties palette shows all properties of
the specified object. When selecting multiple objects, the Properties palette shows the command properties of the selected
objects. If none of the objects are selected, the Properties palette displays the general properties of the current layer, View
properties as well as the UCS information. By default, double-click an object opens Properties palette if the Properties palette is
hidden. This operation is not available when the objects are block, hatch pattern, text, multiline, external reference or gradient
fill.

AWING SAMPLE MECHS.dwg

Ol 70 32 14__ 23
R3 719 i
6N | 3 [ e 24T
N Cd? | i 7™
{ 1
g © © /:\"(i\
i s —

@_) Ay Y

. 29 2x45° 16 55

2x45° | 60 100

195
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LusoCAD also supports Quick Properties, which is a set of
objects properties displayed through the Properties Palette. You
can customize your own Quick Properties; you can decide to
show your preferred object type with selected object properties
to save the limited drawing space. You can set the objects
properties to display in quick properties from CUI.

Palette Settings:
You can click the Properties button or right-click on the Title bar of the palette or window to enable Anchor left/right, Auto-hide
(There is an Auto-hide button in the Title bar) or adjust the transparency of the floating palettes or windows.

|+

- £ e
Move )
Size
Close

Allow Docking
Anchor Left <
Anchor Right >
Auto-hide
Transparency...
Shadow displ...

Plot style
Plot style

Plot table att..

=

Anchor Left<: Anchors a dockable window or palette to the left of the drawing area. When the cursor is moved on it, the

anchored palette or window displays with full opague, when the cursor is moved away, it hides automatically. Also, when an
anchored window is open, its content overlaps the drawing area.

Anchor Right>: Anchors a dockable window or palette to the right of the drawing area. When the cursor is moved on it, the
anchored palette or window displays with full opague, when the cursor is moved away, it hides automatically. Also, when an
anchored window is open, its content overlaps the drawing area.

Auto-hide: A floating window rolls open and closes as the cursor moves across it. When this option is unchecked, the window
stays open.

(3 Transparency x
Transparency: Adjusts the level of transparency for the window and on mouse

General

How transparent should the palette be?

over.

Clear ' Solid
e How transparent should the palette be: Sets the transparency of a palette 100% Opacity
while the cursor moves away from the palette. It's also controlled by the Rolover

How transparent should the palette be on mouse-gver?
GLOBALOPACITY system variable. - P s
e How transparent should the palette be on mouse-over: Sets the 0% Ge=a

Click to Preview

transparency of a palette while the cursor moves on the palette. It’s also
controlled by the ROLLOVEROPACITY system variable.

[[] apply these settings to all palettes

[[] pisable all window transparency (global)

Cancel
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e  (lick the Preview button: Press the button, it displays the transparency of palette while the cursor moves away from the
palette, release the button, it displays the transparency of a palette while the cursor moves on the palette.

e Apply these settings to all palettes: Applies transparency settings to all palettes. It's also controlled by the
APPLYGLOBALOPACITIES system variable.

e  Disable all window transparency(global): Controls whether palettes can be adjusted transparency. It's also controlled by
the PALETTEOPAQUE system variable.

2.1.13.  NAVICUBE

NaviCube is a navigation tool that is displayed when you are working in 2D model space or 3D visual style, which allows to
switch between standard and isometric views easier. It consists of a cube, compass and options, is draggable and clickable,
and supports switching to any available preset views, rolling the current view, or setting the current view as the Home view.
You can enter the NAVICUBE command or click Ribbon = View = 3D Tool * NaviCube to control whether to display the
NaviCube in the drawing area. When the value is ON, the NaviCube is displayed, when the value is OFF, the NaviCube
disappears.

Appearance of the NaviCube: The NaviCube is displayed in one of two
states: inactive and active. When your cursor is not touching the
NaviCube, it’s inactive, it appears partially transparent by default so that
it does not obscure the view of the model. When you move the cursor
over it, it becomes active, it is opaque, so the view of the objects in the
current view of the model may be obscured. And you can use other
properties of the NaviCube within the Settings option.

Inactive
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Cube: Itis in the top right comner of the drawing
area over the model and shows the current o
viewpoint of the model. When moving the
cursor over it, you are able to click the faces,
corners or edges to change the views
conveniently, as well as click on the cube and
drag it to roll the current view. Corner

ry
LEFT

Compass: The compass is displayed below the NaviCube
and indicates the north direction defined for the model. You
can click any of the directional letters on the compass to
rotate the model.

When the view is “Front” “Back” “Left” or “Right”, some little triangle buttons will display around the cube, which allow you to
switch between adjacent views by clicking them.

> When clicking the triangle button at the right or left side, the view is switched to its right or left adjacent view. So, you
can continuously switch between different views and rotate the navigation cube horizontally by clicking these two
buttons.

FRONT e RICHT
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> When clicking the triangle button at the top or bottom side, the view is
switched to top or bottom view. The top and bottom triangle buttons can only
be clicked once.

> When clicking the triangle button at corners, the view is switched to the edge
view of two adjacent views. The corner triangle buttons can only be clicked
once.

Options Menu:
> Home: Changes to Home view

> NaviCube Settings: Opens NaviCube Setting window
e On-screen: Identifies the viewport where the NaviCube is displayed.
e Navicube size: Specifies the size of the NaviCube.
e Inactive Opacity: Controls the opacity of the NaviCube when inactive.
e Show UCS Menu: Controls the display of the UCS drop-down menu.
e /ooms to extents after view change: Specifies if the model is forced to fit the current viewport after a view change.
o QOrient Navicube to current UCS: Controls whether the NaviCube reflects the current USC or WCS.
e Show compass below the Navicube: Controls the whether the compass is displayed below the NaviCube tool.
e Restore Default: Restore NaviCube settings to default values.
> 3D views: Displays view control list.
> Coordinated system: Controls coordinate system.
> Upside down: Changes to the view side which is parallel to the current view side.
> 90° Clockwise: Rotates 90 degrees clockwise.

> 90° Counter Clockwise: Rotates 90 degrees counterclockwise.
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Right-click Menu:

>

>

2.1.14,

Home: Goes back to Home view

Set Current View as Home: Specifies the current view as the Home view.

NaviCube Settings: Opens the NaviCube Setting window.

Help: Open Online Help system, Home — Commands — N — NAVICUBE
command.

Lasso Selection

Home

Set Current View as Home
MaviCube Setting
Help

The Lasso selection allows you to create an irregularly shaped window or crossing selection set. The implementation of lasso

selection can not only replace frame selection to select simple objects but also solve the problem of difficult selection of some

complex objects using frame selection.

To use the lasso selection, just hold the mouse button down while dragging the mouse to create the lasso. When you release

the mouse button, the lasso is completed.

21141,

Lasso Selection Modes

Lasso selection provides three modes: Window Lasso, Crossing Lasso and Fence Lasso, you can press the spacebar to cycle

through the Lasso modes.

> Window Lasso Selection: Hold the mouse button down and drag the mouse from left to right, only the objects that are

completely enclosed in the selection area are selected.
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> Crossing Lasso selection: Hold the mouse button down and drag the mouse from right to left, the objects enclosed in and

that are crossed by the selection area are selected.

> Fence Lasso Selection: Specify points to define a fence, the objects that pass through the fence will be selected.

2.1.14.2.  System Variable Compatibility

LusoCAD optimizes the PICKAUTO system variable to be consistent with ACAD.

System Variable Description Value

Value Description

Used in conjunction with 1asso
selection to control the automatic
PICKAUTO windowing for object selection. This 0
system variable is also used to control
the opening and closing of the asso.

Selects an object by clicking. It only
stores the value, and the value will
not take effect.

Selects an object by clicking. Turns
off automatic window and crossing
selection.

Starts a window or crossing
selection if the cursor is not directly

over an object when clicking;
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Selects an object directly by
clicking if the cursor is on the
object, selection complete.

Starts a window or crossing
selection even if the cursor is
directly over an object.

Starts a window or crossing 1asso
selection if the cursor is not
directly over an object when
clicking;

Selects an object directly by
clicking and dragging if the cursor
is on the object, selection
complete.

Note: To specify more than one option, enter the sum of their values. For example, entering 5 specifies the bitcode 1 and 4

options.
Value
3 The combination of bitcode 1 and bitcode 2 which has the same effect as bitcode 2
5 The combination of bitcode 1 and bitcode 4 which has the same effect as bitcode 4
6 The combination of bitcode 2 and bitcode 4
7 The combination of bitcode 1, 2 and 3 which has the same effect as bitcode 6
Summary:

> When the value of PICKAUTO is 0, the objects can be selected only by clicking.

>  When the value is 1, 2 or 3, it’s window selection.

> Whenthe value is 4, 5, 6 or 7, it’s the window selection and crossing lasso selection (To specify a window selection area,

click and release the left mouse button, move the cursor, and click again to finish; To create a 1asso selection, click, drag,

then release the left mouse button to finish).
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2.2. Customize the Drawing Environment

In LusoCAD 2025, there are different elements of the working environment that can be customized to fit your needs.

2.2.1.  SetInterface Options

In the Options dialog box, you can change many of the settings that affect the interface and drawing environment.

@ options

Window Elements
Appearance Theme: | GstarCAD

[ Use large buttons for Toolars
[ Show ToolTips

Layout Regen Options

(O Regen when switching layouts

O Cache mode! tab and last layout

@ Cache model tab and al layouts

Layout elements

Display Layout and Model tabs

Display printable area

Display paper background
Display paper shadow

FACreate viewport in new layouts

Current profile: <<Unnamed Profie>> Curert draming Drawing1.dwg

File Display Openand Save Plotand Publish User Preferences  Draw  Selection set Profiles

Display menubar Display fl tabs
Display Drawing status bar [ ] Display scrollbars 05 |R

[]Show Page Setup Managerfor new layouts

Display resolution
~ Are and circle smoothness

Segments in a pohyline curve

endered obiect smocthness

e

Contourlnes per suface

Display perfommance
[0 Pan and zoom with raster § OLE
Highlight rester image frame only
Apply solid il
] Show text boundary frame only
] Draw true sihouettes for solids and sufaces

Crosshair size

[

Fade control
Xref display

In-place edt and annotative representations

oK Cancel Apply Hep

2.2.2.  Settings of Modifying Interface

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog

box, Open and Save tab, select Automatic Save and enter the interval in minutes.

@ Options

Curent profile: <<lUnnamed Profile

File Save
Save az
AutoCAD 2018 Drawing(”.dwa)

Maintain visual fidelity for annotative objects
Maintain drawing size compatibility

Thumbnail Preview Settings...

Incremental save percentage

File Safety Precautions
Automatic save
Minutes between saves

[+ Create backup copy with each save
] Fulltime CRC walidation
[ Mairtain a log file

svi File extension for temporary files
Security Options...

Display digital signaturg information

g Cument drawing: Drawing1.dwg

File Display OPE”GHdSEVE Plot and Publish  User Preferences  Draw  Selection set  Profiles

File Open

EI Number of recently-used files

[] Display full path in title
Application Menu

EI Mumber of recently-used files

Hrefs
Demand load Xrefs
Enable v

Q Retain changes to Xref layers
Q [] Allow other users to Refedit cument drawing

GRX Applications

Proxy images for custom objects:

Show proxy graphics -

Cancel Aoply Help

23



Chapter2_Starting Up LusoCAD 2025

Color (Display tab): Specify the background colors used in the layout and Model tabs and the color used for prompts and
crosshair.
Font (Display tab): Change the fonts used in the window and in the text window. This setting does not affect the text in your
drawings.

Search Path (Files tab): Set the search path to find drawing support files such as text fonts, drawings, line types, and hatch

patterns.
@ Options
Current profile: <zlnnamed Profile s> !
Fle | Open and Save Plot and Publish  User Pre

2.2.3.

Window Elements

Appearance Theme: v
Display menubar Display file tabs
Display Drawing status bar  [_| Display scroll bars
[] Use large buttons for Toolbars

Show Tool Tips

Colors... Fonts...

Save and Restore Profiles

@ Options

Current profile:

<<Unnamed Profile s I
Display Open and Save Plot and Publish  User Pr

Search paths, file names, and file locations:

% Support File Search Path
% ‘Working Support File Search Path

H

H

H Customization Files

t| Help and Mizcellaneous File Names

£ Text Editor, Dictionary, and Fort File Names
£ Print File, Spooler, and Prolog Section Names
E- Printer Support File Path
H

H

H

3|

3|

H

H

afalalatal

% Automatic Save File Location

% Color Book Locations

% PDF Import Image Location

E Template Settings

% Tool Palettes File Locations

% Authoring Palette File Locations

% Log file location

]% Temporary Drawing File Location

]% Temporary Extemal Reference File Location

i
[
£
£
£
&
&
[
£
£
£
£
[
[+
£
£
[]----% Texture Maps Search Path
£

j% DGN Mapping Setups Location

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled. By
default, your current options are stored in a profile named Default. The current profile name, as well as the current drawing
name, is displayed in the Options dialog box.

LusoCAD 2025 stores the profile information in the system registry and saves it as a text file (an ARG file) and also organizes
essential data and maintains changes in the registry as required. If you make changes to your current profile during a session
and you want to save those changes in the ARG file, you must export the profile. When you export the profile with the current
profile name, LusoCAD updates the ARG file with the new settings. You can re-import the profile to update your profile setting

@ options

Curert profle: <clnnamed Profie>> By Curent drawing

Fle  Display Openand Save Plot and Publsh User Preferences
Avalable profiles

<<Unnamed Profile>>

@ add Profile

Profile name-

[Wew DWG 4P Workstation

(Classic Project engineeringl

Apply 8 Close Cancel

oK Cancel

Drawing dwg

Apply

Draw  Selection set Profiles

Set Curent
Addto List.
Rename..,
Delete
Export.
Import

Reset

@Expurtpmfi\e X
Savein: | CAD v| =] E} E] Vieww
£ A | Name . Date modified
.T.j Ne items match your search.
]
=
1
T
<
@ File name Drawing1.arg e | | I
“ | Save as type Configuration File(*.ARG) el
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2.2.31.  MOVEBAK Command

The new MOVEBAK command changes the destination folder for drawing backup (BAK) files. Once you specify a path, the
drawing’s BAK files is placed in that path after every save operation.

Enter new value for MOVEBAK, or for none <current setting>:
Entera . (Period) for none or type the folder name

If you enter ".", the MOVEBAK folder name is cleared and new BAK files will be created in the original folder.

2.3. Customize User Interface

Drag & Drop Customization: An innovative way to customize user interface must be easy and quickly according to user needs, so
this is possible by drag and drop action, that means users can drag any command from the command list and drop it into
workspaces elements like ribbon panels and toolbars that are visible at top right corner of the CUI dialog box. Users will not have
restrictions to place anywhere or even arrange a preferred command on a panel or toolbar. Ul customization has never been easier
and flexible through Drag & Drop action.

(3 Customize User Interface m} X
@ Elements Custamization % Warkspace Customization = Transfer
Customization List: F Panel Preview A
Al Customization Files
] [0 Text Incremental Copy
O Arc-Aligned Text
O Change Text
O] Text Qutline
O Autematic Text Numbering
] Row 3
... <SLIDEOUT=
]-ﬂ] Annotate - Dimensions
137 Annotate - Leaders
i-{37] Annotate - Table Properties o
i-£37 Annotate - Markup we] (&
=-{5] Annotate - AnnotationfScaling e |z}
Panel Dialog Box lfauncher B Display [l
i &7 Row 1 Mame Autamatic Test Murnbering
i.. ] «SLIDEOUT= E Appearance
137 Block Editor - Manafe w Buttan Style SmallwithoutT ext
- ’ B Command
Command List: -3 Command Mame Automatic Test Mumbering
Diescription Automatic Text Mumbering: TCOUMNT
All Commands > |autd | x ﬁ Command Dizplay Name TCOUNT
Command / Source Macra “CC_TCOUNT
Anangs Frame Autoratically GCAD Tags
Anange Frame Automatically EXPRESS B Access
AutoEorTstraln ] GCAD KeuTip
Automatic Text Humbering GCAD R . .
| Avtomatic T ext Mumbering EXPRESS ) Toolip Title Automatic Text Mumbering
Paint Cloud Auto Update GLAD B Advanced
Surface Auta Trimming GCAD Element ID ID_TEXTE
Element ID RENU_DOOT
Fl Imanes he
oy cnca | [<
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Brief introduction of CUI dialog box:
1. CUl dialog box: Now the CUI dialog box is divided into three tabs: Elements Customization, Workspace Customization and
Transfer tab in which the main attraction is the Elements Customization tab through its new way of customization (Drag & Drop).

[c]
& Eloments Cuntomaation @ Workspace Customastion & Trandle
R Puopeties F
&8 B
A & General
MHamne Goa
Display Hame
Fiename
12 Quick Access Toolbars.
o 3 Ribbon
4 I Toolbars
‘Command List R
Al Commands v Q@@
Conmend Souce ~
0 ENPRESS
3Puint 6CaD
7 2D A Cip Planes 6D
D At Divtarce 5Cap
BCAD
GCAD
GCAD
6D
6Cap
BCAD
o Command

2. Right click menu: Context menu is available for different interface elements as shown below:

E Ouick hecess Toolbars

4 E Rename FZ =-E3 Ribben 2 Quick Access Toolbars
1 73 Tabs = {9 Ribbon
Rastore = #-1ET Tabs
B = Panels =3 Fanels
1 E Reset =] Annotate - Text
1-FR Hew Fanel Panel Dialog Box Launch
E Find. .. Hew Bow £ i
RRE B 41 Hew Pamel
Replace. .. Hew Rew
11
1 ﬁ_ Eename F2 Hor Sub—Fanel
Delete Hew Drop-down
Add Separator
Thaplicate
Lery Dalate
Copy
Find """ Duplicate

Eeplace. .. Command List:
| Find

All Commands Replace. ..

3. Find command: There are several methods to quickly find out the command you want, with these methods, you never need to
browse the command from the top of the list until the end which greatly enhance your work efficiency.

1 2 3 4 5«
Command List: A
All Commands v Q)
Command Source L
0 EXPRESS
45 EXPRESS
[T] Add Bias EXPRESS
o, Add Column EXPRESS
Z.c Add Row EXPRESS
Adjust Character EXPRESS
& Align Tool EXPRESS
Angular EXPRESS
28¢ Arc-Aligned Text EXPRESS
Area Sum EXPRESS
B Arrange Frame Automatically EXPRESS
“, Arrange Tool EXPRESS
7 A 8hach | sader ta Snnatation FXPRFCS %
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1. Filter the command by Category: Click the button right side and select the category the Command List:
command belongs which will reduce the command search scope LGS —

GCAD Commands
ExFRESSCommand
Custam Commandz
Contral Elements

2. Filter a command by entry relevant keywords: For example, input “dimension” in the filter, all ~ |ri

Edit
the commands contain the word “dimension” will be shown, reducing the number of fen
Format
commands to browse. Todls
Draw
Dimenzion
Command List: fa Modify
[ Commands | | dmensian |
Command Source o
NL’:{ change dimension text ExPRESS
conzhaint settings, dimensional GLCAD
dimersion GLAD
WA dimension edit GCAD
dimengion precision GLCAD
Wy dimension text edit GCAD
WMy dimension update EXPRESS
"Q dimenszion, align text, angle GLCAD
1 dimension, align text, center GCAD
,.:_. dimenszion, align text, left GCaD
dimenszion, align text, home GCAD
,._",. dimension, align text, right GCAD
"? dimension, aligned GCah w

3. Command cleaner: If you input the keywords in the filter, the icon will automatically change to which is used

to clean the content in the filter, meanwhile, the following command list will return to the default state.

4. Find and replace: In Find tab input the command you want to find out and click Find Next, the command you searched will be
positioned accurately. In replace tab, you can replace one command with another command, but we suggest not change the
standard command name and description.

Command List: A

[All Commands

Command Find and Replgce 3

T Replace Block Find Tm
=7 Replace Block
-~ Reset Aray
o2 Reset Anay
. Reset &rray
Reset Block
Reset Dim Text Valu
Reset Dim Text Valug

i qil [V]ignore case
Eesel Mgppl[r)g Eiy @i Search string found in command ‘Revision Cloud’ property
estore 9" 'a Restrict Search to ‘Command Name’ at position 0.(1/2)
.. Restore Viewports
Reverse Main Customization File{gcad .cuix) Find Selected Command Find Next Close
Reverse Direction
Reverse Direction
Revision Cloud

Find what: Revision cloud

3

5. Create a new command: If it is necessary to add a secondary development program command to the command list, you can
set the items following the current command settings as shown below.

B

Properties

B Command
Mame Array
D'ezcription
Command Dizplay Mame ARRAY
Macro “CTC_aray
Tags
El Advanced
Elerment 1D
B Images
Small image RCDATA_1E_ARRRAY
Large image RCDATA_16_ARRRAY
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Restore and reset:

If all the customization operation has been finished, but you made some mistakes
when customizing CUI or you are not satisfied with the effect, restore and reset can
help you recover to the original settings.

Restore: Restore the backup Settings, click "Apply" button, the data before
modifying will be saved as backup files which are used for recovery.

Reset: Recover to the initial setting when first installing LusoCAD.

2.4. Import, Export and Migrate User Custom Settings

LusoCAD 2025 supports importing and exporting the settings of the current version, as well as importing settings of old

@ Customize User Interface

@ Elements Customization & Workspace Customization

Customization List:

All Customization Files

=-(P Gcap
E C

Rename F2

w5

Restore
Reset

Find...

Replace...

version, which enable users to avoid repeating same settings when they install the software. Users can also import Tool Palettes

from AutoCAD.

2.4.1.  Import and Export Settings of Current Version

You can import and export settings of the current version in the WINDOWS Start menu without starting LusoCAD, which makes
the operation more convenientand simpler. And importing the saved exported settings when the software is reinstalled or installed

on other machines will save plenty of time.
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Export Settings of current version: Open windows start menu, find your LusoCAD item and click “Export the settings of current
version”, choose the location you prefer to save the “.cfgbak” file and save it.

Export Custom Settings X
« v 4 |5 » ThisPC » Documents > v o arch Docu
Organize v New folder N ]
o [ This PC A Name Date modified Type ze L)
P 30 Objects Camtasia Studio 13:54 File folder
B Desis Custom Office Templates 1 File folder
eskto
P Downloads 1:04 File folder
| FastViewCloudService ; File folder
¥ Downloads Cloud 41 File folder
D Music GDN File folder
& | Pictures Sheet Sets File folder
B videos Inventor Server for AutoCAD 2019 File folder
. MiWiFi_Upl 113 File folder
a Local Disk (C) Wik Upload o
R Tencent Files 010: File folder v
= Equipment @) , R
File pame: | gcad.cfgbak v
Save as type: File(".cfgbak) v
~ Hide Folders Cancel

Import Settings of current version: Open windows start menu, find your LusoCAD item and click “Import the settings of current

version”, find the “.cfgbak” file and open it.

Import Custom Settings

Organize »  New folder

~
[ This PC

B 3D Objects
[ Desktop

|z] Documents
& Downloads

D Music

=/ Pictures

B videos

‘s Local Disk (C:)
s Equipment (D:)
= Document (E:)

e Nlebin el

2 E s TispC »

v <

Documents »

Name
Camtasia Studio
Custom Office Templates
Downloads
FastViewCloudService
Cloud
GDN
Sheet Sets
Inventor Server for AutoCAD 2019
MiWiFi_Upload
Tencent Files
WeChat Files

|| gcad2021.cfgbak

File name: | gcad2021.cigbak

Date modified
913:34
3 10:38
2020/6/111:04

Search Documents

Type
File folder
File folder
File folder
File folder
File folder
File folder
File folder
File folder
File folder
File folder
File folder
CFGBAK File

v } File(*.cfgbak)

E2 w

m @

~

10,465K

Cancel

Exported Settings include:

»  Options: File locations, Display options, User preferences, Drafting settings, Selection settings and other custom settings
»  Customize User Interface: Workspace, toolbars, ribbon customization, command, keyboard and mouse button

customizations

Alias file (gacd.pgp)

Printer support file

Hatch pattern (*.pat)

Tool Palettes

Template file (*.dwt)

Fonts and shapes (*.shx)
Line type (*.lin)

Font mapping file (gacd.fmp)

YV VV V V V V V
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2.4.2.  Reset Settings to Default

In LusoCAD 2025, you are able to reset LusoCAD settings to default by clicking Windows Start menu # LusoCAD 2025 »
Reset Settings to Default.

~
Q Reset Settings to Default

c USB Dongle License Tool

You can only reset the settings when the software is closed.

If the software is closed, the Reset Settings dialog box will pop up, you can select ‘Back up and reset custom settings’ option to
create a backup file that contains your customized files before resetting the product. Or you can select ‘Reset custom settings’
option to reset the product without creating backup files of your custom settings.

@ Reset Settings - Backup X

Resetting LusoCAD 2025 will remove all user customized settings and files, and restore them
] i-\ to their ariginal installed states. What do youwantto do?
L

Mote: Custom settings and files can be backed up before performing the reset. Not all custom settings are stored in
files and cannot be backed up.

—> Back up and reset custom settings
A backup file is created that contains your customized files before resetting
the product.

=> Reset custom settings
Custom settings are not backed up before the product is reset.

Cancel

Note:
e Resetting the custom settings actually is cleaning up the registry information of LusoCAD software and deleting the
Local folder and Roaming folder. After starting LusoCAD again, the new Local and Roaming folder will be regenerated.

e Backing up and resetting the custom settings actually is cleaning up the registry information of LusoCAD software and
backing up the Local folder and Roaming folder under C:\Users\username\AppData and then deleting the Local folder
and Roaming folder. After starting LusoCAD again, the new Local and Roaming folder will be regenerated.
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2.4.3.  Migrate from a Previous Release

LusoCAD 2025 adds a "Migrate from a previous release" feature in the WINDOWS Start menu program items, which allows users
to migrate selected settings of old versions directly to the new version after installation without copying and setup manually under
same language. The earliest version that can be migrated is LusoCAD 2016.

Migrated Settings includes: @ wigrate Custom Settings %
> Options: File locations, Display options, User preferences, Drafting e e e
settings, Selection settings and other custom settings

> Customize User Interface: Workspace, toolbars, ribbon Migration settings from:
customization, commana, keyboard and mouse button o
customizations Sz bR
> Alias file (gacd.pgp) Fiopters 7 Cocomzs e e
> Printer support file s stz oar) e e
> Hatch pattern (*.pat) e petenCpe) Tl ekt
> Tool Palettes el e () el
> Template file (*.dwt) o nd stapee” s e essoges setings
>  Fonts and shapes (*.shx) Elront meporng fi(scod )
> Line type (*.lin) U S
»  Font mapping file (gacd.fmp)

Cancel Help
Note:

> After migration from older version, the relevant settings of current version will be overwritten, and can't be restored.
> After migration from older version, the new functionalities that only current version supports, will be reset to default.

2.4.4.  Import AutoCAD Tool Palettes

You can import AutoCAD customized Tool palettes in the WINDOWS Start menu easily. If you installed AutoCAD in your PC, you
can just import the file from the path in AutoCAD options. If you need to import AutoCAD customized Tool Palettes from another
equipment, the path can be anywhere, but the folder must include AcTpCatalog.atc file.

=} % Tool Palettes File Locations:

= C\Users\OVS\AppData\RoaminglAutodeski\AutoCAD 201HR23.0\enu\supporti ToolPalette

Before importing an AutoCAD tool palette, read carefully the following notes:

1. The default blocks of AutoCAD cannot be directly imported into LusoCAD. If you want to import default blocks of AutoCAD to
LusoCAD, you need to drag them to the drawing from the Tool Palettes, and add them back to Tool Palettes in AutoCAD, then
save the drawing and import.

2. The imported file is only block and command, hatch pattern, light source, constraint, table and other objects haven't been
supported yet.

3. If there is a lack of grip point in the imported dynamic block, probably it’s the result of the imperfect action of the dynamic
block.
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4. All eligible LusoCAD paths will be detected first when you import the file into LusoCAD directly, the entire Tool Palettes in
LusoCAD will be overwritten.

5. The order of the tools list in Tool Palettes after import may be different from that of AutoCAD. The reason is that AutoCAD
supports a file recording the order of the tools in Tool Palettes, but LusoCAD does not.

6. If the source DWG drawing location is changed before you import custom AutoCAD Tool Palettes and its tools, the block(s)
imported into the palettes in LusoCAD will be unable to be used without that corresponding DWG drawing original saved path.

2.5, Tool Palettes

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool
palette are called tools. You can create a tool by dragging an object onto the tool palette. In
LusoCAD, blocks and external references (xrefs) can be dragged onto the tool palette. The new
tool inserted will have the same properties into your drawing. Also, you can close, create and ‘ [ ool bes 1
customize the paletts by doing right click on it. To open the tool palettes just press CTRL+3 or
Type TOOLPALETTES command.

Single bed 1

BT Single bed 2

N &0
5 =]
- Close
Block Reference
Color Bylayer d Mew Palette
Layer O 2
Linetype CONTINUOUS Customize Palettes...
Customize Commands...
" All Palettes

2.6. Design Center

With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents:

.
- Browse for drawing content on your Dg v .&|a|e e .
CompUtef Of a networked Folder | Open Drawingsl History I
Open Drawings IE‘ Name

dflve a Drawingl_1_3828 v vy Dimension Style

. o . [ Layout
- View definition tables for named objects EE';?
and then insert, attach, copy and paste the f?ﬁ:ﬁ; e
definitions into the current drawing. = tneape
- Create shortcuts to drawings and folders I
that you access frequently.
- Add content such as xrefs, blocks to a 5
drawing. .
- Drag drawings, blocks to a tool palette for =

convenient access
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Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and
related support files, Xrefs, layouts and named objects, including blocks, layers, ling types, text styles and dimension styles
within a drawing.

Open Drawings: A list of currently opened drawings is displayed. If you click a drawing file and then click one of the definition
tables, you can load the content into the content area.

History: A list of previously opened files is displayed. If you double-click a drawing file from the list, you can load the content
into the content area.

Favorites: If you have contents that you need to access quickly on a regular basis, the Design Center provides a solution to
finding those. When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you
can save shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you
create are stored in the Favorites folder.

2.7. Clean Screen

Now, if users want to maximize drawing space, they can press the keywords Cirl+0 or select the icon (Clean Screen) located in
the right corner of the status bar. After executing this command, Toolbars and dockable windows (excluding the main menu bar,
command line and status bar) will automatically be cleaned. This function can provide better visibility as large as possible to
make it easier to fully understand every detail of the drawing.

2.8. Lock Ul

Lock Ul locks the position and size of toolbars and dockable windows such as Design Center, Properties palette, etc. To unlock
them temporarily, hold down CTRL key. LockUI setting is stored as a bit code using the sum of the following values:

0 Toolbars and windows not locked

1 Docked toolbar locked

2 Docked or anchored windows locked

4 Floating toolbars locked

8 Floating windows locked
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3. Create, Open, Save, Recover a Drawing and Manage Drawings

3.1. Create a Drawing

3.1.1. Create a New Drawing Using Default Settings

When the system variables FILEDIA and STARTUP are setto 1,
typing NEW at the command bar, it opens Startup dialog box, from
which you can use Default Setting, Template or Wizard to create a
new drawing.

You can select either imperial or metric units for the new drawing.

Imperial measurement system: The drawing uses internal default
values with default boundary is 12 x 9 inches.

Metric measurement system: The drawing uses internal default
values with default boundary is 429 x 297 millimeters.

3.1.2.  Create a New Drawing Using a Setup Wizard

From the Startup dialog box, you can select "Use a Wizard" tab to
create a new drawing by the wizard. There are two wizard options
illuminated as follows:

Advanced Setup Wizard:

r@CrEateNemem'ng & J‘
|Eﬂ7 [] |°@| Open Drawings
Select a File:

File Path
4 i + Browse..
Size:
Modified
ok | [ Canced |

Wizard Description

drawing. Based on the template gcadiso dwt.

Set the units, angle, angle measure, angle direction, and area for your new

| [ ]

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings
such as units of measurement style, precision, direction, and origntation based on template gcadiso.dwt.

Selectthe angls of messurement and the precion for
angles

® Decmal Degrees

—
Units

A Length.
Angle Measure ' Width:
AN
Angle Direction - NN
B Area \ \ Length:
297

(oo J[ Mot ] [ coe

Angle M

B Angle Direction -

- =
Advance
Aogulor ® East N
» fogl x N %
e Measure 5 Noth \ _
N & \ e
o
270

Angular

% N Enterthe area you want to represent using
~ Full scale units. Example: to draw in an
Anguiar S area 12x 9 meters, enter 12 under Width and 9 under

(oo J[ M ] [(omeal ]
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Quick Setup Wizard: From this option, you can specify units of measurement, cene vevorr
precision of displayed units, and grid limits based on template gcadiso.dwt. ﬁlﬁlﬁl Use template

Select templates

Browse.

Template information
No Template information.

3.1.3.  Create a New Drawing Using Template

(3) Select Template Fil

When you need to create several drawings with default
settings, you can save time by creating a template file

<« GstarCAD » R19 » en-WW » Template »

Organize v New folder #E#- O @
designed to create the same drawing files so that you do not EETZT R '
B Desktop SheetSets 2018/8/2215:21
need to specify default settings each time you start. L ol .
Conventions and settings commonly stored in template files T
. . . . P Libraries Select afile to preview.
include: unit type and precision, title blocks, borders, and an

logos, layer names, snap, grid, and ortho settings, grid limits, || < compue

> &, Local Disk (C)

dimension styles, text styles and Linetypes. e '
Also when the system variables FILEDIA and STARTUP are set

to 1 and 0 separately, typing NEW opens Select Template dialog box, from which you can select the desired one or use the
default template by clicking the arrowhead button next to the Open button.

3.2. Open a Drawing

3.2.1.  OpenaDrawing

BwHB S

File Edit View Insert

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, F B e
drawing standard (dws) files and drawing template (.dwt) files. You canalso
open and check drawings that you suspect are damaged.

To open an existing drawing: ~ File > Open Command line> OPEN Using shortcut> CTRL+0
i the dial hoose the tvoe of i (@ . =
1. In the dialog box, choose the type of file you [ oo 0w ST ‘
want to open. L o] Name ‘ Date modified Type Prevews
=i B30 Sample 2014/1/714:26 DWG File
B helicopter 2019/8/1211:05 DWG File
S B helicopterl 2019/8/1211:05 DWGFile
2. Choose the folder containing the desired file. ] g;*;ﬁ';ijj""* i
“ Find File.
3. Choose the drawing you want to open, and then ) tocts
click the Open button or Double click on the |
drawing you want to open. N I — ’
".% ere Béxﬁﬁemplm(-m)
~ | Fies of type: [DrewingCng) o] [ Cancel |
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3.2.2.  Multiple Open Drawings

You can open multiple drawings at one time. There are several methods for switching a drawing to another.
- Acting the drawing by clicking it or using shortcut keys of <Ctrl+Tab>.

- You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use
Arrange Icons to align icons if there are several minimum drawings.

|._G EHEHB &S« [t Drafting
p—

File Edit Wiew Insert Format Tools Draw  Text Dimension Modify Wi Express Parameter Application  Cloud Ng

Home Insert Annotation 3D Surface Mesh Layout View

= H
al A [
& O . .'II v m v

Modify - Annotation «

T B Lock Location
[~

m Cascade

mm Arrange lcons

+ 1 Drawing1_1_000001EEBABCT

Window...

3.3. Save a Drawing

3.3.1.  Save aDrawing

You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In
addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created
your drawing using a template, saving the drawing does not alter the original template.

To save a drawing:  File > Save Command ling>SAVE Using shortcut> CTRL+S

& BB & &« 2 - 200Dmfting
File | Edit View Insert Format Tools Dra

CTRL+N

CTRL+O

CTRL+S
SHIFT+CTRL+S
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Remark: When you save a drawing the first time, the program displays the Save Drawing As
dialog box so that you can choose a directory and type a name for the drawing.

33.2 Save Your Drawing Automatically

You can specify to save drawing files automatically in order to minimize the lost data once

a problem occurs.

If you start the automatic save option, your drawing is saved at specified time intervals. By
default, system assigned the name filename. sv$ for temporarily saved files, filename here

refers to current drawing name.

3.3.3.  Save Part of a Drawing File

You can use BLOCK command or WBLOCK command to create a new
drawing from part of an existing drawing. You can select entities or a
block definition in your current drawing and save them in a new
drawing file. The description also can be saved in the new drawing.

3.3.4.  Save to a Different Type of Drawing File

@ Options
Current profile <<Unnamed Profiles> |
File Display lot and Publish  User Pr
File Save
Save as:
AutoCAD 2018 Drawing(”.dwa) ~

Maintain visual fidelity for annotative objects
Maintain drawing size compatibility

Thumbnail Preview Settings...

50 Incremental save percentage

File Safety Precautions
Automatic save

Minutes between saves

Create backup copy with each save
[ Full4ime CRC yalidation
[ Mairtain a log file

sv§ File extension for temporary files
Security Options...

Display digital signature information

(3 Write Block

Source

Block:

() Enttire drawing
(®) Objects

Base point

m Pick point

=< e

I

Destination

R
L 1]
L 1]

Objects
5 | Select objects 0¢
(®) Retain

(O Convert to block
(C) Delete from drawing

& Mo object selected.

File name and path:

D:\Program Files'\New Block.dwg

Insert units: Millimeter

Help

Choose the format from Save as Type in the Save Drawing As dialog box, you can save a drawing to an earlier version of the
drawing format (DWG) or drawing interchange format (DXF) or save a drawing as a template file.

To save a different format: ~ File > Save As

Command line> SAVE AS

(P save drawing as

x

Savein ‘ MECHANICAL DRAWINGS

v‘ G EJE] viewr

@ DRAWING SAMPLE MECH1.dwg
:j (3 DRAWING SAMPLE MECH2.dwg
@ DRAWING SAMPLE MECH4.dwg
3 DRAWING SAMPLE MECH5.dwg
. 3 DRAWING SAMPLE MECHE MODIFY.dwg
Ijl 3 DRAWING SAMPLE MECH®6.dwg
(@ DRAWING SAMPLE MECHS.dwg

AutoCAD 2013(LT2013) DXF(" i)
| AutoCAD 2010(LT2010) DXF[" dif}
AutaCAD 2007(LT2007) DXF(* i)
| AutoCAD 2004(LT2004) DXF(" dif}
[ AutaCAD 2000(LT2000) DXF(* i)
| AutoCAD R12/LT2 DXF[" ]

AutoCAD 2018 Drawing(" dwg) v

File name

Save as type

Preview:

Options...

Security Options

Save

Cancel

Using shortcut> SHIFT+CTRL+S
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3.3.5. DWG Convert

DWGCONVERT command converts one or a bunch of selected drawing files to another dwg version available. The newly
generated file can overwrite the original one, and it can also be compressed into a self-extracting EXE file or a ZIP file to
facilitate batch format conversion of the entire project drawing.

Bes Tree  Fie Table

m
4

R R
H

FORTIVO PLANTAS dwg
_estructurales dng
54515_001 dwg

1344463399 dng

1344464123 dwg

1344465690 dng

3 Table cwg

ARQUITECTURA CO| (@) Convertion Setup
arqutectura defintivo
Base Support dng
Beach House Sample

Included 11fie(s). 749 MB

Convert to 2010 finplace)

3.3.6.  Batch conversion between graphical file formats

Converts one or a bunch of selected drawing files
to an older or current dwg version available. The - Lo
newly generated file can overwrite the original
file, and it can also be compressed into a self-

extracting EXE file or a ZIP file to facilitate batch
format conversion of the entire project drawing.

Steps to Convert DWG files to different format

1. Click “File”>"“DWG Convert” in turn

2. Click “DWG Convert” dialog box >“Add File” (Near the bottom)

3. In"Select File” dialog box, you need to browse to the folder where the graphics file is to be converted.

4. Click the graphic file name, and then click “Open”.

5. In "DWG Convert” dialog box, click “Conversion Setups”. In “DWG Convert” dialog box, create a new Conversion Setup
(NEW), modify existing Conversion Setup (MODIFY) or select a previous Conversion Setup, and then click “CLOSE”.
In “DWG Convert” dialog box, click “CONVERT”.
If the Conversion Setups specify an EXE or ZIP file, browse to the desired destination folder, then double-click the file to
select it. If needed, input a new name for the file.

8. Click “SAVE”.
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3.3.7.  Use Backup Files (3 Options
Current profile: <<linnamed Profile=> |
LusoCAD creates a backup file with the current drawing name and a File Displav Plot and Publish  User Pr
".bak" extension to save the previous version of the current drawing File Save
when launching "backup automatically" option. i
AutoCAD 2018 Drawing(® dwa) R

3.3.8.  Reduce the Time Required to Save a Drawing File

Maintain visual fidelity for annotative objects
Maintain drawing size compatibility

Thumbnail Preview Settings ...
In order to reduce the time of saving a drawing file, you can specify the Incremental save percertage

incremental save percentage on the Open and Save tab of Options
dialog box or from the ISAVEPERCENT system variable.

The incremental save updates only the portions of the saved drawing file you changed.
Drawing files will contain a percentage of potentially wasted space when you use

incremental saves. This percentage increases after each incremental save until it reaches the
specified maximum value, and then a full save is perform.

3.4 Recover a Drawing

3.41.  Recover a Damaged File

@ Options

Cument profile: <<Unnamed Profile>>

File Display’ Plot and Publish  User Py

File Save
Save as:
AutoCAD 2018 Drawing(* dwg) ~

Maintain visual fidelity for annotative objects
Maintain drawing size compatibility

Thumbnail Preview Settings...

ierenertal save prcertzge

File Safety Precautions
Automatic save

Minutes between saves

Create backup copy with each save
[ Full4ime CRC validation
[ Maintain a log file

svs File extension for temporary files

Security Options...

Display digttal signature irformation

You can recover some or all of data by reverting to a backup file or using commands to find and correct errors if a drawing file
is damaged. A drawing file may be damaged by a hardware failure, power outage and system crash. You had better create a

backup file if the drawing is important.

In the Open and Save tab of Options dialog box, you can specify the backup file are created when you save drawings and set the
proper interval time for saving. Then a backup copy file with a ".bak" extension is created when you save the named drawing
once again. After that, a backup file is always updated while you are executing the command SAVE or SAVEAS.

You can use RECOVER command to check and attempt to open a damage file. Then use AUDIT command to find and correct

errors.

To open a damaged file:  File > Drawing Utilities> Recover
Command line>RECOVER

@ Setect Fies =]
Look in Orawing and picture - 0 r@
Date Type Size Tags S
= WUAYEB... Fiefolder : —
2011/3/201...  ICAD Draw 1906 kKB Evg? ¥
. 0137201 21918 SEVY
214/6/510. 2127¢8 5 B
21297261 0329KB
B 201714 45098
B30 MODEL SAMPLE  20151/271.., 1375KB EndFie...
i | Biomoonswe. msunn. sk
0151/281... _iCAl 672K8 ] Lpcate
> el 215/47141 686 KB
- By 3d rendering 01247511 0k
B30 SYNC HOUSEFL.. 2012/97191.. &0 Ke
3D VILLESAVOYE  2014/4/148. 1144 KB
» 27113, 1CA 478 KB
a
“ Bysupedatist 200777196, 5682K8
- B3-P0UDEPORTIVO... 2011/3/201... 1CAD Draw 1734 K8
Fie game 30 model (e |-
Fies of twe Drawng(" dwg) > [ Cancel
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1. In the dialog box at Files of Type, choose the type of file you want to recover.
2. Choose the directory containing the damaged file.
3. Choose the damaged file you want to recover and Click the Open button or Double click on the drawing you want to open.

To check errors for a drawing file:  File > Drawing Utilities> Audit Command line> Audit

4 1\ Model

-
Command: AUDIT

Fix any emors detected? [Yes/No] <N=Y
120165 objects audied

Total emors found during audit 0, fieed 0

= X

Command:

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit
2. Input Y or N to determine whether to recover the errors that are automatically found by LusoCAD and then press Enter.

3.4.2.  Drawing Recovery Manager

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened
drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files
that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup

File list on the "Drawing Recovery", if there is any damage to the file, the system attempts to recover the drawing in process of

backup.
Drawing Recovery Manager x
Skip to automatic save file local

When program or system stopped by accident, the drawing files needed to recover are sorted
5 BLOCKS2
into the foIIowing types. ) - [#) BLOCKS 2.1 5038.5v

"B BLOCKS 2.dwg

- Recovered drawing file saved when program fails (DWG)

i e BLODKE 2

- Temporary saved file (sv$) SRR e

- Backup file (BAK)

- Source drawing file (DWG)

Preview: ¥
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LAYOUTS SHEET SET MANAGER

3.5. Manage Drawings

SAMPLE SHEET SET
1 SHEET A
In LusoCAD the Sheet Set Manager allows you to manage the entire project 2 SHEET B
3 SHEETC
drawing sheetsets. It can manage all the workflow from sheets creation, 4 SHEETD

printing and publishing. etc.

In Sheet Set Manager, a sheet set is an organized collection of sheets from
several drawing files and each sheet in a sheet set is a layout in a drawing file.
Begin taking advantage of sheet set functionality for your current projects with
minimal effort by importing your current drawing layouts into a sheet set. You can easily open drawings from a central location
while you continue edit them using traditional tools.

3.5.1.  Sheet Set Control

Lists menu options to create a new sheet set, open an existing sheet set, or switch between open sheet sets.

W firt test @&

v Mfirst test
Recent >

New Sheet Set...

Open...

E] 4 - Section View Over.
Bl Architectural
.& Structural

= | @E-)E)

e %f'éf::::[ Tree View: Displays the contents of the sheet ist.

-] 1 - First Floor Plant Layout
&) Section View
K] 2 - Plan View Layout
| /

Details or Preview: Displays either descriptive information or a
thumbnail preview of the currently selected item in the tree

£ 4 - Section View Overall
[_j@ Landscape

...... K] 6 - Landscape Street Map

i view
@] Architectural
6 - lAnd Street M
@] Structural % scape Street Map

&) Electrical / L
&) Mechanical =

&) Plumbing Status: Accessible
Sheet: Landscape Street Map
Description:

Views:
[none]

File Name: 6 Landscape Street Map.dwg
Location: C:\Users\asus\Documents\
File Size: (243,358 bytes)

Last Saved: 2014-10-31 21:43:44

Last Edited By: asus

Sheet Size: 297.0 x 210.0

= Cralas 1100
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You can use the following actions in the tree view: S Mot
.5 General I
o Right-click to access shortcut menus of the operations that are relevant to the & @,’E Open
i ~E2-n Open read-only
currently selected item. s
=8 Landscap
El6-La Import Layout as Sheet...
% ;r::::f: Rename & Renumber...
@ Electri(a.l Remove Sheet
S = '
Properties...

o Double-click items to open them. This is a convenient method for opening drawing files from the Sheet List. You can also
double-click items in the tree view to expand or collapse them.

et Set Manager 3 x
e ) @&
5 Mfirst test
| B General

1- First Floor Plant Layout
|-l Section View

K1 2- Plan View Layout
& 4 - Section View Overall
| &) Landscape
o T
&) Architectural
B Structural
&) Electrical
&) Mechanical
&) Plumbing

|

| Pubiah to OWF
| 1} [ pesmoowec
|

|

Publish to POF
Publish to Plotter

Publish using Page Setup Override

R Landscape
&2 Inchude for Publish »
Q) Aschitectural Open
Q Stuctuat Qi el oo £t Subset and Sheet Publh Setings..
R Blectrical Publish in Reverse Order
R Mechanical New'Sheat.. Inchude Plot Stamp
& Plumbing R - Plot Stamp Settings...
Rename & Renumber... N e
Semovesbet SheetSet Publish Options -

» Pubish Dialog Box ..

o Move the cursor over a single item to display descriptive information or a thumbnail preview of a selected sheet, view, or
drawing file.

Geness

1 it FooePlant Layout
& G Section View

& 2- Plan View Layout

] 4 - Section View Overah

Q Sucturs L

R Bectrical

8 Mechanical

& Prumbing Status: Locked for £4i by asus ASUS-PC

Sheet: Landscape Street Map
Descrpton:

Fie Name 6 Landicape Street Map.dog
Location: C:\Users\asus\ Documents)
Fie Size: 245,358 byter)

Currently Open By-asus.
Last Saved: 2014-10-31 214344
Last Edied By: asus

Sheet Sie: 297.0x 2100

Scale- 1300

Model | 6 Landscape Street

o Drag items within the tree view to reorder them.
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3.5.2.  Sheet Set Manager Basic Information

Opening Sheet Set Manager
Ribbon: View tab > Palettes > Sheet Set Manager or Type: sheetset

ation

O =

Named Restore

Ap
D ®
teoe0
Wireframe o 'E

isual Styles Model Vie

Creating a Sheet Set
Once the Sheet Set Manager is open, select the pull down box at the
top and then click on New Sheet Set.

A new dialog box will pop up displaying the 4 steps in creating a Sheet
Set.

Begin
Under Begin there are two options for creating a sheet set.
Option one

Is using “An example sheet set” that allows the use of a standard
template to create the sheet set.

Option two

Is using Existing drawings to start a new sheet set. We are going to
select the Existing Drawings option.

Sheet Set Details

Help

“g“

Properties
rt

Xref

Palettes User Interface

[ S| Manager (SHEETSET)
:=]

0 et anager

Recent >

New Sheet Set...

Open...

-
Create Sheet Set - Begin

®Begin

Sheet Set Details
Create a sheet set using

Choose Layouts
Confirm () An example sheet set

(@ Existing drawings

This is where basic information like sheet set name, description, and file location can be added.

- -
Create Sheet Set - Sheet Set Details

=

Beget Name of new sheet set:

P Sheet Set Details

iew Sheet Set (1]

Choose Layouts
Description (optional):
Confirm

‘ Store sheet set data file (.dst) here:

C:\Users\asus\Documents

accessed by all contributors to the sheet set.

Sheet Set Properties

“ Note: The sheet set data file should be stored in a location that can be

L]

[ <Back N Next > J[ Cancel
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Choose Layouts

Existing layouts can be added to the sheet
set by browsing for the proper file needed

in the drawing set. Once the layouts are
selected, click Mext to confirm.

Confirm

The confirm tab will give a summary of
the layouts to be added to the set. After
selecting the Next button, the new layout
will be added to the sheet set.

Import layouts to the Sheet Set Manager

To add a new sheet from an existing drawing layout, right click the title of the sheet set

. ) e @
and select Import Layout as Sheet. A new pop up box will appear which allows you to ol s I HMAM'[;
icti i 9|2 - Layout! Hangieckoed

browse for an existing drawing to add a layout. §13-Lyouzlod  Open

K] 4-Layoutl Am  Open read-only

K 5 - Layoutl Vert|

£ 6 - Layout2 Bus New Sheet..
(oo oy s s L ] w

Salact drawing files contaning layouts: & 9 - Layoutts Ch Rename & Renumber...
£ 10 - Layoutl5 S Remove Sheet

A to only one sheet set. I belongs you
must create a copy of the layout to import it

Drawing Name Layout Name status
[T valve Ldwg Layoutl Avalabie for import
@] valve 1.dwg Layout2 Avallable for import

< m 3

] Prefix sheet titles with file name

Import Checked Cancel Help

Managing Sheet Set
Moving and Removing Sheets from a set

Once the sheets have been added to the Sheet Set Manger, they can be

dragged and dropped to the order needed. To remove a sheet from the ey T
. . . 5 - Layoutl Vertical en read-on
set, right click and select Remove Sheet. e (|
i 7 - Layout3 Top Plat New Sheet...
--&J] 8 - Layout10 Chain E Import Layout as Sheet...
K] 9 - Layoutl6 Chann
&7 10 - Layout15 Small Rename & Renumber...

Begin Select folders containing drawings. Layouts in the
drawings can be added to the sheet set.

Sheet Set Details
» Choose Layouts [ Browse... ] [ImportOpﬁons ]
Confirm |, AUTOLIFT 43D-5.5TON -

£V ARM LOCK HANDLE.dwg
VK] Layout3 Arm Lock Handle Assembly
K Layout1 Handle Shaft

K Layout2 Lock Handle Gear

ARM PIN.dwg

[VIK] Layout1 Arm Pin

CARRIAGE.dwg

K Layout1 Vertical C Profile

K Layout2 Bushing
VK] Layout3 Top Plate
== D

Crese shee et- o

Begin Sheet Set Preview:
Sheet Set Details = New Sheet Set (1) |s
Choose Layouts ﬂ 1Layout3 Arm Lock Handle Assembly

2 Layout1 Handle Shaft =

¥ Confirm 3 Layout2 Lock Handle Gear

4 Layoutl Arm Pin

5 Layout1 Vertical C Profile

6 Layout2 Bushing

7 Layout3 Top Plate

_@‘ 8 Layout10 Chain Block Support

Sheet Set Manager X

&7 11 - Layout Be
&7 12 - Layout8 Sh
713 - Layoutt3 L eTransmit...
K7 14 - Layouts Be
&7 15 - Layout7 B

Publish »

Properties...

T

Tip: If the import box is not checked, the layout is already in the sheet set or the
layout is unable to be imported into the set.

@R-E-l
=) New Sheet Set (1) -

& 1 - Layout3 Arm Lock Handle Asseml| |
i 2 - Layoutl Handle Shaft

-] 11 - Layout6 Bearind
£ 12 - Layout8 Short ¢
&1 13 - Layoutl3 Lock .

i 14 - LayoutS Bearing eTransmit...

-] 15 - Layout7 Bearing
K] 16 - Layoutl1 Squar:

Publish >

Properties...
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Rename and Renumbering Sheets

To rename and renumber a sheet or a subset, right click on the P —
sheet needed to be changed and select Rename & Renumber. 2 e i
Layout name: Layout2 Lock Handle Gear
File name:  ARM LOCK HANDLE.dwg
A pop up box will show up that will allow the number, sheet title Folde path: | F:PRODUCT LINEWPLATFORM
and layout name to be changed. Rename options ;
Rename layout to match: Rename drawing file to match:
[] Sheet title [ sheet titie
[ IPrefix with sheet number ["IPrefix with sheet number
[ < Previous ] [ Next > ] I OK ] [ Cancel ] [ Help ]
Adding project information to a sheet set 7
innt i ; i heetsetpoperies I
To add project information to the sheet set, like I
project name, project number, and project gzzsamﬂe Elmoms o
8 iption
description, right click on the sheet set title and e — oo
, T RJ1-lsy  CloseSheetSet ?“"“‘b""‘k“ oy
scroll down to the sheet set Properties. A new pop Bl e i dordiuntd
. . . il e s'... Project number
up box will display that allows the update of project o L e =
. . K- Lazj Project milestone.
information. Q7-1a  (RemcAlishes B S iy
) ) ) ) ) % ;:tag Publish ::: sxe:ge I?camz C:\Users\asus\Documents\
Tips: Project information in the sheet set can be w1 ST e o
- Transmittal Setups...
used in object such as fields 3 ]
[ Edtcustompropertes.. | [ ok | [ cancel | [ Hep |

Creating Subsets in Sheet Set Manager

Sheet Set Manager a X

Creating subsets in Sheet Set Manager is a fast way to organize and find what
is needed in a big drawing set. To create a subset, right click on the sheet set

and then to New Subset.

The Subset Properties box will pop up.
Most of the properties are basic.

Select OK.

A new subset is added to the sheet set
manager.

Tip: To move a sheet to the new subset,
simply click and drag to the desired
subset.

= Subset
Subset Name
Create Folder Hierarchy
Publish Sheets in Subset
New Sheet Location
Sheet Creation Template
Prompt for Template

@e-E
Sheets 7 =

-

-iJ 1 - Layout3 Arm Lock Hz Close Sheet Set
{5 2 - Layoutl Handle Shaft
-] 3 - Layout2 Lock Handle New Sheet..
-] 4 - Layoutl Arm Pin
-] 5 - Layoutl Vertical C Pr Import Layout as Sheet...
& 6 - Layout2 Bushing
-] 7 - Layout3 Top Plate Resave All Sheets
-] 8 - Layoutl0 Chain Block 3

K] 9 - Layoutl6 Channel An LA ’
- 10 - Layout15 Small C Pr eTransmit...
-~ 11 - Layout6 Bearing Sup Transmittal Setups...
-] 12 - Layout8 Short Chan .

£ 13 - Layoutl3 Lock Hang Eropettiesss
&1l 14 - Lavout5 Bearina Support Assemt 1 1

New Subset (1)

No

Publish by Sheet ‘Include for Publish’ Sett...
C:\Users\ovs\Documents'

Arch D{C:\Users\ovs\AppData‘lLocal\

No
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Publishing Sheet Sets
Sheet Set Manager makes it simple to publish a full set or only select sheets of the construction documents. There are two
ways to plot: Publish directly to the plotter/file or use the Publish dialog box.

Publish and Plot directly to the plotter/file
Right click on the sheet set, scroll to Publish, and then Publish to Plotter.

This method is used to plot and publish when the page setup is set per layout. The drawback to using this
option is if someone plots one of the sheets using the plot command and saves the setup to the layout, the
layout will not publish properly. Sheetset can also be packaged and shared through e-transmit.

Publish to DWF
Publish to DWFx
Publish to PDF
Publish to Plotter

Sheet Set Manager
e “@

£ New Sheet Set (1) =
& 1 - Layout3 Arm Lock Handle Asseml|
-KJ] 2 - Layoutl Handle Shaft

Publish using Page Setup Override

-id) ERTEE - Include for Publish >
K4 Open
5 Open read-only Edit Subset and Sheet Publish Settings...
K16 Publish in Reverse Order
K 7 Rl heee Include Plot Stamp
-5 8 Import Layout as Sheet... Plot Stamp Settings
B9
K710 Rename & Renumber... Mmoo Dace ol
% 1; iemove Sheet Sheet Set Publish Options ...
- 1
» Publish Dialog Box ...
13 9
K 14 eTransmit...
% E Properties...

& 17 - Layoutl4 Small Plate Hole

Publishing using Publish dialog box may not be as fast as Publishing directly to the plotter/file, but there is
less of a chance the document will come out wrong.
You are also able to use Page Setups saved in the | == . LS L}
Sheet L — Publsh Options infomation
drawing to particular sheets or the full set. e T EE e
. . . LQ."E__..__J Narming: Specfy name
To pull up the dialog box, right click the Sheet Set | s it
. . i i e e
title, scroll to Publish, and then to Publish Dialog B | s&m w& o Sy 5P O |
ox. The Publish Dialog Box will be displayed. %’.’me,mmm‘” e S
ST . o e - e
1 m:x:;m ; gm
. . . ) 6 Layout2 Bushing No emors
Now with page setups, Publish Dialog Box can chan | ;ng;:;“;mm b s
9 Layout 16 Channel Angle Cut  No emors
ge the way the document is published. Now we hav :?m:éf?:;;”;:m‘ gx |
e the options to publish to Plotter named in Page Seocod Shee Detols g e B
mﬂ::: [ ARM LOCK HANDLE dwg Number of copies tnckuda plot stamp {&4
Setup, DWF, DWFx, and PDF. Lo e [l ok o ' Gnssnbgnn [ \
. . B | ﬁ.;;.:—m oot 5% s Gy Pecen ot ot e |
Selecting the Sheet Set Publish Options allows the TS [ -
options to change information like default output location S ‘
He Deials | Pubisn Coce | [ Hen

and naming. ! _
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Srite Hor

[0 ite vent

B cascade

Publish Options Information
Location: C:\Users\asus\Documents\
File Type: Muli-sheet fie

Layerinformation: Don' include

Q Curent sheet set: New Sheet Set (1)

| Default output location (plot to file) -]
|Location | C:\Users\asus\Documents\

| Common DWF/PDF options -]
Type [Muitisheet fle

Name New Sheet Set (1)

| Layer informat...| Dont include

[Incomorate C... | Line overwrte

| DWF data options -
[ Password pro.. [ Disable

Passwod _|N/A

Block informa...| Dont include

Block templat... | N/A

|Sheet setinfo._| Dontinclude

|Sheet informa...| Dont include

|3D DWF options -

[Group by Xeef.. [N/A
[Publsh with m..| /A

[Cok ] [Coce] [ o |

Tip: One of the major options | change the most is type. Multi-sheet file will place the full set in one file and the Single-sheet

file will place each sheet per file.
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4. Control the Drawing Views

41, Redraw and Regenerate a Drawing

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by

refreshing, or redrawing, the display.

To redraw (refresh) the current window display:  View > Redraw

Command line> REDRAW

To regenerate the current window:  View > Regen Command line> REGEN

N view e
2 Redraw
5N TOOL.d

Regen

5 Regen Al
Zoom
Pan
Orbit
Viewports

& Named Views..

3D Views

% (7 Hide
% Visual Styles
] Render

' Display
= Toolbars..
.

b1 Model { Layoutl /Layout2

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision.
Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the

appropriate screen coordinates.

42. Magnify a View (Zoom)

You can use ZOOM command to zoom in or zoom out the
drawing view to meet your needs. You can change the
magnification of your drawing at any time. The cursor changes to
a magnifying glass when a zoom tool is active. Zoom out to
reduce the magnification so you can see more of the drawing or
zoom in to increase the magnification so you can see a portion of
the drawing in greater detail.

Remark: If you are working in a layout viewport and cannot zoom,
the layout viewport may be locked. The scale and view do not
change in model space while panning or zooming in a locked
layout viewport.

VN Insert Format Tools

Draw Dimension Modify Window Help Express

Manage
).dwg  BEARING DRAWING.dwg LAYOUTBYPATH SAMPLI

Export Help Express

@ Redraw
Regen
% Regen All
Zoom 3
Pan 3
Orbit 2
Viewports 3
[& Named Views...
3D Views 2
(7] Hide
Visual Styles 3
Render 3
Display 3
= Toolbars...

2L LD PHPHOF D

Realtime

Previous
Window
Dynamic
Scale
Center

Object

hlgs/

2 _.
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421.  Zooming Methods

To zoom, you can use any of the following methods:
- To define the portion of the drawing to zoom, create a window.

- To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.
- If you have a mouse with a wheel, rotate the wheel to zoom in and out.

4.2.2.  Zoom to Magnify a Specified Rectangular Area

You can specify a rectangular area defined by two corners to display the objects within that area as large as possible. The
lower-left corner of the specified area becomes the lower-left corner of the new view.

To zoom in to an area using a window:  View > Zoom> Window Command line> Z0OOM
1. Choose View > Zoom > Window

2. Select one corner of the window around the area you want to magnify.
3. Specify the opposite corner of the window around the area you want to magnify.

V) nsert Format Tools Draw Dimepsion Modify Window Help Express Eile Edit View [nsert Format Tools Draw Dimepsion Modify Window Help Expresd
o7 Redraw but ~ View  Manage  Export  Help  Express Home  Inset  Annctation 3D Llayout Vi Manage  Export  Help
Regen DRAWING.dwg 4 LAYOUTBYPATH SAMPLE.dwg _ x MECHANICAL DRAWING.dwg
T Regen Al r 1
Zoom » | @), Realtime I 1
b ' Previous | ——q
Orbit '@, window |
Viewports » | 6B Dynamic I
T Named Views.. @, Scale I 1
3D Views @ Center 1 I
(7 Hide a 1
Visual Styles @ 1
Render a 1 |
Display @, I 1
= Toolbars... @, 1 I
-

42.3. Zoomin Real Time

lodify Window Help Express

Manage  Export  Help  Express

Realtime option zooms dynamically by moving your pointing device up or
down. By right-clicking, you can display a shortcut menu with additional
viewing options.

To zoom in real time:  View > Zoom>Realtime
Command line> RTZOOM
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1. Choose View > Zoom > Realtime from the main menu.
2. Hold the left mouse button, then drag the cursor forward to zoom in and move back to zoom out.

4.2.4. Displaying the Previous View of a Drawing

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire
drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps
back through up to 25 successive zoomed or panned views.

4.2.5.  Zooming to a Specific Scale

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of
the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at
the center of the current viewport remains centered on the screen.

To zoom to a specific scale relative to the current display:  View > Zoom=>Scale Command line> Z0OOM

1. Choose View > Zoom > Scale from the main menu.

2. On the Zoom toolbar, click the Zoom Scale.

3. Type ZOOM in the command line, choose the Scale option, and then press Enter.
4. Type the scale factor, followed by an x (such as 2x).

5. Press Enter.

Eile Edit View Insert Format Tools Draw Dimepsion Modily Window Help Express

V(Y Insert  Format

& Redraw
Regen

% Regen All

Zoom

Tools Draw Dimension Modify Window Help Express

Insert  Annotation 3D layout  View Manage Export  Help Express
'OUTBYPATH SAMPLE.dwg % MECHANICAL DRAWING.dwg

ut
DRAWING. dwg

View  Manage  Export  Help  Express

Realtime
Pan

Orbit

Previous
Window
Dynamic

Scale

Viewports
Named Views...
3D Views »

(7 Hide

Visual Styles »

Center
Object

In

Render 3 Out

All
Extents

Display »
= Toolbars.

2B OO PREIPDH P

4 4 b » " Model / Layoutl /| Layout2

first point as displacement>:
mmand: ZOOM

pecify comer of window, erter a scale factor (X o nXP), or

[All Center/ Dynamic/Extents/Previous/Scale/Window/Object] <real time: SCALE
Erter a scale factor (X ornXF): 3

4.2.6. Displaying the Entire Drawing

Z00M Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display
the objects on layers that are turned off but do not include objects on frozen layers.

Z00M All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger.

50



Chapter 4 Control the Drawing Views

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar
displays the drawing to its extent, making the image fill the display to the greatest possible magnification.

4.3. Pan and View

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing
horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space. The
only change is the portion of the drawing displayed. To pan, you can use any of the following methods:

- For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting
point of the pan. The second point indicates the amount of pan displacement relative to the first point.

- To pan in real time, use the Pan Realtime tool on the Standard toolbar.

- If you have a mouse with a wheel, press and hold the wheel, and then move the mouse.

Vi"Q Insert Format Tools Draw Dimepsion Modify Window Help Expr

To pan inreal time:  View > Pan>Realtime Command line>PAN & Redraw .
Regen
% Regen All
1. Choose View > Zoom > Realtime from the main menu. — Ny O
. . . Pan » |+l Realtime
2. Move the cursor in the direction you want to pan. bt = ron
3. To stop panning, press Enter, ESC or choose Exit from the shortcut menu. Vet g Let
[ Named Views.. Right .
3D Views riE up ot
To pan using a mouse with a wheel: (] vide i Dam _ /‘4
Visual Styles 3 o
Render 3 %
1. Press and hold the wheel and then move the mouse in the direction you T ' :
= Toolbars...

want to pan (The MBUTTONPAN system variable controls this feature.)
4.4, Display Multiple Views on Model Space

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can
divide one window into multiple windows. You can also open and display multiple drawings.

441.  SetModel Space Viewports

The viewports created on the Model tab completely fill the [ F A T T

drawing area and do not overlap. As you make changes in
% Regen Al
one viewport, the others are updated simultaneously. You zoom X :
can do the following operations at the model space ’ o —_
viewport: Moo | e
(7 Hide 2 Viewports ©
Visual Styles » 3 Viewports
- Set Snap, Grid, and UCS icon modes; Pan; Zoom; and Render o e
Display 5 lygonal Viewport
restore named views. T Toobas. E J“
- Save orientations of UCS with individual viewports.
- When executing a command, you can draw from one 8 8
viewport to another. .
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- Name a viewport arrangement in order to you can reuse it on the Model tab or insert it on a layout tab.
- When you work on 3D models, setting up different UCS in individual viewports is helpful.

44.2. VPMAXNVPMIN

VPMAX allows you to expand the current layout viewports and switch to Model Space for editing without worrying about
messing up viewports’ scales and limits, while VPMIN allows you to restore the current layout viewport.

System Variable Description Value Value Description
Controls whether { mize th t 0 Do not maximize
ontrols whether to maximize the curren
VPMAXIMIZEDSTATE ,
viewport (read-only) o
1 Maximize
4421. VPMAX

Expands the current layout viewports to fill the screen and switches to Model Space for editing.

You can enter the viewport maximized state in the following four ways:
> Enter the VPMAX command in the Layout Space, and then click to select the viewport to be maximized; (when there is
only one viewport in the layout, the viewport will be maximized directly without the need to select)
> Enter the VPMAX command after selecting a viewport in the Layout Space;
> Double-click the viewport border in the Layout Space;

> Click the maximize viewport icon on the status bar in the Layout Space. ﬁj

4422. VPMIN

Exits the maximized state and returns to the current Layout Space.

You can exit the viewport maximized state in the following three ways:
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> Enter the VPMIN command;

> Double-click the blue border line;

> Click the minimize viewport icon on the status bar in the Layout Space. E_]

4.4.3.  Working with Multiple Views of a Single Drawing

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple

windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the

display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others.

And also you can switch from one window to another at any time.
To create multiple views:  View > Viewports Command line> VPORTS

1. Choose View> Viewports-In viewports menu, choose 1, 2, 3, or 4 viewports.

2. Type h if you want the horizontal orientation, or type v if you want the vertical orientation.

To join two views:  View > Viewports> Join Command line> VPORTS

1. Choose View > Viewports > Join -Click anywhere inside the window you want to keep.

2. Click anywhere inside the adjacent window you want to join to the first window.

To restore a named window configuration:

1. Type -V PORTS system variable at the command line and press ENTER.
2. Then type Restore.

3. Then type the name of the window configuration you want to restore.

@ Viewports

jew Manage Export New Viewports  Named Viewports

- LB L = |8

MNew name:

Standard viewports:

“Active Model Configuration®
Single

Two: Vertical
Two: Horizontal
Three: Right
Three: Left
Three: Above
Three: Below
Three: Vertical
Three: Horizontal
Four: Equal
Four: Right
Four: Left

Preview

*Current™
2D Wireframe

*Current™
2D Wireframe

*Current*
2D Wireframe

*Current*
2D Wireframe

Apply to: Setup:
Display ~ 2D

-

Change view to

“Cument™

Visual Style:
~ | | 20 Wireframe

Cancel

Help
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4431.  VPSCALE

The VPSCALE (viewport scale) command reports the real scale of the current viewport of a selected layout viewport.

1. You can open a recent drawing with layouts or create a new viewport on layout space with a desired scale according to paper
format.

2. Type VPSCALE command on the command line, and then select the edge of the viewport.

3. The command line will show the correct viewport scale according to unit measure you are working with.

4. Notice the status bar shows the right scale of the selected viewport only at layout space.

378" =10
172" =107
34 =10
=10
Madel ) Layoutl 4 Tayoutd [+ 12 =10
¢mmand: VPSCALE 3" o1g"
elect edge of viewport. 6 10gr
FPTa
Command: Specify opposite torasr:
Custom...

Command :

Command : " Hide Xref scales

\ik“——b
Gl - | 1] (S0 SN CIPN (C1)1 56 - AN = I

444,  Working with Multiple Drawings

With the multiple document interface, you can open and work on several drawings at one time, you can copy, cut, or paste an
entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages:
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You can see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the
Window menu, the following three methods that determine how drawings are arranged are provided for user's choice.

B Cascade

= Tile Horizontally

3 Qiﬂ.kh [:] Tile Vestically
- Cascade s o
- Tile Horizontally . ; /ef.u
. . : \ B2 (@ (avoureveat savete
- Tile Vertically T - Wﬂ"
¢ [
|

ome

445.  View Manager

@ View Manager

With the view manager, you can create, set current, update layers, edit ot o

boundaries, and deletes named views, and switch quickly between each Qi
P - - - R

view, it is helpful to reduce many unnecessary view adjust operation. o8

Camera X

Camera Y

Camera Z

Update Layer

Target Y

[

[

1

Target X [
[

Target 2 [
[

Roll angie

Height 166.6543

Wicth 4335443

Perspective Off

Lens length (nm) |50

45, Specify a 3D View

Set Current

Edit Boundraries

New...

Delete

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and visualizing 3D models. You can

specify a new viewpoint to create new objects or modify the existing objects.

451.  Setthe Viewing Direction

You view three dimensional drawings by setting the viewing direction. The viewing direction establishes the viewing position.
When you view a drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. You can change the viewing
direction to look at the drawing from a different vantage point or to work on a three dimensional model from a different

orientation.

To set a new viewing direction: ~ View >3D Views> Viewpoint Presets
Command line> DDVPOINT

1. Choose View > 3D Views > Viewpoint Presets
2. Set viewing angles at absolute to WCS and relative to UCS by moving the position of the
needle according to your preference. Then click OK button.

@ Viewpoint Presets

Set Viewing Angles
(®) Absolute to WCS

150-.

From:

X Axis:

oy

X
(O Relative to UCS
From:
XY Plane:

Set to Plan View

Cancel

Help
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To display a plan view of the current drawing:

1. Choose View > 3D Views > Plan View from the main menu.
2. It concludes with three plan views: Current UCS, World UCS and Named UCS. Choose one what you want.

File Edit WCTY Insert Format Tools Draw Dimension Modify Window Help

iew  Manage
OUTBYPATH SAMPLE.dwg - MECHANICAL DRAWING.dwg

GN TOOL 4 Regen

Bxport  Help

View > 3D Views> Plan View

Command line> PLAN

Qee0C @RaODaa

Current UCS
World UCS.
Named UCS

SELECTION.dwg  Dr

(D Viewpoint Presets

Et Viening Angles
$) Absolute to WCS

From:

X Axis: 2700

From;
XY Plane:

Set to Plan View

Cancel

Help

b » "\ Model Tayoutl | Layout2

452. Isometric View

You can define perspective views of a
model to create realistic effects. Select
predefined standard orthographic and
isometric views by name or description.
These views represent commonly used
options: Top, Bottom, Front, Left, Right,
and Back. In addition, you can set views
from isometric options: SW (southwest)
Isometric, SE (southeast) Isometric, NE
(northeast) Isometric, and NW
(northwest) Isometric.

V) Insert Format Tools

& Redraw

Draw

ut

Manage

Dimension Modify Window Help
Export
OUTBYPATH SAMPLE.dwg ~ MECHANICAL DRAWING.dwg  OVERLAPPING SELECTIOM.dwg  Drawing3.dwg sampledwg

Regen
Fh Regen Al
Zoom )
Pan )
[ |
Viewports >
Named Views... 7 a
30 Views » Viewpoint Presets..
7 Hide Plan View »
Visual Styles | e
Render v Botom
Display L |6 Left
[C  Toolbars... 5 Right
i) Front
M Back
Q) SWsometric
&3 SELometric
& NEIsometric
€ NWlometric
s

) 'r
0y
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45.3. Draw 2D Isometric Views

With Isometric Snap, you can create 2D objects that appear to be 3D solids.

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can easily align objects along one
of three isometric planes. However, although the isometric drawing looks like 3D, it is actually a 2D representation.

(3 Dratting Settings x

500 0GR Poier Tracking Object Snap  Dyname bpue Cuack Properses 11|+

Sup Yparg 0 ] Bock edter

7] Equel X and ¥ spacing

Snap type. Gad X apacing 0
@Gdne God ¥ spacing i

@ Rectangular s Major ine overy §
O mametrc map

454,  Setlsometric Grid and Snap

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified viewpoint. When the snap angle
is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 degrees. With Isometric Snap on, you can work
on any of three isometric planes, each with a pair of associated axes.

- Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips align along the 90- and 150-
degree axes.

- Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips align along the 30- and 150-
degrees axes.

- Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips align along the 90- and 30-
degrees axes.

(@) Drafting Settings b4
: 90°
Snap and Grid | Polar Tracking  Object Snap  Dynamic Input  Guick Properties M| 4 | *
[] Snap On (F9) [1Grid On {F7)
Snap spacing Girid style TO p
) Display dotted grid in
Snap X spacing 12D modd! space
Snap Y spacing: [ Block editor
[ SheetAayout
Equal X and Y spacing
Giid spacing
Snap type e
(®) Grid snap ey
(®) Rectangular snap Maior line every: 5 =
O lsometric sniap Grid behavior
Adaptive grid
] Allow subivision below grid . Left
spacing Right
Display grid beyond Limits
[] Follow Dynamic UCS
300 1500
Options... Cancel Help
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In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5 or CTRL+E. specifying
one of the three isometric planes results in Ortho and crosshairs to be aligned along the corresponding isometric axes.

For example, when Ortho is on, the points you specified align along the simulated plane you are working on. Therefore, you can
draw the top plane first, and switch to the left plane to draw another side and then switch to the right plane to complete the

drawing.
L. Orthe Mode(F8)

Top plane Left plane Right plane

455,  Change a 3D View Dynamically

You can view objects from any viewing direction by holding down mouse or other pointing devices and moving dynamically.
With dynamic viewing, you can display the effects of changing viewpoint while you change the view. You can execute move or
zoom operations as the 3D Orbit is active. When the 3D Orbit is active, you are not allowed to modify objects. LusoCAD
supports more orbit options like Free Orbit, 3D Continuous Orbit, Orbit along the X-axis, Orbit along the Y-axis, Orbit along Z-
orbit and 3D Orbit Center. Additionally, users can create two new meshes through DISH and DOME commands. To close 3D
Orbit, press Enter, ESC or choose Exit from the shortcut menu.
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45.6.  Hide Lines or Shade 3D Objects

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly or entirely) that are located

behind other objects, or generates a simply shaded image displayed in the current view. You can use HIDE command to
remove the hidden lines to verify the current placement of these surfaces. Hiding background lines makes the display much
clearer, but you cannot modify hidden-line or render views.

45.7.  Add Simple Shading to 3D Objects

Although hiding lines can enhance the drawing and clarifies the design, shading produces a more realistic image of your
model. You can modify shaded objects as you normally would. When a shaded object is selected, the wireframe and grips
appear on top of the shading.
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45.8.  Section Plane

SECTIONPLANE command creates a section object that acts as a cutting plane through 3D objects and saves the selected section plane as a

2D or 3D block. You can move the section object dynamically in a 3D model or in a surface area. You can use the active section to analysis

model by moving the section object in the object. Create cross-sectional views that can be saved or reused.

4.6. Render

Rendering creates a 2D image based on a 3D scene. It
shades the scene's geometry using the lighting you've
set up, the materials you've applied, and environmental
settings such as background and fog. At a basic level,
you can use the render command to render your model
without applying any materials, adding any lights, or
setting up a scene. You cannot move or adjust this light.

46.1.  Light

Section Plane

Select section plane

A\ (No section plane objects selected)

20 section/elevation block creation settings
30 section block creation settings

@) Live Section settings

Active Live Section

[ Color &

Linetype Continuous

Linetype Scale |1

Default

Show Yes

Face Hatch Predefined/SOLID
Angle 0

Hatch Scale 1

Hatch Spacing |1

Color Color 8

Linetype Continuous
Linetype Scale |1

Lineweight Defautt

] Apply settings to all section objects

Lighting adds the finishing touch to the scene. You can add point lights, spotlights, and distant lights and set the location and

photometric properties of each.

Point Light: A point light radiates light in all directions from
its location and does not target an object.

Spotlights: A spotlight can be directed towards an object.
Distant Lights: Simulates the effect of sunlight and can be
used to show how the shadows cast by a structure affect the
surrounding area.

Light List: Displays a list of types and light name used in
model. Distant lights and the sun do not appear as interface
objects in the model.

Tes
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46.2. Materials

You can add materials to objects in your drawings to provide a realistic effect. In
the context of rendering, materials describe how an object reflects or transmits
light. Within a material, maps can simulate textures, bump effects, reflections,
or refractions.

n A

1/ @i[R)%)
T
Template: Water | |
Diffuse: L~
Shininess: -

Refraction index: o u

Translucency: | [
SeHilumination: | [I

] Diffuse map o
100

{4 b ¥ \Model
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5. Precision Tools and the Properties of Drawings

5.1. Specify Units, Angles and Scale

Specify the units of measurement you want to use, their format, and other conventions.

5.1.1.  Set the Units Format

You can set the display format of the unit that includes: scientific, decimal,
engineering, architectural and fractional notation. To enter architectural feet and
inches format, you can indicate feet using the prime symbol ('), for example, 72'3.
You do not need to specify inches by entering quotation marks (*). You can set the
unit type and precision in the Quick Setup wizard, the Advanced Setup wizard, or
the Units Control dialog box. These settings control how your coordinate, offset,
and distance entries are interpreted, and how coordinates and distances are
displayed.

To open drawing units dialog: ~ Format > Units Command line>UNITS

51.2.  DWGUNITS

@ Drawing Units

Insertion scale
Units to scale inserted content

Milimeters

Sample Output
1.5, 2.0039.0
3<45,0

Lighting

Angle
Type:

Decimal Degrees ~

Precision:

0 v

[ Clockwise

Units fer specifying the intensity of lighting

Intemational

oK |

Cancel

~

Direction... Help

Different projects or application scenarios may require different units. For example, architectural design might use meters, while
mechanical design might use inches. In LusoCAD 2025, the newly added DWGUNITS command allows you to change the units
of drawings to meet the standard size and annotation requirements of the drawing and avoid errors due to using different units.

You can enter DWGUNITS command or click Ribbon # Express = Modify ® DWG Units.

Command Line Prompts:

» (1) Enter units for length <3>: The default unit for imperial drawings is
"3. Millimeters" and for metric drawings is "1. Inches". Six common units
are available.

> (2) Enter linear display format<4>:

Drawing unit display formats:

1. Scientific

. Decimal

[ ]

Engineering

. Architectural

[0 [ =Y

. Fractional

F|'I
=|
+

1. Inches
. Feet
3. Millim

. Centimet

. Decimeters
s

5. Meter

er linear display format <45>:

[=]
[

Drawing units:

t

s
S

Enter unit for length <3>:
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> (3) Enter linear display precision<4>:

Architectural linear display precision formats:
_qn
1. 1/2"
2. 1/4"
3. 1/8"
L AEE
5. 1/32"

= '1;54"
) 1;128"
3. 1}’256"

Enter linear display precision <4>:

> (4) Scale objects from other drawings upon insert? [Yes(Y)/No(N)] <Yes(Y)>:

Controls whether objects inserted into the current drawing will be scaled according to existing objects. If set to "Yes,"
inserted objects may be scaled to better match the current drawing environment.

> (5)‘Match INSUNITS to drawing units? [Yes(Y)/No(N)] <Yes

Ensure that the dimensions of objects match the scale of the drawing. If set to "Yes," inserted objects will be measured
and displayed using the same units as the current drawing.

> (6) |Scale objects in current drawing to reflect change in units? [Yes(Y)/No(N)] <Yes(Y)>:

Controls whether the dimensions and scale of objects in the current drawing are adjusted to reflect the unit modification.

> ) Include objects in Paper Space? [Yes(Y)/No(N)}] <Yes(Y)>:
Controls whether objects are included in paper space.

For example, when converting a drawing from imperial (inches) to metric (millimeters) units, after executing the DWGUNITS
command, the unit of the object is modified:

Note: Different options may lead to different prompts. Just follow the prompts on the command line for accurate instructions.
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5.1.3.  Set Angle Conventions

You can specify the location for angle 0 and the positive direction for
the angle measurement: clockwise or counterclockwise. You can also
specify the format and the number of decimal fraction.

- Specify the measurement unit and precision: The units include grad,
radian, surveyor's unit and degree, minute and second.

- Specify where the angle measurement starts from: east, west, south,
north or others. For example, to enter a coordinate relative to the current
coordinate for a property line that is 54 feet, 7 inches long with a
bearing of 60 degrees north, 12 minutes, 6 seconds east, enter
@54'7"<n60d12'6"e.

@ Direction Control

Basze Angle
(®) East

() Morth
() West
() South
() Other

G

50
180
270

Pick / Type

Cancel

- Specify the positive direction: counterclockwise or clockwise. The angle 0 can be set to any location.

5.1.4.  Setting Scale Factors

Instead of drawing to a particular scale, you draw everything full size in the
program. When you print your drawing, you can assign the scale at which

the drawing is to print. Scale, however, does affect the way a few elements
such as text, arrows, or lingtypes print in your drawing. For example, when
you draw text, you need to determine the text size so that when you print it
|ater at a particular scale, the text height is correct.

After you determine the eventual scale of your finished drawing, you can
calculate the scale factor for the drawing as a ratio of one drawing unit to
the actual scale unit represented by each drawing unit.

The following table shows some standard architectural and engineering
scale ratios and equivalent text heights required to create text that measure
1/8 inch high when you print the drawing at the specified scale.

You can use these scale factors to predetermine the size of your drawing to
make sure that it fits on a specific size paper when you print it. You control
the size of your drawing by the drawing limits. To calculate the drawing
limits to match the size of your paper, multiply the dimensions of your
paper size by your scale factor.

Standard <rale rating and eanivalent text heinhts

Scale

1/16" = 1-0"
1/8" = 1-0"
3/16" = 1-0"
1/4" = 1-0"
3/8" = 10"
1/2' = 1-0"
34 =10
1" = 1'-0"
11/2' = 10"
3" = 10"

1" =10'

1" =20

1" =30

1" = 40'

1" = 50

1" = 60

1" =100’

Scale factor ~ Text height

192 24"
96 12"
64 8"
48 6"
32 4"
24 3"
16 2"
12 1.5"
8 1"
4 0.5"
120 15"
240 30"
360 45"
480 60"
600 75"
720 90"
1200 150"
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5.2 Drawing Limits

You can specify the drawing limits that form an invisible boundary around your drawing. You can use the drawing limits to make
sure that you do not create a larger drawing than can fit on a specific sheet of paper when printed at a specific scale.

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96) on a sheet of paper
measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x
96), which allows a 1-inch margin around the edges of the

[{:{-1] Tools Draw Dimension Modify Window Help

printed image. S [
Layer tools v
@ Color,
To set the drawing limits: ~ Format > Drawing limits o
Command line> LIMITS e
& TetStyle..
&, Dimension Style...
Plot Style...
1. Choose Format > Drawing Limits o v\ Model (Layoutl (Lo
B % [Fommand: _LIMIT:
2. Specify the x-coordinate and y-coordinate of the upper right == B el o000
. . . . . . . Specify upper right comer <420.0000.237.00003: x
drawing limit and the lower left drawing limit. You can also click i Prt.
Rename...

Select to specify the drawing limits by selecting points in the
drawing.

5.3. Grid and Grid Snap

The grid is a rectangular pattern comprised of minor and
major lines extended over the drawing area. Displaying grids
and using grids snap improve the performance of
regenerating. When you turn Snap mode on, the cursor
adheres or snaps to the invisible grids. Grid and snap settings
are effective tools to use in your drawing to ensure accuracy.
In addition, the cursor can be restricted to move orthogonally i —
only or guides can display on the screen automatically at

specified polar angle increments.

Uno} on
(o}

5.3.1. Change Grid and Snap Spacing

You can turn Grid and Snap on and off and specify their spacing on the Snap @ orting setings x
and Grid tab at the Drafting Settings dialog box. Grid spacing does not have to STl e Tt i Bame e Ersiagms ([
h . A d d . b d f hl ISnapOn(FB} I [ Grid On (F7)
match snap spacing. A wide grid spacing can be used as a reference while a Grawe
ap spacing gric spacing e
closer grid spacing helps you specify points accurately. e

[ Sheet/layout
Equal Xand Y spacing
Grid spacing

Snap type Grid X spacing: 0

(®) Grid snap Grid Y spacing:
I

@ Rectangular snap Majorine every
O lsometric snap Grd behavior
Adaptive grid

[[] Alow subdivision below grid
spacing

Display grid beyond Limits
[ Follow Dynamic UCS

Options. Cancel Help
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5.4, Use Object Snaps

Object snaps enable you to quickly select exact geometric points on
existing entities without having to know the exact coordinates of those
points. With object snaps, you can select the endpoint of a line or arc, the
center point of a circle, the intersection of any two entities, or any other
geometrically significant position. You can also use object snaps to draw
entities that are tangent or perpendicular to an existing entity.

5.4.1.  Setting Object Snaps

[EEaiynetpoint or | FERT |28

ayoutl / Layout2

SNAP  GRID

(sl (ol e RURN OSNAP | OTRACK EERVUS(E 1NN DYN

You can set object snaps using any of the following methods:

1. Choose Tools > Drafting Settings > Object Snap, and then click
one of the object snap tools.

2. On the Object Snap toolbar, click one of the object snap tools.

3. On the status bar, right-click on the Object Snap button to choose
Settings.

4. Press and hold down the Shift key while right clicking anywhere
within the drawing window to display the object snap shortcut menu,
and then choose the object snap you want to set.

@ Drafting Settings

X

Snap and Grid  Polar Tracking  Object Snap  Dynamic Input  Quick Properties M| 4 | *

Object Snap On (F3)
Object Snap modes
0 Endpoint
[ Midpoint
Center
[] Geometric Center
[INode
[ Guadrart

L& =

Hooom [H

Intersection

=[] Extension

Object Snap Tracking On (F11)

4 [ Parallel Select All
0 [Jinsertion Clear Al
L [Pemendicular

75 [ Tangent

T [ Nearest

5 [ Apparent intersection

o3¢ [ Distance from Endpoint

1 To track from an Osnap paint, pause overthe paint while in a
%=  command. Atracking vector appears when you move the cursor. To
stop tracking, pause overthe point again

Options

e | [t

Additionally, you can find an option called Distance from Endpoint. This option allows snap a certain distance from any

endpoint of objects like line, arc, spline, pline, ellipse arc, mline and any other lines. As long as you pass the cursor over an

object from its endpoints, you will see a green snap point at an accurate distance.

s S50mm distance from endpoint

Another option called Divide Segments allows snap the divided segment points of objects like line, arc, spline, pline, ellipse
arc, mline and any other lines. Before, if you want to find the divide point, first you need to generate the divided points object,

then snap those points to draw. Now as long as you pass the cursor over an object mentioned above, you will see a green snap

point at an accurate distance.
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5.4.2. AutoSnap Tools

(@ options x
Current profile: <<Unnamed Profile> i@ Cument drawing Drawing1 dwg
The automatic snap tool is a visual aid tool for snapping that St e e M
. . [ Marker isplay polar tracking vector
help you see and use object snaps more efficiently. When any S s o i
. . . . ] Display AutoSnap toolip [4] Display Auto Track tooltip
object snap is on, the system displays a marker and a tooltip W o e ot et
when you move your cursor on over a snap point. AutoSnap Gl o
turns on automatically when an object snap is on. By default, ot M Sae oerre Sae
AutoSnap marker, tooltip and magnet are on. You can change a | nE}FL |
the settings of AutoSnap on the Options dialog box. AutoSnap P ——
consists of the following snap tools: :m:“"“'”:m
[JReplace Zv;a\ua with current elevation
Marker: The object snap location is displayed when the cursor
moves over or near an object. Marker shape is determined by
the snap it is marking. | [ [

Tooltip: Indicates which part of the object you are snapping to in a flag at the cursor location.
Magnet: Attracts and locks the cursor onto the nearest detected snap points.

Aperture box: Surrounds the crosshairs and defines an area within which, when you move the cursor, system evaluates objects
for object snaps. You can determine if the aperture box is displayed or not, and the aperture box size can be changed too.

5.4.3.  Selection Cycling

With the new SELECTIONCYCLING system variable you can quickly select overlapped or coincident objects in current drawing
as well as set selection cycling options.

Enabled

Use Icon

Settings...
HELGOXLAS-H= vTa@®E A+ & EC

@ Drafting Settings X
Dynamic Input  Quick Properties  Magnifier Symmetric Draw  Selection Cycling |4 | *
. . . . . Allow selection cycling
The Selection Cycling button is located on status bar. Right-click the I
button to specify the selection cycling settings. These settings control I Diplay seection cycing st box
. . . (®) Cursor-dependent
whether a badge or the Selection dialog box displays when you hover ot
over or select an overlapping object. Distance in pichs(P)
() Static
Show title bar(B)
Options... Cancel Help
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Allow selection cycling: Turns on/off the selection cycling functionality. You can also set this option with the
SELECTIONCYCLING system variable.

Display selection cycling list box: Displays the Selection Cycling list box.

Cursor-dependent; Moves the list box relative to the cursor position according to quadrant (Top Left, Top Right, Bottom Right,
Bottom Left), distance in pixels or just static.

Show title bar: To save screen space, turn the title bar off.

To select overlapping objects, make sure that make sure that Selection Cycling on status bar is turned on. As you roll your
cursor over objects, you will see an icon indicating that multiple objects are available for selection. Click to see a list of
available objects, and then click in the list to select the object you want.

DORMITORIO PRINCIPAL [2amssis s s s s s s ssssssssssiNSsSESSESSSSSESsssSSSsssSssEssssssssss Ll

[0 s E N - 510
I == i =
Selection Cycling X 1 == o=t
DORMITORIO PRINCIPAL WHatch
NPT N, 30 M Palyine
M it
Wl Wipeout &=
MLine

DORMITORIO PRINCIPA

Model [ayoutl { Layout2

Gd V&L

5.5. Use Polar Tracking and Object Snap Tracking

Auto tracking includes polar tracking and object snap tracking. You can turn them on and off by repressing POLAR and OTRACK
buttons on the Status Bar. When the polar tracking mode is on, the cursor moves along the specified angle. When the object
snap tracking is on, the cursor moves along an alignment path based on the snap point.

5.5.1.  Polar Tracking

Guides display on the screen automatically at the polar angle increment that you specify when
polar tracking is turned on. For example, if you draw a line with angle increment set as 65
degrees with polar tracking turned on, the rubber-banding line displays at 65 degree increments.

To enable polar tracking and specify the polar angle increment:

place Editing

1. Do one of the following:

- Choose Tools > Drafting Settings from the main menu.

- On the Object Snap toolbar, click the Object Snap Settings button.
- Type DSETTINGS in the command line and then press Enter.

2. Switch to the Polar Tracking tab.

3. Select the Polar Tracking On checkbox.
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4. Do one of the following to specify the polar angle increments:

- Select an angle from the Increment Angle drop-down list. @Sd— m
- Mark the Additional Angles check box and click New to define a custom angle o oo et e
increment. R
5. Click OK. v =

- Pr—

Remark: To toggle polar tracking on and [0 oo (G i
off at any time, click the Polar Tracking
button on the status bar or press F10.

To draw objects using polar tracking:

- Turn on polar tracking and start a drawing command, such as ARC,
CIRCLE, or LINE. You can also use polar tracking with editing commands,
such as COPY and MOVE.

- As you move your cursor to specify points, notice the dotted polar

tracking line that appears at the tracking angles you specified. Points you

specify while the line is displayed conform to the polar tracking angle. oz

SNAP GRID ORTHO otrack w1 [

M

5.5.2.  Object Snap Tracking

Object snap tracking can track along alignment paths that are based on object snap points and display tooltips at the acquired
points. After you acquire a point, horizontal, vertical and polar alignment paths relative to the point are displayed when the
cursor moves over their drawing path. For example, you can specify a point along a path that is based on an object endpoint or
midpoint or an intersection between objects.

You can also use system variable TRACKPATH to control the display of polar and object snap tracking alignment paths.

pa in
Endpoint: 46.3636 < 0°

v Object

I drawn
x

4 Model | Layoutl |  Layout2

start point

sve oo orro couv EEVIDNS v EOECE® 0|
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5.6. Use Orthogonal (Ortho Mode)

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at right angles, or
orthogonally. For example, when the Draw Orthogonal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180
degrees, or 270 degrees. As you draw lines, the rubber banding line follows either the horizontal or vertical axis, depending on
which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor movement is restricted to
orthogonal equivalents within the current isometric plane. Ortho mode and polar tracking cannot be on at the same time.
Turning on Qrtho turns off polar tracking.

To fast enable orthogonal drawing: ‘h T —
Specify next point: EEDE (|<o0°

1. Press F8 or press the ORTO button at the status bar. o
ENLUEN i ORTHO OSNAP I QOTRACK DYN I MODEL -

5.1 Working with Linetypes

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. You can assign linetypes to
objects by layer, or by specifying the linetype explicitly. And also, you can specify its scale, F
load more linetypes into the program from a linetype library file, and create your own @:; %F TEm -

custom linetypes.
ByBlock

Continuous

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and P e

—  — - — DASHDOT2

BYBLOCK. You cannot rename or delete these linetypes. ) T remm

- Mare...

Remark: You should not confuse these linetypes with the hardware linetypes provided by o

some plotters. Both linetypes of dashes produce similar effects. However, if you use both
linetypes at the same time, the results can be unpredictable.

5.71.  Load Linetypes

LusoCAD includes the linetype definition files gcad.lin and gcadiso.lin. If you select gcadiso.lin, you can use ISO pen-width
option when you plot.If you want to know what linetypes are already available, you can display a list of linetypes that are loaded
in the drawing or stored in an LIN (linetype definition) file. Both linetype definition files contain several complex linetypes.

@Linatype Manager X

@ Load or Reload Linetypes hs
Linetype fiters Tood Delete
Show all inetypes | Clinver fiter = iz o]
Currert Hide details
Cumert lnetype:  Bylayer Available Linetypes
Linetype Appearance Description Lnetype Descrigtion -
’ BANKLNET .
! Bylayer BANKLINEZ Stone Bank Ao_o_ o 0 0 0000 ..
ByBlock - BANKLINE3 Stone Bank B-000000000 ..
Cortinuous — Cortinuous BANKLINE4 Gravel Bank _0._0._0._0._0._0._...
BANKLINES Sand Bank _:.__. e
BANKLINES Grass Bank
BANKLINET UYLy
o BANKLINES I
BANKLINES .
EriFlebiene BATTING Batting 55555555555555555555...
B BORDER Boder . ._ . _ ..
BORDERZ Border(Sab . . . . . . . . hd
Use paper space units for scaling 1.00 Millimeters
oK Cancel Help i 21
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m-2 |8 BT68RTB A @L@ F I
- 5 (=
Q@v

et -3, ||| LHo Bylayer
Text  Linear Insert

m & |9 8 FRIARE

5.7.2.  Change the Linetype of an Object

You can change the linetype of an object by changing the linetype
of the layer the object is on, reassigning the object to another layer,
or by specifying a linetype for the object directly.

5.7.3.  Setthe Current Linetype

By default, all objects are created using the current linetype,
which is displayed in the Linetype Control on the Properties
toolbar. To modify this current linetype, you can select a linetype
and make it current in the Linetype Manager dialog box. If the
current linetype is BYLAYER, objects are created using the
linetype assigned to the current layer.

If the current linetype is BYBLOCK, objects are created using CONTINOUS linetype until they are grouped into a block. When
you insert the block, it acquires the current linetype setting.

To make the linetype current:

Select a linetype from the Linetype Control pull-down list on the Properties toolbar, which is set to the current linetype.

5.7.4.  Control Linetype Scale

You can set global or individual scales for objects to control the display of linetypes. The Global Scale Factor and Current
Object Scale are displayed in the Linetype Manager. The Global Scale Factor value is stored in the system variable LTSCALE,
which changes the linetype scale globally for new and existing objects.

The Current Object Scale is stored in the system variable CELTSCALE, | @ tinepemsnager x
. 'y . . Linetype fitters e
which specifies the linetype scale for new objects. In a layout, You can | iswe e S Dt —
use system variable PSLTSCALE to adjust the linetype scale in urertnetioe:  BrLaver
. . Linetype Appe: Description
different viewports. Blayr
ByBlock —_—
Continuous Continuous
Remark: Setting the linetype scale too large or too small may result in
a line pattern looking like a solid line, depending on what the scale e e Tow
view is or at what scale the drawing is printed. Errrers |l
Use paper sp: s f ling 1.00 Millmeters
oK Cancel Help

To set the current individual linetype scale:
Command line> LINETYPE

Format > Linetype

1. Choose Format > Linetype
2. Click the Show Details button.

3. In the Current Object Scale field, type the linetype scale that you want to make current.

4. Click OK.
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To change the global linetype scale:

1. Choose Format > Linetype

2. Click the Show Details button.

3. In the Global Scale Factor field, type the global linetype scale that you want to change. Then click OK button.

5.8. Working with Layers

o
3 X i

Layers are like the transparent overlays you use in manual : : § §
drafting. You use layers to organize different types of drawing b = .

=  ReE & @ W& HODEN2 — Defat e ]
information. Each object in a drawing exists on a layer. When
you draw an object, it is created on the current layer. 2 e
5.8.1.  Create and Name Layers
You can create an unlimited number of layers in every drawing and use those layers for organizing information. When you
create a new layer, it is initially assigned the color white (or black, depending on your system settings) and the linetype
CONTINUOUS. By default, a new layer is also visible. After you create and name a layer, you can change its color, linetype,
visibility, and other properties.
To create a new layer:  Format > Layer Command line> LAYER
1. Choose Format > Layer
2. Click the New Layer button.
3. Type a name for the new layer and then click OK.
To change a layer name in the current drawing:
1. Choose Format > Layer
2. In the Layer Properties Manager dialog box, click the name of layer you want to change.
3. Type a new name and click OK button.
5.8.2.  Setting the Current Layer

[ Layer Properties Manager _ ==

When you start a drawing, objects are created in | 5 s & - = x
the current layer. By default, the layer 0 is setto  ||7||2% ) = % "5 (5 g comee oo, P B Novveetioese Do
the current layer, but you can also create a new &
one and make it current. Any subsequent S e G @ mw o —oaac j
objects you create are associated with the
current layer and use its color and linetype. |

To make a layer current:

1. Choose Format > Layer

2. In the Layer Properties Manager dialog box, select a layer and then click the Set Current button to make the layer current
3. Click OK.
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5.8.3.  Removing Layers

You can remove unused layers from your drawing with PURGE or by deleting the layer from the Layer Properties Manager.

5.8.4.  Controlling Layer Visibility

A layer can be visible or invisible. Objects on
invisible layers are not displayed and do not print.
By controlling layer visibility, you can turn off
unnecessary information.

To turn layers on or off:
Command line> LAYER

Format > Layer

1. Choose Format > Layer
2. Click the icon under "On" tab in the layer list.
3. Click OK button.

5.8.5.  Locking and Unlocking Layers

Locking a layer prevents you from accidentally
modifying its objects. You cannot edit a layer when
it is locked (but visible and thawed). If you lock the
current layer, you can still add new objects to it.
You can also change the linetype and color
associated with a locked layer. Unlocking a layer
restores full editing capabilities.

To lock or unlock layers:
Command line> LAYER

Format > Layer

1. Choose Format > Layer from the main menu.
2. Click the icon under "Lock" tab in the layer list.
3. Click OK button.

5.8.6.  Controlling Layer Printing

Controlling layer printing is another way you can
specify which objects print in your drawing. By
controlling layer printing, you can turn off
unnecessary information during printing. When you
turn off printing for a layer, objects drawn on that
layer are still visible, but they do not print.

Layer Properties Manager &

Current layer: LINES

S8 &% X ¢

>

»

(=2

Status NamelOn AIFreeze Lock Color Linetype Lineweight Plot Style
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J
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9 " M W. Continu.. — Defaut Colo
2 .
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g
z
Vg
v
Vg
=
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To turn layer printing on or off: ~ Format > Layer Command line> LAYER

1. Choose Format > Layer
2. Click the icon under "Plot" tab in the layer list.
3. Click OK button.

5.8.7.  Setting a Layer's Print Style

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style tables contain print
styles that you set up to control what objects look like when they print, without actually changing the objects in the drawing. If
your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These types of print style
tables automatically determine printing requirements by the color assigned to a layer or an object.

To change the print style assigned to one or more layers (only in a drawing that uses named print style tables):
Format > Layer Command line> LAYER

1. Choose Format > Layer a
2. Click the name of Plot Style in the layer list to
Caolor Linetype Lineweight Plot Style & | Plot  New viewport fr...  Description

open Select Plot Style dialog box, from which, you 0. = " SR li'ﬁtweh B ]
i i | pd Continuous Default Color_72 anges plot sfy'e for entire crawing

can specify the desired plot style. _j

Default  Color_10 = 3

Continuous

3. Click OK button. CET

5.8.8.  Freeze or Thaw Layers

You can also freeze layers to improve the performance of operations such as zooming and panning or producing hidden lines or
shaded images. When a layer is frozen, objects drawn on that layer are no longer visible.

To freeze or thaw layers:  Format > Layer Command line> LAYER
1. Choose Format > Layer

2. Click the icon under "Freeze" tab in the layer list.
3. Click OK button.

Layer Properties Manager
=

Curent layer: LINES
B4 &y XV
> (| Status Name On Freeze | Lock a Color Linetype Lineweight Plot Style Plot New viewpot
el 0 H Freeze: - - : @ “J
< CENT... H Freezes or Thaws layer globally for entire drawing @ d
7 HIDE el W W.. HIDDEN2 — Defautt Color_7 (=] o)
Vg L B W.. Continu... — Defauk Color_7 [=] 2
W.. Continu... — Defauk = i
[ 82 HIDDEN2 — Defaut Color 82 () o)
W W.. Continu... — Default Color_7 & =)

74



Chapter 5 Precision Tools and the properties of Drawing

5.8.9.  Setting the Layer Color (- xooeryore (=)

Layer Properties Manager

| Curent layer: Layer 1
Each layer in a drawing is assigned to a color. L L IR XY
» us 28 -
LusoCAD uses the BYLAYER color as the default S e s
. . . 7 CENT. ¢ o W 1524}
color setting for object creation so that new o v G % o mwf

objects are drawn in the color of the layer on
which they are inserted.

To change the layer color: ~ Format > Layer
Command line> LAYER e o) o) e |

»

1. Choose Format > Layer

2. Click the icon under "Color" tab in the layer list to open Select Color dialog box, from which, you can specify the desired
color through index, true and color books tabs

3. Then click OK button.

5.8.10. Setting a Layer's Linetype

Each layer uses a default linetype. Linetype determines the appearance of objects both on the screen and when printed. It's
recommendable to assign the BYLAYER linetype to any object that you draw on that layer.

To change the linetype assigned to one or more layers:  Format > Layer Command line> LAYER
1. Choose Format > Layer —— . . W
oo XY Select Linetype

2. Click the Linetype name in the layer list to open  [>][sew tome o Froere tosc & com [uoenme !

. ] ] < 0 rot ' W Conrous Loaded netypes
Select Linetype dialog box, from which you can Z E D mwcmws || [rewe P
V=4 o @ W.. HIDDEN2 CENTER ———e o Corter |
specify the desired linetype. — ]| [T
REFE o3 " mewoDEN2 ff T
P-4 LINES o] Il W.. Continuous

3. Click OK button.

5.8.11. Setting a Layer's Lineweight

Each layer uses a default lineweight. Lineweights determine the thickness of objects 1

both on the screen and when printed. All new layers are assigned the DEFAULT = -y
oo

lineweight, which is .25 millimeters or .01 inches. If you want a different lineweight TR oz ‘_ |

assigned to a layer, you can easily change it using Layer Properties Manager. o oo
e f.

. i N — Default Col 0.30 mm
To change the lineweight assigned to one or more layers:  Format > Layer — Dok C3
Command line> LAYER = =

[ OK ] [ Cancel ] [ Help

1. Choose Format > Layer

2. Click the Lineweight name in the layer list to open Lineweight dialog box, from which, you can specify the desired
lineweight.

3. Click OK button.
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5.8.12. Filter List of Layers

You can use a layer filter to limit the display of layer names in

Currert layer: Layer 1 Filter name:
the Layer Properties Manager. The following properties can F|& @ » ‘i?] e
. . . e ? || Status Name On -
be mC|Uded m the fllter deflnltlon Layer names, CO|0FS, = 0 3 Status Name On Freeze Lock Color Linetype Lineweight PlotStyle Plot
[ _cev_+f
linetypes, lineweights, and plot styles. Whether layers are = e
. W Llayert ()
locked or unlocked, turned on or off, frozen or thawed in the o x|
7 LINES ,

current viewport or all viewports. When setting filter re—
conditions, you can also use wild-card characters to filter

status Name On Freeze Lock Color Linetype Linewsight FlotStyle Flot

= 0 9, }:1 " MWw.. Continu... — Default Color_7 %
, \ = CEN.. ) % ] BIIS2CENTER — Default Color_i52
names by name. For example, typing D* displays layer name | > = =pe @ @ Beom.—om.ces &
S Al Shows Blyen.id) |~ HDE ) % G BW.HDDEN2 —0.235..Cobr7 (@
L ——— " 1= unes ) 0 ' M. Continu.. — Default coler 7 (5

preceded with D, just click Add button if the filter name has
been specified.

To filter list of layers:

1. Choose Format > Layer

2. Click the New Property Filter icon, located at top left of the window.

3. In the Layer Filter Properties dialog box, under filter definition, click the tabs properties you want to filter. Then click OK.

5.8.13. LAYULKALL

~N (7 iiv| #Ease @jbpode BlBooean QR v M ~(| @ TS S SET S
If you have a lot of layers locked and need to SO0 O | Eome B A @rd v | B weesse
. . . Line Pu\ihne C\rv:\e Avrc I ~ || @ Move (Rotate ®3 Copy - v W]~ Dm.;ﬁ;gs o
unlock them all in your drawing, you can input - — s
LAYULKALL command to unlock all the locked 1/ LA ewy X b f“ @
layers immediately. “ ‘ Layer

5.9. Dislaying Lineweights

Lineweights are displayed differently in paper space layout than model space. Lineweights are useful for graphical
representations of different objects and information.

5.9.1.  Display Lineweights in Model Space

Properties o x [T Crawingl.dwg | sampledwa 2

In model space, a 0-value lineweight is displayed as a
pixel, and other lineweights are display with a pixel width
proportional to their real-unit value. In model space,
lineweight display does not change with the zoom factor. A
lineweight value that is represented by a width of several
pixels is always displayed using the same number of
pixels. In model space, press LWT button on the status
toolbar to turn lineweight display on and off.

b Moded Layoutl [ Layout2 /

> one EFIETEEIIEmENETY 00 |
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5.9.2.  Display Lineweights in Layouts

In paper space (layout tab), lineweights are displayed in exact plotting width. In plot preview and paper space, lineweights are
displayed in real-world units, and lineweight changes with the scale factor. From the Plotting Scale tab of Plot dialog box, you
can control the lineweight plotting and scaling in a drawing. In paper space, press LWT button on the status toolbar to turn
lineweight display on and off. This change does not affect the lineweight plotting.

Properties & x4 DrawingLawg | sampleawg %
T 1
General - r -1
Color mBylayer
Layer Lines

Linetype — Bylayer
Linetype scale |7
Plot Stle BYCOLOR

5.10.  Spell Command

Users can check the spelling of all text as it is entered in your drawing with Spell command. Users can also specify the specific
language dictionary that is used and customize and manage multiple custom spelling dictionaries.

3
Check Spelling ==
r
Display the areas you want checked for spelingl/)
Entiedawng ]|
Cunient custom dictionary(M)
[Engish 7 SelingsD )
ot in dictionaylld) T
Proffessional T
uggestions| )
Professional Ignore(l)
Professional | Ignore Allia) J
[ ChangelC) J
[ Chengerm) |
[ oesew ][ HelpH)
|

511, Hardware Acceleration

Hardware Acceleration leverages the GPU, which excels at handling images,
to assist the CPU, thereby enhancing graphic display quality and work
efficiency, and improving overall performance. Enabling hardware
acceleration provides more efficient, high-quality real-time display effects
compared to the CPU, and offers better highlight effects.
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Hardware Acceleration can automatically determine whether to activate based
on the user's hardware configuration. It can also be manually controlled using
the command GRAPHICSCONFIG, or by clicking the Performance Settings icon
in the status bar.

@ Graphics Performance

Hardware configuration

Graphics Card : NVIDIA GeForce RTX 2050
Driver Version : 310152919
OpenGL Version : 46.0

Graphical Display Settings

Hardware Acceleration 158

Take advantage ofthe GPU to optimize graphics rendering efficiency.If
compatibility issues arise, turn off hardware acceleration and then retry.

Smooth Line Display

Remove jagged edges from the graphic for a smoother graphic display.

Ok Cancel

> Hardware Configuration:

Help(H)

Displays the current user's hardware environment, including the Graphics Card, Driver Version, and OpenGL version

information.

> Graphics Display Settings:

Hardware Acceleration; Enable to activate Hardware Acceleration, using GPU for optimized graphics rendering. If disabled, the

mode switches to the default "Software Mode”.

Smooth Line Display; Removes jagged edges from the graphic for a smoother display.

System Variable Description Value Value Description
Indicates whether Hardware Acceleration is 0 Disabled
HARDWAREACCELERATE enabled or disabled. (Read-only)
1 Enabled

Note: If hardware acceleration cannot be enabled, it may be due to the hardware environment not meeting the requirements:

> OpenGL version below 4.2 or outdated driver version. You can try upgrading the system's graphics driver.

> If you encounter compatibility or performance issues, you can try disabling hardware acceleration.

> To ensure the best software experience, Windows 7 and earlier versions of the operating system are not supported.
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If your system has dual graphics cards (dedicated and integrated), it is recommended to manually set the high-performance
graphics card to achieve better display performance. The method to set the high-performance graphics card depends on the
graphics card model and its corresponding software and driver version. Taking Windows 11 as an example, the manual setting

method is as follows:

> Right-click on the desktop and select "Display settings".

> In"Display settings", find "Graphics".

> Onthe "Graphics" page, under "Custom options for apps", click "Browse", find gcad.exe in the installation path, and add it

to the list.

> Click on the LusoCAD application in the list and then click "Options".

> Inthe Graphics preference dialog box, select "High performance" and click save.

Compared to the previous version, LusoCAD 2025 shows improved display effects in the following areas:

5.11.1. Highlight Display

Hardware Acceleration provides clearer highlighting effects, marking selected objects more distinctly. This allows users to
identify, select, and operate more accurately, enhancing the user experience.

System Variable Description Value Value Description
Controls the highlight display mode of 0 Dashed lines
SELECTIONEFFECT selected objects when Hardware
Acceleration enabled 1 Blue glowing line highlighting effect
Sets the colour of the glowing highlighting
SELECTIONEFFECTCOLOR effect when objects are selected 0 Valid values are from 0 to 255
Note: Only applies when
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SELECTIONEFFECT is set to 1.

5.11.2. Basic Visual Styles Support
Added support for two visual styles: Conceptual and X-ray:

> Conceptual Visual Style: Typically used in the early design stages, this style makes the graphics appear simpler.
> X-ray Visual Style: Allows for a clearer view of the relationships between objects.

These visual styles control the display of drawings, making objects clearer and improving drawing efficiency.

Conceptual X-ray
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5.11.3. Lighting Improvements

LusoCAD optimized lighting, making the effects softer and allowing adjustments based on real-time preview. Key improvements
include:

»

Point Light: Provides uniform illumination in all directions, suitable for simulating indoor lighting or general ambient
lighting.

Spotlight: Concentrates light in a small area, ideal for highlighting specific objects or emphasizing focal points.
Web Light: Displays the range or area formed by the light, simulating the radiation range of light.
Target Point Light: Specifies a point as the light source, commonly used to simulate a light bulb or flame.

Free Web: Illuminates the surrounding environment without being blocked by surrounding objects.

Hardware Acceleration OFF Hardware Acceleration ON
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6. Create Objects

Drawings are made up of objects. In general, you draw objects by specifying points with the pointing device or by entering

coordinate values at the command prompt.

6.1. Draw Linear Objects

6.1.1.  Lines

A line consists of two points: a start point and an endpoint. You can connect a series of lines, but each line segment is

considered a separate line object.

Todraw a line:  Draw > Line Command line> LINE
1. Choose Draw > Line from the main menu.

2. Specify the start point.

3. Complete the first line segment by specifying the endpoint.
4. Press Enter to complete the command.

To start a new line at the endpoint of the last line drawn, start the
Line command again and press Enter directly at the "Specify first
point:" prompt.

6.1.2.  Multilines

Multilines consist of several parallel lines, called elements.

Point
B

peciyrestponior ][ s |

Point
A

=

4 b # ' Model /Layoutl / Layout?

[ErReE
[Select object: Speciy opposte comer: 1 found
[Select object:

[Command: LINE

ISpecy fist

JLRNS LTl PoLAR | oshiap | orack RVGECIE Dvh | Mc

You can determine the position of elements by specifying offset from the origin of each element. By default, multiline objects
contain two elements. You can create and save new multiline styles by yourself or modify existing mline styles.

To draw a multi-line: ~ Draw > Multiline
1. Choose Draw > Multiline from the main menu.
2. Specify the start point.

3. Specify the endpoint.

4. Press Enter to complete the command.

Curent Muliine Style: - STANDARD
Styles:

Preview: STANDARD

Command line> MLINE

< » » " Model {Layoutl {Layout2

cify start point or [Justification/Scale/STyle]:
cify next point:

cify next point or [Undo]:

pecify next point or [Close/Undo]:

-528.9422, -129.3366, 0

SNAP GRID ORTHO POLAR [eNITY

’anm Maltine

Descrpton NEW STYLE|

Caps Eements
Ofiset Color Linetype

Line: i [ 0500 BYLAYER  Bylayer
05 BYLAYER  Bylayer

Outerarc: [ [

breraes [ =]

Angle 000 000 4 Deete
il 0,000
Offset.
Fillcolor: CINene =
Color: WEy Lo
Displayjoims: [ frenees:
oK Cancel ‘ Hep |
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6.1.3.  Rays

Aray is a line in three dimensional space that starts at a point
and extends to infinity. Because rays extend to infinity, they
are not calculated as part of the drawing extents. The default
method for drawing a ray is to select the start point of the ray
and then specify its direction.

Todrawaray: Draw > Ray Command line> RAY

1. Choose Draw > Ray from the main menu.
2. Specify the start point and the direction.
3. Press Enter to complete the command.

6.1.4.  Construction Lines

A construction line is a line through a given point, oriented at a specified
angle in three dimensional space and extending to infinity in both directions.
You can also draw a construction line at a specific angle or at an angle

relative to an existing object.

To draw a construction line:  Draw > Construction Line

Command line> XLINE

1. Choose Draw > Construction Line from the main menu.
2. Specify a point along the line.

3. Specify the direction.

4. Press Enter to complete the command.

6.1.5.  Polylines

A polyline is a single object with connected sequence of line segments or/and arc
segments. When you draw a polyline, you can switch to different options. After you
draw more than one segment, you can close the polyling, undo or finish.

To draw a polyline with straight segments:
Command line> PLINE

1. Choose Draw > Polyline from the main menu.

2. Specify the start point.

3. Specify the endpoint of each segment.

4. Press Enter to end or enter ¢ (close) to close the polyline.

Draw > Polyline

it nite
we

i« 4 v 1 " Model {Layoutl / Layout2

=g
a (Speciy base paint or [Displacement] <Displacement>: Specy secand paint or <us
e first point as displacement:
Command: RAY

peciy start point

ks Point
LA

X

Speciy through point

11494.5506, 1330.2165, 0

HITLINNS U TGl PoLar | osnap | otrack UMD ovi | moDEL -

=

v

i—x

M 4 r W Model ; Layoutl / Layout2

& ICommand: “Cancel®
B {Command: *Cancel®
Command: Cancel™
Command: “Cancel®
Command: "Cancel
Command: XLINE
{Specify a point or [Hor/Ver/Ang/Bisect/Offset]: H
Specify through point:

{Specify through poirt:
{Specify through poirt.

i E ORTHO [Ze]EEN OSHAP [ OTRA

LX:L—M—

4 4 b M Model /Layoutl / Layout2

& [Specify start point:

§ [Current line-width is 0.0000

(Specify next point or [Arc/Haffwidth/Length,Undo/MWidth]:
{Specify next point or [Arc/Close/Halfwidth./Length/Undo, Width]
{Specify next point or [Arc/Close/Halfwidth./Length/Undo,/Width]
Specify next point or [Arc/Close/Halfwidth/Length./Undo/Width]:
Specify next point or [Arc/Close/Halfwidth/Length./Undo /Width]:

11497.¢ 9.4548 0 SNAP  GRID |gelaiiel POLAH
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To draw a line and arc combination polyline:
Draw > Polyline Command line> PLINE

1.Choose Draw > Polyline from the main menu.

2.Specify the start point.

3.Specify the

endpoint.

4 At the command prompt, choose Arc.
5.Specify the endpoint of the arc segment.
6.To complete the command, Press ENTER.

To create closed polylines:  Draw > Polyline

When creating polylines with PLINE command, the Close option is only available if no less than two line or arc segments are

1

peciy ndpomesraeer |7 ]
X

M 4 v ¥ 4 Model / Layoutl /A Layout2

®
n

1

ISpecify next point or [Arc/Close/Halfwidth./Length./Undo./Width]:
\Specify next point or [Arc/Close/Halfwidth./Length/Undo/Width]:
ISpecify next point or [Arc/Close/Halfwidth/Length./Undo.Width]: A
\Specify endpoint of arc or
[Angle/CEnter/Close/Direction/Halfwidth./Line/Radius/Second pt/Undo. Width]:
\Specify endpoint of arc or
[Angle/CEnter/CLose/Direction/Halfwidth./Line/Radius/Second pt/Undo. Width]:

SNAP  GRID [gelinpglely FPOLAR

14639104, 13

OSMY

Command line> PLINE

drawn. A closed polyline object is drawn if you connect the start point of the polyline to endpoint of the last line or arc segment

with a line or arc.

Layer 0
Linetype

LWPolyline
Color Bylayer

Bylayer

4 4 » b Model [ Layoutl / Layout?

|/ X

{Specify endpoint of arc or
[Angle/CEnter/CLose/Direction.Halfwidth/Line/Radius., Second pt/Undo,/Width].
{Specify endpoint of arc or
[AngleCErter/ClLose/Direction,Halfwidth /Line /Radius./Second pt/Undo./Width]: LINE
ISpecify next poirt or [Arc/Close/Halhwidth /Length,/Undo,/Width]:

ISpecify next poirt or [Arc/Close/Halfwidth /Length,/Undo,/Width|: CLOSE

To create wide polylines:  Draw > Polyline

(S0 ORTHO [zl OSNAP

Command line> PLINE

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE command. The Width and
Halfwidth options set the width of the next polyline segments you draw. You can set the width of individual segments and make

them taper gradually from one width to another.

| [ o]

M« » M Model s layoutl /4 Layout?

a

Speciy ending width <0.3000>

Specify next point or [Arc/Close/Halfwidth/Length/Undo Width]:
|Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:
ISpecify next point or [Arc/Close.Halfwidth/Length/Undo/Width]
|Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:
(Specify next point or [Arc/Close/Halfwidth/Length/Undos/Width]
Specify next point or [Arc/Close/Halfwidth/Length/Undo Width]:

79,0 SNAP GRID ORTHO P
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To draw a boundary polyline:  Draw >Boundary

Pick Points

1. Choose Draw > Boundary from the main menu.
Island detection

2. Specify the objects by doing one of the following: oy rterton

Retain boundaries
- Current viewport Define a boundary set with all Object type:
entities in the current viewport. if this option is Boundary set
selected, any boundary set currently used will be (Corrt Vopert -] =
canceled. [ ok ] [ cancel | [ Hep

l

Command line>BOUNDARY (23 Beunder cresion SRl 5|

- Existing set Click New button to switch to the drawing area, and prompt users to select objects for defining boundary sets.
Press Enter to return to the dialog box after selection. This option is only available after selecting objects by using the New
button.

3. Select the Island Detection option.

4. Click Pick Points.

5. In the drawing, click inside the area whose closed perimeter forms the boundary, not on the polyline itself. If desired,
continue clicking inside additional closed perimeters.

6. To complete the selection, press Enter.

7. In the Boundary Creation dialog box, click OK.

Y

—

|

[Pickintemal point:_|

—_—

v

o

LWPalyline
Color Bylayer
Layer 0

Linetype Bylayer

4 4 ¢ Model / Layoutl / Layout? H 4 + ¥ Model £ Layoutl / Layout?
% |Pick intemal point: Selecting all objects... X |Analyzing the selected data...Emor analyzing intemal islands
1 [Selecting everything visible... 1 Pick intemal point:

lAnalyzing the selected data... BOUNDARY created 1 polylines

lAnalyzing the selected data... Emor analyzing intemal islands
Pick intemal paint:

Command:

Command:

SNAP GRID ORTHO

11559.7166, 1350.4103, 0

11561.1469, 1351.7565, 0

6.1.6.  Polygons

Creating polygons is a simple way to draw squares, equilateral triangles,
octagons, and so on. Polygons are closed polylines with between 3 and
1,024 equal-length sides.

To draw a polygon by vertex:  Draw >Polygon

Command line>POLYGON

4 4 » » “Model {Layoutl {Layout? /

1% |Enter number of sides <4>: 6

; pecify center of polygon or [Edge]:

|Enter an option [Inscribed in circle/Circumscribed about circle] <1>:1

! |[Specify radius of circle:
-423.689, -223.8862, 0

1. Choose Draw > Polygon from the main menu.
2. Type 6 to specify six sides for the polygon.

3. Specify the center of the polygon.

4. Specify the vertex of the polygon.

SNAP GRID ORTHO POLA
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6.1.7.  Rectangles

Rectangles are closed polylines with four sides. You draw a rectangle by specifying its opposite corners. The rectangle is
normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the rectangle to
any angle.

To draw a rectangle:  Draw > Rectangle
Command line>RECTANG

1. Do one of the following:
- Select Draw > Rectangle on the main menu.
- Click the Rectangle tool or type RECTANG command and press j»

Enter.

€ < » » Model {Layoutl [Layout?

B (Specify fillet radius for rectangles <0.0000>: 10
o Specify first comer point or [Chamfer/Elevation/Fillet/Thickness/Width]:
§jSpecfy other comer point or [Area/Dimensions/Rotation]:

SNAP GRID ORTHO POLAR [eIPUE OTRACK  LWE]

Eﬁpmfy first comer pointt or [Chamfer/Elevation/Fillet/Thickness/Width]: F

2. ldentify one corner of the rectangle or enter an option. Specify
first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:

-272.9449, -287.2165, 0

3. Identify the opposite corner of the rectangle or enter an option. Specify other corner point or [Area/Dimensions/Rotation]:

6.1.8.  Points

You can draw a point object formatted as either a single dot or as one of 19 other possible display styles.

To draw a point:  Draw > Point Command line>POINT + 4
T4
1. Choose Draw > Point > Single Point from the main menu. . n %
2. Specify the location of the point. -_._
x

To draw several points:

1. Choose Draw > Point > Multiple Point from the main menu.

2. Specify the location of each point.

To change the size and appearance of point objects:
Format > Point Style Command line>DDPTYPE

1. Choose Format > Point Style from the main menu.
2. Under Point Style, select the style you want.

3. Under Point Size, specify the point size, or choose one of the options.

4. Click OK button.

M 4 » » 4 Model £ layoutl / Layout?

K Command:
@ [Command:
Command: _POINT

Cumrent point modes: PDMODE=2 PDSIZE=-3.0000
Specify the pairt:

SMAP GRID ORTHO POLAR |[ReRiiFNS

©) Set Size Relative to Screen
Set Size in Absolute Units

ok J( cocel J[ b0

When you regenerate the drawing, all point objects change to reflect the new size and appearance settings.
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6.1.9.  Freehand Sketches

A freehand sketch consists of many straight line segments, created either as individual line objects or as a polyline. Before you
begin creating a freehand sketch, you must set the length, or increment, of each segment. The smaller the segments, the more
accurate your sketch, but segments that are too small can greatly increase the file size.

To create a freehand sketch:

1. On the command line, enter SKETCH and press Enter.

2. At the "Record increment" prompt, enter the minimum line segment length.

3. Move the cursor to the drawing area, then click or enter p (pen) to begin sketching. +
4. Click or enter p (pen) again to lift the pen up and stop drawing, so that you can '

move the cursor around the drawing area without drawing.
5. Enter R (Record) at any time to write into the drawing the line you're drawing and

£ Command: SKETCH
those al[eady draWn 1 [Record increment <1.0000>: 3

(Sketch. Pen eXit Quit Record Erase Connect P

6. Press Enter to complete the sketch and write all lines into the drawing. <Pen down> <Pen up>

4 4 » p s Model / Layoutl 4 Layout2

399 lines recorded. <Pen down

To erase freehand sketch lines:
1. While running the SKETCH command, enter E. If the pen was down, it moves up. +
2. Move the cursor to the end of the line you drew last and then move it back as far

along the line as you want to erase.

3. To end the erasure and return to the sketch Command prompt, enter E. If you want g s
. . . . . Command: SKETCH

to change the current viewport while sketching, make sure the pen is up and all lings | Feeosinoenen 0.

(Sketch. Pen eXit Quit Record Erase Connect E
Erase: Select end of delete.

4 4 » b 4 Model / Layoutl / Layout2

were written into the drawing.

-7000.3231, -597 4671, 0 SNAP GRID ORTHO POLAR

6.2. Draw Curved Objects

6.2.1.  Arcs

An arc is a portion of a circle. There are numerous ways to define an arc, the default method uses three pick points, a start
point, a second point and an end point. Using this method, the arc will start at the first pick point, pass through the second
point and end at the third point. Once you have mastered the default method try some others:

- 3 points

- Start, Center, End

- Start, Center, Angle

- Start, Center, Length

- Start, End, Angle

- Start, End, Direction

- Start, End, Radius

- Center, Start, End

- Center, Start, Angle

- Center, Start, Length

- Continue

— =+ e+ 4 o
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2nd
point ™ 5 ot
" Start, Center, End
1st 3rd
poin oint T Stot, Center Angle
Start, Center, Length
Y -
s [ start, End, Direction

4 4 ¢ » 4 Model £ Layoutl ¢ Layout?

Start, End, Radius

*

Command: _MTEDIT

o [Command: ARC

\Specify start point of arc or [Center]:

\Specify second point of arc or [Center/End]: <DORTHO Off>

” Center, Start, End

Center, Start, Angle

Specify end point of arc:

To draw an arc by 3 points as sample:  Draw > Arc>3 points

1. Choose Draw > Arc > 3 Points from the main menu.
2. Specify the start and second points.
3. Specify the endpoint.

6.2.2.  Circles

The default method for drawing a circle is to specify a center point and radius.

You can draw circles using any of the following methods:
- Center, Radius

- Center, Diameter

- Concentric

- 2 points

- 3 points

- Tangent, Tangent, Radius

- Tangent, Tangent, Tangent

To draw a circle by specifying its center and radius:
Draw > Circle>Center, Radius Command line>CIRCLE

1. Choose Draw > Circle > Center, Radius from the main menu.
2. Specify the center point.
3. Specify the radius of the circle.

-10 5 6, 0 SMAP GRID ORTHO  POLAR [Reirt [ejiarie s

" Center, Start, Length

(e Continue

enter, Radius

enter, Diameter

p Tan, Tan, Radius

Tan, Tan, Tan

Center

point TRadius
point _ "Rac
[inser]
iy =i e

M 4 b b ' Model £ Layoutl / Layout2

Hd>n

(Specify origin of UCS or [Zfs/3 poirts/OBject/Face/View/X/Y/Z] <0.0.05:
Command: C

CIRCLE Specify center point for circle or [3P/2P/ Ttr/Arc/Muttiple]:

iSpecify the radius of circls or [Diamster]:

SNAP

a

GRID ORTHO  POLAR

88



Chapter 6 Create Objects

To draw a circle tangent to existing objects:
Draw > Circle>Tan, Tan, Radius Command line>CIRCLE

1. Choose Draw > Circle > Tan, Tan, Radius from the main menu.

2. Select the first tangent point on the object to be tangent with the circle.

3. Select the second tangent point on the object to be tangent with the circle.
Specify the radius of the circle.

6.2.3.  Ellipses

4
4 4 » »# “Model £ Layoutl f Layout2 q,

IRCLE Specify center point for circle or [3P/2P/Ttr/Arc/Multiple): T
pecify point on abject for first tangent of circle

pecify point on abject for second tangert of circle

pecify radius of circle: Specify second poirt:

-3.2505,10.2104, 0 SMAP GRID ORTHO  PC

The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse and then specify a distance
representing half the length of the second axis. The endpoints of the first axis determine the orientation of the ellipse. You can

draw ellipses using any of the following methods:
- Center

- Axis, End

- Ellipse, Arc

To draw an ellipse by specifying the axis and endpoints:
Command line>ELLIPSE

Draw > Ellipse>Axis

1. Choose Draw > Ellipse > Axis, End from the main menu.
2. Specify the first endpoint and second endpoint.
3. Specify a distance for half the length of the second axis.

To draw an elliptical arc by specifying the axis endpoints:  Draw > Ellipse>Arc

1. Choose Draw > Ellipse > Arc from the main menu.
2. Specify the first endpoint.

3. Specify the second endpoint.

4. Specify the half length of the other axis.

5. Specify the start angle of the arc.

6. Specify the end angle.

6.2.4.  Splines

Spline is a smooth curve that passes through a series of control points. Multiple
points are required for drawing irregular splines that can be closed as well, so the
start and endpoints are coincident and tangent. The tolerance in a spline, describes
how precisely fits between multiple points (lower tolerance, more closely the spline
fits the points). Usually there are two ways to create splines:

- Create a spline converted from a polyline using Spline option of PEDIT command.
- Create a spline using SPLINE command.

2nd
endpoint

st ey dmer o oo

endpoint

4 4 » b 4 Model £ Layoutl / Layout?

ISelect object
|Speciy base pairt or [Displacement] <Displacement: Speciy second poirt or <us
e first point as displacement>:

Command: ELLIPSE

|Speciy axis endpoint of elips or [Arc/Canter]:

|Speciy other endpaint of axds:

ISpecty distance to other axis or [Rotation]

SNAP GRID ORTHO POLAR OSN.

Command line>ELLIPSE

2nd
endpoint

1st
endpoint

M 4 » w Model / Layoutl / Layout2

# |Specify axis endpoint of elipse or [Are/Center]: ARC
& |Specify axis endpoint of elliptical arc or [Center]:
|Specify other endpoint of ads:

[Specify distance to other axis or [Rotation]:

|Specify start angle or [Farameter]: 15

|Specify end angle or [Paremeter/Included angle]:
Command

M 4 » M 4 Model /layoutl / Layout?

Command: spine

Unknown command "spine”. Press F1for help.
Command: SPLINE

Specify first point or [Object]:

(Specify next point:

|Specify next point or [Close/Fit tolerance] <start tangent>
|Speciy next point or [Close/Fit tolerance] <start tangent>:

-98.9606, £.5228, 0 SNAP  GRID ORTHO  POLAH
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To draw a spline:  Draw > Spline Command line>SPLINE
1. Choose Draw > Spline from the main menu.

2. Specify the first point of the spline.

3. Specify the second point of the spline.

4. Specify as many more points as you want.

5. When you have finished, press Enter.

Specify next point or
To draw a closed spline:  Draw > Spline Command line > SPLINE
1. Choose Draw > Spline from the main menu.
. . . . 4 4 » b . Model /Layoutl / Layout2
2- Specny the fIrSt p0|nt Of the Spllne % ISpecy next point or [Close/Fit tolerance] <start tangent:
. . . # |Specify next point or [Close/Fit tolerance] <start tangent>:
3. Specify the second point of the spline. Specty s port o s/ trancel <t tanger
Specify next point or [Close/Fit tolerance] <start tangent>:
4. Specify as many more points as you want. ety ot ot o Kl oo ot ot
. . Specify next point or [Close/Fit tolerance] <start tangent >
5. When you have finished, on the command line, type C and press Enter. 110,425, 5591, 0

6. To complete the command, specify the tangent point.

M 4 b » 4 Model 4 Layoutl / Layout?

* |Specify next point or [Close/Fit tolerance] <start tangent=:
[Specify next poirt or [Close/Fit tolerance] <start tangent>:
{Specify next point or [Close/Fit tolerance] <star tangent>:
[Specify next poirt or [Close/Fit tolerance] <start tangent>:
ISpecify next point or [Close/Fit tolerance] <start tangent>: C
[Specify tangent:

ICommand:

5, -14.7229, 0 SHAP  GRID

=

6.2.5.  Helix

Creates a 2D spiral or 3D spring. Initially, the default base radius is set to 1. During

a drawing session, the default value for the base radius is always the previously ‘.h\.
entered base radius value for any solid primitive or helix. The base radius and top g‘
radius cannot both be set to 0. 2, \ 2
To draw a helix:  Draw > Helix Command ling>HELIX

The following prompts are displayed: Number of turns = 3 (default)Twist = CCW (default)
1. Specify center point of base: Specify a point

2. Specify base radius or [Diameter] <1.0000>: Specify a base radius, enter d to specify the diameter, or press ENTER to
specify the default base radius value

3. Specify top radius or [Diameter] <1.0000>: Specify a top radius, enter d to specify the diameter, or press ENTER to specify

the default top radius value

Y

.

4 4 ¢ ¥ “Model /layoutl / Layout2

W 4 » » " Model {Layoutl [ LayouZ
P [Command: HELIX
Tums = 3.0000 Twist =CCW * Command.
Specify center point of base: M= STRETCH =
ISpecity base radius or [Diameter] <12.6743> Specify stretch poirt or [Base poirt/Copy/ Undo/eXtl:
ISpecify top radius or [Diameter] <6 5348> mand Spect copostc comer
'Speciy helix height or [ods endpoirt/ TumsAum Height AWist] <30.0000>:50 m::: g nee
Command: e

GRID ORTHO POLAR
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6.2.6.  Donut

Donuts are solid, filled circles or rings created as closed, wide polyline. The system variable FILLMODE controls whether to fill
the donut or not. FILLMODE is set to 1, creates filled donuts; if FILLMODE is set to 0, creates without filled.

To create a donut, you specify its inside and outside diameters and its center. You
can continue creating multiple copies with the same diameter by specifying
different center points. To create solid-filled circles, you can just assign the same EEm—

value for the inside radius and outside radius.

To draw a donut: ~ Draw > Donut Command line>DONUT 14> AModel 4 Lajoutl ALayoutz
):l g‘?;c?fy origin of UCS or [Z4is/3 points/OBject/Face View XY /2] <0.0.0>
Command: DONUT
1. Choose Draw > Donut from the main menu. oot ade daneer of dont 20000 10
2. Specify the inside diameter of the donut. e o
3. Specify the outside diameter of the donut. o : SNAP _GRID ORTHO _POLAR

4. Specify the center of the donut.
5. Specify the center point to draw another donut, or press Enter to complete the command.

6.3. Create 3D Objects

With 3D models, you can: View entities in three dimensions, create three-dimensional entities, edit entities in three-
dimensional space, edit three-dimensional solids, display hidden-line and shaded views of three-dimensional entities.

6.3.1. 3D Thickness and Elevation

By default, the program creates new two dimensional objects with a zero
elevation and thickness. The easiest way to create a three dimensional
object is to change the elevation or thickness property of an existing two
dimensional object. You can extrude any two dimensional object into a three
dimensional object by changing the thickness of the object to a nonzero
value. For example, a circle becomes a cylinder, a line becomes a three
dimensional plane, and a rectangle becomes a box.

4 4 » n " Model {Layoutl /Layout2

To set the current elevation:  Command line>CHANGE 1 fsoeoty chenge port or [Properet P
[Enter property to change [Color/Elev/LAyer/L Type/t Scale/L Weight/ Thickness/Mater
al/Annotative): E
(Specify new elevation <0.0000>: 40
[Enter property to change [Color/Elev/LAyer/LType/t Scale/LWeight/ Thickness/Material/ Annctative]:

1. Type CHANGE on the command line, and then press Enter after selecting TR
the two dimensional object(s).
2. Enter P (Properties) and press Enter.

Command Line X
3. Enter E (Elev) and press Enter. Command: CHANGE .
. . Select object: Specify opposite comer: 1 found
4. Specify a new elevation, and then press Enter. T et obieet

[Specify change point or [Properties]: P

Enter property to change [Color/Blev/Lbyer/L Type/t Scale/L Weight/Thickness/Mater
jal/Annotative]: T

[Specify new thickness <0.0000>: 40

Enter property to change [Color/Blev./Liyer/LType/tt Scale/LWeight/ Thickness/Mater
jal/Annotative]:

Command: M -

Command: < G
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To set the current thickness:  Command line>CHANGE

1. Type CHANGE on the command line, and then press Enter after selecting the two dimensional object(s).
2. Enter P (Properties) and press Enter.

3. Enter T (Thickness) and press Enter.

4. Specify a new Thickness, and then press Enter.

6.3.2. 3D Faces

You can create a three dimensional face, which consists of a section of a plane in three dimensional space. After you specify
the fourth point, the program continues to prompt you for additional faces by alternating prompts for the third point and fourth
point to allow you to build a complex three dimensional object.

To create a three dimensional face: o e e ]

. isible]:
Draw > Modeling>Meshes>3D Face ety b et e s face> 8
Command line 3DFACE e . :

iSpechy third poi le] <exdt>

1. Type 3Dface on the command line.
2. Specify the first point of the three x
dimensional face.

3. Specify the second, third, and fourth points.

4. Specify the third and fourth points for additional faces.
5. To complete the command, press Enter.

6.3.3.  Ruled Surfaces

You can create a ruled surface, which is a three-dimensional body that
approximates the surface between two existing entities. You select the
two entities that define the ruled surface. These entities can be arcs,
circles, lines, points, or polylines.

To create a ruled surface:
Draw > Modeling>Meshes>Ruled Mesh

ment wireframe densty: SURFTAB1=6

Command line>RULESURF elect first defining curve: A

elect second defining curve -

p:mmand: 4 [

1. Type RULESURF on the command line.
2. Select the first defining object.
3. Select the second defining object.
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6.3.4.  Tabulated Surface

Tabulated surface meshes are used as a serial of paralleled
polygon on specified path, you should draw direction vector
and original object before creating a tabulated surface. The
objects like a line, arc, circle, ellipse, or 2D or 3D polyline can

be used as outline curves for defining polygons.
Command Line

Command: TABSURF
To create an extruded surface mesh: Curent wirsframe density: SURFTAB1=6
. Select object for path :
Draw > Modeling>Meshes> Tabulated Mesh ocioct object for droction vector
Command line>TABSURF Command:

1. Type TABSURF on the command line.
2. Select the object to extrude.
3. Select the extrusion path.

6.3.5.  Revolved Surface

Use REVSURF command to create a surface of revolution by rotating a profile of the object about an axis. The object to be
revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, polygon, closed spline or torus. REVSURF is useful for
surfaces with rotational symmetry.

To create a revolved surface mesh:  Draw > Modeling>Meshes>Revolved Mesh Command line>REVSURF

1. Type REVSURF on the command line.

2. Select the object to revolve.

3. Select the object to be used as the axis of revolution.
4. Specify the starting angle.

5. Specify the number of degrees to revolve the object.

Command Line x
ICommand: REVSURF

Current frame densities: SURFTAB1=6 SURFTAB2=6
(Select objects to rotate

[Select object that defines the @ds of revolution:
[Specify start angle <0>: 360

ISpecify included angle (+=cow. —=cw) <3605 =
Command

6.3.6.  Solid Box

A solid box consists of six rectangular surface planes. The base of the box is always parallel with the xy plane of the current
UCS. The length of the box is mapping to X axis of current UCS, and its width maps to Y axis, and height maps to Z axis.
RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a box using EXTRUDE.
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To create a box:  Draw > Modeling>Box Command line>BO0X

1. Choose Draw > Modeling > Box from the main menu.

T
2. Specify the first comer of the base. Koot s coe or Kt

3. Specify the opposite corer of the base. et vt e rotr
4. Specify the height. R

6.3.7.  Solid Cone

By default, the cone's bottom lies on the XY plane of the current UCS. The cone height is parallel to the Z axis. The apex
determines the height and orientation of the cone. You can draw a 2D circle and then use EXTRUDE to taper the circle at an
angle along the Z axis to create a solid cone. To complete the truncation, you can subtract a box from the tip of the cone with
the SUBTRACT command.

To create a cone:  Draw > Modeling>Cone Command line>CONE
1. Choose Draw > Modeling > Cone from the main menu. Eeregre T |
2. Specify the center of the base of the cone. Command tine

. . . Specify center umnl of base or [3P /2P Tir/Hliptical]: *Cancel*
3. Specify the radius or diameter. [ommend: o

. . Specify center paint of base or [3P/2P/Ttr/Hlliptical].
4. SpeCIfy the he|ght pecify height or [2P/Auds endpoin

/Top radius] <66.4522>

6.3.8.  Solid Cylinder

You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the xy plane of the current
UCS; the height of a cylinder is always parallel with the z axis. You can draw a circle and then use EXTRUDE to create a solid
cylinder.

To create a cylinder:  Draw > Modeling> Cylinder Command line>CYLINDER

1.Choose Draw > Modeling> Cylinder from the main menu.
2. Specify the center of the base of the cylinder.

3. Specify the radius or diameter.

4. Specify the height.

‘Command Line
[2dwirsframe./dwireframe, Hidden, Realistic/Conceptual/Other] <Conceptual>: _2

Regenerating mode!
Commany d: CYLINDER

pechy height ar [2P/As endpoin
] <112.20625; <ORTHO On»<ORTHO OF
S <
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6.3.9.  Sphere

The latitude lines of a sphere are always parallel with the xy plane of the current UCS; the central axis is always parallel with the
z axis. You determine the size of a sphere by specifying either its radius or its diameter.

To create a sphere:  Draw > Modeling>Sphere
Sl

Command line>SPHERE 1 Command Line

(ﬂ" 7 [Select object: Specify opposite comer: 2 found
‘E{gg! (Select object:

Command: SPHERE

{Specify center point or [3P/2P,/Tir]
{Specify radius or[Diameter]:
Command.

1. Choose Draw > Modeling > Sphere from the main menu.
2. Specify the center of the sphere.
3. Specify the radius or diameter.

6.3.10. Torus

Atorus is constructed by revolving a circle about a line drawn in the plane of the circle and parallel with the z axis of the current
UCS. You determine the size of a torus by specifying its overall diameter or radius and the diameter or radius of the tube (the
circle being revolved).

Command Line

[Select object

Command: TORUS

[Specify center point or [3P/2P/Ttr]:
[Specify raidus or[Diameter]:

[Specify tube radius or [2Point/Diameter]:
Command:

To create a torus:  Draw > Modeling>Torus
Command line>TORUS

1. Choose Draw > Modeling > Torus from the main menu.
2. Specify the center of the whole torus.

3. Specify the radius or diameter of the whole torus.

4. Specify the radius or diameter of the body of the torus.

6.3.11.  Pyramid

You can create a tetrahedron (three-sided pyramid) or a four-sided pyramid. The base of the pyramid is always parallel to the xy
plane of the current UCS. You determine the size of the pyramid by specifying the base points and either the apex, the corners
of the top surface, or the endpoints of the ridge.

To create a pyramid:  Draw > Modeling> Pyramid Command line>PYRAMID

1. Choose Draw > Modeling > Pyramid from the main menu.
2. Specify the first point for the base of the pyramid.

3. Specify the second and third points.

4. In the prompt box, choose Tetrahedron.

5. Specify the apex of the tetrahedron.

‘Command Line

Command: PYRAMID

4 sides Inscribed Circumscribed

[Specify center poirt of base or [Edge/Sides]
[Specify base radius or [Inscribed] <32.94662:

{Specify height or [2P/Auxis endpoint/ Top radius] <141.6134>
Command.
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6.3.12. Wedge

You can create three dimensional wedges consisting of five surface planes. You determine the size of the wedge by either
specifying a second comer and the height; defining the wedge based on a cube having a given length; or specifying the length,
width, and height.

To create a wedge:  Draw > Modeling>Wedge
Command line>WEDGE

Command Line

{Specify height or [2Paint] <55.1953>: Cancel™
Command: WEDGE

Specify first comer or [Center]

[Speciy other comer or [Cube/Length]:
ISpecify height or [2Point] <55.1953>
Command:

1. Choose Draw > Modeling> Wedge from the main menu.
2. Specify the first corner of the base.

3. Specify the opposite corner of the base.

4. Specify the height.

6.3.13. Solids Extrude

EXTRUDE command, extrudes the profiles of the selected object along the chosen path to create solids. The entities you can
extrude are planar 3D faces, closed polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You cannot
extrude objects contained within a block or polylines that have crossing or self-intersecting segments.

To create an extruded solid:  Draw > Modeling > Extrude Command line>EXTRUDE

Command Line
{Command: EXTRUDE

1. Choose Draw >Modeling> Extrude from the main menu.
2. Select the object to extrude.
3. Select the extrusion path or specify the height.

6.3.14. Solids Revolve

ument wireframe density: ISOLINES=4
(Select objects to extrude: 1found
ISelect objects to extrude:
(Specify height of extrusion or [Direction/Path,/ Taper angle]
ICommand

REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving axis can be X, Y axis of
current UCS as well as lines, polylines. Objects can be revolved are closed polylines, polygons, rectangles, circles, ellipses,
regions and so on.

To create a revolved solid:  Draw > Modeling>Revolve Command line>REVOLVE

1. Choose Draw > Modeling> Revolve from the main menu.
2. Select the object to revolve.

3. Do one of the following to define the axis of revolution:

- Specify a start point and an end point.

- Type 0 and press Enter to select an object.

- Type x and press Enter to select the x axis.

- Type y and press Enter to select the y axis.

4. Specify the angle of revolution.

Command Bar x
Command: REVOLVE

Select objects:Find out 1, total 1

Select objects:

Specify start point for axis of revolution o
r define axis by Object/Xaxis/Yaxis/Zaxis:
Specify endpoint of axis: [
Specify angle of revolution <366>:

Command : d +
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6.3.15.  Solid

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default method is to
specify the corners of the plane. After you specify the first two corners, the plane is displayed as you specify the remaining
corners. The program prompts you for the third point and then the fourth point.

To draw a quadrilateral plane:

1. Choose Draw > Modeling > Meshes> 2D Solid
2. Specify the first, second, third and fourth point.
3. Finish the command, press Enter.

6.3.16. Flatshot

With FLATSHOT command you can create a 2D representation of all 3D objects based on the current view.The edges of all 3D
solids, surfaces, and meshes are projected line-of-sight onto a plane parallel to the viewing plane. The 2D representations of
these edges are inserted as a block on the XY plane of the UCS. This block can be exploded for additional changes.

Block Reference
Color Bylayer

Layer 0
Linetype BYLAYER

Flatshot dialog box

Destination: Controls where the flattened representation is created.

Insert As New Block: Specifies to insert the flattened representation as a block in the current drawing.

Replace Existing Block: Replaces an existing block in the drawing with the newly created block.

Select Block: Closes the dialog box temporarily while you select the block you are replacing in the drawing. When you finish
selecting the block, press Enter to re-display the

Block Selected / No Block Selected: Indicates whether a block has been selected.
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Export to a File: Saves the block to an external file.

@ Flatshot %
Foreground Lines: Contains controls for setting the color and linetype of lines that N
are not obscured in the flattened view. ® Insert as new block
Color: Sets the color of lines that are not obscured in the flattened view. OEE:"“E"‘"“”Q*""“

Linetype: Sets the linetype of lines that are not obscured in the flattened view.

Obscured Lines: Controls whether lings that are obscured in the drawing are O ot toafie

displayed in the flattened view and sets the color and linetype of these obscured Filename and path:
| | nes. Cilsershovs'\Documents'MNew Block .dwg
Show: Controls whether obscured lines are shown in the flattened representation. E e
When selected, the 2D flattened representation displays lines hidden by other e Lo v
objects. Linetype: Confinuous
Color: Sets the color of lines that lie behind geometry in the flattened Ob:'w
view. Color: W ByBlock -
Linetype: Sets the linetype of lines that lie behind geometry in the flattened view. Linetype: Controus v
Include Tangential Lines: Creates silhouette edges for curved surfaces. Jinclude tangerta sdges
Create: Creates the flattened view. [ Smocthing

| Create Cancel Help

6.3.17. Creating Composite Solids

You can create composite three-dimensional solids by combining, subtracting, and finding the intersection of two or more
solids. With UNION command, you can combine the total volume of two or more solids or two or more regions into a
composite object.

To combine solids:  Modify>Solid Editing>Union Command line>UNION

Command Line

1. Choose Modify>Solid Editing> Union from the main menu. Commar Carca”

2. Select the objects to combine. Kt bt 1, 213
[Select object:
Command

To subtract solids:  Modify>Solid Editing> Subtract Command line>SUBTRACT

Command Line
mmand: “Cancel*
mmand: SUBTRACT
elect solids, surfaces, and regions to subtract from
elect object: 1found
elect object:
mmand.

To intersect solids: ~ Modify> Solid Editing>Intersect Command line>INTERSECT

1 Choose Modify> Solid Editing> Subtract from the main menu.
2. Select the objects to subtract from one another.

1. Choose Modify > Solids Editing > Intersect from the main menu.
2. Select the objects to intersect.

Command Line
mmand: "Cancel™
mmand: "Cancel™
mmand: INTERSECT
elect abject: Specify opposite comer: 2found
elect object
mmand.
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6.3.18. POLYSOLID

The POLYSOLID command allows you to create 3D solid in a shape of a wall directly or by selecting existing polylines. A polysolid
is drawn the same way you draw a polyline, which is created with continuous straight and curved segments.

Command :

Wl ro.vsoL
Command: POLYSOLID

After inputting the POLYSOLID command, you will get 4 options
(Object, Width, Height, and Justification) in the command line
and dynamic input box. 362251494502

> Type “Width” or “Height” to set width and height.

> Type ‘Justify” to set justification (Left, Center, Right).

> When you start drawing solid wall after clicking on your first point, it gives you 2 options (Arc, Undo) in the command
ling and dynamic input box. If you don’t input any of them, you can just continue drawing your lines.

> lfyou type “Arc”, it can give you 3 options (Close, Direction, Line), you can draw the arc by 2 points or enter “Direction”
to draw the arc by tangency direction.

> You can also type “Close” to close your
polysolids or type “Line” to change
back to line again. If you type “Undo”,
it will back to previous point.

> Ifyou type “Object” in dynamic input box or in command line,
you can convert existing lines, 2D polylines, arcs, and circles
into 3D solids with default height, width, and justification. This
feature only allows select objects one by one.

PSOLWIDTH: System variable, sets the default width for the 3D
polysolid.

PSOLHEIGHT: System variable, sets the default height for the 3D
polysolid.

6.3.19. PLANESURF

You can input PLANESURF command or click Ribbon — Surface — Plan to create a planar surface by selecting closed objects or
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specifying the opposite corners of a rectangular surface. When the comers of the surface are specified by the command, you can
create a surface parallel to the work plane.

SURFU / SURFV: System variable, sets the number of lines displayed on the surface

DELOBJ : System Variable, decides whether to delete defining objects.

3D-PLANESURF cwg

6.3.20. SURFOFFSET

You can input SURFOFFSET command to create a parallel surface at [ S g Q ¢ # m

a specified distance from the original surface. bl Loft PSR ot (] P
¥ Sweep Create  to NURBS CV

After selecting the surface and pressing enter, you will get 4 options Create

(Flip direction, Both sides, Solid, Expression) in the command line es  parallel surface 2

and dynam|C Input bOX. stance from the

original surface

Drawing1.dwg . Offset (SURFOFFSET)

> You can Offset the surface in one direction (the arrows will show on one side of the surface) by entering a distance or
select the point on the drawing.

100



Chapter 6 Create Objects

> Ifyou type “Flip direction”, the arrows will flip to another side.

> Ifyou type “Both sides”, you can Offset the surface in both directions (the arrows will show on both sides of the surfaces)

> Ifyou type “Solid”, you can Generate the surface to a solid after the offset

> Ifyou type “Expression”, you can enter a formula or equation to specify the distance of the surface offset.

101



Chapter 6 Create Objects

SURFAGEASSOCIATICITY: System Variable, when the value is 1, Expression option will be displayed. This option does not update
the offset distance default value the next time you enter the command.
SURFACEMODELINGMODE: System Variable, when the value is 1, the surface will be a NURBS surface.

6.3.21.  CONVTOMESH

You can input CONVTOMESH command or click Ribbon- Mesh — Convert to MESH to convert eligible 3D objects into meshes,
the objects will be smoothed at the same time in the conversion as well.

[E] convromesH  HLINE
Command: CONVTOMESHE

Eligible objects include: solids, closed polylines, regions, 3D face, 3D surfaces, polygon meshes.

When the 3D entities that are extruded, swept, lofted, and revolved with arcs are converted to meshes, and the number of faces
and vertices after conversion cannot be displayed correctly

FACETERMESHTYPE: System Variable, controls the level of smoothness upon conversion (If the mesh type is not set to be
optimized, the converted object is not smoothed).

DELOBJ : System Variable, decides whether to delete defining objects.

6.3.22. CONVTOSOLID

You can input the CONVTOSOLID command to convert eligible objects to 3D solids.

Eligible objects include: )

» 3D meshes that completely enclose a volume Home  Inset  Annotaion 3D Suface M

»  Surfaces that completely enclose a volume

»  Closed polylines and circles with a non-zero thickness property;
wide polylines must have a uniform width

The Command has following limitations:

> You can select one or more objects to convert to solid, if any object in your selection set is in invalid for the command,
you will be prompted again to select the objects.

> I's not available to convert planar surfaces or regions with contiguous edges to 3D solid.

> I's notavailable to convert separate objects to 3D solid. If the surfaces enclose a watertight area, you can convert to a
solid with the SURFSCULPT command.

SMOOTHMESHCONVERT: System Variable, only supports value 3. Smoothness and optimization effect won't be supported in
the version.
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DELOBJ: System Variable, decides whether to delete defining objects.

6.3.23. CONVTOSURFACE

You can input the CONVTOSURFACE command or click Ribbon- Mesh — Convert to SURFACE to convert eligible objects into

3D surfaces. @ A& H D & -~ 2D Disfiing
Home Insert Annotation Surface Mesh Layout View

Eligible objects include: 2D solids, 3D solids, Mesh objects, Planar
3D faces, Regions, Zero-width polylines with thickness, Polylines with
global-width, Lines with thickness, Arcs with thickness, Closed plane
curve.

SMOOTHMESHCONVERT: This System Variable only supports value 3. Smoothness and optimization effect won't be supported
in the version.

DEOBJ: System Variable, when sets the value to 0/3/-3, the defining objects won’t be deleted, when the value is -1/-2, there
will be a two options for users to choose delete or not, when it is 1/2, the defining objects will be deleted.

6.3.24. CONVTONURBS

You can input CONVTONURBS command or click Ribbon- Surface — Convert to NURBS to convert solids and procedural surfaces
to NURBS surfaces. You can also convert meshes to NURBS surfaces after converting them to a solid or surface by CONVTOSOLID
or CONVTOSURFACE command.

Insert Annotation 3| Surface Mesh Layout View Manage Exp|

Drawing1.dwg

There are a series of new functionalities for NURBS control vertices editing and display, such as
e  SHOW CV: Shows control vertices. You can adjust the NURBS surfaces by clicking the control vertices, you will get 4
options (Base, Copy, Undo, Exit) in your command line and dynamic input box.
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Undo: Cancels the previous step.

Exit: Stops adjusting control vertices.

HIDE CV: Hides control vertices.

ADD: Adds control vertices. After selecting the object, you will

get 2 options (Knots, Direction) to add control vertices and set

the position.

>  Knots: Turns off the display of control vertices and allows
you to place a point directly on a surface. This option only
displays if you select a surface; it does not display for
splines.

> Direction: Specifies whether to add control vertices in the
U or V direction. This option only displays if you select a
surface; it does not display for splines.

YV V V V

e  REMOVE: Removes control vertices. There are at least 2 control
vertices in each direction.

Base: Moves your control vertices according to the base point and second point you choose.
Copy: Copies a new NURBS surface and move it, the original surface won't be deleted.

DELOBJ : This System Variable decides whether to delete defining objects.

6.4. Point Cloud

LusoCAD 2025 supports point cloud file extensions (.rcp and .rcs) as attachment in a drawing. The point cloud is inserted at the
specified coordinates, based on the location of the Insertion object snap. Users can apply object color and RGB scan colors to

display point cloud data.

-

~| G B30] views

Preview:

Find File...

Locate

vl [Comen ]

(B select Point Cloud File
Lok in: | paintcloud
Py || testSample.rcp
IEI
\
L
b
File name test Sample rep
Files of type: Paint Cloud Project(”.rcp)

“ Cancsl
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When users attach the Point Cloud data, the following options will be displayed in Attach Point Cloud dialog box:

(3 Attach Point Cloud *
Name testSample ~ Browse...
Preview Path type Scale
Specify on-screen
Relative path ~ 1
Insertion point Rotation
Specify on-screen Specify on-screen
Use geographic location
[ Lock point cloud
ZFoom to paint cloud
Show Details e FES

o  Name: Identifies the point cloud file to attach.

o  Browse: Opens the Select Point Cloud dialog box, a standard file selection dialog box where you can find and select a

e Path type:

point cloud file.

Path type

> Full path: Uses the full path of the specified file, including the root R
]‘0|der and a” SUbf()lderS that Contam the point ClOUd flle ..................................................................................................

> Relative Path: Uses the file path relative to the current drawing file to |nuc.?§,:;i%ﬁfath
reference the point cloud file.

> No Path; Only uses the file name of the point cloud file for referencing. The file must be located in the same folder
as the current drawing file.

Insert point; Specifies the location in the drawing where the base point of the point cloud will be attached.
> Specify On-screen: Specifies the insertion point in the target drawing while you insert it.
> XY, Z: Sets the coordinate values of the insertion point.

Scale: Specifies the scale factor for the inserted point cloud.
> Specify On-screen: Specifies the relative scale of the point cloud as you attach it.
> Scale: Sets the scale factor of the point cloud.

Rotation: Specifies the rotation angle for the inserted point cloud.
> Specify On-Screen: Specifies the rotation angle of the point cloud by the pointing device.
> Angle: Sets the rotation angle of the point cloud.

Other Options:

> Use Geographic Location: Inserts the point cloud based on the geographic data in the point cloud file.
> Lock Point Cloud: Controls whether an attached point cloud can be moved or rotated.
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>  Zoom to Point Cloud: Zoom to the extents of the attached point cloud object automatically.

e Show/ Hide Detfails: Includes number of points, Point Cloud unit, and Point Cloud data.

Point cloud information

Points: Point cloud unit Meters
8772682 Unit factor: 1000
Point cloud data: Point cloud size in LusoCAD units
RGB: YES LusoCAD units Millimeters
iy YES With: 236415414
Normal YES Lar?gm 24241522
Classification: NO R T
Segmentation data: YES
Found in C\Users\OVS\Desktop) DWG Samples
Saved path C\Users\OVS\Desktop) DWG Samples

- OK Cancel Help

6.5. Create Regions

You can convert a closed object into a two dimensional region. After you create a region, you can modify it using the various
three dimensional tools. You can create regions from closed objects, such as polylines, polygons, circles, ellipses, closed
splines, and donuts.

Command Line
m- Command: REGION
. . < " - “ Select object: Specify opposite comer: & found
To create a region:  Draw> Region BEN p B3 BW i
B 5] : : ‘Hnnpe:dlact.ed
Command ling>REGION Bl "%‘R e

Layer 0

Linetype Bylayer

1. Choose Draw > Region from the main menu.
2. Select the objects to create the region and press Enter.

6.6. Create Revision Cloud

REVCLOUD command creates or modifies a revision cloud You can create a new revision cloud by selecting two corner points
or polygonal points, dragging your cursor or you can also convert an existing object such as a circle, ellipse ,polyline or spline
to a revision cloud.

rle:

olygonal/Freehan

aximum arc length: 6 Nermal Type:Freehand

/Style/Modify] <Object>:

Minimum arc length: 3.33

pecify start point or [Arc length/Object/Rectangular/P

6.7. Create Break Line

Creates a polyline and inserts the breakline symbol. To use your own block for the breakline symbol, make sure that the block
contains two point objects on the Defpoints layer.

To create a revision cloud:  Command line>BREAKLINE

1. Type BREAKLINE on the command line. e
. . ) ) [e) o] jeRoNe) Block = BAKLINE DWG, Sze = 100, Edtension = 250
2‘ Specn(y f”st and SBCOHd pOIﬂt fOf breaklme. [eReNe] [sReRe) ;:;:;iyﬂmpmmfnrhreaklmem[EIm:k/Slze/Betensmn/sPeafyhnafﬂrbnea
[elwNel jexeje} ‘Speciy second poirt for breakine:
Qoo [sReRe}

3. Specify location for break symbol. Fpeckylocaton or ook symesl dcbort>
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6.8. Create Wipeout

Wipeouts are created using existing polygons, closed zero-width polylings made up of only line segments, or new polylines
that you draw while using the WIPEOUT command. Also you could use a circle object to be wipeout or even you can pick up a
closed polyline object containing arcs. For example, you can explode and outline a block definition shape (car) then join it as
polyline then wipeout this polyline and group it with the block definition and place it on your drawing as showing below.

To draw a wipeout: ~ Draw>Wipeout Command line>WIPEQUT
1. Choose Draw > Wipeout from the main menu. D D
i

Wipeout

Color ByLayer

Layer 0

Linetype Bylayer [ommand: WIPEOUT

Jpecty first point or [Frames. Pobiine] <Pobiine>:

pecty next poirt

pecify next point. o]

pecy next point or [Close/ Undo]

peciy next point or [Close/Undo]:
Command.

2. Specify the start point and endpoint of each segment.
3. After specifying the last endpoint, press Enter. D

Espigon de carga y

T JLEA = — = NC—"7%

4}_—“ : er— THOU{
i | | WIPEOUT Grouped Polyllne
|

|| || &N
I\ Model {Layoutt ] Layout2 | [/ \

g’gm 49.43,1260.13

N\ L WIPEJOUT

6.9. Create Table

The new Table function with TABLEDIT\TABLESTYLE\TABLEEXPORT command group are possible now to create and modify
table as well as to define the format of table. It is possible to export the table to CVS file and open it on Microsoft Excel.

To draw table:  Draw>Table Command line>Table
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6.9.1.  Insert Table Dialog Box

Input TABLE command and press ENTER, and "Insert Table" dialog box will be open.

Tatie St Irseton behaver
s Spacky aetion port
@ Specky wndow

Cobmn 40w stirge
® Coums

Set col s
Foatrom col e Tee

Second row cel e Hooter

A ctvr row col sty Dua - 4351BPACH ST
43CBPCH-ST

g or Stoca Numeer

43D-CABA-C

o] [ome

|1 KN

43D-CABA-78-45-10

Table Style: Choose a table style from within the current drawing from which to
Table Style

create a table. You can create a new table style by clicking the button next to the

drop-down list.

. N Previ
Preview: Controls whether a preview displays. If you start from an empty table, the e
preview displays an example of the table style. Title
He [Ha [He
ade|ads|ade
r r r
Insertion Behavior: Specifies the location of the table.
Specify Insertion Point: Specifies the location of the upper-left corner of the
table. You can use the pointing device or enter coordinate values at the Sy ——
Command prompt. If the table style sets the direction of the table to read from mes & il -
the bottom up, the insertion point is the lower-left corner of the table. = Baowsr , Row height:
6 = 1 5 Line)
Specify Window: Specifies a size and a location for the table. You can use the
pointing device or enter coordinate values at the Command prompt. When this © ecty i
option is selected, the number of columns and rows and the column width and g o
row height depend on the size of the window and the column and row settings. m ! > 835 [
Rows: Row height:
E 1 : 6 = Line(s)
Insertion behavior
. i . (*) Specify insertion point
Column & Row SeFtlngs. Set the number and size of columns and rows. Crmrem
Columns Icon: Indicates columns. T e
@ Columns: 7 Column width:
. |I|:| 6 = Automatic =
Rows Icon: Indicates rows. 7
7 Rows: © Row height:
B |Automatic| = 8 = Linels)
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Columns: Specifies the number of columns. When the Specify Window
option is selected and you specify a column width, the Automatic option is
selected, and the number of columns is controlled by the width of the table.
If a table style containing a starting table has been specified, then you can
choose the number of additional columns you would like added to that
starting table.

Column Width: Specifies the width of the columns. When the Specify
Window option is selected and you specify the number of columns, the Auto
option is selected, and the column width is controlled by the width of the
table. The minimum column width is one character.

Rows: Specifies the number of rows. When the Specify Window option is
selected and you specify a row height, the Automatic option is selected, and
the number of rows is controlled by the height of the table. A table style with
a title row and a header row has a minimum of three rows. The minimum row
height is one line. If a table style containing a starting table has been
specified, then you can choose the number of additional data rows you
would like added to that starting table.

Row Height: Specifies the height of the rows in number of lines. The
height of a line is based on the text height and the cell margin, which are
both set in the table style. When the Specify Window option is selected
and you specify the number of rows, the Auto option is selected, and the
row height is controlled by the height of the table.

Set Cell Styles: For table styles that do not contain a starting table,
specifies a cell style for rows in the new table.

First Row Cell Style: Specifies a cell style for the first row in the table. The
Title cell style is used by default.

Second Row Cell Style: Specifies a cell style for the second row in the
table. The Header cell style is used by default.

Insertion behavior
() Specify insertion point
@ Specify window

Column & row settings

@ Columns: ) Column width:
I & 2 Automatic -2
") BRows: Row height:
B |Automatic = 6 = Line(s)
Insertion behavior
() Specify insertion point
@ Specify window
Column & row settings
- Columns: @1} Column width:
[0 Automatic-= 635
") Rows: Row height:
B |Austomatic2 6 = Linefs)
Insertion behavior
~) Specify insertion point
Column & row settings
) Columns: @ !! Column width:
[ |Automatic = 635
@ Rows: ") Row height:
E 1 Automatic = |  Line(s)
Column & row settings
© Columns: ) Column width:
II[] 1 Automatic =
") Rows: Row height:
B Automatic 2 8 2| Line(s)|
Set cell styles
okt
Second row cell style:
Al other row cell styles:
Data
Header

A

Title

All Other Row Cell Styles: Specifies a cell style for all other rows in the table. The Data cell style is used by default.

6.9.2.  Table Style Dialog Box

Current Table Style: Displays the name of the table style that is applied to tables you create.

Styles: Displays a list of table styles. The current style is highlighted.
List: Controls the contents of the Styles list.
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Preview: Displays a preview image of the style that is selected in the

Styles list. o e ,
, . . Standard THo Set Cumrent
Set Current: Sets the table style selected in the Styles list as the T
current style. All new tables are created using this table style. b : . J
New: Displays the Create New Table Style dialog box, in which you abE m
can define new table styles. o
Modllfy: Displays the Modify Table Style dialog box, in which you can e
modify table styles.
Delete: Deletes the table style selected in the Styles list. A style that
is being used in the drawing cannot be deleted.
6.9.3.  Create New Table Style Dialog Box
Specifies a name for the new table style and specifies the existing table
style on which the new table style will be based. New Style Name: e
New Style Name: Names the new table style.
. i _ \ Start With:
Start With: Specifies an existing table style whose settings are the default (Sandar =
for the new table style. -
Continue: Displays the New Table Style dialog box, in which you define
the new table style.
6.9.4.  New and Modify Table Style Dialog Boxes o e S s
Starting table
. ) ) ) Select table to start D B
Starting Table: Allows you to specify a table in your drawing to use as an example for igm :
formatting this table style. Once you select a table, you can specify the structure and [reble direction: (e =
contents you want copied from that table to the table style. With the Remove Table s E‘.’w”_]--

icon, you can remove a table from the current specified table style.

General Table Direction: Defines a new table style or modifies an existing table style. It
sets the direction of a table.

Down: The title row and the column heads row are at the top of the table.

Up: The title row and the column heads row are at the bottom of the table.

Preview: Displays an example of the effect of the current table style settings.

Cell Styles: Defines a new cell style or modifies an existing cell style. You can create
any number of cell styles.

Create Cell Styles Button: Launches the Create New Cell Style dialog box.

Manage Cell Styles Button: Launches the Manage Cell Styles dialog box.

Cell styles

> Z

Data

Title

Header

None v

Create new cell styles

Manager cell styles... ic =
Format: General E]
Type: Data X
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General Tab Cel styles
Properties [Header )
Fill Color: Specifies the background color of the cell. [Gorem Jree [oomes]
Alignment: Sets justification and alignment for the text in the table cell. :TZ::?S
Format: Sets data type and formatting for the Data, Column Heading, or Title Alignment: C v
rows in a table. Clicking this button displays the Table Cell Format dialog box, fomzs. el ™=
where you can further define formatting options. T“’e_: . i
Type: Specifies the cell style as either a tag or data. ::E:;a 15

Vertical: 15
M arg ins [7] Merge cells on row/column creation

Cell style preview

Horizontal: Sets the distance between the text or block in the cell and the left ‘ oa
and right cell borders. <14
Vertical: Sets the distance between the text or block in the cell and the top and [ok [ cancel | [ Heb |

bottom cell borders.
Merge cells on row/column creation: Merges any new row or column created with the current cell style into one cell. You can
use this option to create a title row at the top of your table.

Cell styles

Text Tab [Heoder 7 3
Text Style: Lists the available text styles. “g]
Text $WIe Button: Displays the Text Style Dialog Box where you can create or ::i:;: e
modify text styles. e —
Text Height: Sets the text height. Text color
Text Color: Specifies the color of the text. Choose Select Color at the bottom of Text angle: 0
the list to display the Select Color dialog box.
Text Angle: Sets the text angle. The default text angle is 0 degrees. You can enter
any angle between -359 and + 359 degrees.

Cell style preview

‘ Bg

<[]

Borders Tab [ok [ Cancel | [ Hep |
Lineweight: Sets the lineweight to be applied to the borders you specify by [E:':’des 7 B3
clicking a border button. If you use a heavy lineweight, you may have to increase —i= Iml
the cell margins. i
Linetype: Sets the linetype to be applied to the borders you specify. Choose Linetype:
Other to load a custom linetype. Color:

Color: Sets the color to be applied to the borders you specify by clicking a ::‘”:_'e“”es e

border button.

Double Line: Displays table borders as double lines. @ Q D E] @D

Apply the selected properties to borders by clicking the
Spacing: Determines the spacing for double line borders.

Cell style preview =
‘ ag
=]

[ ok [ camcel | [ Hep

111



Chapter7_ Modify Objects

7. Modify Objects

You can easily modify the size, shape, and location of objects. You can either, enter a command first and then select the
objects to modify, or you can select the objects first and then enter a command to modify them.

7.1. Remove Objects

You can use ERASE command to delete objects, whatever the methods you use to select objects. To restore the deleted
objects, use UNDO command. You can remove objects using one of the following methods: Delete objects with ERASE
command, cut the selected objects to the clipboard, or press DELETE to remove the selected objects.

7.2. Copy Objects

You can duplicate objects within the current drawing. The default method is to create a selection set and then specify a base
point, and a displacement point, for the copy. To copy objects at the specified distance, you can specify the distance directly
when the Ortho Mode or Polar Tracking is on.

Create only one copy of object one time:

1. Choose Modify > Copy from the main menu. <. % C“““d":;;
2. Select the objects, and then press Enter. AT s oy Spechy coposte comer:3found
. | "r------;:--\ [Cumrent settings: Copy mode = Muttiple
3. Oﬂ the Command ||ne, type 0 (mode) ".\ i ,‘f i (Specify base poirt or [Displacement/mOde] <Displacement=: O
b ooy bose poit or [Dkplecemert mCde/Hufple] <Displecemert second
4. On the command |ine, type S (S|ng|e) : ; = it or <use first point as d > <ORTHO On>

[second point or <use first point as displacement>: |[777] 0|

5. Specify the base and displacement point.

Create multiple copies for selected object one time:

1. Choose Modify > Copy from the main menu.

2. Select the objects, and then press Enter.

3. On the command line, type O (mQde).

4. On the command line, type M (Multiple).

5. Specify the base and displacement point of the first copy.
6. Specify the displacement point of the next copy.

7. To complete the command, press Enter.

Command Line

OPCCIy DOeG oo
Enter a copy mode opt
Specify base point or [
rst poirt as displaceme
{Specify second poirt ¢
{Specify second point

7.3. Mirror Objects

You can specify a baseline to create a mirror image using MIRROR command. The mirror image is symmetrical with the
original one. So if you want to create a symmetrical objects, you only need to draw a half one, then create a full one using
MIRROR command. Besides picking start and end point to define mirror axis, you can also directly select objects as mirror axis
like a line, polyline, a line of block or an external reference drawing.
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To mirror objects: T T T e e s
Err
O Q O Command: “Cancel”
Command: MIRROR

2. Select the object, and then press Enter.

(Select object: Specify opposite comer: 7 found

1. Choose Modify > Mirror from the main menu. N TN TN N e o

3. Specify the first and second point of the mirror line.

pecty fist point of mimor finc:
Specity second paint of mimor lin

4. On the command line, if you want to retain the original objects, type N; if you want to delete the original objects, type Y.

7.4. Offset an Object

You can use the offset to copy selected objects and align them offset to the original objects at a specified distance. You can
make offset objects using arcs, circles, ellipses, elliptical arcs, lines, two dimensional polylines, rays, and infinite lines.

To make an offset copy by specifying the distance:

1. Choose Modify > Offset from the main menu.

2. Specify the distance (select two points or enter a distance).
3. Select the object to offset.

4. Specify on which side of the object to place the parallel copy.
5. Press Enter to complete the command.

To make an offset copy passing through a point:

1. Choose Modify > Offset from the main menu. )
2. On the command line, type T (Through). .
3. Select the object to offset.

4. Specify the point for the object to pass through.

5. Press Enter to complete the command.

7.5. Create an Array of Objects

Command: OFFSET

Parallel: [Through point]<Distance> <5»:3
Select objects:

[Both sides]<Side for parallel copy>:
Select objects:

Command: OFFSET

Command :

New array options are available to create copies of objects arranged in rectangular, polar, or path pattern. The new array is as a
whole (dynamic block). It can be dynamically adjusted the number of ranks, spacing and other related parameters through

Ribbon Panel, Properties and Grip.

To create a rectangular array:

1. In “2D Drafting” workspace, click

“Home” >“Modify” > “Rectangular Array” in turn.

2. Select the object to be arrayed and press “ENTER”.

3. In the array preview, drag the grips to adjust the spacing and
number of rows and columns.

You can also modify values in "Array" Ribbon .

Array Rectangular
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To create a polar array:

1.In “2D Drafting” workspace, click

“Home” >“Modify” > “Polar Array” in turn.

2. Select objects to array.

3. Specify center point of array (array preview will be
showed).

4. Input “i” (items), and then input the number of items
to array.

5. Input “a” (angle) and then input the fill angle.

You can also select grips to edit array.

To create a path array:

The best way to use Path Array is to create them at first.
And then you can use the tools or “Properties” of the
Ribbon to modify them.

1.In “2D Drafting” workspace, click
“Home” > “Modify” > “Path Array” in turn.

2. Select the object to array, and “ENTER”

3. Select an object (such as a line, a polyline, a 3D
polyling, a spline, a helix, an arc, a circle or an ellipse)
to be as a path to array.

4. Specify the way to distribute items along the path:

8
=]
o
>
e
<

Array Path

If you want to distribute items evenly throughout the path length, please click “Properties” panel in Ribbon >“Divide” in turn. If
you want to distribute items at a specific distance, you can click “Properties” >“Measure” in turn.

5. Move the cursor along the path to adjust the items.
6. Press “ENTER” to finish Array.

7.6. Move Objects

You can move objects to a new place without changing the objects. You can perform MOVE command and then select object
(1) to move; specify a base point (2) and Displacement point (3). The object is moved from point 2 to the point 3.

To move entities:

1. Choose Modify > Move from the main menu.
2. Select the objects, and then press Enter.
3. Specify the base and displacement point.

,,,,,,,,,

OBIJECT

O

Opposite corner:Find out 1, total 1
Select abjects:

Specify secon d point or <use first point &

[Specify second point

't
or <use first point as displacement>: |[[EE[E] |[<0°

%

|specify stretch point or Q‘ [236.9633] ||< 52° |
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To move an object using grips:

1. Select the object.
2. Click a grip to select it.
3. Drag the object to where you want to relocate it and press Click to release.

1.1. Rotate Objects

You can rotate the selected objects around a specified point. You can specify the rotated angle by specifying a point on the
drawing or entering the angle value directly. The direction that objects rotate depends on the value you enter is positive or
negative.

To rotate objects:

[Specify rotation angle or &[0 |[<69° |

Command: ROTATE

. ) OBJECT Select objects to rotate:
1. Choose Modify > Rotate from the main menu. @ e Sejecms o roate

2. Select the objects, and then press Enter. ety roasion o
3. Specify the base point and rotation angle.

[P A Specify rotation angle or [Copy/Reference] <@»:<Ortho off_
>

To rotate a selection set in reference to an Absolute Angle:

1. Choose Mod|fy > Rotate from the main menu. A'TNMQI“OI): ] o
2. Select the objects, and then press Enter.

3. Specify the base point. Y Specity <he base. poine:

4. On the command line, type R (Reference). berts ::(:leh;ffmm ——
5. Specify the reference and new angle.

Bar

select objects to rotate:
Opposite cerner:Find out 2, total 2
select objects to rotate:

7.8. Align Objects

You can align objects with another through move or rotation with ALIGN command.

Select objects:
specify first source point:
specify first destination point:

To align and object to other as reference: OBJECT
[©] B
v EETE"?T;QEES:W out 1, total 1

1. Choose Modify > Align from the main menu.
2. Select the object, and then press Enter. DESTINATIO
3. Specify the first source point. OBJECT

4. Specify the destination point.

5. Press Enter to finish the command.

Command:

7.9. Scale Objects

You can use SCALE command to scale the proportionality of the selected objects. You can type a scale factor or specify a base
point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; and a scale factor that is smaller
than 1 shrinks the object.
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To scale a selection set by a scale factor:

1. Choose Modify > Scale from the main menu. OBJECT Q Select ovjectsiFind aut 1, total 1
fomm - ' Select objects:

H VT Specify the base point:
2. Select the objects, and then press Enter. @ e |Specify scale factor or [Copy/Reference] <2.53:
3. Specify the base point. L‘»

Specify scale factoror || FXTIT |[< 2707
4. Specify the scale factor. o I ]

7.10.  Lengthen Objects

You can change the length of entities or the included angle of arcs. The results are similar to extending and trimming.This
command does not affect the closed entities.

To change the length of an object by dragging: OBJECT

1. On the command line type LENGTHEN.

2. On the command line, type DY (DYnamic). oo ol setect objects o change>: i

LENGTHEN

3. Select the ObJBCt yOU Waﬂt to Chaﬂge ;:i:(ia;g;:::ts[E;n::::é:E;:a,E:;:r:t/Tota1](Sela:t objects to list length»:DY \;|
3

New start point for line: <

4. Specify the new endpoint or included angle.

7.11.  Stretch Objects

When stretching objects, you have to specify a base point and displacement point. You should use crossing selection to select
the desired objects. With using grip edition, you can also stretch objects.

To stretch an object:

OBIECT
1. Choose Modify > Stretch from the main menu. @ ‘O —
2. Select the objects using either a crossing window or — | I
a CrOSSing pOlngﬂ, and then press Enter. Select gk;?;ZEtz:to stretch by crossing-window or crossing-polygon. .. &
. . Opposite cornerirind out 3, total 3 I
3. Specify the base point. ooty bice meint or [Displacemnt] <Displacenents: i

Specify second point or <use first point as displacement>: <[]

4. Specify the second point of displacement.

To stretch an object using grips:

1. Select the object.

2. Click a grip to activate it.
3. Drag the grip.

4. Click to release.

= A
i

y stretch point or [347.4944<214°|

40
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7.12.  Trim Objects

You can clip, or trim, objects so they end at one or
more implied cutting edges defined by other objects.
You can trim arcs, circles, lines, unclosed polylines,
and rays.

To trim an object:

1. Choose Modify > Trim from the main menu.

2. Select one or more cutting edges, and then press Enter.

3. Select the object to trim.
4. Press Enter to complete the command.

To trim several objects using the fence selection method:

1. Choose Modify > Trim from the main menu.

2. Select one or more cutting edges, and then press Enter.

3. On the command line, type F (Fence).

4. Specify the first point of the fence.

5. Specify the second point of the fence.

6. Press Enter to complete the command.

7.13.  Extend Objects

-

[Fence/Crossing/Project/Edge/eRase/Undo].

[Select object to trim or shift-select to extend or
[FenceCrossing/Project/Edge/eRase/Undo].

[Fence/Crossing/Project/Edge./e

=} [Rase/Undo]

[Select object totim or shift-select to etend or_[[ I |12

---------------------

elect objects or <select all>:
elect object to tim or shift-select to extend or

[Fence/Crossing/Project/Edge/eRase/Undo]: FENCE |j

pecify next fence point or
Undo]

You can extend objects so that they end at a boundary defined by other objects. You can extend arcs, lines, two-dimensional
polylines, and rays. Arcs, circles, ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as

boundary edges.

To extend an object:

1. Choose Modify > Extend from the main menu.

2. Select one or more objects as boundary edges, and then press Enter.
3. Select the object to extend, and press Enter to finish the command.

To extend an object to an implied boundary:

1. Choose Modify > Extend from the main menu.

2. Select one or more boundary edges, and then press Enter.

3. On the command line, type E (Edge).
4. On the command line, type E (Extend).
5. Select the object to extend, and press Enter to finish.

[Fence/Crossing,/Project /Edge//Undoa]:

elect object to extend or shift-select to tim or
[Fence/Crossing,/Project /Edge//Unda]:

[Fence/Crossing/Project /Edge
Undo]:

\ EEEEEEE

[Fence./Crossing/Project/Edge//Undo]:
elect object to extend or shift-select to trim or
[Fence/Crossing/Project/Edge/Undo]:

=

[Fence/Crossing/Project/Ed
/Undol: 4l r
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To extend several objects using the fence selection method:

1. Choose Modify > Extend from the main menu.

2. Select one or more boundary edges, and then press Enter.

3. On the command line, type F (Fence).
4, Specify the first and second point of the fence.
5. Press Enter to complete the command.

714,  Create Breaks

[Select objects or <select all>:
[Select object to extend or shift-select to trim or
[Fence/Crossing/Project/Edge/Undo]: FENCE

pecify next fence point o

[Unda]: L

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, you must specify two
points for the break. By default, the point you use to select the entity becomes the first break point; however, you can use the
first break point option to select a break point different from the one that selects the entity.

To break an object:

1. Choose Modify > Break from the main menu.
2. Select the object.
3. Specify the second break point.

To select an object and then specify the two break points:

1. Choose Modify > Break from the main menu.
2. Select the object.

3. On the command line, type F (First point).

4. Specify the first and second break point.

7.15.  Create Chamfers

‘Command Line

&0

&0

Command Line
‘Select object
‘Specity second break point o [First point]: FIRST

{Specty first break point:
{Specty second break point:

Command:
Command:

50

You can connect two nonparallel objects by extending or trimming them and then joining them with a line to create a beveled
edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a chamfer, you can specify how far to trim the
objects back from their intersection (distance distance method), or you can specify the length of the chamfer and the angle it

forms along the first object (distance angle method).

When chamfering a polyline, you can chamfer multiple segments between two selected polyline segments, or you can chamfer

the entire polyline.

To chamfer two objects using the distance-distance method:

1. Choose Modify > Chamfer from the main menu.
2. On the command line, type D (Distance).

3. Specify the first chamfer distance.

4. Specify the second chamfer distance.

mmana: Lancel
Command: CHAMFER
"Trim" mode) Curent chamfer Dist1 = 20.0000. Dist2 = 20.0000
(Select first ling or [Undo/Polyline/Distance/Angle/Trim/mEthod /Muttiple]. D
(Specify first chamfer distance <20.0000>: 15
(Specify second chamfer distance <15.0000>
[Select first line or [Undo/Polyline/Distance/Angle/Trim/mEthod/Multiple]:
[Select second line or shift-select to apphy comer: “Cancel”
Command:
Command:
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5. Select the first object to chamfer.
6. Select the second object to chamfer.

To chamfer two objects using the distance-angle method:

1. Choose Modify > Chamfer from the main menu.
2. On the command line, type A (Angle).

3. Specify chamfer length on the first line.

4. Specify chamfer angle from the first line.

5. Select the first object to chamfer.

6. Select the second object to chamfer.

To chamfer selected vertices in a polyline:

1. Choose Modify > Chamfer from the main menu.
2. Select one polyling segment where you want to
begin the chamfer.

3. Select the other polyline segment where you want
to end the chamfer.

To chamfer all vertices in a polyline:
1.Choose Modify > Chamfer from the main menu.

2.0n the command line, type P (Polyling).
3.Select the polyline.

7.16.  Create Fillets

T

Command Line

elect it ine or (U
peciy chamer leng
peciy chamer angle fror

i
ath onthe firs line <0.0000>: 15
mihe firs line <03: 20

ple]: ANGLE

e/

ine.
cond e or shift-select to apply comer

m

[Trm" mode) Currert chamfer Lengih = 15.0000. Angle = 20

mmand

Command Line

Command: “Cancel®

Command: CHAMFER

Trim" mode) Curent charfer Dist1 = 50,0000, Dist2 = 50.0000

‘Select fit ine or [Undo/Polyine/Distancs/Angle. Trim/mEthod Mutiple]: D

LWPalyline
Color Color150
Layer 0

Linetype Bylayer

peciy first chamfer distance <50.00003: 70
pecty second chamfer distance <70.0000>: 70
elect first line or [Undo./Poiyline, Distance/Angle.Trim/mEthod/Mukiple]
elect second line or shift-select to apply comer.
mmand:

LWPolyline
.| Color Color150

Layer 0

Command Line

(Command: CHAMFER
Trim'" mode) Current chamfer Dist1 = 5.0000, Dist2 = 5.0000

[Select firs Ine or [Undo/Polyine/ Distance./Angle/Trm/mEthodMutiple]: D
|Speciy first chamfer distance <5.0000>: 5

ISpeciy second chamfer distance <5.0000>

(Select firs line or [Undo/Polyine/Distance/Angle/Trim/mEthod/Muitiple]: P
[Select 2D polyine:

[7lines have been charfered

[Command

Linetype Bylayer

You can create a fillet using FILLET command. This command can apply to the objects such as arcs, circles, ellipses, lines,
polylines, rays, splines or construction lines. A fillet is an arc that connects two objects smoothly and has a specified radius.
An inside comer is called a fillet; an outside corner is called a round. Before creating fillets, you should ensure the distance
between each vertex is long enough to accommodate the fillet radius in order to insert a fillet arc. When the fillet radius is set to
0, no fillet arcs are inserted. If two polyline segments are separated by one arc segments, system deletes this arc segment and

extends the lines to intersect with each other.

To fillet two objects:

1. Choose Modify > Fillet from the main menu.
2. On the command line, type R (Radius).

3. Specify the fillet radius.

4. Select the first and second object.

Boeeeee [ o

Command Line

{Command: “Cancel*

Command: FILLET

Cument settings: Mode = Trim, Radius = 0.0000

(Select first object or [Undo/Polyline/Radius/Trim/Muttiple]: RADIUS
(Specify fillet radius <0.0000>: 30

(Select first object or [Undo./Polyiine/Radius/Trim/Multiple]

(Select second object or shift-select to apply comer:

Command

ICommand
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To fillet an entire polyline:

Command Line
Command: FILLET

. B ICurent seftings: Mode = Trim, Radius = 30,0000
. . . h H {Select first object or [Undo/Polyline/Radius/ Trim/Muttiple]: R
1. Choose Modify > Fillet from the main menu. | oy T —
2‘ O[’] the Command |ine, type P (Polylme) i s h‘w }:sﬁfLasl/Cmssmg/BOX/Fence/WPnlygnn/CPﬂlygﬂn/AUm/Undﬂ/Pn
3‘ Se|ect the p0|y||ne . - g%ilvz.ggi%:[Undn/PaMme/Ramus/Tnm/Mump\e] P
To fillet selected vertices in a polyline:
1. Choose Modify > Fillet from the main menu. ?"'mﬁl%":‘;?—
2. Select one polyline segment where you want o0 st o Lo Poeeeion Tam At} RADIUS
. . (Specify fillet radius <30.0000>: 15
to begin the filet. i P i)
3. Select the other polyline segment where you S e eSS o Come | [F L | e
want to end the fillet.
7.16.1. Trim and Extend Filleted Objects
While performing fillet, you can select Trim option to decide
whether the selected edges are extended to the endpoints of
fillet arcs. By default, all objects except of circles, ellipses,
closed polylines and splines are trimmed or extended when
FILLET>TRIM>TRIM FILLET>TRIM>NO TRIM

performing filleting.

7.16.2. Fillet Line and Polyline Combinations

If the objects to fillet are a line and a polyline, the ling or its
extension must be intersecting with one of the polyline
segments. With Trim option on, the filleted objects join with
the filleted arc to form a new polyline.

7.16.3. Fillet Parallel Lines

You can fillet parallel lines, rays, and infinite lines. The first entity

must be a line or ray, the second entity can be a line, ray, or infinite

line. The diameter of the fillet arc is always equal to the distance
between the parallel entities. The current fillet radius is ignored.

PARALLEL

LWPalyline
Color Magenta

Layer 0
metype syayer | PLINE & LINE
PLINE & LINE %% FILLETED
PARALLEL

LINES FILLETED
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7.16.4. Invert Fillet

Invert Fillet has a very wide range of usage particularly in
construction and furniture industry. The FILLET command now
offers a new option called Invert. You can create a reverse fillet

by this option.

?’ Select first object or [2252.2509,1640.7329)

Undo | Polyline | Radius | Trim Muttiple

7.17.  Disassociate Compound Objects

You can convert a complex entity, such as a block or polyline, from a single entity into its component parts. Exploding a
polyling, rectangle, donut, polygon, dimension, or leader reduces it to a collection of individual line and arc entities that you
can then modify individually. Blocks are converted to the individual entities, possibly including other, nested blocks that

composed the original entity.

Pr o X 04 Drawingldwg X

_"“ 0] 2| [ [
émmed g nnnnnnnn [0) - = R -
T E — El = s

L : : bt I

Linetype “Mutiple™ : |y H

Linetype scale |1 L S el 4

Plot Style BYCOLOR o

el EXPLODE EXPLODE EXPLODE EXPLODE

eshic PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES

NN L=d ) E

2 % |47 DrawingLdwg <

[T /
et etrton Laver Y %g

Plot Style BYCOLOR
lpewsiht | Mhitpe” EXPLODE EXPLODE EXPLODE EXPLODE

ok PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES
3D Visualization -
Materials Bylayer

With the following exceptions, exploding an entity usually has no visible effect on a drawing:

- If the original polyline had a width, the width information is lost when you explode it.
- If you explode a block containing attributes, the attributes are lost, but the original attribute definitions are retained.
- Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding an entity, because they

will adopt the default color, linetype, lineweight, and print style until inserted into another block.
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7.18.

Modify Polylines

Objects such as rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids, cylinders, and
spheres, are all editable polylines. To modify a polyline, perform PEDIT command. The available options vary depending on
whether the selected polyline is a two dimensional or three dimensional object. If the selected object is not a polyline, the Edit
Polyline tool provides the option of turning it into one. You can convert only arcs and lines into polylines. If several arcs or lines
are joined from endpoint to endpoint, they can all be selected and turned into one polyline.

Properties

Mo selection | |

General -
Color M Bylayer
Layer [
Linetype — Bylayer
Linetype scale |1
Lineweight — Bylayer
Thickness 0

3D Visualization o
Materials Bylayer
Shadow displa..| Shadow and receiy

T -
Center X 36701919
Center Y 3522038
Center 7 1]
Height 69.6622
Width 169.0509

Misc -
UCSicon On | Yes
UCSiconato..|Yes
UCS per view...| Yes
UCS Name

7.19.  Modity Multilines

4 Drawingldwg x

VO A0 A4

CLOSED PLINE OPEN PLINE WIDTH PLINE

IR

v |

PLINE TO SPLINE PLINE VERTEX
x

Model

LWPaolyline

Color Bylayer
Layer 0

Linetype Bylayer

W4 kM Layoutl / Layout2

You can use methods such as common editing commands, a multiline editing command and multiline styles to edit multilings
or their elements. You can use MLEDIT command to add or delete vertices for a multiline, to control the way two multilines
intersected (cross and T shape that can be closed, open or merged), to add multiline style or set multilines from the existing
multiling style, such as the number of elements, color, linetype, lineweight and the offset of each element.

7.20.  Clip

A Mottines eaie T ===
T use a toal, chck on the koon. Dbject selection must be pefomed after the tool has been
selected
Multines Edit Tools
I [+ b
i T L [xl
Closed Cross Closed Tee Comer Joint Cut Single D
o = om e 8
ar L il ™
Open Cross Open Tes Add Ve Cu A
L == e [N | | l:l D
= - i [
Merged Crose Merged Tee Oicdete Vertex Weld 4
| Com Help

The new CLIP command clips a block, external reference, image, viewport, and underlay (PDF or DGN) to a specified boundary. It can be
used to replace XCLIP IMAGECLIP VPCLIR PDFCLIR DGNCLIP commands.
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7.21.  Add selected

You can use this function to create a new object of the same type and properties (such as colors, layers, lineweight, linetype
and scale factor) as selected object but with different geometric values.

For example, creating objects based on selected circles uses the general properties of the circle, such as colors and layers, but
prompt you to enter the center and radius of the new circle.

Steps to use ADDSELECTED:
1. Select the object which the new object bases on.

2. Right-click and select "Add Selected".
3. Create an object similar to the selected object according to the prompts.

7.22.  Multiple

Executes a command repetitively, avoiding press enter or space bar key. Because this command only repeats command names,
all parameters must be specified each time. If we want to draw more than one circle, you can enter MULTIPLE, knock down
“ENTER”, and then enter the CIRCLE, “ENTER”, you can draw a circle without the need to press the call to repeat the circle of
the order in the process.

7.23.  Set by layer

Changes the property overrides of the selected objects to ByLayer including color, linetype, lineweight, and materials.

7.24.  MKSHAPE Command

The MKSHAPE command creates a shape definition based on selected objects. You can create custom linetypes easily. If you
create a shape that exceeds 2200 bytes of data, MKSHAPE creates complex geometry shapes to form a single shape.

1. Create a polyline object like a line, rectangle, circle or a closed object.
2. Type MKSHAPE command to save a .shp file with a proper name for your shape.

e —
3. Enter the name of the shape and input a resolution value (lower value input equals polyline shape degraded, higher value
input equals similar shape as original polyline selected).

4. Specify an insertion point in drawing area, select the polyline created and press Enter.

5. If you want to insert the created new shape, execute SHAPE command and input its name.
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6. Specify an insertion point, scale and rotation.

Comnand: HKSHAPE
Reading shape File: O:\FEATURES)

FEATURES \AKSHAPE 2. shg. . |Dene..

Inter the name of the shape2

This shape slready exists. Ouerwrits it? [Yes/llo] <osiy

select object: 1 found
Select abject:

Determining geometry extents... |Done.
Building coord lists...|Done.
Formating coords. .. |Done.

iriting new shape. .. |Dane.

Command
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8. Notes and Labels

8.1. Create Text

Create text, multiline text (mtext) and text that includes one or more leader lines.

8.1.1.  Single-Line Text

You can use TEXT command to create a single or multiling text. Each line text is an independent object which can be modified.
Before typing text, you can specify the text style and the way to align at the prompt of creating text.

Press ENTER if you have typed some characters, and then the command line prompts to input characters for the next row of
text. While creating single line text, you are also enabled to extend or compress certain single line text object in specified space
to meet with your need by means of selecting Align or Fit option from the TEXT command line prompt.

To create text;

1. Choose Draw > Text > Single Line Text from the main menu.
2. Specify the start point for the text.
3. Specify the height of the text.

Command: TEXT
4. Specify the text rotation angle. o e oy (3532 Amaratve: No
. Specify height <8.3532> 5
5. Type the text, and then press Enter at the end of each new line. Speciy rotation angls of text <03

6. To complete the command, press Enter again.
To specify the line text alignment:

1. Choose Draw > Text > Single Line Text from the main menu. ST T A T
2. 0n the command line, type J (Justify) and press ENTER. = O m

3. Type an alignment option BR to align text at its bottom-right corner. oty tatpert it Uyl ST B B
. {Specify bottom-right point of text:
4. Type the text, and then press Enter at the end of each new line. ﬁEzz%::;r:::g;;M,
ICommand:

5. To complete the command, press Enter again.

8.1.2.  Multiline Text

Multiline text consists of one or more lines of text or paragraphs that fit within () T ——
a boundary width that you specify. When you create multiling text, you first ultiline

determine the paragraph's boundary width by specifying the opposite corners Text sam ple
of a rectangle. The multiline text automatically wraps so that it fits within this B

rectangle. After defining the text frame, the system opens the In-Place Text pommand ine_
Editor, which is comprised of a text frame and the Text Formatting toolbar. et it ot o # e o

. [Specify opposite comer or [Height/Justification./Linespacing/RotationStyle/ Widt
You can type text in the text frame and change the style from the Text p/Columnl

Formatting toolbar.

125



Chapter 8 Notes and Labels

To create multiline text:

1. Choose Draw > Text > Multiline Text from the main menu.
2. Select the first and second corner of the text area.

3. In the Multiline Text window, type the text you want.

4. To create paragraphs, press Enter and continue typing.

Remark: Other text features please refer to the express tool guide.

On the toolbar, make format changes as follows:

1. To change the font of the selected text, select a font
from the list.
2. To change the height of the selected text, enter a new

value in the Height box. _ S () 1+

3. To apply color to the selected text, choose a color Multiz : MULTILINE

from the Color list. Text sample TEXT SAMPLE

4. Click OK on the toolbar or Press <Ctrl + Enter> .

Justify Multiline Text: You can specify the attachment point at the top left, top Text Farmatiing

center, top right, middle left, middle center, middle right, bottom left, bottom lz"j“’g | g”ﬁ"“ﬂ: — ]Gl _

center, or bottom right. The multiline text can flow left to right, right to left, top to [ B a—

bottom, or bottom to top. MULTILINE
g

Format Characters within Multiline Text: During creating multiline text, you can
assign a new value to the selected objects to overlap the default setting. You can
specify underlines, bold, color and fonts for a single or multiple characters, or
different text height.

Indent Multiline Text and Use Tabs: You can control the appearance of text
objects and create a list by specifying the tap stops and indenting text. The
arrowheads on the ruler are used to define the indent of text (first line and
paragraph).

Specify the Line Spacing: The line spacing of multiline texts is the distance
between the baseline of one line of text and the baseline of the next line of text.
You can right-click in the textbox and choose Paragraph to specify the desired
line space when the cursor stays on the text frame.

Create Stacked Characters: Stacked text is text or fraction applied to mark
tolerance or measure units. Before creating stacked text, you have to use special
characters to indicate the stacked place for the selected text.

BIIIE5 o o + Wi -|[E) o] g

2| o, Underline | ]

E ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
[Width:55.3200]
“ L| | | | 1 | | r | ar
MUL TILINE
g ...................
Text Formatting
[ Standard |28 Days Later |25 B I
Hrs|lesss=|[E]) a|lana @ o
[x] oo | pog
. 15
MULTHINE | ..
25x
Other..
SPAE!ME Clear Line Spacing
T

Stacked 1/4
Stacked 2111
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The following contents present the special characters and illustrate how to create stacked text:

- Slash (/): Stacks text vertically and separates them with a horizontal line.
- Pound sign (#): Stacks text diagonally and separates them with a diagonal line.
- Carat (™ ): Creates a tolerance stack, which is stacked vertically as well as not separated by a line.

You can also use Stack button on the toolbar to create stacked text.

8.2. Work with Text Styles

The text style is applied to the text objects. You can use text style to control the text font, size, angle, direction and other
features. By default, the current text style is STANDARD, and you have to make other text styles current when you want to apply
them. The STANDARD text style has the following default properties:

r@TextStyle
Currert text style:  Standard
L= Fort
‘%-ﬂa'E Fort Name: Fort Stye:
) [pea o) [Pogia )
["] Use Big Font
Size
I [C] Annotative Height
[[] Match text 0.0000
orientation to layout
[Nm '] Current Style Name
Upside down Width Factor:
1.0000
| Aa B b C C BT (Oblique Angle:
[ Vertical []
[ ooy | [CCamcel ] [ Heb ]
To create a text style:
'@ Text Style
1. Choose Format > Text Style from the main menu. || curenttet ayie: syiet
. Styles:
2. Click New, type a new text style name, and then A v o e Font S
click OK. Shye 1 Azl Rounded MTBold  ~|  [Bold ) e ]
. ["] Use Big Fant
3. Under Text Measurements, specify the Text = ’
u ze
Height, Width Factor, and Oblique Angle. ez ot
[ Match text 2.0000
4. Under Text Font, select the name, style, you want — - Rl
Curmrent Style Name
to use. [ Upside down Width Factor:
. . 2.0000
5. Click Apply, and then click OK. | asBBCC ] Backwards A
[ Vettical 30
(v | [ Qo= | [ ek
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8.3. Create Leader

8.3.1.  Leaders

A'leader is a line or spline with arrowhead at one end, and
annotations (Mtext, blocks as well as tolerance) at the other end.
Generally, you place an arrowhead at the first point. An annotation,
created as dimension text, is placed immediately adjacent to the
last point.

To create a leader and an annotation:

1. Choose Dimension > Leader from the main menu.
2. Specify the starting point of the leader.

3. Specify the endpoint of the leader line segment.

4. Specify additional leader line segment endpoints.
5. After you specify the last endpoint, press Enter.

pecify leader start point:
pecify next point
pecify next point or [Annotation/Format/Undo] <Annotation::
pecify next point or [Annotation/Format/Undo] <Annotation:
pecify next point or [Annotation/Format/Undo] <Annotation>: <ORTHO On>
pecify next point or [Annotation/Format/Undo] <Annotation:
pecify next point or [Annotation/Format/Undo] <Annotation:
pecify neat point or [Annotation/Format/Undo] <Annotation::
Erter first line of annotation text or <options>: LEADER

anmand'

6. Type the annotation, and press Enter to enter the next line of annotation text.

7. Press ENTER to complete the command.

8.3.2. Mleader

Multileader is used to attach annotation to multiple leader lines. Multileader could be used to give additional information or

special instruction in a point or specific area on your drawing .It also has more capabilities like using multiling text or blocks as

leader content in our drawing. This version supports the complete multileader set options like Add Leader, Remove Leader,

Align and Collect.

/o ML STD BLOCKS 5
PP Ams

Muttileader ~

Express

B Muitiieader Collect (MLEADERCOLLECT)
c ftileaders that

ws of
nd displays the resutt
e leader line

58,34
ot
oo

A

39373167, 1993525, 0 8 B bSOt @
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84.  Modify Text

8.4.1.  Change Text

All of text objects can be moved, rotated, deleted and copied, just like other objects. You can change the properties at the
Properties panel. You have two methods to modify single-line text:

- To modify only the content of text, use DDEDIT command.
- To change text style, location, size and content, use PROPERTIES command to open Properties palette, from which, you can
make the relevant settings.

To edit single or multiline text:

1. Type DDEDIT and then press Enter.

2. Select the single line or multiline text.

3. If select the single line text, the Edit Text box will pop up, edit the text and then press Enter.

4. f select the multiline text, the In-Place Text Editor will pop, edit the text according as you need.

Text Formatting

[ Standard + | @Anal Unicode MS ~]25 +B f U § v o3 & HRed - | =) ox | d

=li=-| = dm | @ 0/ |5 w50 |5 |

IEI . . . . Qb‘ elect an annotation object or [Undo]:
J Od Ify elect an annotation object or [Undo]: “Cancel™
mmand: DDEDIT
|§ ISelec{ an annotation object or [Undo]:
s m
MO ¢ Re it U
To change single or multiline text properties: " et o
B Miext Edit...
. . . . Clipboard 3
1. Select a single line or multiline text object. @ Eme
. . . . . $ Move
2. Right-click the selected object and then click Properties on the shortcut menu. @ Copy Slecion
. . ] scale
3. In the Properties palette, enter any new text in the Text Contents, and then change O Rotte
Draw Order >
formatting and other properties as needed. B Growp
Deselect All
4. You can also do double-click on the multiline text to open the In-Place Text Editor, from o e
which, you can modify the contents and formats of text. Sl
Popetes
MText: BNEAE
Hyperink
| |

Cortents ‘pxsm 1:{f@~Arial Unicode MSh
Style Standard
Justify Mc
Direction By style
Text height

MODIFY

Line space factor 1

Line space distance | 8.3333

. Line space style Atleast
= = Background mask No
Defined wih 224358
Annotative No
Defined height 11378
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9. Dimensions and Tolerances

Dimensions indicate the measurement values of objects (e.g. length or width),

distance or angles among objects, or the distance between feature point and the
specified origin. You can create five basic types of dimensions: linear, angular, radial,

28

diametral and ordinate. Dimensions have several distinct elements: dimension text,

dimension lines, arrowheads, and extension lines.

Dimension text: A character string that usually indicates the measurement value,

includes prefixes, suffixes, tolerances, etc.

Dimension line: Indicates the direction and extent of a dimension. For linear dimensions, it displays as a line, for angular

dimensions, it displays as an arc segment.

3\ /

Arrowhead: Usually displayed at both end of the dimension line. You can specify various sizes and shapes for arrowheads or

tick marks.

Extension lines: Extend from the object to the dimension line, in order to define dimension ranges.

91. Create Dimensions

You can create dimensions by selecting the entity to dimension and specifying the dimension line location, or by specifying the

extension line origins and the dimension line location.

9.1.1.  Horizontal and Vertical Dimensions

As you create linear dimensions, the system automatically applies a horizontal
or vertical dimension depending on the specified extension line origins or the
location where you select an object. However, you can create a dimension by

specifying it be horizontal or vertical.

To create a horizontal or vertical dimension:

1. Choose Dimension > Linear from the main menu.

2. Press Enter, and then select the object to dimension. Or, you can specify the

first and second extension line origins.
3. Specify the dimension line location.

9.1.2.  Create Aligned Dimensions

In the aligned dimensions, the dimension line is parallel to the line passing
through the extension line origins. The aligned dimension is also parallel to the
objects you specify. The system creates the extension lines automatically.

)

——
-

60
Horizontal

Vertical
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To create an aligned dimension:

1. Choose Dimension > Aligned from the main menu.
2. Press Enter, and then select the object to dimension. Or, you can specify the first and second extension line origins.
3. Specify the dimension line location.

9.1.3.  Create Baseline and Continued Dimensions

Both baseline and continued dimensions are multiple linear dimensions. Baseline dimensions are measured from the same
baseline and continued dimensions are placed end to end. Before creating either baseline or continued dimension, you have to
create a linear, aligned, or angular dimension.

To create a linear baseline dimension:

60
1. Choose Dimension > Baseline from the main menu. 40 C
2. Specify a second extension line origin. 20 B
3. Select the next extension line origin. A
4. Continue selecting extension line origins as required.
5. To end the command, press Enter twice.
To create a linear continued dimension:
1. Choose Dimension > Continue from the main menu. 20 17 18
2. To select a starting dimension, press Enter. A B C
3. Select the next extension line origin, and then press Enter. Or press Enter, and
then select an existing dimension to continue.
4. To add continued dimensions, continue selecting extension line origins.
5. To end the command, press Enter twice.

0

9.1.4.  Create Rotated Dimensions
You can create rotated dimensions at a rotated angle you specify using DIMLINEAR
Rotated option. An example of a rotated dimension is shown in the following illustration.
In this illustration, the specified angle of the rotated dimension is equal to the angle of the slot.
9.1.5.  Create Angular Dimensions 97°

Angular dimensions are used to measure the angle between lines or three points. You
can dimension objects including circles, arcs, and lines. When you create the
angular dimension, you can modify the text contend and alignment before placing the
dimension line.
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To dimension an angle between two lines:

1. Choose Dimension > Angular from the main menu.
2. Select one line.

3. Select the other line.

4. Specify the dimension line location.

To dimension an angle encompassed by an arc: 161°

1. Choose Dimension > Angular from the main menu.
2. Select the arc.
3. Specify the dimension arc location.

9.1.6.  Create Radial Dimensions

You can create radial dimensions for circles or arcs to measure their radial. The radial ,{/1,
dimension is a line with an arrowhead that points to a circle or arc. <

To create a radial dimension:

1. Choose Dimension > Radius from the main menu.
2. Select the arc or circle.
3. Specify the dimension line location.

9.1.7.  Jogged Dimension

Jogged dimension is namely jogged radius dimension, which is also called "scaled radius dimension". User can specify center
position to place the origin of dimension for replacing center point of circle or arc within radius dimension. DIMJOGGED
command is useful for creating dimensions in case that the center of circle or arc to be dimensioned is located outside the
layout and can't be displayed in its actual position either.

To create a jogged radius dimension:

1. Choose Dimension > Jogged from the main menu.

2. Select a circle or an arc. Q.’lfo
3. Select center position as the dimension origin.

4. Specify a point to position the jog symbol.
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9.1.8.  Create Diameter Dimensions

You can create diameter dimensions for circles or arcs to measure their diameters. Creating diameter dimensions resembles
creating radial dimensions. You can create various diameter dimensions based on the location and size of circles or arc, and the

settings of the dimension style.

To create a diameter dimension:

1. Choose Dimension > Diameter from the main menu.
2. Select the arc or circle.
3. Specify the dimension line location.

9.1.9.  Create Ordinate Dimensions

PAA

Ordinate dimensions are used to measure the perpendicular distance from an origin point called the datum to a feature, such as
ahole in a part. Ordinate dimensions are comprised of a leader line with an X or Y value, and leaders are drawn along the

orthographic direction at the current UCS.

To create an ordinate dimension:

1. Choose Dimension > Ordinate from the main menu.
2. Select the point for an ordinate dimension.
3. Specify the ordinate leader endpoint.

9.1.10. Create Quick Dimension

Creates or edits a series of dimensions quickly by typing QDIM command.

To create a quick dimension:

1. Choose Dimension > Quick Dimension from the main menu.
2. Select the geometry to dimension, and then press Enter.

3. On the command line, it will display "Specify dimension line position, or

[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint

/Edit/seTtings] <Continuous>:".You can perform the operation as desired.

The default is Continuous.

o) & = 3
24 o 2
™ T S B
- < T
‘ } S
RSt S R e E— —{—: ; )
1726,27 ’ 0
1715,97 Ko s
1706,16 off
e *-\\\\
3
18 |
“ /
)

Command Line
olact gromatry o dmenskon: | found. Siotal
elect geomaly o dinersion. | found. Biclal
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9.1.11. Create Arc Length Dimension

Arc length dimension is available for measuring the arc length of arc or polyline arc segment. LusoCAD creates arc length
dimension by specifying extension ling position directly after selecting arc by default. And use an arc symbol as arc length
dimension, which is differing from linear dimension and angular dimension.

ST

40
To create an arc length dimension:

1. Choose Dimension > Arc Length from the main menu.
2. Select an arc or polyline arc segment.
3. Specify a point to position the arc length dimension.

9.1.12.  DIMREASSOCIATE

. / H Insert Annotati 3D Surf; Mesh L. t Vi M
You can input DIMREASSOCIATE command to — == —=_—1 0=
. . _ . A KEET ke |~—.|M.:..:..:..L-<chmﬂ
associate or reassociate selected dimensions to £ B A e A% T S e ‘
Mtext .

. . . Di
objects or points on objects. Standard | T pser

-
T

R -

After enabling the DIMREASSOCIATE command, you will be prompted to choose
associating particular dimension objects or associating all disassociated objects in the
drawing one by one.

[~ Select objects or D
Disassociated

If you select Disassociate option
All of dimensions that have any disassociated defining point with geometries in the drawing will be selected to associate or
reassociate one by one. You can press ‘Esc’ to stop the command, but associations you have made will be kept.

If you select any dimension objects
> When the defining point of selected dimension object doesn’t associate with the geometry, the X mark is displayed.

71 Specify first extension line arigin or | EEREFETRVTEXNTE

> When the defining point of the selected dimension object associates with the geometry, the ] mark is displayed.
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- If you press Enter or select ‘Next’ option, you are able to skip to the next extension-line origin point.

- If you select ‘Select object’ option, you are able to select a geometric object to associate with the dimension.

- If you press ‘Esc’, you will stop the command, but associations you have made will be kept.

9.2. Use Dimension Styles

You can control the appearance of dimensions by changing settings to help maintain dimensioning standards, you can store
these settings in dimension styles.

9.2.1.  Dimension Styles

You can create, save, restore, and delete named dimension styles. Dimension styles provide a way for you to change various
settings that control the appearance of dimensions. You can change the following settings:

- Extension lines, dimension lines, arrowheads, center marks or lings, and the offsets between them.

- The positioning of the parts of the dimension in relation to one another and the orientation of the dimension text.

- The content and appearance of the dimension text and units of the dimension value.

To create a dimension style: (3 Dimension Style Manager =
1. Choose Dimension > Style from the main menu. Y T —
2. In the Dimension Style Manager dialog box, click New. S5t [ ——
3. Type the name of the new dimension style and choose which S (Lcomme ] | g
style started with and what kind of dimension used for. Then click ﬁ?g.f;h - %
Continue. UD"'“"‘E‘ —

4. In the New Dimension Style dialog box, change the dimension Lt [Aldimensions 8

seftings as necessary. Repeat this step for each tab, as needed. | . =

5. To end the command, click OK. Helo
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(3 New Dimension Style: new dim style ===
Lines | Symbols and Amows | Text | Adust | Prmary Units | Atemate Units | Tolerance |
Dimension Lines
Color BBk - 1.1l
e
4 =
Lineweight ByBlock > & &
5y
Extend beyond ticks ’ ‘
Baseline spacing s = 5
o
Suppress [IDimine 1 [7] Dimline 2
Extension lines
Calor: M ByBlock ~|  Extend beyond dim lines 125
= Offst from orgin 0525
et
[T Fixed length extension lines
Lineweight: ByBlock b
Length 1
Suppress:  [[Etlne]  [[]Edine2
i [ ok | [ Caneed | [ Heb

To rename a dimension style:

1. Choose Dimension > Style from the main menu.

2. In the Styles list do one of the following:
- Double click the required style.

- Right click on the required style name and then choose Rename.

3. Type the new name.
4. Click Close to exit.

To delete a named dimension style

1. Choose Dimension > Style from the main menu.
2. In the Styles list, right click on the required style name, and then

choose Delete.
3. Click Close to close.

To display information about the current style:

1. Choose Dimension > Style from the main menu.

2. In the Dimension Style Manager dialog box, click Compare.

3. In the Compare Dimension Style dialog box, choose the same
dimension style from the Compare and With pulldown list, all properties

for specified dimension style will be displayed.

4. If you want to know the different information between two styles,
choose one style in the Compare box, choose the other in the With box,
and then you will see difference in the following tab.

5. Click Close to close.

I al
(3 Dimension Style Manager i
Current Dim Stye: 150-25
Styles: Preview of: Standard
Set Curert

10159

Rename

A Annotative U
15025
Set Current -‘ |—- =

Delete

List:

Dont list styles in Xrefs

11555 /\
20208
(=i >
RO.B045

Desciption

1S0-25 + Atemiate precision = 2, Atemate
ratio factor = 25,4000, Altemate tolerance
precision = 2, Amowhead size = 0.1800,

Dont it styles in Xrefs

r o
(3 Dimension Style Manager =]
Curert Dim Sty 150-25
Styles Preview of: Standard
A Annctative Set Curent
150-25
Set Current Loz
Rename T /\
o5
Delete @ 20208 Qenide
&07
\
RO.8045
Lt Desciption
o 000, et s
styles Y| ratio factor = 25.4000, Atemate tolerance

precision = 2, Amowhead size = 0.1800,

-
@ Compare Dimension

]

Styles

Compare: [Standard

With: [NEW STYLE -

gead found 4 diferences:

Description

Color of dimension line
Dim line linetype

Dim line linewsight

Ext line: color

Variable Standard  NEW STYLE
DIMCLRD  ByBlock  Blue
DIMLTYPE BYBLOCK Continuous
piMLwo - -2 35
DIMCLRE  ByBlock Green

Help
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9.2.2.  Modify Dimension Lines

On the Line tab of the Modify Dimension Style dialog box, you can
set the color of dimension lines, lineweight, ticks beyond extend
line, baseline spacing, and visibility.

9.2.3.  Modify Extension Lines

Extension lines have the following properties: color, lineweight,
distance beyond extension lines, offset from start of extension lines,
and visibility. You can set these properties on the Ling tab of the
Modify Dimension Style box:

- The distance beyond extension lines means how far the extension lines

extend beyond the dimension line. Syt o o | o[ Py e [ s s [
- Start offset is the distance between the extension line origin and the start s}
of the extension line, also called extension origin offset. r
Leader: L @ E‘Dai
9.2.4.  Choose Dimension Arrowheads .
You can control the appearance and size of arrowheads or hook marks Dinensin e G
placed at the ends of dimension lines. You can specify different arrowheads | = -
for both ends of a dimension or leader lines. The First arrow is toward the
(oK ] [ Cancel | [ Heb

first extension line; The Second arrow is toward the second extension line.

To choose an arrowhead:

1. Choose Dimension > Style from the main menu.

(3 Modify Dimension Style: NEW STYLE

Lines | Symbals and Amows | Texd | Adjust | Primary Units | Atemate Units | Tolerance |
Dimension Lines
o e
10159
linchpe Continuous
20208
Bxtend beyond ticks 0 i @ e
Bassine spacing: 038
RO.8045
Suppress [IDimine1  [C]Dimiine 2
Extension ines
Color Extend beyond dim lines: 01z
pU—— §
Offset from ongin: 00625 =
ipo i
[] Fixed length extension lines
Lineweight. ByBlock
Length: 1
Suppress [lEtine 1 [lEdlne2

ok | [ cancel | [ Hep

3 Madify Dimension Style: NEW STYLE

2. In the Dimension Style Manager dialog box, select the style you want to change and click Modify button.
3. In the Modify Dimension Style dialog box, click the Symbols and Arrows tab.

4. Make your selections under the Arrowheads.
5. Click OK and then choose CLOSE to exit.

9.2.5.  Fit Dimension Text within Extension Lines

When there is no enough space between extension lines to accept
both of dimension text and arrowheads, you have to adjust one or
both of their placement. By default, the system fits them best
depending on the available space. You can specify other methods
to place them on the Adjust tab of the Modify Dimension Style
dialog box.

(3 Modify Dimension Style: NEW STYLE

Lines | Symbols and Arows | Text | Adiust | Primary Units | Atemate Units | Tolerance |

Fit optionis

[ there isnt enough room to place both text and
amows inside extension lines, the first thing to
move outside the extension lines is:

@ Ethertext or amows best ft)

) Amows

O Text

(©) Both text and amows

) Abways keep text between ext fines

[] Suppress amows if they dont fit inside:

Text posttion

When text is ot in the default postion, place i
@ Beside the dimension line

©) Over dimensian line, with leader

) Over dimension e, withaut leader

10159

11955

/\

RO.B045

Scale for dimension fealures
[C] Annctative
() Scale dimensions to layout

@ Use overall scale of: 1.0000

Fine Tuning
[] Place text manually
[] Draw dim line between ext lines

[=}
=

[ Cancel | [ Heb
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To format dimensions:

1. Choose Dimension > Style.

2. In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify.
3. In the Modify Dimension Style dialog box, click the Adjust tab.

4. Under Fit Options and Text Placement, select an option.

5. Click OK and choose Close to exit.

9.2.6.  Fit Diameter Dimension Text

You can create various diameter dimensions based on text placement, fit options
and the selection of "Always keep text between ext lines" option on the Adjust tab.

Modify Dimension Style: new dim style

Et options
if there isnt enough room to place both text and
amows inside extension lines, the first thing to
move outside the extension lines is:
Either text or amows (best fit)
Amows
Text
Both text and amows
| © iz kesp o beiween st s |

Suppress amows i they don! fit inside

@37
@ @ q;;\ .

Default horizontal User defined horizontal
placement text outside placement dimension line

circle, center mark, and arrows, no center mark,
no forced interior line forced interior line

9.2.7.  Align Dimension Text

Whether the text is inside or outside the extension
ling, it has no effect on the justification of dimension
text. You can choose whether the text is align with the
dimension lines or remains horizontal.

To align dimension text with the dimension line:

1. Choose Dimension > Style.

2. In the Dimension Style Manager dialog box, select
the style you wish to change and choose Modify.

3. In the Modify Dimension Style dialog box, click
the Text tab.

4. Make your selections.

5. Click OK and choose Close to exit.

Text and arrows inside
with inside horizontal

option selected

Lines | Symbols and Amows | Text | Adust | Primary Units | Atemate Units | Tolerance |

Text appearance

Text style
Text color
Fill color
Text height

Fraction height scale

Text postion

[Standard > ][]
WRed -]

[Green -l

Draw frame around text

Veriical

Horizontal

View Direction:

(Offset from dim line:

From left to right. -

0625

Tet aignment
(©) Horizortal

@ Aigned with dimension inc

(21150 standard

Lines ISymbolsandew:le Adjust _learylh(slﬂema

, 16,6

Scale ford
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9.2.8.  Position Dimension Text Vertically

The vertical text placement is the position of the
text relative to the dimension. You can place text
above, below, or centered within the dimension
line, or use the JIS dimensions.

9.2.9.  Position Dimension Text Horizontally

Lines | Symbols and Arows | Text

| Adjust | Primary Units | Altemate Units | Tolerance |

Text appearance
Text style

= —(

Text color: WRed M

Fill color: MGreen -
Text height: 25

Fraction height scale 1

Draw frame around text

Text posiion

=
.

Text alignment

@ Horizontal

Vertical Up -

Over Ex Line 1 -
From right to et -

0625

Horizontal:

View Direction:

Offset from dim line:

() Aligned with dimension line

(2150 standard

(

ok | [ Cancel | [ Heb

] R

The position of text along the horizon is relation

to the extension lines. The settings include Centered, At Ext Line 1, At Ext Line 2, Over Ext Line1, and Over Ext Line2.

9.2.10. Dimension Units

You can determine the appearance and format of the
primary and alternate dimension units. You can set
the primary units for linear and angular dimensions,
including unit format, numeric precision and so on.
These settings control the display of dimension
values.

To round off dimensions:

1. Choose Dimension > Style from the main menu.

Lines | Symbols and Amows | Text [ Adust | Primary Units | Atemate Units | Tolerance |

Linear Dimensions

Decimal -

Uit formt:

Precision.

Fraction format 00
Decimal separator

Round off:

Scale factor
[ Apply to layout dimensions ort ly
Zer suppression
] Leading
Sub-unts factor
100

Traiing
0 Feet

Sub-unit suffoc: 0nches

0K | [ Cace | [ Heb

2. In the Dimension Style Manager dialog box, select the style you wish to change and choose Modify.
3. In the Modify Dimension Style dialog box, click the Primary Units tab.
4. In the Linear Dimensions and Angular Dimensions fields, type or select the nearest value to which you want to round off

dimensions.
5. Click OK and choose Close to exit.

9.2.11. Alternate Units

You can create a dimension in two systems of measurement simultaneously in a drawing. This feature is helpful when you want
to add feet and inches dimensions in a drawing created using metric units. The alternative units appear in a square brackets ([])
in the dimension text. Alternative units can be applied to linear dimensions only.The precision for alternate units determines the

number of decimal places.
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To create an alternate dimension: - . : ——

Lines | Symbols and Arows | Text | Adust | Prmary Units | Atemate Units | Tolerance |

Display altemate urits

- G B

1. Choose Dimension > Style. -

2. In the Dimension Style Manager dialog Prcion

box, select the style you wish to change s R /

. Round distances to: o =
and choose Modify. i Plcerer
| —

3. In the Modify Dimension Style dialog A

@ After primary value

Zero suppression

box, click the Alternate Units tab. [ Leacing @ Tising s

4. Click the Display Alternate Units check Ca— -

bOX Sub-unit suffix:

5. Make your

selections. Cox ] [owm] e |F

6. Click OK and choose Close to exit.

9.212. Display Lateral Tolerances

Lateral tolerance represents a value that the amount a measured distance can vary. You can control the degree of accuracy
needed for a future by specifying tolerances in manufacturing. These dimension tolerances indicate the largest and smallest
permissible size. You can also apply geometric tolerances to indicate deviations of form, profile, location, orientation, and
runout.

Deviation tolerances represent with the plus and minus values that are appended to the dimension values. If the deviation
tolerances are equal, the + signs precede them and they are known as symmetrical. Otherwise, the plus value locates above
the minus value.

The vertical placement of tolerance values that is relative to the main dimension text can be specified. For example, you can
align the tolerances with the top, middle, or bottom of the dimension text.

[ Lines | Symbols and Arows | Text | Adjust | Primary Units | Akemate Unis | Tolerance |
Tolerance format
ot L1
eiho [Smmencal -]
None SYMMETRICAL
P 3
mem T g @
Limits o >
Upervae: | e ’ ' % DEVIATION
Lower value: 0 @‘P +0,5
& 24 -0 24%0,5
Scaling for height: 1 =
Atemate unit tolerance
Tolerance aignment 35+0,5 35405 +0,5
e R EECes: 00 -0,6 0,6 35-0,6
® Algn operationsl symbols Zero suppression
Zero suppression Leading Dfest
eaiea o Teing Ot TOP MIDDLE DOWN
[¥] Trailing 0 Inches
[ ok | [ cawd | [ Heb - | | ‘ | ‘ |
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9.2.13. Set the Scale for Dimensions

Setting dimension scale depends on the method you use to lay out and plot drawings. Dimension scale has effects on the size
of dimension geometry relative to the objects in the drawing. In addition to text height and arrowhead size, dimension scale
affects offsets in dimension as well, such as the extension line origin offset. When you create dimensions, it's recommended to
set the size and offset to values that represent their actual plotted size. However, the tolerances, measured lengths, coordinates,
and angles cannot be applied to the overall scale factor. The method of creating dimensions in a drawing layout is shown as
follows:

- Dimension in model space for plotting in model space. If you want to create dimensions that are scaled correctly for plotting,
you have to set the system variable DIMSCALE to the inverse of the desired plot scale. For example, if the plot scale is 1/4, you
have to set DIMSCALE to 4.

- Dimension in model space for plotting in paper space. If you want to create dimensions that are scaled automatically for
display in a paper space layout, you have to set the DIMSCALE to 0. This method is useful when you encounter the following
situations: the dimensions in a drawing need to be referenced by other drawings (xrefs); when you create isometric dimensions
in 3D isometric views. To prevent the dimensions in one layout viewport from being displayed in other layout viewports, it's
recommended to create a dimensioning layer for each layout viewport that is frozen in all other layout viewports.

- Dimension in layouts. You can create dimensions in paper space by selecting model space objects or by specifying object

snap locations on model space objects. The dimensions created in a paper space layout do not need additional scaling: there is
no need to change the default value of DIMLFAC and DIMSCALE.

9.3. Modify Existing Dimensions

You can modify all components of the existing dimension objects in a drawing either individually or by using dimension styles.

9.3.1.  Modify Dimension Style

You can modify all of properties of
the existing dimension objects in a

() New Dimension Style: new dim style 2

Lines | Symbols and Arows | T | Adust | Prmary Uns | Akemate Lnks | Telersnce
Tolerance format

. . . . () imensian Style Manager = — — - _H ‘
drawing using dimension styles. GRS e — = I P ./_\
You can also create a dimension o wa — |Rae - || B NGPY AN

. . _l | - o / - -
style override to temporarily H A\ = _

. ) ) E— ' Ovends__| ‘Scaling for height
change a dimensioning system ,-~ = =] |[— =
variable without changing the . s o

. . o e e By Abgn operatonal symbols Zaro suporession

current dimension style. If a o ] -
dimension style is changed, the Lo [t ) et

dimension associated with that
dimension style updates
automatically.

V| Tralng Dinches

ok ] [ cawa | Hebp
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9.3.2.  Make Dimensions Oblique

Extension lines are normally created at a perpendicular angle to the

dimension line. You can change the angle of the extension lines, however, so

that they tilt relative to the dimension line.

To make oblique extension lines:

1. Choose Dimension > Oblique from the main menu.
2. Select the linear dimension, and then press Enter.
3. Type the obliquing angle, and then press Enter.

Z
3
=
3
g

Linear
Aligned
Arc Length
Ordinate

Radius
Jogged
Diameter

Angular

Baseline

Continue

Dimension Space

Dimension Break

Leader
Tolerance...
Center Mark
Inspection
Jogged Linear

Oblique
Align Text

[N T TI0BA H IF P00 EAS

Dimension Style...

Dimension Modify Window Help Express

5
G

Remark: To align the oblique angle if you don't know the exact measurement, use snaps to pick two points on the entity.

9.3.3.  Dimension Jogged Linear

The DIMJOGLINE command is available for adding or removing jog
symbol for linear dimensions. The jog symbol is default to be placed at
the center point between first extension line and text. To relocate jog
symbol, you can adjust the position of dimension text or specify new
position to locate jog after reselecting dimension.

To add a jog to linear dimension:

1. Choose Dimension > Jogged Linear from the main menu.

2. Select a linear dimension.

3. Specify a point on the dimension line to determine the jog symbol, or
press ENTER directly to position the jog symbol in default place.

9.3.4.  Dimension Inspection

PILCIEEL] Modify Window Help Express

[%] Quick Dimension

Help

Express

Dimension inspection is created to transmit the frequency of inspecting the part
being dimensioned, the dimension value and parts tolerance are ensured to be
within specified range. Dimension inspection is composed by a frame and internal
text and contains utmost three kinds of information field: inspection tag, dimension
value and inspection rate.

Inspection tag, used for mark the text of dimension inspection is located at the left
side within the inspection frame. Dimension value is the value before adding
dimension inspection, which is located at the central part of the inspection
dimension including tolerance, text and measurement value.

Inspection rate is expressed by percentage, which is located at the right side within
the inspection frame, indicates required frequency of the part being created.

[ Linear
%, Aligned
4F Arclength — 52 —
‘i Ordinate
(®) Radius
?) Jogged
(2 Diameter
4 Angular
[t Baseline
H  Continue
\[, Dimension Space
' Dimension Break
52
A Leader
Tolerance...
(3) Center Mark
/- Oblique
Align Text >
&, Dimension Style.
I Override
i Update
Inspection Dimension oS
[R | Select dmensions
Shape Label/Inspection rate
o Rund  (OX[109%) 7lLabe
T
foad:
¥ Inspection rate
Nooe XXX 100%
9%
Cancel
(EXT|77,94|957.)
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To create an inspection dimension:

1. Choose Dimension > Inspect from the main menu.

2. In the Inspection Dimension dialog box, click Select Dimensions button.

3. Select dimensions to add dimension inspection, and then press ENTER to finish selection and return to the dialog box.
4. Select a shape for frame from the Shape option.

5. Click Label option to input label in the text box.

6. Click Inspection Rate option to input a valug in the text box.

7. Click OK.

To remove an inspection dimension:

77,94
1. Choose Dimension > Inspect from the main menu.
2. In the Inspection Dimension dialog box, click Select Dimensions button.
3. Select dimensions to remove dimension inspection, and then press ENTER to
finish selection and return to the dialog box.
4. Click Remove Inspection button. - _
5. Click OK.
9.3.5.  Adjust Dimension Space
Once you have created multiple 77,94
paralleled linear dimensions or g T 46,08
angular dimensions, you can adjust - : %
the space among these paralleled I % 36,77 7
lines with an equal value either 7 i
default or specified. DIMSPACE
command adjust the space among Z é

paralleled linear or angular

dimensions or overlapped

dimensions automatically in case

that the original space is not equal values. If you set the space value to 0 when adjusting space among dimensions, you can
align selected dimensions at the dimension line as well.

9.4, Add Geometric Tolerances

@.505-.525

[ 4 B.0050|A[DM[B]
Geometric tolerances show acceptable deviations of form, profile, \\;TQMW Datm
orientation, location, and runout of a feature. You add geometric Qatum Mataril
tolerances in feature control frames. These frames contain all the Secondary Datum
tolerance information for a single dimension. Geometric tolerances ;a?;n'; Zi‘n“d’l"“on
can be created with or without leader lines, you can create them :'m:r'm
with TOLERANCE or LEADER command. Diameter Symbol Indicating

Cylindrical Tolerance Zone

Geometric Characteristic
Symbol
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A feature control frame consists of two or more components. The first feature control frame contains a symbol that represents
the geometric characteristic to which a tolerance is being applied, for example, location, profile, form, origntation, or runout.
Form tolerances control straightness, flatness, circularity and cylindricity; profiles control line and surface. In the illustration,
the characteristic is position.

9.41.  Geometric Tolerance Dialog Box

Specifies the symbols and values for a feature control frame.

1. Geometric Characteristics symbol (menu) 1 2 3 4 5 6

2. Tolerance Zone form (toggle) e =)

3. Tolerance zone value v VvV v v v v —
. . Sym Tolerance 1 Tolerance 2 Datum 1 Datum 2 Datum 3

4. Material condition symbol (menu) o - H N : BN n

5. Datum reference 1 of 3 H N H N [ | ] | | ‘

8
6. Datum reference 2 of 3 [T teoe w0 Projected Tolerance Zone: [B) 4«— 7 |
, 9 h

7. Projected tolerance zone symbol (toggle) " e (d

8.  Projected tolerance zone value Ok ][ Cancel ][ Hep ] ‘

9.

Datum identifier

9.4.2.  Geometric Tolerance Symbols

The geometric tolerance symbols and their characteristics are shown in the following.

1. Position (Location) 8.  Flatness (Orientation)

2. Concentricity or Coaxiality (Location) 9. Circularity or roundness (Form)
3. Symmetry (Location) 10. Straightness (Form)

4. Parallelism (Origntation) 11. Profile of a surface (Profile)

5. Perpendicularity (Orientation) 12. Profile of a line (Profile)

6. Angularity (Orientation) 13. Circular runout (Runout)

7. Gylindricity (Orientation) 14. Total runout (Runout)

11 12 13 14
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9.4.3.  Material Conditions

Depending on control type, you can add a diameter symbol prior to the tolerance value, and specify a material condition
symbol behind this value. You can apply material conditions to features that can vary in size.

9.4.4.  Datum Reference Frames

A datum reference consists of values and modifying symbols. A datum is a theoretically exact geometric reference that
measures and verifies a theoretically exact point, axis, or plane. The system provides up to three datum reference letters and
relative symbols followed by the tolerance value.

9.45.  Projected Tolerance Zones

Projected tolerance zones control the height of the fixed perpendicular part of the extension area, and control tolerance
accuracy by positional tolerances. Before you set the symbol to projected tolerance zones, you set a height value to specify the
minimum projected tolerance zone.

9.4.6. Composite Tolerances

A composite tolerance consists of two tolerances that applied to the same geometric characteristic of a feature or for features
that have different datum requirements. Before you create a dimension and add a composite tolerance for a drawing, you have
to specify the first line of a feature control frame and then choose the same geometric characteristic symbol for the second line
of the feature control frame. The specified geometric symbol compartment is extended over both lines. Then you can create a
second line of tolerance symbols.

To add a geometric tolerance;

1. Choose Dimension > Tolerance from the main menu.

2. In the Geometric Tolerance dialog box, click the first square under Sym and select a symbol to insert.
3. Under Tolerance 1, click the first black box to insert a diameter symbol.

4. In the Text box, type the first tolerance value.

5. To add a material condition, click the second black box and click a symbol to insert it.
6. Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value.

7. Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.

8. Click the black box to insert a material condition symbol for each datum reference.

9. In the Height box, type a projected tolerance zone height value, if appropriate.

10. To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box.
11. In the Datum Identifier box, add a datum value and then click OK.

12. In the drawing, specify the location of the feature frame.
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10. Blocks, Attribute and reference

Block Definition =)
- 19
10.1.  Create and Insert Blocks i g e ‘
Specify On-screen Specify On-screen Annotative ‘
Blseases] [ O |
Retain
Usually, blocks are several objects combined into one that : ® Convertto bock S
. . . . . - Delete | Alow exploding
you can insert into a drawing and manipulate as a single z ey
object. Blocks can help you better organize your work, Setings Descrption
Block unit
quickly create and revise drawings, and reduce drawing file Milmeter v
size. [ etk
Open in block edtor [ok__ ][ cance Help

10.1.1. Create Blocks

Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a single object. A
block can consist of visible objects such as lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks
are stored as part of the drawing file. You can use several methods to create blocks:

- Combine objects to create a block definition in your current drawing.

- Create a drawing file and later insert it as a block in other drawings.

To create a block for use within a current drawing:

1. Choose Draw>Block> Make from the main menu.

2. In the Block Definition dialog box, enter a block name in the Name

box.

3. Click Pick point button to specify the insertion point for the block in
the drawing area.

4. Click Select objects button to select the objects for the block, then

press Enter after selection. Then click OK button.

10.1.2. Create Nested Blocks

e
o
N () i =
*’ u !* Objects to Block 2
.. .- EE——
~|- T T T
[ SRR = RSO | L TR

You can define blocks and other blocks as nested blocks so as to simplify the organization of complicated blocks. With nested
blocks, you can build a single block out of several components. But you should notice that blocks that reference themselves

cannot be inserted.

---------------------------------

--------------------------------
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10.1.3. Create Drawing Files for Use as Blocks ey
Source
Block:
. . . () Ertire drawing
You can create a block as a separate drawing file that you can insert © Objects
Base point Objects

into other drawings. I S
-0 (@ Retain
() Convert to block

() Delete from drawing

To save a block as a separate drawing file:

0

M D%

0
2 objects selected

1. On the command line, type WBLOCK.
2. Under Source area, choose one of the following:

Destination
File name and path:

-]

- Block: Saves existing block object to a separate drawing file.
- Entire drawing: Saves the entire drawing to a separate drawing file.
- Objects: Saves those objects you select to a separate drawing file.

Insert units: [ Millimeter - ]

3. Under Destination area, type the name of the drawing file you want to create and choose the saved path, click OK to save.

10.1.4. Change the Base Point of Drawings to Be Used as Blocks

When inserting a drawing file into another drawing as a block, by default, system uses the origin (0,0,0) of WCS as the base
insertion point. To specify different insertion point, you can use BASE command. Next time you insert the same block, system
uses the new insertion point by default.

10.1.5. Update Changes in the Original Drawing

Once the drawing file has been inserted into another drawing as a block, the original drawing changes as well. But the block
having been inserted will not change. If the block happens to change along with the original drawing, you should attach it as
external reference but not as a block.

10.1.6.  Use Paper Space Objects in Blocks

Objects created in paper space are not contained in the block when it is being inserted into the drawing. You can convert the
objects in paper space as block or save as an individual drawing file before inserting into other drawings.

Insert ==
10.1.7. Insert Blocks = T @
Path

You can insert blocks and other drawings into the current r——r S Rotaton |

V| Specfy On-screen Specfy On-screen Specy On-screen
drawing. When you insert a block, it is treated as a X 1 foge: 0
single object. When you insert a drawing, it is added to ok Bock Unt

1 ers
the current drawing as a block. You can then insert l:' :m
Unform Scale actor.

multiple instances of the block without reloading the

ok J(camce ][ hoe

original drawing file. If you change the original drawing
file, those changes have no effect on the current drawing unless you redefine the block by reinserting the changed drawing.
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To insert a block;

1. Choose Insert > Block from the main menu.

2. In the Insert Block dialog box, under Insert, click Block Name.
3. In the Name box, select the name of the block you want to insert.
4. If you want to use the pointing device to specify the insertion point, scale, and rotation, select Specify On-Screen. Otherwise,

enter values in the Insertion Point, Scale, and Rotation boxes.

5. Click OK to insert.

To insert an entire drawing into the current drawing:

1. Choose Insert > Block from the main menu. : - - @ -
2. Click Browse to specify the file from the Insert Block dialog Path

box. o s =

3. You can use the default insertion point, scale, and rotation or XS”:"O“W :”T"O”W WMTW
select Specify On-Screen and enter values in the Insertion Point, Y. 0 Y1 .

Scale, and Rotation boxes. z 0 = K Unt:  Mdmeters

4. If you want the objects in the block to be inserted as individual vyl e il

objects instead of as a single block, select Explode. Precondition - Concel e

is the block you created is allowed to
explode.
5. Click OK to insert.

10.1.8. Modify a Block Definition

You can redefine all instances of a block within the current drawing. To redefine a block that was created in the current drawing,
you create a new block using the same name. You can update all the blocks in the current drawing by redefining the block. If
the block was inserted from a separate drawing file that was subsequently updated, reinsert that block to update all other

instances in the current drawing.

To redefine a block in the current drawing:

1. Choose Draw > Block > Make from the main menu.

2. In the Block Definition dialog box, type the name of the
block you want to redefine in the Name box.

3. Click Pick point button to specify a point as the insertion
point for the block in the drawing area.

4. Click Select objects button to select the objects for the
block, and then press Enter after selection.

5. Click OK.

6. Click Yes in the prompt box that displays to redefine the
block in the current drawing.

() Block Definition

Hame:
1 -

Base point Objects

"1"is already defined as a block. What do you want to do 7

Number of 1 block reference in the drawing: 1

YYes: Redefine block, No: Don' redefine block

Settings Description
Block unit:

Millimeters -

Hyperink

Behavior

[] Open in block editor

OK

] [ Canes | [

Help
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10.1.9. Remove Block Definitions

Too many block definitions in a drawing file may
affect the drawing size. To reduce the size of a
drawing, you can remove unused block definitions.
Erasing a block reference from a drawing may delete

the block reference but retain the block definitions in g
the block definition table. Using PURGE command
can help removing unused block references from Al

your drawing in order to reduce the drawing size.
You should erase all references from a block before
you can purge the block definition.

10.1.10. Define and Use Block Attributes

Named Objects

© Yiew items you can purge
Viey items you cannot purge:

Items not used in drawing:

MutiLine Style
Plot styles
Regstered appication
Shape:
- [3 Table styles
B Textstyes

V! Confirm each item to be purged
Purge pested items.

An attribute is a particular object that you can save as part of a block definition. Attributes consist of text-based data. You can
use attributes to track such things as part numbers and prices. Attribute values are either fixed or variable.

To define an attribute:

1. Choose Draw>Block> Define Attributes from the main menu.
2. Under the Attribute, type the tag, prompt, and default text.

3. Under Insertion Point, specify the location of the attribute, or
click Specify on-screen to select a point in the drawing.

4. Under Mode, select the optional attribute modes.

5. Under Text Settings, specify the text characteristics.

6. To add the attribute to the drawing, do one of the

following:

- Click Define to add the attribute and keep the dialog box active
S0 you can define another attribute.

- Click Define and Exit to add the attribute and end the
command.

To edit an attribute definition:

1. On the command line, type DDEDIT.

2. Select the attribute definition text to edit.

3. Modify the attribute tag, prompt and default in the Edit Attribute
Definition that displays.

4. Click OK.

Attribute Definiti

Mode

[ Invisible

|| Constant

[ Verity

[ Preset

Lock position
[ Muttiple lines

Insertion Poirt
Specify on-screen

7
A8

Z

Align below previous attribute definition

X
Attribute:
Tag:
Prompt:
Defauit @
Text Settings
et e
[ Annotative
Test height 25
Rotation: a
Boundary width: 1Y
[ ok | [ Caned | [ Hep |

(<) Edit Attribute Definitio

Taa:
Prompt:

Default:

STEW|

small stew

Ok | [ Cancel | [ Heb
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10.1.11. Modify Block Attributes

You can use the Block Attribute Manager to modify attributes in
block definitions. For example, you can modify the following items:

- Attributes of blocks can be displayed after modification.
- Text properties that define how attribute text is displayed in the

drawing.

Tag SOFA
Promgt. HOW MANY BODES?

Defat 3

- Properties that define the layer that the attribute is on and the attribute line's color, weight, and type

To edit an attribute attached to a block:

1. On the command line, type DDATTE.

2. Select the block to edit. The Edit Attributes dialog box displays

all the attributes attached to the block you select.
3. Edit the attribute values as necessary. Then click OK.

10.1.12. Extract Block Attribute Data

Enter EATTEXT to start Attribute Extraction if the blocks
in the drawing contain attributes. You can extract block
information according to the wizard prompt and
generate list S0 as to overview the attributes information
of the blocks. You can get guide information from the
wizard until you accomplish selecting drawings, blocks
and block attributes.

With the extract block attribute data function, you can

B K

Block name:SF

HOW MANY BODIES? 3 ‘

@ Drawing/Shest set
Include cument drawing

() Select objects in the currert cyaw\ng

C)

Drawing files and folders:

&

Data Extraction - Additional Settings ﬂ

) Folder
() Graphics
(B C\Users\ovs'Deskioph

Extraction settings
Extract objects from blocks

Extract objects from xrefs

| tnculue xrefs in block counts

Extract from
(7 Objects in model space
(@) All objects in drawing

[ oK ] [Cancel] [ Help ]

easily create list using drawing data through extracting attribute information and export to external files.

10.1.13. Synchronize Attributes

The ATTSYNC command applies attribute changes in block definitions to all block references of the same name. You can use

this command to update instances of blocks containing attributes that were redefined using the BLOCK or BEDIT commands.

ATTSYNC does not change any values assigned to attributes in existing blocks. ATTSYNC removes all changes of format or
features that are made by ATTEDIT or EATTEDIT commands. And it also deletes all extended data associated with blocks and
might affect dynamic blocks and blocks created by third-party applications.
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10.2.  Reference Other Drawing Files (Xrefs)

External references provide additional capabilities not available when you insert a drawing as a block. When you attach an
external reference, however, any changes you make to the original drawing file are reflected in the drawings that reference it.
External references are useful for assembling master drawings from component drawings. Use external references to coordinate
your work with others in a group. External references help reduce the drawing file size and ensure that you are always working
with the most recent version of a drawing.

10.2.1. Attach External References

When a drawing is attached to current drawing as external reference, it will be linked to the drawing, any changes to the
referenced drawing may affect the external reference in current drawing. External references are inserted into the drawing as
block definitions and used as single objects, but you should distinguish the external references and blocks.

To attach an external reference:

1. Choose Insert>External References from the main menu.

2. Click the DWG icon at the top left of the window.

3. In the Select Reference File dialog box, specify the drawing file to attach and then click Open.

4. In the External Reference dialog box, under Reference Type, choose how you want to insert the drawing:
- Attachment: Inserts a copy of the drawing and includes any other drawings references.

- Overlay: Lays a copy of a drawing over your original drawing

5. Make any additional selections and then click OK.

6. If you marked Specify On-screen for any items, follow the prompts to attach the external reference.

External Reference x

Elo-o
(1) 13
Reference Nome Status Sae
N orawngt Opened
& moos2 Losded 163.20K8

E; BLOOKS 2IDTNAMIC BLOCKE  Not referenced 0.00 4B
K B00S 20MAMICBLOKE  Unloaded

Reference ...
Status

Tyve
DATE
Save path
Found At

10.2.2. Control the Properties of Referenced Layers e

Name 4  On Lok Coor  Lnetwe  Lnewsgt

You can control the visibility, color, linetype, and other
properties of an xref's layers and make these changes
temporary or permanent. If the VISRETAIN variable is set to 0,
these changes apply only to the current drawing session. You o R T
can also control the fade display through XDWGFADECTL B
variable. In addition you can control Xref layer properties directly into the Layer Manager Properties dialog box.

N
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[IEXLY) Window Help Express

10.2.3.  Xref Clipping Boundaries z
e
You can control whether to display clipping boundary of xref ﬁ Ve
through setting system variable XCLIPFRAME. Also you can Clip |5 .
Xrefs by selecting the option on the menu bar: §
Modify> Clip>Xref JE=
10.2.4. Nestand Overlay External References o
o e

Xrefs can be nested in another xref and attached to current
drawing. In the process of attaching, you can select insertion position, scaling factor and rotation angle for xrefs.

10.2.5. Binding an Xref to a Drawing

- -0
To provide a copy of a drawing containing external references to someone else, you

Reference Na... Status Size

must also provide all the external reference files. Binding the external references makes oraningt opened ]
%]

them a permanent part of the drawing, which is similar to inserting a separate drawing o

as a block. You can bind external references by doing right click to the selected Xref file. & o

Attach... E

Unload
Reload 74.0KB ]
Detach
Bind...

Path

10.2.6. Refresh Xrefs

(3 Bind Xrefs/DGN underlays

You can refresh the Xref by clicking the refresh button located at the top Bind Type

. @) Bind
of the External Reference Dialog Box. &8 ‘
) Insert

10.3.  DGN Underlay

& 0 0y y [T 4 T (L S esme heies
5 o3 DR RGD L S I
) v -

In LusoCAD 2025 version, the full DGN files are supported and
related commands such as DGNIMPORT, DGNATTACH,
DGNADJUST, DGNMAPING, etc are available. Now you can import
and attach as underlay a Microstation native format.
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10.4.  DWF Underlay

LusoCAD supports DWF Underlay, you can insert a DWF file as Underlay.

10.5.  PDF Underlay

9 select Reference File

=

Lookin: |, Drawing and picture -2
Name Date Type Size
). 2015 drawings 11/28/2014 ... File folder
| test drawing 1217/2014 ... File folder

B

=i

File name:

Files of type:

m-
Togs

T i

If you receive project drawings in the form of a PDF file, you can reuse that PDF data in your own LusoCAD drawing files.

Select Reference File | Attach PDF Underlay . 4 (=
Lookin: |, Drawing and picture - @ mE-
Ham (PDF UNDERLAY - Browse
I Name Date Type Size Tags
e 1. 2015 drawings 11/28/2014 .. Filefolder Select e o more poges from POF e
| test drawing 12/17/2014 ... File folder
PO UNDERLAY 10/24/2014 ... Adobe Acr... 4,301 KB Eatiin= Sm
N THPlano Seccional La .. 4/14/20146... Adobe Act.. 201 kB ] Specfy Onsereen
.
1 1
\ Insertion Point
e
[] Speciy On-sereen
Rotation
= T ] Do
_| .
o
w
< 1L ]
Fik name PDF UNDERLAY - Open
Files of type: PDF files("pd) - Cancel [ox [ e J[ wo |
PDF files(" pdf) -—-—

After inserting the PDF file as underlay, then you can start

drawing or placing geometry at specific point of the underlay.

What’s more, you can adjust the underlay display like contrast, fade, monochrome, and colors for background through the

properties palette.
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10.6.  About Clipping Underlays

The clipping boundary can be specified as a
limited portion of the external reference graph,
block reference, graphics, viewport, and underlay.
You can clip external reference such as DGN.
DWF. IMAGE. PDF and other underlay or block
reference. You can use clipping boundary to
determine the external reference or block
reference section that you want to display, or to
hide the redundant parts of the reference inside or
outside the boundary by the following methods.

Clip Block

N i o o B

ON | OFF | Cipdepth | Delete | generate Polyline 4 b

The boundary can be a polyline, a rectangle, or a polygon whose vertexes are limitedwithin the global scope of the underlay.
You can modify the boundary of the graphics to be clipped. When you clip the graphics, you do not change the object in the
external reference or block, but only change the way they are displayed.

Clib AlemboLg

10.7. Edit Reference Tab

With REFEDIT function allows you to edit blocks as reference. Users can access this function from toolbar in the classic
interface and also there is an edit reference panel in ribbon interface. In edit reference panel, users can select the options like
save changes, discard changes, add to working set and remove from the working set base on block modifications. Now you can
edit an xref or a block definition directly within the current drawing.

Reference Edit Reference Edit

Repeat REFEDIT
Identity Reference | Se Identfy Reference | Seftings | Recent Input »

Reference name: Reference name Prevew =1 4 | Edit Xref In-place
BTG 17 HATCH LY G 17 HATCH BOUNDARY IMPROVEMENT - |

L GITHA £@ G17 HATCH BOUNDARY IMPROVEMENTpersor —— | Open Xref
£BGI7THA £@ G17 HATCH BOUNDARY IMPROVEMENTplanta Foee" =™ Clip Xref
S GI7THA £8 G17 HATCH BOUNDARY IMPROVEMENTplanta g ‘

£3GI7THA £@ G17 HATCH BOUNDARY IMPROVEMENTplarta External References...
£ G17HA £3 G17 HATCH BOUNDARY IMPROVEMENTplanta |
|
|
|
|

B0

B GITHA £ G17 HATCH BOUNDARY IMPROVEMENTlanta T
£ GI7HA £@ G17 HATCH BOUNDARY IMPROVEMENTplanta ~ s
i, »

Clipboard >

Isolation >

Path:  FPLATFOF Path:  F:PLATFORMFEATURES DWG\G17
© Automatically selec @ Automatically select af nested objects.
Prompt to select ne ) Prompt to select nested objects

Erase ; St -

Move

Copy Selection

i Scale
Rotate
Draw Order >

‘_
CHies % Q

Group »

Deselect All ;2 y [
Select Similar

Quick Select...
QuickCalc
0y Find..

% Properties
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The objects that you select from the selected xref or block are temporarily extracted and made available for editing in the current
drawing. The set of extracted objects is called the working set, which can be modified and then saved back to update the xref or
block definition.

Reference Edit Dialog Box
Identify Reference Tab: Provides visual aids for identifying

@Rdnenceidit ()
what to edit and control how it is selected. oty bonee e
Reference Name: Displays the reference selected for in- aaagenm.
place editing and any references nested within the selected s porasl
reference. If multiple references are displayed, choose a prpisddstianlrarins
ra . . . £& REFEDIT ENHANCEMENTiplantas04
specific xref or block to modify. Only one can be edited in £ REFEDIT ENHANCEMENTplantas04

& REFEDIT ENHANCEMENTplantas04
& REFEDIT ENHANCEMENTplantas04 -

place at a time. e
Preview: Displays a preview image of the currently selected ® Atomatically select al nested objects
reference as it was saved in the last drawing. The reference St e
preview image is not updated when changes are saved.
Path: Displays the file location of the selected reference. If it is a block, no path is displayed.

Automatically Select All Nested Objects: Controls whether nested objects are included automatically in the reference editing
session.

Prompt to Select Nested Objects: Controls whether nested objects must be selected individually in the reference editing

session.

Settings Tab

Create Unique Layer, Style, and Block Names: Controls whether
layers and other named objects extracted from the reference are
uniquely altered. If selected, named objects in xrefs are altered Ll or, Lo e L
(names are prefixed with $#8), similar to the way they are zsia:;::i:j::'::::::dm"g
altered when you bind xrefs. If cleared, the names of layers and

other named objects remain the same as in the reference
drawing. Named objects that are not altered to make them
unique assume the properties of those in the current host
drawing that share the same name.

Display Attribute Definitions for Editing: Controls whether all
variable attribute definitions in block references are extracted
and displayed during reference editing. If Display Attribute Definitions for Editing is selected, the attributes (except constant
attributes) are made invisible, and the attribute definitions are available for editing along with the selected reference geometry.
When changes are saved back to the block reference, the attributes of the original reference remain unchanged. The new or
altered attribute definitions affect only subsequent insertions of the block; the attributes in existing block instances are not
affected. Xrefs and block references without definitions are not affected by this option.

Lock Objects Not in Working Set: Locks all objects not in the working set. This prevents you from accidentally selecting and
editing objects in the host drawing while in a reference editing state. The behavior of locked objects is similar to objects on a
locked layer. If you try to edit locked objects, they are filtered from the selection set.
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10.8.  PDF Import and Export

You are able to import TrueType text, the geometry, and raster images froma PDF [(3)
file or underlay into a current drawing as LusoCAD objects. |
e 22 e
Savein: DWG - H Save 5 PDF
2 Name : Date modified Type Cmot Selingy T
i No items match your search. Mo b Save . Other Formats
B e B -
i B -
“ Output Controls m
= Do = v
Export: |Window ) =
@ et =
@ Senc
File name: Drawing? - [sve ] [ Page Setup Override... -
‘ Saveastpe: [PDF Fies( pdi) <] [ cencel ] [[C
)

LusoCAD 2025 also supports to export to PDF file format. You can access this
feature from File button - Export - PDF or input EXPORTPDF from the command line.
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11, Hatches and Raster Images

@ s o S =~

o B i | Do

111, Hatches - g | Fe— "“6“‘ | 6]
Swatch lj &,E:::,::mm s
—— — it

11.1.1. Define Hatch Boundary — B -

To create a hatch, you should define hatch boundaries first by means e fw = Ei:g

of selecting objects to be hatched or picking a point inside the S“T” - :::7 o

desired object. A hatch boundary can be any combination of objects, T ge—

such as lines, arcs, circles, and polylines that forms an enclosed (oo ) ] «

area.

11.1.2.  Control the Hatching in Islands

You can specify methods of hatching objects in outermost boundary as normal, outer and ignore. Normal is the default hatch
pattern. Besides, you can view hatching results of different types in the Islands area on Hatch tab of the Hatch and Gradient
dialog box.

Normal: Hatch the pattern from the outer boundary to inside. Hatching process will be stopped when encounter inner crossing
points, and continue hatching until second inner crossing point appears.

Outer: Hatch from the outer most layer of configuration, and keep the internal blank.
Ignore: Ignore internal objects, only hatches outer objects.
To select objects for hatching:

1. Choose Draw > Hatch from the main menu.
2. From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:
Normal, Outer, Ignore:

“

-

NORMAL ISLAND OUTER ISLAND IGNORE ISLAND

3. To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other
options. Existing objects are always retained.

4. In the Boundaries, click Select Objects button.

5. In the drawing, click the objects to be hatched individually, and then press Enter when done.

6. In the Hatch and Gradient dialog box, click OK.
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Select an area for hatching:

1. Choose Draw > Hatch from the main menu.
2. From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:
Normal, Outer or Ignore.

hndtids
s,

OUTER ISLAND

/ %’l‘p

=
NORMAL ISLAND

IGNORE ISLAND

3. To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other
options. Existing objects are always retained.

4. In the Boundaries, click Pick Points button.

5. In the drawing, click inside the closed perimeter of a boundary. If desired, continue clicking inside additional closed
perimeters.

6. To complete the selection, press Enter. Then click OK button.

11.1.3.  Choose and Define Hatch Patterns et coser S ==
[ Hateh | Gradent| Boundaries
Type and pattem Add: Pick points
. . . Tie @ Add: Select objects
Hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can e mos L] |
select a hatch pattern from a set of predefined patterns, or you can define a 0 {E
pattern of your own. The hatch pattern you used most recently is the default p—— b
pattern the next time you add hatching. The program supplies predefined C— EE] B
standard hatch patterns, which are stored in the ICAD.pat and ICADISO.pat hatch I e
; -
pattern library files. g e
To specify a predefined hatch pattern:
EE Inhert Properties
1. Choose Draw > Hatch from the main menu. o] ] >

2. In the Hatch and Gradient dialog box, click the Hatch tab.
3. Beside Type, click Predefined to apply a scale factor to make the pattern larger or smaller than the default size.

4. Enter the scale factor as a percentage of the default.

5. Enter the angle in degrees (1-360). The default angle is clockwise; you can change the angle of any hatch pattern by entering
a numerical '
value.

6. Enter the ISO pen width. This option is only available if
you select existing ISO hatch pattern in the Pattern option.
7. To copy the pattern properties from an existing hatch,
choose Inherit Properties. - - - - B
8. To associate the hatch pattern with its boundary objects, under Other options, select the Associative check box. An
associative hatch updates automatically if you move any of its boundaries.

9. To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.
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To specify a user-defined hatch pattern:

1. Choose Draw > Hatch from the main menu.
2. From the Hatch and Gradient dialog box, click the Hatch tab.

3. Beside Type, in the Type list, click User Defined.
4. For Spacing, enter the line spacing for the pattern.

5. To copy the pattern properties from an existing hatch, choose Inherit Properties, and select a hatch pattern from a hatched
object in the drawing.
6. To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative
hatch updates automatically if you move any of its boundaries.

7. To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.

To use a predefined library pattern:

1. Choose Draw > Hatch from the main menu.
2. Click the Hatch tab.
3. Select a Predefined type.

4. To select a predefined pattern, do one of the following:

- In the Pattern list, click the pattern name.

- Click the graphical representation of the hatch pattern.
5. To continue, add a hatch by selecting objects or picking

points to selected area or boundary you want to hatch. —
Store as default hSPHALT
—————— BOARD
Proview BOARDW
BOARDWN
(3 Hstch and Gradie:
[ [ 55T Boundares Options in Gradient tab:

Color
(@ One color

Color1

| S
ra

Orientation

[l Centered

|
J

@) Two color

Color2

Angle: 0

Add: Pick poirts
Add: Select obiscts
ER| Remove boundaries

13| Becreate boundary

Q| yiew Selections

Options

[F] Annotative

[¥] Associative

[] Create separate hatches

Draw order.
Layer:
Transparency:
o [

Inhert Properties

Preview

0K

o] Ca) >

Hatch | Gradient

nnnnnn

Cobor L]
ANSIZ2
ANSI33
ANSI34
ANSI35
ANSI36
ANSI37
Angle: ANSI38
ARBBIE

Swatch:

Custom patterr

Angle and scale

0 -
Double AR-BES

Spacing

150 pen width:

Hatch origin

() Specified origin

AR-BB16C

AR-BRELM
AR-BRSTD
AR-CONC
AR-HBONE
AR-PARQ1
© Use curentoign /- RHCCF
¢ AR-RSHKE
AR-SAND
| Clck to set n2<2BRIKC
2X2BRIKS
Defauit to bouncaneHORLK

]
i
Recreate
Hatch Pattern Pall

bour

Type and pattem
Tipe Add: Select chjeets
N

| Remove boundaries

dar

Hatch and Gradies )
|

LA ANSI {150 Other Predefined | Custom

ANSI31 ANSI32
ANSI35 ANSI36

7

ANSIZ3

el
[
otes
ot

ANSI37

)
ANSI34
5

2835
ANSI32

ANS! fron, Brick, Stons mason

Draw Order: Assigns a draw order to a hatch or fill. You can place a hatch

or fill behind all other objects, in front of all other objects, behind the

hatch boundary, or in front of the hatch boundary.

Layer: Assigns new hatch objects to the specified layer, overriding the

current layer. Select Use Current to use the current layer.

Transparency: Sets the transparency level for new hatch or fills, overriding

the current object transparency. Select Use Current to use the current

object transparency setting.
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11.1.4. Hatch to Back

In order to avoid a filling pattern blocks any text, label or other graphics on the current drawing, you can set the display order of all the fill
patterns to back position from all other objects with HATCHTOBACK command.

11.2.  Work with Raster Images

You can view and manipulate raster images and associated file paths in your drawings.

11.2.1.  Attach, Scale, and Detach Raster Images

Raster images consist of a rectangular grid of small
squares or dots known as pixels. Raster images can
be copied, moved, or clipped as well as a normal
object in the drawing. You can also adjust the
contrast, transparency, image quality and image
frame visibility. Additionally, when inserting raster
images, the file format depends on the content of
the file rather than the extension name. The
following table display all the image file formats
supported:

11.2.2.  Attach Raster Images

Use IMAGEATTACH command to select and [Soakiones : =)
Lookin: [ Deskdop - 0@
i . . i oz . — Nome:  |20151202100143 v] [ _Bome |
attach raster images, or bitonal, 8-bit gray, 8- . | en e -
bit color, or 24-bit color image files to a n ' gl Baeen v
w1 245KB  Kankan JP| Insertion Port
drawing. The image file can be inserted as oo Sl Bt O e
) , i = x 0 Disyonsomn
blocks as many times as you like once = s et r B woe o
== 4 NONA VOICES File folder
attached to the current drawing, you can clip A s
. \ @ aoa . | B
the attached raster image and setup its e
. . Fies of type: | Al image fiee -
lightness, contrast, fading and transparency. = e .
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To attach a raster image:

1. Choose Insert > Raster Image reference from the main menu.
2. Specify a file to attach, and then click Open.

3. In the Image dialog box, in the Insertion point and Scale, click
Specify on-screen. Specify an angle value in Rotation, and then
click OK.

4. Specify a insertion point.

5. Specify a scale.

Model / Layoutl  Layout?

11.2.3.  Scale Raster Images

You can specify scale factor in the Image dialog box, otherwise to attach it by its original size. The raster image will be scaled
by the specified factor, the scale factor is used without unit by default.

11.2.4. Detach Raster Images

Raster images can be detached if it no longer needs to use in the drawing, a specified image detached from the drawing
together with its multiple copies, links and definitions, but the original image file will not be influenced.

11.2.5.  Modify and Manage Raster Images

Controls the properties such as displaying and clipping boundary of raster images. You can view and manipulate attached raster
image and change its saving path in Image Manager. Users can turn on/off image boundary in current view using IMAGEFRAME
command and setting up the values 0 (off) 1(on).

To turn image frames on or off for all images:

1. Choose Modify>0bject> Image> Frame

2. Do one of the following to toggle frames off and on:

- Type value 1 to display and print frames for all images in a drawing.
- Type value 0 to hide all frames on the screen and during printing.

v

| .

Model  Layoutl | Layout2

ommand: _imageframe
MEnter new value for IMAGEFRAME <1>: @
Regenerating model.
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To clip an image in the shape of a rectangle and polygon:

1. Choose Modify>Clip> Image

2. Select the edge of the image you want to clip.

3. Type N (New boundary) to create a new clipping boundary.
4. 1f you choose Rectangular:

- Define the first comer of the clipping rectangle. N m
- Define the second corner of the clipping rectangle. The selected image is t ;;M
clipped so that only the interior of the rectangle is visible.

5. If you choose Polygon: \ V ‘
- Select the points for the polygon, and then press Enter ‘
when the polygon is complete. The selected image is

clipped so only the interior of the polygon is visible.

11.2.6. Change Raster Image Brightness, Contrast, and Fade

Use IMAGEADJUST to adjust displaying result and lightness, contrast and fade that are related to the display and plot effect
when plotting drawings. IMAGEADJUST does not affect the original raster image as well as other instances of the image.

[ Image Adjust g‘
: Brightness 20151202100143
Dark ) Tint 28
Contrast
Low {2 High 50
W ) e 0
(oK) (CConcel ) [ hew )

11.2.7.  Improve the Display Speed of Raster Images

You can adjust the display speed by setting the raster image quality. The image quality is sorted into high and draft levels, If the
quality is set to draft, the image will be displayed with some granular materials, however with faster display speed.
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12. Layout, Plot and Publish Drawings

Sregesere verco [ ==l

12.1.  Create Multiple-View Drawing Layouts B comoes o

Page setups

Cument page setup: <None>

.
12.1.1.  Overview of Layout
Import
A layout represents a plotted page on which one or more model views are Tt
displayed. LusoCAD provides two collateral working environments as Model and R e iR
Layout tab. You can create thematic models on Model tab. Multiple slides of the S o e
model can be set in Layout tab. Use these general steps to prepare your drawing I ::"mc
Lo . ove or Copy...

for printing multiple layouts: Select All Layouts

Activate Previous Layout
Activate Model Tab

1. On the Model tab, create your drawing.

Page Setup Manager...

2. Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create a Plot...
new Layout tab Export Layout to Madal...
3. Create at least one layout viewport on the Layout tab. Use each viewport to help control Layokee g

which portion of the drawing prints and at what scale.
4. Specify additional settings for the layout, such as the scale of the drawing, print area, print style tables, and more.
5. Print or plot your drawing.

You can right click on Layout tab and select "New layout" to create a new layout, and also import layout from template. Options
on Shortcut menu are listed:

12.1.2.  Work with Model Space and Paper Space

Model space is generally used for creating and editing drawings. Preparations for plotting are usually working on paper space
for the drawings on layouts are close to the plotting effects. e

Model space is an area in which you create two dimensional and three

dimensional objects based on either the World Coordinate System (WCS) or

a user coordinate system (UCS). The contents of paper space represent the

paper layout of your drawing. In this work area, you can create and arrange

different views of your model similar to the way you arrange detail drawings T ——

or orthogonal views of a model on a sheet of paper. Fo T T TS I

Layout tab is enabled to make relevant plot settings. Paper space is provided
in each layout option, and you are allowed to create viewports and specify
page setup such as paper size, orientation and location that can be saved
together with the layout.

Color Bylayer
Layer 0

You can save and name the page setup and apply it to other layouts when L---—---"—------------ -
setting pages. You can also create new layouts using existing layout template
file (DWT or DWG). Click on the Model tab, you can view and edit objects in model space.
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12.1.3.  Specify Layout Settings

Once created a drawing in Model tab, you can toggle to Layout tab and setup the layout for plotting, such as paper size,
drawing orientation and so on. You can right click on the Layout tab to create new layouts or import from template files, and
then click Modify button on the Page Setup Manager dialog box to set the page.

12.1.4. Select a Paper Size for a Layout

The paper size here refers to the size of the drawing. When you start Plot dialog box in Layout tab, you can assign the paper
type from pull down list of the Paper Size text box. The Paper size is directly previewed from the sketch with its size and units.
The available paper types provided in the pull down list are decided by the current configuration. If you want to configure
plotters to export raster images, you must specify output size by pixels. The paper size can be customized in the Plotter
Configuration Editor.

12.1.5. Determine the Drawing Orientation of a Layout (5 paesein Lo —
The drawing orientation is sorted into Landscape and Portrait, 7 w
which decide the plotting orientation of the drawing to be seen ona : ' e

paper. Once specified the drawing orientation, you can control

whether to plot the top or the bottom of the drawing by selecting [s0p o0z
Plot Upsize-down option. The changes setup in Page Setup dialog e
. . . . = Sedle rspace
box are still saved in layouts. Certain page settings can be replaced 10 [t <) [Tz ‘
by customized plot settings, but the settings will not be saved in ! Dmmime | B
the layout unless you click Apply to Layout option.

12.1.6.  Adjust the Plot Offset of a Layout

You can offset the geometry on the paper by entering a positive or negative value in the X and Y Offset boxes. Changing the
plotting origin may change the position of drawing on papers. The plot origin locates at the left lower corner of plotting area
with offset value of 0 relative to X and Y direction. Select Center on Paper if the specified plot area is part of the drawing rather
than the whole layout, which changes the position of plot origin.

1o
I

Plot with origin (0,0) Plot with origin (10,10)
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12.1.7.  Set the Plot Area of a Layout

You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot option is drawing limits which
means plotting all the objects within the drawing paper. The plot origin is (0,0), located at the left lower corner of the page. Do

the following methods to select a plot area:

Layout: Plots all the objects within the drawing paper.

Window: Set the Plot Scale for a Layout, Plots any portion of the
drawing you specify within the rectangle window. Click the
Window button to use a pointing device to specify opposite
corners of the area to be plotted, and then return to the Plot dialog
box.

Extents: Plots the portion of the current space of the drawing that
contains objects.

Display: Plots the contents displayed in current view.

12.1.8.  Set the Plot and Lineweight Scale for a Layout

'@ Page Setup - Layoutl

Page Setup

Name. <None>

Printer/Potter

Shaded viewport options

Plotter None.
Locatior Nt applcable

Description:  The layout wil not be plotted urless 3 new
corfiguration name is selected

Papersize

Plot style table (pen assignments)

e
Lowe ]

[T Display plot sytes

As displayed

plotter

Plot options

(150_A4_210.00 % 257.00_ MMy

-] Plot object ineweights

[ Plot with transparency

Plot area
Whatto pit:

ﬁi

Window
erts to prtable ares)
isplay Millmeters [ Center the plot

<

000 Vilimeters

Plot scale Plot with plot siyles
Fit to paper Plot paperspace last

Scale: [] Hide paperspace objects
10000 (Miimeters ~]= | Drawing arertaiion

© Porrait

10000 s ® Landscape

[Bssns ooy [ Plot upside-down

ok | [ canca | [ Hep ]

When you specify a scale to output your drawing, you can choose Fit to Paper to scale the drawing to fit onto the selected
paper size. Usually, the objects in model space are displayed at the scale set in layout viewports. To plot the objects in model
space with the scale specified in layouts, you assign the scale to 1:1.Even if plot scale of layouts is assigned, it's enabled to
scale the lineweight at a certain scale. Scaling the lineweight is nothing to do with the plot scale when plotting drawings, which

is mainly used for the lines included in the objects to be plotted.

12.1.9.  Move and Copy Layouts

You can right click on the Layout tab to select Move or
Copy option, on the Move or Copy dialog box. You can
select a layout which you want to place after the current
layout. To Create a Copy of current layout, you can select a

place before the layout you selected. You should notice
that Model tab can't be moved or copied.

layout and check Create a Copy, the copied layout will E

New layout
From template...
Delete

Move or Copy..

Select All Layouts
Activate Previous Layout

Activate Model Tab

Page Setup Manager..
Plot...

Import Layout as Sheet..
Export Layout to Model...
Define the Viewport from Model..

Hide Layout and Model tabs

5
@ e oo
Move or copy selected layouts
Before layout:
Layoutl
Layout2
(move to end)
[ create a copy

12.1.10. Create Layout from Template

Right click on the Layout tab to select from template option
to import DWG or DWT file directly, using information of
existing template to create new layouts. System provides
template file with extension name as .dwt. Layout templates
from any drawing templates can be imported into the
current drawing.

Bl (3 sviect Terpiate from Fie
Look in Template - @3
= | | Name ’ - Daten
= qcad /A7
geadiso 10/8/2
I
»
‘g Fie name: Drawngl
| Files of type: Standard Template(".dwt)
—= ] Feare
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To create a new layout from an existing file:

1. Choose Insert>Layout>Layout from Template
2. In the dialog box, select the desired template file, and then click Open. In the Insert Layout(s) dialog box, select the layout(s)
you want to insert, and then click OK. You can choose multiple layouts by holding down Ctrl while selecting layout names.

12.1.11. Create and Modify Layout Viewports

On a Layout tab, you must create at least one layout viewport to see your model. Each layout viewport is created as a separate
entity that you can move, copy, or delete. Any changes you make in one layout viewport are immediately visible in the other
viewports (if the other layout viewports are displaying that portion of the drawing). Zooming or panning in the current viewport
affects only that viewport.

Create layout viewports:

1. On the command line, type MVIEW.

2. Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or
4 separately, or specify two opposing corners to create a
custom viewport.

3. Choose the viewport arrangement, typing H (Horizontal) or V
(Vertical).

4. Do one of the following:

- To arrange the viewports to fill the current graphic area, type F
(Fit).

- To fit the viewports within a bounding rectangle, specify Comand:

the corners Of a fECtaﬂg|e Iviewpor’ts: [ON/OFF/Fit/Lock/2/3/4/Polygon/Object]<First corner>:FIT < |

You can create a single layout viewport, or you can divide the graphic area into many viewports arranged
[Horizontal/Vertical/Above/Below/Left/Right].

Layer v P

Color Hred

Linetype CONTINUOUS
Lineype scale  |1.0000
Uneweight BYLAYER
Hyperink

To modify layout viewport properties:

1. Click the border of the layout viewport whose
properties you want to modify.

Center-X 5.3829
Center-Y 40204

2. Open the Properties palette through the menu T
option "Tools >Palettes>Properties" or "Modify > :m :‘:m
Properties". oL e

3. In the Properties palette, select Standard Scale, — e

and then select a new scale from the list. The scale you choose is applied to the viewport.
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Turn Layout Viewports On or Off;

1. Click the desired Layout tab.

2. Type MVIEW and then press Enter.

3. Type ON or OFF.

4. Select the edge of the layout viewport to turn on or off, then
press Enter.

Create Non-rectangular layout viewports:

Use Object and Polygonal options of MVIEW to create irregular viewports,

Select Object option to convert objects created in paper space to viewports. While selecting
Polygonal option to draw irregular polylines including arcs and lines which are enabled to
either intersect or three vertexes at least, the polyline will be closed automatically.

12.2.  Plot Drawings

Command :

Opposite corner:

Command :

Opposite corner:

Command :

Cancel

viewports: [ON/OFF/Fit/Lock/2/3/4/Polygon/Object]<First corner>:OFF

JO

When a drawing is completed, you can output it using several methods. You can plot the drawing on paper or create a file for

use with another application.

12.2.1. Plot Settings

When you create a drawing, you do most of your work on the
Model tab. At any time you can print your drawing to see how
it looks on paper. It's easy to startup printing, and then later
create layouts and custom print settings to enhance your
printed output.

To start printing:

1. Choose File > Plot from the main menu.
2. Set the printer and relevant parameters, and then click OK.

12.2.2. Set Paper Size

E
(3 Plot-Model

(B Plot-Model

Page Setup Plot sty tabie (pen assignments)

-@

Name: [arione> Add ] [Mene

Prnter/Pltter
Name

Shaded viewport aptions

Shade plot As displayed -

1v) [ Propetes

oo

None

Plotter: Qualty

Location: Not applicable B
Description The layout wil not be plotted unless a new plotter
ed

corfiguration name is select Plot options

Plot to File [C] Plot in backgrourd

Plot object ineweights
Flot with plot styles

Paper sige Number of copies

Bl 1

150_A4_(210.00_x_297.00_MM)

Plot paperspace last
Plot area

Whatto plet:

Plot scale
Fitto paper

Hide paperspace obiects
[] Plot stamp o
Save changes to layout

Scale: | User define

Plot offset (origin set to printable area) 1.0000
1155

Drawing orentation
@ Portrait

Nilimeiers v | =

Milimetsrs [~ Center the plot 244982 | units

© Landscape

)|

1365 Willmeters

<R

Scale lneweights 7] Plot upside-dawn

3
T

spiytoLayout | [_OK__ ][ Cancel [ Heb

Paper size

You can assign the paper type from pull down list of the
Paper Size text box. If you want to setup paper size, you
should configure plotters first, all the available plotters
are both system plotters of Windows configured and non-
system driven.

"280.00_x_1600.00_Pixels) T

Page Setup

Nzme [(None>

=
e
2
=i
=
i

Prirter/Plotter

Name Nong

Plotter: Mone

Location: Mot applicable

Description: The layout wil not be plotted unless & new plotter 197534 00_w)
configuration name is selected. B
Plot to File 10_x_420.00_MM)

00x_42.00_Inches)
10_7_36.00_inches)
107% 48,00 Inches) -

Paper size

[ 150_A4_(210.00_x_297.00_MM) hd
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To select a printer or plotter:

1. Choose File > Plot from the main menu.

2. From the Name list in Printer/Plotter area, select a printer or plotter you want to use, and then click OK.

12.2.3. Position the Drawing on the Paper

You can adjust the position of the drawing to be plotted on a paper before plotting.

To specify the print area origin:

1. If necessary, click the desired Layout tab or the Model tab.

2. Choose File > Plot from the main menu.

3. Do one of the following in the Plot Offset area:
- To center the specified print area on the printed
page, select Center the Plot check box.

Plot offset {origin set to printable area) 1.0000 = Drawing orientation

Milimeters [7] Center the plot ~ Portrait

X

:

04959

0.0000

Milimeters

29463  units

® Landscaps:

Scale [newsights 7] Plot upside-down

- To specify an origin for the print area, type the X and Y coordinates.

4. Select OK, and then click Apply to Layout.

12.2.4.  Set Drawing Orientation

The drawing orientation determines whether to plot a drawing portrait or landscape. If

1 [] Plot with plot styles
you select Landscape, plots the drawing using the length edge as horizontal. While :‘;‘E":::::;:;'lm
selecting Portrait to plot the drawing using its minor edge as horizontal Changing, the gmmw
drawing orientations just like rotating the paper under the drawing. Meanwhile, Dﬁmng;nemw
selecting Plot upsize-down to control whether to locate the drawing upsize-down on s A
paper. L [E Pt upside donn
wolayot | [ ok ][ cancel |[  Hep ]@

12.2.5. SetPlot Scale

Plot scale of the drawing can be specified directly from the Scale pull-

down list in Plot Scale area of Plot dialog box. You can also choose

User define to set desired plot scale, or choose Fit to Paper to scale the
drawing to fit onto the selected paper size. The plot scale together with
plot unit and drawing unit must be specified before plotting. For
example, if you select the paper size to mm, entering 1 under mm and
10 under Units blank produces a plotted drawing with each plotted unit

represents 10 actual millimeters.

[_remrtotmo |0k ][ Conedt | mer | ©

Saves changes that you make in the "Plot dialog box” ta the
layout.

Quality _Gene«al ~

Plet options
[ Plot in backaround

Plot object lineweights

Plot scale Hide paperspace objects

[CIFtto paper [ Plot stamp on

Scale: | User define. - [ Sawe changes to layout

efine
efin
rawing u

[T Plot upside-down

=] i) ©

O N Ny e g g

=l

ST T gBEBERsTY RN

i
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To automatically scale the drawing for printing:

Plot scale Hide paperspace objects

Fit to paper [ Plot stamp on

1. If necessary, click the desired Layout tab or the Model tab. e [l g S
2. Choose File > Plot from the main menu. 100 | ngpg] = | D ceraton

Inches ) Portrait
f . . . . . pLc R tillmeters | = N
3. To scale the drawing to fit on one printed page, in Plot Scale, click Fit to T ;::’“a::
Paper. [movtomos |[ ok |[ concad |[ meb |

4. Select Apply to Layout and click OK.

12.2.6.  Set Plot Options

The following options show plot patterns with instructions on how to plot objects.

Plot in Background: Specifies the plot is processed in background.

Plot Object Lineweights: Specifies that lineweights assigned to objects and
layers are plotted.

Plot with Plot Styles: Plots a drawing with specified plot styles. Plots
lineweights automatically once by selecting this option automatically. If you do

Qs

Plot options
Plot in background

Plot object linewsights
Plot with plot styles

Plot paperspace last

not select this option, objects are plotted with their assigned properties and not Hids paperspace cbjects

with the plot style overrides. :”mf: Frasmon =

Plot Paperspace Last: Plots model space geometry first. Paper space geometry o0 [iimees  +| =

is usually plotted before model space geometry. ’9':‘*3“*‘_ “‘ ® Landscepe
EEEEE ] Plot upside_down

Hide Paperspace Objects: Suppresses the plotting of objects that are located
behind other objects regardless of how it's displayed on screen. This option is
only available in the Layout tabs.

Plot Stamp on: Horizontally or vertically places the plot stamp information on a specified corner of a drawing. The plot stamp
settings can be saved to log file, also cannot be saved. -
Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the layout if you click OK.

[ opytoimyon |[ ok [ cancd |[ meb | &

12.2.7. Specify the Area to Plot

To specify a portion of the drawing to print, if necessary, click the desired Layout tab or the Model tab.

1. Choose File > Plot from the main menu.
2. Under Print Area, click one of the following:

Page Setup Flot style table {pen assignmerts)

Display: Plots the current view on the screen. = = e ) | e
Extents: Plots the contents within the specified drawing extents. o R
Limits/Layout: Plots the contents within the specified drawing o e =
limits or entities in the printable area. . T e
Window: Plots the portion of the drawing contained in the e — e mw
specified window. Click the Window button to use a pointing

What to plot: T Hide paperspace objects
'_Jwa’ Scde:  [Userdefine

prittable area) 10000 s

ilintsters. (7] Center the plot

device to specify opposite corners of the area to be plotted and
then return to the Plot dialog box.
3. Select Apply to Layout and click OK.

 Bxterts
Limits
Window

y. 1365 Milimeters

[T Plot upside-down
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12.2.8. Preview a Plot

Viewing a drawing before printing gives you a preview of what your drawing will look like when it is printed.

To preview a drawing before printing: _@7
1. If necessary, click the desired Layout tab or the Model tab. B — S

Pt HacChenPDF

2. Choose File > Plot Preview from the main menu. it
3. Do one of the following:

-To print the drawing, click preview and click Plot on the top left corner
of print preview.

-To return to the drawing, click the off button or press Esc.

12.2.9. Use Plot Styles

Plot styles help you control what your drawing looks like when it is printed. Because plot styles are saved in plot style tables,
which are files located on your computer, you can reuse them to help eliminate the need to reconfigure your print settings each
time you print a drawing. A drawing can use one type of plot style table at a time. There are two types of plot style tables: -

Color-dependent plot style tables (CTB) contain a collection of plot styles based on each of the ¥ |
255 index colors available in a drawing.-Named plot style tables (STB) contain a collection of Plot st tabl fpen assigrmerts)
plot styles that you define. They can vary regardless of color. &

5 DWF Vitual Pens.ctb
5 Fill Pattems cth
. gead.ctb
To assign plot style tables: Grapscale b
~ monochrome .ctb
Screening 100%.ctb
Screening 25% cth

1. If necessary, click the desired Layout tab, or click the Model tab. Ptk
New.
2. Choose File > Plot from the main menu. Oper..

3. Under Plot Style Table (pen assignments), select a plot style table in the one of the following:
None: Applies no plot style table. Objects plot according to their own properties.

Monochrome: Plots all colors as black. e =
New: Creates a new plot style table. I |
4. Select Save Changes to Layout, and then click Apply to Layout.

To Modify plot style tables:

1. Choose File > Plot from the main menu.

2. Under Plot Style Table (pen assignments), click the plot style table you want to
modify, and then click the button to display “Plot Style Table Editor”.

3. Click the General tab on Plot Style Table Editor, and then do any of the following:

- Enter a new plot style description. Lot ] [ oo ] [0
- Select Apply global scale factor to non-I1SO linetypes to apply the scale factor

- Enter a scale factor to apply to non-ISO linetypes used for any plot style in the current plot style table.
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4. Click the Form View tab, and then do any of the following:

- Make changes to a color-dependent plot style by selecting it in the Plot list, and then
make color, linetype, or lineweight changes for the plot style in Properties area. Your
changes are saved automatically for the selected plot style.

- Make changes to a named plot style by selecting it in the Plot list, and then make
color, linetype, or lineweight changes for the plot style in Properties area. Your changes
are saved automatically for the selected plot style.

- Add a new plot style by clicking Add Style. Enter a new name, and then click OK.
Select the options for the plot style. (Available for named plot styles only.)

- Delete a plot style by selecting it in the Plot list, and then click Delete Style. (Available
for named plot styles only.)

5. Click OK.

12.2.10. Plot Files to Other Formats

Plot style table file name:
geadctb

'

Fie Information
MNumber of syles: 255
Path: C:\Users\ovs"App Data \RoamingVR19\en-W. Mgcad ctb
Version:1.0
Legacy (can be usedto import old DV/Gs)

7] Apply global scale factor to non-150 linetypes

1 Scale facter

SavedCose | [ Cancel | [ Heb

Plot files have various formats. You can output drawings in any image formats with unique plotter driver.

@ Plot-Model X
Page Setup Plat style table (pen assignments)
Mame: <MNones w Add... None =
Printer/Flotter Shaded viewport options
Mame: Mone V Properties. .. Shade plot As displayed w
D'WF6 ePlot pc3 ~
Platter: | DWFx ePlot (XPS Compatible), Quality General v
- DWG To PDF.
Location:  [Publish TaVWeb JPG pc3
Descrigtion: Publish ToWeb PNG.pc3
BSCAption: | 55 1.0 pc3 _
| Add Plotter... Flot options
Flot to Fl%| Manage Flotter... ] [ Plat in background
| Plat object li ight:
Paper size MNumber of copies e
o [] Plot with transparency
150 Ad (210,00 x 257.00 MM) w~ 1 =
Plot with plot styles
Plot area Plot scale Plot paperspace last
What to plot: Fit to paper Hide paperspace objects
Display v Scale: | User define [ Plat stamp on
Sawe changes to layout
Plot offset {origin set to printable area) 1 Milimeters | =
Drawing orentation
% [11.55 Milimeters [ ] Center the plot 33333 (®) Portrait 3
" () Landscape
Y. |-1365 Millmeters Scale ineweights [ Piot upside-down
Preview .. Apply to Layout Cancel Help &«
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12.2.11. Publish Drawings

Specifies drawing sheets that you can assemble, reorder, rename, copy, and save for publishing as a multi-sheet drawing set.

You can publish the drawing set to a DWF, DWFx,

or PDF file or send it to the plotter named in the page setup for hardcopy

output or as a plot file. The following options are displayed in the Publish Dialog Box:

Publish 5
(None j'] % 8 Location: C:\Users\ovs\Documents\
Publshto: 4 : Fie Type: Muisheet fie
[Pbu«nmndhpagem v Naming: Specfy name
) Agomatically load all open d 5 Layer infomation:  Don! include
Merge Control: Line overwrte

6 7 8 9 10 :
[~ g @ 16 Poinoons.. |
Tmmilii 3D DWF 12 Page Setup ]7_37 Status
| (#) UnsavedDrawing 1-Model & <Defauk None> " No emors

UnsavedDrawing 1-Layout 1 & <Defak None> " No emors
&3 UnsavedDrawing 1-Layout2 & <Defauk None> + No emors
%DRAWING SAMPLE MECH4-Model & <Defauk None> o No emrors

DRAWING SAMPLE MECH4-LOCKI} & <Defauk None> o No emors
£.J DRAWING SAMPLE MECH4-LOCKI} & <Defaut None> o No emors

Publish Output
Selected Sheet Details | 5 |
Source drawin : |
e Number of copes: {7 [ inciude plot stamo 19 &)20

Layout Name 1 = —
Fdeves P Drsthnisdonnd 0] - (4] 22
Plot size = ; £ S
Piot scale = ("] Open in yiewer when done 23
Page setup de
[ HoeDwss |14 [ ][ Cocs | [ Hb |

1. Load Sheet List Button: Displays
the Load Sheet List dialog box, in
which you can select a DSD file or a
BP3 (Batch Plot) file to load.

2. Save Sheet List Button: Displays
the Save List As dialog box, in which
you cansave the current list of
drawings as a DSD file.

3. Sheet List: Displays the current
drawing set (DSD) or batch plot (BP3)
file.

4. Publish to: Defines how to publish
the list of sheets. You can publish to
gither a multi-sheet DWF, DWFx, or
PDF file.

5. Automatically load all open
drawings: When selected, the
contents of all open documents are
automatically loaded in the publish
list.

6. Add Sheets Button: Displays the
Select Drawings dialog box, in which
you can select drawings to add to the

list of drawing sheets.

7. Remove Sheets Button: Deletes the
selected drawing sheets from the list
of sheets.

8. Move Sheet Up Button: Moves the
selected drawing sheets up one
position in the list.

9. Move Sheet Down Button: Moves
the selected drawing sheets down one
position in the list.

10. Preview Button: Displays the
drawing as it will appear when plotted
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on paper by executing

the PREVIEW command.

11. Sheet Name: Combines the
drawing name and the layout name
with a dash (-).

12. Page Setup/3D DWF:Displays the
named page setup for the sheet. You
can change the page setup by clicking
the page setup name and selecting
another page setup from the list

13. Status: Displays the status of the
sheet when it is loaded to the list of
sheets.

14/15.Show and select sheet details:
Displays and hides the Selected Sheet
Information and Selected Page Setup
Information areas.

16. Publish Options: Opens

the Publish Options dialog box, in
which you can specify options for
publishing.

17. Number of Copies: Specifies the
number of copies to publish.

18. Precision: Optimizes the dpi of
DWF, DWFx, and PDF files for your
field: manufacturing, architecture or
civil

engineering.

19. Include Plot Stamp: Places a plot
stamp on a specified corner of each
drawing and logs it to a file.

20. Plot Stamp Settings: Displays
the Plot Stamp Dialog BoxPlot Stamp
Settings Dialog Box, in which you can

specify the information, such as
drawing name and plot scale that you
want applied to the plot stamp.

21. Publish in Background:Toggles
background publishing for the
selected sheets.

22. Send the Sheets to the Plotter in
Reverse Order: When selected, sends
sheets to the plotter in reverse of
default order. This option is available
only if the Plotter Named in Page
Setup option is selected.

23. Open in Viewer when Done: When
publishing completes, the DWF,
DWFx or PDF file will open in a viewer
application.
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Chapter 13 Create and Edit Dynamic Blocks

13. Create and Edit Dynamic Blocks

Dynamic block references contain grips or custom properties that change the way the reference is displayed in the drawing after
it is inserted. Dynamic blocks allow you to insert one block that can change shape, size, or configuration, instead of inserting

one of many static block definitions.

Some dynamic blocks are defined so that geometry within the block can only be edited to certain sizes specified in the block
definition. When you use a grip to edit the block reference, tick marks are displayed at the locations of valid values for the block
reference. If you change a block property value to a value other than one specified in the definition, the parameter will adjust to

the closest valid value.

13.1.  Dynamic Block Editor

You can access the Block Editor by typing the edit command or by double-clicking the block without attribute. The Block Editor
ribbon interface will show as below, the black arrows mark the stand for parameters, while the yellow lighting is the symbol for

action. It will pop-up toolbars in a classic interface.

& “ AL IRV s PEE {UUUYYLS e %8G
dﬁ Lg D\f® Lt?n Y}?-ya = vﬂ AclV m O m \'v' b (‘ li: -; g—: -i l‘d Vu:h 11 ¢, X Ch%ock
Block Attribute B+ ] S Y4 E State 4
Manage Tool Parameter Act Parameter Set: Visibility [t
%smtch 2
%stretch 1
%Texﬂ?lip 2
Y
& stretch
FlipState
X
cal
visiblity > ﬁ o
distance '

% TextFlip 3
FlipState 1

X[Select objects:

pposite corner:Find out 2, total 2
Select objects:

Current settings: Copy mode = Multiple

Specify base point or [Displacement/mOde] <Displacement):
Specify second point or use first point as displacement):
Fommand:

13.1.1.  Dynamic Block Editor Tool Panels

vl£

a2 x
e saecun %[BT

Color W ByLayer
Linetype ByLayer

Lineveight  BYLATER

Using the tools in this Tool Panel to define, edit and modify dynamic blocks definitions , makes it very convenient and fast.

Manage
Save or Save as the default block; Create or edit another block.

8 <
5

Sawve 5

Elock

Manage
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Tool
Define, edit or update the block attribute.

=l

Define lpdate
Attribute

Taol

Parameter

You can add parameters for Dynamic Blocks on this panel.

TR
= o

oo

i

Parameter

B +

Parameter

Action
You can add actions for Dynamic Blocks on this panel.
G ¢ aE

fetlon

13.1.2. Parameters

Parameter Sets
You can add the parameter set on this panel.

= N - |
TR TRTR TS

A Ae TF 9 N TR To
= 4
* B E
P

arameter Sets

£
£

Visibility
This panel is specially used for Visibility editing.

= .
Visibility
State
Vizibility

Close
It is used to exit the Block Editor. Before exiting, some
commands like save or open etc. might not work.

X

Close Flock
Editor

Claose

Define custom properties for the dynamic block by specifying positions, distances, and angles for geometry in the block. You
add parameters to a dynamic block definition in the Block Editor. In the Block Editor, parameters have an appearance similar to
dimensions. Parameters define custom properties for the block. Parameters also specify positions, distances, and angles for
geometry in the block reference. When you add a parameter to a dynamic block definition, the parameter defines one or more

custom properties for the block.

A dynamic block definition must contain at least one parameter. When a parameter is added to a dynamic block definition, grips
associated with key points of the parameter are automatically added. You must then add an action to the block definition and

associate the action with a parameter.

Parameters also define and constrain values that affect the dynamic block reference's behavior in a drawing. Some parameters
can have a fixed set of values, minimum and maximum values, or increment values. For example, a linear parameter used in a
window block may have the following fixed set of values: 10, 20, 30, and 40. When the block reference is inserted in a drawing,
you can only change the window to one of these values. Adding a value set to a parameter allows you to limit how the block

reference is manipulated in a drawing.

Point Parameter

lcon: LE'

Command: BParameter—0
Defings an X and Y location in the drawing. A point
parameter can be associated with a move or stretch action.
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Linear Parameter

4 [
Icon;

Command: BParameter—L

Shows the distance between two anchor points. Constrains
grip movement along a preset angle. A linear parameter can
be associated with a move, stretch, scale or array action.

Polar Parameter
o
lcon: "+

Command: BParameter—P

Shows the distance between two anchor points and displays
an angle value. You can use both grips and the Properties
palette to change both the distance value and the angle. A
polar parameter can be associated with a move, scale,
stretch, polar stretch, or array action.

XY Parameter

:DD
lcon;

Command: BParameter—X

Shows the X and Y distances from the base point of the
parameter. It can be associated with a move, scale, stretch,
or array action.

Rotation Parameter

Icon:ii\n

Command: BParameter—R
Defines an angle. The rotation angle can be in any value, or
be defined in a range or a specified value.

Alignment Parameter

Icon: =

Command: BParameter—A
Defines an X and Y location and an angle. An alignment
parameter always applies to the entire block and needs no

action associated with it. An alignment parameter allows the
block reference to automatically rotate around a point to
align with another object in the drawing. An alignment
parameter affects the rotation property of the block.

Flip Parameter

=3
lcon:

Command: BParameter—F
Aflip parameter flips objects. You can associate a flip
parameter with a flip action.

Visibility Parameter

=

lcon: 5

Command: BParameter—V

Controls the visibility of objects in the block. A visibility
parameter always applies to the entire block and needs no
action associated with it. In a drawing, you click the grip to
display a list of visibility states available for the block
reference.

Lookup Parameter

lcon: Ij

Command: BParameter—K

Defines a custom property that you can specify or set to
evaluate a value from a list or table you define. It can be
associated with a single lookup grip. In the block reference,
you click the grip to display a list of available values. You
can associate a lookup parameter with a lookup action.

Base Point Parameter
+5

Command: BParameter—B

Defines a base point for the dynamic block reference relative
to the geometry in the block. Cannot be associated with any
actions, but can belong to an action's selection set.

lcon:
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13.1.3. Actions

Actions define how the geometry of a dynamic block reference will move or change when the custom properties of the block

reference are manipulated in a drawing.

Move %

ICommand:BActionTool—M

A move action causes objects to move a specified distance
and angle such as a point, a linear, a polar, an XY parameter,
etc, moves all objects in a selection set in a/any direction.

Scale &

Command:BActionTool—S

A scale action such as a linear, a polar, an XY parameter, and
S0 on, scales the selected objects in the direction of the
parameter. Users can manipulate the grips in different way
by changing the properties and values in the Properties
palette.

Stretch [+

Command:BActionTool—TA stretch action causes objects to
move and stretch a specified distance in a specified
location. A stretch action associated with a point, a linear, a
polar, an XY parameter, etc.

Polar Stretch [}

Command: BParameter—PIn

A polar stretch action rotates, moves, and stretches objects a
specified angle and distance when the key point on the

associated polar parameter is changed through a grip or the
Properties palette.A polar stretch action can only be applied
to a polar parameter.

Rotate (%

Command:BActionTool—P

A rotate action is always associated with a rotate parameter.
Selected objects can be rotated freely, or the way the grips
are manipulated is different in the Properties palette.

Flip [
Command:BActionTool—F
A flip action is always associated with a flip parameter.

Amay 55

Command:BActionTool—A

An array action is associated with a linear, a polar, an XY
parameter, etc, copies and arrays selected objects in
different way.

Lookup [E]

Command:BActionTool—L

A Tookup action can only be associated with a lookup
parameter.

13.1.4. The General Steps of Creating a Dynamic Block Definition

In order to get a Dynamic Block Definition, improve block editing efficiency and avoid repeating modifications, we can create

Dynamic Block by the following steps.

Step1: Planning

Before creating Dynamic Block, it is essential to plan Dynamic Block, plan the functions, appearance, the method of drawing
and required Parameter(s) and Action(s) which are needed to achieve prospective functions.

Step2: Draw geometric figure

The included basic pixel during Dynamic drawing, of course, you can draw these pixel in Block Editor.
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Step3: Add Parameter and Action

This is the most pivotal step when creating Dynamic Block. When editing the Parameter and Action, you not only consider the
achievement of Parameter and Action, but also consider the readability of Dynamic Block and the convenience of Modification,
let the action point of the Parameter attach on the corresponding pixel as far as possible, and put the Action near to its relevant
parameter, if there are more Parameters and Actions, they still need to be renamed for understanding, editing and Modification.

Step4: Test Dynamic Block
Save and Exit Block Editor, start the Dynamic Block test to check if it reaches to the prospective effect.

138.2.  Dynamic Blocks Creation Samples
See what you are able to do within the Dynamic Block Editor, and get the most out of your design. See the follow samples:
13.2.1.  Base Point Parameter

Although the majority of parameters only taken into effect when operations are matched with actions, there are exceptions, base
point parameter is one of them.

1. Define blocks: Define block and draw a circle in the block editor, as shown. - Ig 2B % | 3¢
Visibility JALibil ity Close Block

State Editor

Visibility Close

2. Add base point: Click "base point" parameter on the parameter panel, put the parameter on the center of the circle according
to system prompt, as shown in the below illustration.

1%

Parameter

3. Insert block: Save and exit block editor, insert the block in the model.
You can realize, base point becomes the insert point of the block after
adding the base point parameter. Please note, if you set an insert point
via the block define dialog box, and add a base point parameter as well,
the base point is the default insert point.

Specify insertion point or | CCNEE |<28° |
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13.2.2. Visibility

Using the Visibility Parameter function, you can control the display and hide a certain view in Dynamic Block.

1. Prepare view: Prepare a three cars view and define as block.

2. Add Parameter of Visibility: Enter into Block Editor by Double-clicking the Block or right- click the menu, click the button
Visibility of Parameter in the Parameter panel, appoint the position of the Parameter according to the system prompt, as shown
below.

v‘\’isibilit';
3. Edit the states of Visibility: Double click the button Visibility, the Visibility States dialog box will be displayed. In the dialog
box, you can rename, new and remove the Visibility States. In order to control the visibility of the three cars view in this

example, we click on new for the three Visibility States as shown in the following picture.

Click the following button as shown in the picture and choose roadster in the pull down menu.

Visbilty Statesty
I % B o Froae [
e e B =
Visibility ——————
State Roadster [% DeletelD]
Vl cars

i
[ ok ][ cancel |[ HebH) |
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Click the “Invisibility” button in the Visibility tool panel, select truck and car, make them I= Z/d'fti L X
invisible in the “roadster” state, as shown in the following picture, after selecting, press e s
enter to confirm. For the state of “Car” and “Truck”, set them in the same way. ~ Visibitity ‘ﬁ

4. Move and Adjust; After finishing the editing of the Visibility States, move the three cars
view to make them overlap as shown in the picture bellow.

1%ibITity

5. Test Dynamic Block: Insert the edited Dynamic Block into a drawing, select Dynamic Block and click the grip of Visibility
Parameter, choose one item in the pop-up pull-down list, Dynamic Block will change the display state automatically, as shown
in the following picture.

‘ Roadster
Cars
v Truck

13.2.3.  Alignment

#

Alignment Parameter can give dynamic blocks the function of alignment automatically, which Roughri/éss can
save the step of rotating the blocks. /
p g Y7 a2

N 4
\
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1. Add an alignment parameter for a roughness symbol: Draw a roughness symbol in the Block Editor. Select the icon of the
alignment parameter. Specify the location and the aligned orientation of the parameter following what the computer asked as
shown in the picture, the dotted line is the align orientation.

2. Test the dynamic block: Insert the roughness dynamic
blocks, move the align grips, the symbol will align with
the interface of the dimensions, as shown pin the picture W o y /) -

below. g \ [> Wiz

Flip: When you use the "roughness symbol block" to label the spare parts, the symbol is sometimes already in the right
position, however, the characters' direction is not right. We need to add the "character flip" function to receive the correct label.

1. Add flip parameter: Click the "flip" parameter button, add the flip parameter S/ visiblity

; - - !
according to prompt, as shown in the picture. PTRRP Y ’Roug eSS

2. Add flip action; Click the flip action button on the action panel, match

parameter and object for the action. Herein, we choose "roughness" as the object, and position the action button, as shown in

below picture. l

T FlipState 1
flip 2
&= Use the same method to add a pair of flip

f‘Fli‘p's'm'e' 4 -Rfoug €SS % flin1  parameter and action of the vertical direction,
X as shown:

VVisiblity

13.2.4. Point Movement

- 1 |

1. Draw a drawing: Draw a drawing and define it as a block.

Position

ﬁMove

2. Add point parameter: Click point parameter on the tool bar, define the parameter
position according to prompt, as shown in the picture.

b
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3. Add move action; Click move action button on action panel, match parameter and object for the action, and define the
position. The position of action label does not affect the effect of the dynamic block, however, for the sake of beauty&
convenience, try to put the label near the related parameter.

Select Objects Select dbjects‘

_‘" % Move
¥

e

Placed action

4., Test dynamic block: Insert the dynamic block, drag the blue grip, then move the keyway
to the right accordingly, as shown in below picture. Obviously, the dynamic block can

achieve the expected results. Please pay attention, if it is not run with ortho constraint, the ' = E
omn

keyway can move towards every direction because the direction of the point parameter is

random, the characteristic of the — . -

parameter decides
the characteristic of action.

- - ‘—_:*__

13.2.5. Linear Movement

Actually, limited to the demand of the material mechanics characteristics, keyway is only allowed to be placed on the central
line. So, a horizontal movement is enough for keyway and the movement to other direction is not meaningful. Next we will take
advantage of the linear parameter to define the keyway’s movement direction on the central line of the step shaft.

1. Draw: Draw the follow drawing and define it as a block.
= = =

Distance

2. Add linear parameter: The way of adding a linear parameter is similar to 7
dimension, both try to put the absorption point of the parameter on the central ,,AEEP
ling of the step shaft.

Distance

!
3. Add Move Action: Different from the point move, after specifying the T

parameter, the system will prompt: Specify parameter that is related to

movement. Select right grip of parameter as “Related parameter point”, as _._%E'EQ:/ = .
shown in the following picture.

Related parameter point
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The parameter point we mentioned corresponds to the operate point of Move.
After exiting Block Editor you can drag this point to make dynamic block

Distance

change correspondingly. After selecting the related parameter point you can .
specify the move objects for action, as shown in the following picture. Place e B
action label, save and exit dynamic block.
4 Test Dynamic Block: Select dynamic block and drag the right grip of the
parameter. Meanwhile, no matter how the cursor moves, the keyway is limited
to the central line of the step shaft. That is to say with the limitation of the =
linear parameter, the dynamic block can only move along the direction
specified by the linear parameter.
13.2.6.  Number of Grips — fge DIS TACE, B e O
é E gMOVC Dist type Hone
In the Block Editor, select the linear parameters, change ——¢!u> B B o
the number of grips to “1” in the properties panel. Base Location Start Point
Save and exit the Block Editor, choose the Dynamic Block, you will g
find that one grip has disappeared. In fact, after changing the number & S
of grips from “2” to “1”, the first thing that disappeared was the basic ¥
grip of parameters, namely the first point when adding parameters.
13.2.7.  Angle Offset o
',’_:;' Position-Y 26.5695
. . Dl stance :'!' %—??P Distance multiplier |1
Open Block Editor, choose the Angle offset from 0°to 30°in — : e
the action property, save and exit the block editor il = = re e
Fhaggre
—
Select the Dynamic Block and then move the right side grip. You will find it ///’

can only move in the direction of 30°as it is shown in the follow picture. The
direction of action can change according to the Angle Offset.

13.2.8. Linear Stretch

During a mechanical design, we often need to change the position as well as the dimension of the keyway. In this section, we

will add Linear Tensile function for the keyway on the step shaft.
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1. Add linear parameter:

Distance

2. Add stretch action: Click the stretch action button on the action
panel, choose parameter according to prompt and define right
grip as key parameter point, as shown in below picture. The black
object is the operational object of the action, the broken line
frame is the stretch frame, objects intersect with stretch frame will
be stretched, objects which will be selected by the stretch frame

will move.

2 '
‘W Stretch VertesX 58,2514
4 2 v 23.7259

Distance

Distance multipll
Angle offset 0

3. Test dynamic block: Exit from block editor, drag stretch grip to stretch

the keyway, as shown in the picture.

13.2.9. Parameter Value Set

For mechanical designs, we often need to stretch the keyway to a certain length. Now, let us see how to realize an accurate
stretch. Pick linear parameter in block editor, click entry frame which is on the right side of" distance type" on the Properties

Start-X 56.6813
Stretch Start-Y 24.1734
End-X 57. 4514

panel, a drop-down menu will pop up.

Therein, none is the default option, which means it
can stretch optionally. With the other two options,
you can define the maximum and minimum number
respectively.

End-Y 24.1734
— Label offset 2.4279
Distance 0.8001
Angle
'
Dist minimum
=5 i Dist maximum

Base Location Start Point
Show Properties Tes
Chain Actions Mo

"Increment" means stretch increasingly, a Value set appears as shown
below after selecting increment. If you choose "list", a Value set appears

as shown in below picture, the dynamic block can only be stretched

according to the number in the list.

Click the text frame which is on the right side of the "distance
value list", one button with ellipsis on it will appear. Click this
button, a "Add distance" dialog box will be displayed. Add

three numbers “17.“1.5”.“2” in the dialogue box, as shown in

below picture.

Exit from block editor and stretch the right grip, you will see
several gray lines appearing on the right side of the keyway,

Dist type

oic v s (R

Dist inerement [0

~|  amber of Grips|t

Dist t I t A 3
i it Dist type li=zt

Dist walue list |0 5001

Dist minimum o

Dizt maximum

Add Distance Value 33

Distances to add:

|
0.8001
1

15

list
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and the keyway can only be stretched to the gray line position, as shown in below picture. Obviously, by value list, you can
define certain numbers of the stretch, to realize an accurate stretch.

Tl —-
Vi

18.2.10. Symmetrical Stretch

There is an easy way to realize the two-way stretch which %Left (StEaten) Right (Stretch)

is adding two actions of stretch. Though it can realize a AT e e
two-way stretch, the action of stretch is independent. The T

parameter needs some additional setup to realize the two-

way symmetrical stretch. - = =

- First, add two stretch actions for parameter, and select

the two grips of the two parameters as the relevant point of each action.

- Second, in the misc, modify the base location from "Start Point" to "Mid Point", like shown in the picture below. Save and exit
the block editor.

For the convenience of watching the effect, we drew a vertical center line in the
middle of the keyway, and then stretched the grip to the left side of the keyway or
the right side, as shown in the picture below. As the grips are moving, the two- e

way symmetrical stretch is realized. @

13.2.11. Distance Multiplier 4= = P

Take the step shaft as an example, if we stretch the left part of the step shaft and

the keyway still is at the center point of the smaller diameter shaft after

stretching. Then, we use the “Distance Multiplier” property of action to achieve
the aim.
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1. Add linear parameter and stretch action for step shaft: ,

Hide the right grip of the parameter point, the action stretch -
box is as in the following picture, the bolded object is the | i
action operation object. |

2. Add Move Action for keyway: Select the left grip of the % i v
linear parameter when moving, stretching the related

parameter points. Move the objects of action and select the
whole keyway, as in the following picture. -

3. Modify distance multiplier of action: Select Move E e Y |
Action and modify the default value from 1 to 0.5 in the o
property of the distance multiplier, save and exit the
block editor.

o elion
‘B Hove Selection set 6 Object

4= =he | L == )

4 Test Dynamic Block; Stretch leftwards grip and with the grip moving leftwards,
the smaller diameter shaft will appear with a stretch effect, the keyway will also
move leftwards accordingly, meanwhile, the keyway is in the center of the

smaller diameter shaft of the step shaft all the time. Although Stretch and Move = - - - -
have a common parameter, when the Distance Multiplier of Move is modified to
0.5, the displacement of Move can only stretch 0.5 times of the displacement. f

g . - B

13.2.12. Chain Action

If you want to realize a symmetric stretch without changing the keyway center and the length of smaller diameter shaft changes
with the stretch at the same time, how can you realize that?

1. Add stretch for Step Shaft; Add stretch parameter and action for step
shaft as the following picture shows. There into, the bolded objects o
indicate the operation object of action. Because the follow-up operation |
will not stretch the step shaft by grips of this linear parameter, the grip’s ;
number of the linear parameter can be modified to “0”. it
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2. Add linear parameter for keyways: Set the base point
position of the line parameter as “Center” in order to

ﬁ Stretch

LinearParameter

realize the symmetric stretch function. i W e HEEERES

P

llllll PENTESY
57.4814
24.1734
13798
0. 8001

Dist type Home
Dist minimun |0

Dist maximun

Start Foin v

Show Froperties Etm Foint
i Geaiaan 1B

3. Add the stretch rightwards action for the keyway and realize chain action: Select the “Distance” linear parameter and modify

the chain action of prosperity from “NO” to “Yes” as the following picture shows:

;E;Stretch

LinearParameter

Distance

ﬁs
1

Right)

= = -

Stretch

LinearParameter

Add the Stretch Leftwards action for keyway as the following picture shows.
Special Note: Do elect “Distance” for the linear parameter to stretch

Distance

Streteh (Lef )

55.57T5
24173
-2.252
3.5200

leftwards the operation objects set. This is a necessary procedure of the

chain operation. =

4, Test Dynamic Block: After dragging the left grip, not only the keyway will
stretch bi-directionally and symmetrically but also the smaller diameter shaft of
the step shaft will stretch automatically. This is a chain action. The realization of

a chain action has two important procedures: First, modify the property value of 4 —

the parameter that need to happen as linkage and modify the property of “chain
action” from “NO” to “YES”. Second, elect the parameter of objects that are

elected to linkage action to set.

13.2.13. Scale Action

Scale Action can be matched with the Linear Parameter, Polar and XY Parameter to achieve various Dynamic effects.

Linear Scale

1. Draw: Finish drawing an access hole in a model space and define it as a block, as shown in the following picture.

188



Chapter 13 Create and Edit Dynamic Blocks

2. Add Linear Parameter: Enter into Block Editor to add a linear Starty o

parameter. The start point of the Linear Parameter is the center == 5

of the circle, and choose the number of grip as “1”as shown in i
Angle

the following picture.

Dist type None
Dist minimun 0O

Dist maximum

Base Location Start Point

Show Properties Yes

Chain Actions No

~ [ v
D

2
Humber of Grips k
V| Number of grips associated to
< S object

3. Add Action; Click the Scale icon on the Action Panel, appoint parameter for
Action and box the whole access hole as Action Object, as shown in the
following picture.

4. Test Dynamic Block: Exit from Block Editor and insert the Dynamic block, after pitching up the Dynamic Block, drag the
triangle grip, the objects (nuts) will scale with it.

Polar Scale

When we move the Scale Grip of the Access Hole on the left of circle center, namely move the
base point of the Linear Parameter to the left of the circle center, we will find that the block does
not have a corresponding Scale, as shown in the following picture.

The reason for this is that the Endpoint of the Linear Parameter cannot cross its base point, so
we change the Linear Parameter to be a Polar Parameter, we do not change any other
operations, as shown in the following picture.

Exit from Block Editor, Drag the grips of the Access hole Block again,
you can see, that after the change from Linear Parameter to Polar
Parameter, we can drag the grip to scale the dynamic block in any
direction.
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13.2.14. Scale Character

In this section, we will explain some Scale characters using XY Parameter and Scale Action in a paired example.

1. Drawing graphics: Draw the graphics which need a dynamic block and define them as a block as below:

O

2. Add XY Parameter: Entry Block Editor, add XY Parameter. Parameter adding is similar to Linear Parameter. Pick the first point
of the parameter from the left bottom comer of the rectangle as the base point, the second point from the top right corner and
change the Number of Grips to “1”. Then add Scale Action, as shown below.

...... "
istance

- o tinmer [0

é Scale | Eemen 1“.-8.3?2.. i

*"f Ziztancs [ioraiae SomE %Scale
i @ Y Distance

J
ln

jul
s
Fone

f

o
=

1es(fes

X Distance

H

3. Test the Dynamic Block: After exiting the Block Editor, drag the grip of the top right l —
corner of the rectangle, you can see the whole dynamic block is scaling as the grip is 4 R R A /

moving. It is easy to find that both the circle and the rectangle scale by the base point Q
of the XY Parameter. -

4, Modify Action Base: Modify Base type: go back to Editor, select Scale Action and
change the default “Dependent” to “Independent”.

! Scale

s [pase-r
Y Distance
ket

Eae
o

l‘ X Distance
+ ' S
Specify new base: Single click the right input box of “Base-X" and ;,(”'Scaie» &Eh@
“Base-Y”, you can manually input the coordinate value or you can ¥ Tidaiamnse m .1
single click the small button with ellipsis dots on the right of the e
input box and snap the base point, as shown: 1 +

X Distance
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Specify the base point by crosshair and the circle center as base point. After 7*»
exiting Block Editor, scale the dynamic block. After modifying Base type and
position, the scale center of the dynamic block changes from the XY Parameter ./

base point to the new specified base point (center of the circle).

5. Scale Type: There is “Scale Type” in the Scale Action
Properties. The default value is “XY Scale”. If you choose
“XY Scale”, the dynamic block scales whenever the scale
grip moves to X axis or Y axis. If you choose “X Scale”, it

scales only when the grip of the scale moves to X axis. =

Same, when you choose “Y Scale”. X Distance

,"::’_ scale type
ﬂ!’ScaEE‘%
g aze—X

Y Distance

ject

13.2.15. Rotation

In this section, we are going to use a rotation parameter and rotate action to add a dynamic rotate
function to view index symbols (English system) which are frequently used in architectural drawings. n

1. Draw a drawing: Draw a view index symbol and define as a block, as shown in below picture. w
Please define view number and drawing number as attribute text, so as to revise whenever you want.

2. Add rotation parameter: Pick the center of the circle as the first point of the parameter, system default it as the rotation point,
setangle type as "increment", and define its number as 15 degree, as shown below.

3. Add rotate action: Click the rotation action
button on the action panel, match parameter,
object and position for the action and select the
whole index symbol as the object of the action.

Rotation

4., Test dynamic block: Exit from block editor and insert the block, drag
rotation grip to reach the effect of rotation, as shown in below picture.
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13.2.16. Polar Stretch

We use the Polar Stretch function of Dynamic Blocks to draw the section symbol in this section.

1. Draw, Mirror and Define as a Block: The follow drawing includes the attribute text which can be modified as you need. Then
mirror this drawing and define the mirrored object as a block.

da oAl T A

2. Add action and parameter for the attribute text: Add Point
Parameter and Move Action for text and change the Chain

— X
Action to “Yes” .Itis ready for next step to create Chain
Action for Polar Stretch Action.
Y
3. Add Polar Parameter and Action: Add Polar Parameter whose first point b moa %Polarswetch
should be the center of the section symbol. This point will be the rotation
B~ X

center of the Polar Parameter. Follow the instructions below:
gition
Move

1. Pick the right grip of the Polar Parameter as an associated parameter point and specify the Stretch box (Fig. 3.1).

2. Select objects to stretch and the “position” Point Parameter together, which can accomplish that the text and section symbol
are moving together (Fig. 3.2).

3. Specify objects which rotate only for Polar Stretch Action (Fig 3.3).

4. Specify Action symbol location (Fig 3.4)

5. Repeat the above steps to add the same parameter and action order for the left part.

Distance X Distance

1 1 P o
—JJ— — —‘L_ !
A_/posit

| AP Fhov T Pwew

Fig 3.1 Fig 3.2

Distance Distance

1 L L & g
Mposh ' éé-/posh

ﬁ i/ AT f{} Move

Fig 3.3 Fig 3.4
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Itis better if you hide the grips which are not associated with the Polar Stretch Parameter as below:

Y
ﬁPolarStretchl BisEasaa) H Diditarce | PolarStretch

—s—= X
pomtlonlm osition
%Movel Move

4, Test Dynamic Block: Open the graphic which
needs to be dimensioned and insert the completed
dynamic block (Fig 4.1).

Drag the grip of the dynamic block, the section
symbol can be stretched outward and rotated .
around the center, and you finish the section | |
symbol mark (Fig 4.2). ‘ |

Fig 4.1 Fig 4.2

13.2.17. Polar Stretch Action Characteristics

Modify the grips” number of the polar parameter in the section symbol dynamic block Spfore JoTtIReLIn

in the last example to display both of the two grips of the polar parameter. From the A r —I A
following picture we can see that the central grip is clearly different before and after. Vodified

Before modifying, the central point was actually the base point of the block, and this 5

was the insert point. But after modifying, the center point of block is the base point of & r _I &)

the polar parameter.

Clicking central grip can move the grip to any direction. Meanwhile, the dark blue insert point of block will appear again, as
shown in the following picture. Obviously, the insert point is only covered by the base point of the polar parameter. The base
point of the polar parameter can move arbitrarily, but for the block it seems that no il

. . - A . 4
change is happening. But is it true?

In order to confirm if the block changes or not, we move the grips on both ’\A
terminals and we can find that the section symbol does not centeronthe o~ T .7 Ja D al”
dark blue base point when changing but it takes the base point of the

polar parameter as a rotate center, as shown in the following picture.

\Y!

AI:\\\\-:* Ta o . la

L
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Enter block editor, move up the parameter and the other settings do not change.

| Distance

\
I—[Jg |J—-| Polarstretch
ﬁpolarStretlchl Distancel % olarstrete

_E

Bt X
posnlonlm ’ osition
%Movel Hove

Exit block editor, move the right grip and you can see that ] r
- - A
rotate center moves up along with the parameter. From the Ar -iA :

N

examples above it is difficult to understand that the polar )
parameter cannot move arbitrarily like the point parameter A
and linear parameter, the reason is that the base point of the polar parameter specifies the rotate center of the object, once the
parameter is moved, the rotate center will move accordingly. That the rotate parameter cannot move arbitrarily has the same
reason.

13.2.18. Amay

For the Array function of Dynamic Block we need to use Array Action, we use Array Action to match with Linear Parameter, Polar
Parameter, XY Parameter to achieve various Arrays.

Linear Array

1. Draw: Draw a parts list and define it as a block.

lNo. Name Number | Materials Horm Note

2. Add Linear Parameter: After adding Array Action, we can drag the two grips of the Parameter to make a list array, but
obviously, we hope just to achieve an up array of the blank bar, not a down array, so to avoid a mistakes, we should hide the
grip under the Parameter, as in the following picture.

No. Name Number | Materials Norm Note

Llié Array; lsl'ﬁaal?]lceeArray

i = X

3. Add Array Action: During the add Array Action, the system will require to appoint space between columns. The space
between columns is the distance between the objects that the array created. Here, the line width is 7mm, for the line between
the lines a close up array can be chosen, we appoint that the space between the columns is 7mm.

ArrayD/i stance

‘B Tanlebrray

No. Name Number | Materials Norm Note _f
£ £ X
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4, Test Dynamic Block: Insert Dynamic Block, drag the top right corner grip upwards, the line number of the part list will be

added automatically, as in the following picture.

No. Name Number | Materials

Norm Note

XY Array
Compared with Linear Array, XY Array
has a vertical direction Array.

Polar Array

We see a Dynamic Block example as follows, after
dragging grip, the effect will be as in the following
picture. You can see, not only can we stretch the fence,
but we can also rotate the direction casually, this is the
effect combining Polar Stretch with Polar Array.

Enter into Block Editor; stretch, the ways of adding Array
Action as shown in the following picture, the bold object
expresses the relevance with the selected action. The Polar
Parameter determines the way of Array directly, the Polar Array
will regard the direction of the Polar Parameter as Array
direction, achieving Array functions in any direction.

s

% Array

: ﬁ Stretch

Distance
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14. Parametric Constraints

Geometric constraints manage how objects relate to others, enabling automatic adjustments to other objects when changes are
made. They also restrict changes to distance and angle values, ensuring design precision.

There are 12 types of geometric constraints corresponding to 12 relationships: Coincident, Collinear, Concentric, Fix, Parallel,
Perpendicular, Horizontal, Vertical, Tangent, Smooth, Symmetric, and Equal.

Note: This feature is only available in the LusoCAD 2025 Plus version.

ng17|

Application Cloud Note Collaboration

14.1.  Coincident

Constrains two points to coincide, or a point to lie anywhere on an object or the extension of an object.

o

> Access: Click Ribbon » Parametric » Geometric = = or enter GCCOINCIDENT command.
>  Gommand Prompts:
Select the first point or [Object]: Select the first point or object that needs to coincide.
Select the second point or [Object]: Select the second point or object that coincides with the first point or object.

> Example:

14.2.  Collinear

Constrains two lines to lie on the same infinite line.

>  Access: Click Ribbon » Parametric = Geometric » or enter GCCOLLINEAR command.
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>  Command Prompts:
Select the first object or [Multiple]: Select the first object orc multiple objects that need to be collinear;

Select the second object or [Multiple]: Select one or multiple objects that are collinear with the first object or the group of
objects.

> Example:

14.3.  Concentric

Constrains selected circle, arcs, or eclipses to maintain the same center point.

Y
|

> Access: Click Ribbon » Parametric ® Geometric » -/ or enter GCCONGENTRIC command.
>  Command Prompts:

Select the first object: Select the first object that needs to be concentric;

Select the second object: Select the second object that is concentric with the first object.

> Example:
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144,  Fix

Constrains a point or a curve to a fixed location and orientation relative to the World Coordinate System.

> Access: Click Ribbon » Parametric » Geometric » I_dil or enter GCFIX command.
> Command Prompt;
Select point or [object]: Select the point or object that needs to be fixed.

> Example:

o e

‘ Specify stretch pointor =

14.5. Parallel

Constrains two lines to maintain the same angle.

> Access: Click Ribbon » Parametric » Geometric » 7 or enter GCPARALLEL command.
»  Command Prompts:

Select the first object: Select the first object that needs to be parallel;

Select the second object: Select the second object that is parallel with the first object.

> Example:
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14.6.  Perpendicular

Constrains two lines, or polyline segments to maintain a 90-degree angle to each other

»  Access: Click Ribbon = Parametric = Geometric » X or enter GCPERPENDICULAR command.

> Command Prompts:
Select the first object: Select the first object that needs to be perpendicular;
Select the second object: Select the second object that is perpendicular with the first object.

> Example:

14.7. Horizontal

Constrains a line or pairs of points to lie parallel to the X-axis of the current UCS.

> Access: Click Ribbon » Parametric » Geometric » ~**  or enter GCHORIZONTAL command.
»  Command Prompts:

Select an object or [2Points]: Select the object or two points that needs to be parallel to the X-axis.

> Example:

199



Chapter 14 Parametric Constraints

14.8.  Vertical

Constrains lines or pairs of the points to lie parallel to the Y-axis of the current UCS.

> Access: Click Ribbon » Parametric » Geometric » - or enter GCVERTICAL command.
> Command Prompts:
Select an object or [2Points]: Select the object or two points that need to be parallel to the Y-axis.

> Example:

149.  Tangent

Constrains two curves to maintain a point of tangency to each other or their extensions.

L

> Access: Click Ribbon » Parametric » Geometric » ) or enter GCTANGENT command.
»  Command Prompts:

Select the first object: Select the first object that needs to be tangent;

Select the second object: Select the second object that is tangent with the first object.

> Example:
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14,10. Smooth

Constrains a spline to be contiguous and maintain G2 continuity with another spline, line, arc, or polyline.

> Access: Click Ribbon » Parametric » Geometric or enter GCSMOOTH command.
> Command Prompts:
Select the first spline curve: Select the first object that needs to be smoothed;
Select the second object: Select the second object that satisfies G2 continuity with the first object.

> Example:

1411.  Symmetric

Constrains two curves or points on objects to maintain symmetry about a selected line.

I
> Access: Click Ribbon » Parametric » Geometric » [i or enter GCSYMMETRIC command.
»  Command Prompts:
Select the first object or [2Points]: Select the first object that needs to be parallel;
Select the second object or [2Points]: Select the second object that is parallel with the first object;
Select symmetry line: Select the axis of symmetry.

> Example:
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1412. Equal

Constrains two lines or polyline segments to maintain equal lengths, or arcs and circles to maintain equal radius values

> Access: Click Ribbon » Parametric » Geometric » or enter GCEQUAL command.
> Command Prompts:
Select the first object or [Multiple]: Select the first object(s) that need(s) to be equal;

Select the second object or [Multiple]: Select the object(s) equal to the first object.

> Example:
7 Show/Hide
| @ Show Al —
@ Hide Al Ueicte
Constraints

Geometric ra Manage
—
.\l

Show/Hide (CONSTRAINTBAR): Select objects to display or hide their associated geometric constraints.

Show All: Display all geometric constraints.

~ Hide All: Hide all geometric constraints.
X Delete Constraints (DELCONSTRAINT): Delete all constraints that are associated with the selected objects.

e
“'Constraint Settings (CONSTRAINTSETTINGS): Manage settings related to constraints
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@ Constraint Settings X

{Geometric |

Enter constraint type

Infer geometric constraints H I']r I"'I'j ntal
Constraint bar display settings \ufe r—tl ca I
@ Perpendicular 7/ @ Parallel Selsctil R - _
Perpendicular
7 @ Horizontal 1l @ Vertical Clear Al
o Tangent % @ Smooth (G2) PArallel
7 Collinear © Concentric -I—,a n g ent
[}] Symmetric = Equal C
. . SMooth
i @ Coincident & @Fix
(" |. i~ i~
Only display constraint bars for objects in the current plane Loinci d = th
Constraint bar transparency LOPJCEHTHC
i v COLlinear
8 . . T Pt e
Show constraint bars after applying constraints to selected objects “"3" mm t..-tr 1C
Show constraint bars when objects are selected E I
gua
0K | Cancel Help Fl}‘:

Note: You can also use GEOMCONSTRAINT command to establish or maintain geometric relationships between objects or

points on objects.

The order and selection points of objects can influence their relative positions when applying a geometric constraint to a pair of

objects.

Each option of this command corresponds to an individual command from (1) to (12).

Parametric Constraint Related System Variables

System Variable Description Value Value Description
0 Automatically hides constraint bars
after applying geometric constraints.
Controls the display of constraints bars Displays constraint bars when
for subsequently applied geometric 1 objects are geometricall
CONSTRAINTBARDISPLAY CAUEnty appiied 9o e !
constraints, as well as the display of constrained.
hidden constraints for selected objects. Displays any hidden constraints, but
2 only if the constrained objects are
selected.
1 Horizontal
Controls the display of geometric ,
constraints on constraint bars. Setting it Vertical
| | oetting |
CONSTRAINTBARMODE . _ g
as 4095 could display constraint bars ,
. Perpendicular
for all constraint types
8 Parallel
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constraint bars.

16 Tangent
32 Smooth
64 Coincident
128 Concentric
256 Collinear
512 Symmetric
1024  Equal
2048  Fix
Controls whether the geometric 0 Off
CONSTRAINTINFER constraints are inferred while creating
and editing geometry. 1 Geometric constraints are inferred
0 Name (for example, Width)
Controls the text format for dimensional
CONSTRAINTNAMEFORMAT , 1 Value (for example, 4.0000)
constraints.
) Expression (for example, width =
4.0000)
Does not maintain the geometry’s
Controls constraint behavior when 0 size when a constraint s applied or
CONSTRAINTSOLVEMODE _ N , edited
applying or editing constraints. o o
’ Maintain of the geometry’s size when
a constraint is applied or edited
Controls the transarency of the The valid value ranges from 10 to 90.
CBARTRANSPARENCY parency 50 Higher value makes the constraint

bars more opague.
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15. Share Date between Applications

15.1.  Net Framework Support

NET API enables you to manipulate the application and drawing files programmatically with libraries that are exposed and can
be accessed by many different programming languages such as VB.NET, C# and Managed C+ + .etc. Users are able to
automate tasks such as creating and modifying objects stored in the database of a drawing file or change the contents of a
customization file.

15.2. ObjectARX API

LusoCAD 2025 GRX is compatible with AutoCAD ObjectARX 2020 APIs, programs can be successfully compiled, loaded and
used without editing code, which saves a lot of time in migrating applications developed with AutoCAD ObjectARX.

15.3.  Copylink Command

Using COPYLINK command, Users can copy the current drawing view to the Clipboard and then paste the contents of the
Clipboard into another document as a linked OLE object.

15.4.  Lisp Debugger

You can enter the VLISP or VLIDE command, or click Ribbon  Manage * Applications - Visual LISP Editor to launch the
Visual Studio Code as the Lisp Debugger in LusoCAD 2025, in which you are able to edit, and debug Lisp programs

conveniently.
— == N « 2D Drafting

Home Insert Annotation 3 Surface Mesh Layout View [WEREL

ﬁ | g | hﬂi E [ |m] > F= Visual Basic Editor =J
= o - [f] visual LisP Editor

Interface Edit  Aliases Shortcuts Load Run s Y= . Layer
X R X ==y Runs a VBA macro
Aliases Editor customize Application Script... Translator

Customizes settings Applications s CAD Standards

If you haven't installed the Visual Studio Code software, a warning will pop up, asking you to install it first.
If the Visual Studio Code software has been installed in your PC, it will be opened in a few seconds. You can visit VS Code
official website. e i T

Zutip

205



Chapter 15 Share Data between Applications

(https://code.visualstudio.com/docs/getstarted/userinterface) to learn more details.

LispDebugger:This extension adds support for Lisp files to Visual Studio Code. It allows you to edit and debug your lisp
programs with LusoCAD. When you start VS Code through LusoCAD, it will install the LispDebugger extension for you by
default. And when there is a new version of the LispDebugger extension, it will be updated automatically the next time you start
VS Code through LusoCAD. Or, you can also search and install it in marketplace.

1. Open File
You are able to open LSP files or DCL files and debug
them when the VS Code is opened and LispDebugger
extension is installed.
> Click the LispDebugger extension icon, then
click "Open Folder" icon, select the folder,
and the .Isp and .dcl files will be filtered out.

> Click the file in the list to open it in the
editing area.

> Click the refresh button to reload the selected
file if you need.

2' Edlt Flle c:foo (/ abecdefghiiilst)
Wha*[ yOU can do to edlt the program Wlth (entmake (1list (cons @ "line") (cons 1@ (list @ @ ©)) (cons 11 (list 1
(setq a 1235
LispDebugger extension in VS Code: : S
> Syntax highlight , e
. (setq i (list 123 3.323 "444.22" (cons "bb"™ 222) (list a b) f g h))
> Code folding (setq ii 8)
. (setq j 1235
> Smart hints k 1.234
1 "1.234"
> AUtOCOfﬂp|etI0n m (cons n 234)
)
> (Code snippets (setq o (list 123 3.323 "444.22" (cons "p" 222) (list j k 1) p r s))
(setq kk @)
(repeat 5 (setq 1lst (cons ii 1st)) (setq ii (1+ ii)))
(princ)
)
(setq value)
23 set|
abc setq
[Nsetq
3. Debug

Basic debugging steps include:
> Step 1. Launch VS Code
Step 2. Open a LSP file or a DCL file
Step 3. Add debug configurations and edit launch.json
Step 4. Choose a debug configuration: LispDebugger-Launch or LispDebugger-Attach

Y V VYV V

Step 5. Click Run> Start Debugging (or Press F5)
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LispDebugger-Attach:
Allows you to attach to a running instance of the LusoCAD application to debug the current LSP or DCL file.

RUN

which can be ¢

or run.
Node.js
Run and Debuc \yeh App (Chrome)
To customize Run and Dek Web App (Edge)
and create a launch, 'nstall an extension for LISP...

As long as you choose LispDebugger-Attach configuration, you need to select a running LusoCAD instance as debug adapter. If
there is no running LusoCAD instance in your PC, a warning will pop up, and the file can’t be debugged.

= d_printAndDrawlsp X (]

0BlockV1-? LusoCAD 2825 Professional (Preview)[Trial day left 67] - [VLISP.dwg]
CurveV1-3l5 PID:2996
d_printAndDraw.Isp LB
r (getreal "\n radius"
d(*2r))

Visual Studio Code

e Couldn't find a debug adapter descriptor for debug type ‘attach’(extension might have

failed to activate)
] Open ‘launchjson’ Cancel

LispDebugger-Launch:
Launches a new process of the LusoCAD application to debug the current LSP or DCL file.

RUN

lispDebugger
which can be d
or run. lispDebugger-Launch
Node.js

Run and Debuc yep, App (Chrome)

Web App (Edge)

To customize Run and Det
Install an extension for LISP...

and create a launch

As long as you choose the LispDebugger-Launch configuration, you need to specify the absolute path of the gcad.exe file in the
path format C://Program files//IGENMAI//LusoCAD2023//gcad.exe)

nQm|oe o

extension settings of the LispDebugger extension (

lispDebugger Wil
R
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If you haven't set an absolute path to the gcad.exe file, the debug window will prompt you to set the path.

h for the product.

Enter’ to confirm your input or * to cancel

which can be |d.
selg Lux (ssiengtit sei)

idx (1- idx)
Run and Debug ent (ssname sel idx)
enx (entget ent)
To customize Run and Debug, lst (cons (vlax-ename->vla-object 4
and create a launch,json file.

orrun.

GCAD doesn‘t exist. Verify and correct the folder path to

the product executable.

Source:1ispDebugger (Extension)

4, Debug Actions
Once a debug session starts, the

Debug toolbar will appear on the Step In Step Out
top of the editor. F11 Shift + F11
Step Over Restart
. F10 Ctrl + Shift + F5
> Continue / _ )
Pause: Jumps to next ::y'rcont'nue Stop/Disconnect
breakpoint. Shift + FS

> Step Over: Completes
current line and moves to the next line of code in the current function.

> Step Into: Completes the next line of code. If this line contains a function, go to the first line of the function's code
and stop.

> Step Out: Completes all the code in the current function and return you to the previous function that "called" this
function.

> Restart: Restart the debug session.

> Stop: Stops the debug session.

Note:
> InLispDebugger, press F10 to complete current line and move to the next line of code, while in AutoLisp, press F10 to
complete current line, and then press F10 to move to the next line.
> When you click the Restart icon:
e LispDebugger-Attach configuration: Current debugging session will not be stopped, and the debugging will be
restarted in the current CAD instance.
e LispDebugger-Launch configuration: Stops the current debugging session, end the current CAD instance
(without asking whether to save the drawing), and then re-launch a new CAD instance for debugging.
> When you click the Stop icon:
o LispDebugger-Attach configuration: Stops debugging session, but keeps current CAD instance.
e LispDebugger-Launch configuration: Stops debugging session, end the current CAD instance (without asking
whether to save the drawing).
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5. Run View
Once a debug session starts, the Run View windows will appear on the left of the editor, include:

> VARIABLES » VARIABLES

The Locals and Last Value windows show variable values while you are debugging. The
windows are only available during a debugging session. The Locals window shows
variables defined in the local scope, which is usually the current function or method. The
Last Value displays the value of the last changed variable.

v Last Value

> WA‘I’CH LAST-VALUE*: 1

While you're debugging, you can

use Watch windows to watch variables and
expressions. The windows are only available
during a debugging session. Watch windows
can display several variables at a time while

Add Expression

Edit Expression

. . Copy Value
debugging. You are able to add, edit or
remove expressions by right click on the Remove Expression Delete
Watch windows. Remove All Expressions

> CALL STACK
v CALL STACK PAUSED ONSTEP (S]]

The Call Stack windows display a list of all the procedures that have been C:FOO foolsp 93
executed. It lists the name of the function or procedure that is currently on
the stack. In LispDebugger, the call stack mainly displays the name of the
called function.

> BREAKPOINTS ~ BREAKPOINTS
Wl

A breakpoint is a setting that you can add to a line of code to temporarily pause the M user-unhandled

execution at that line. Breakpoints can be toggled by clicking on the editor margin or using

F9 on the current line. The Breakpoints windows allow you to control all breakpoints. Remove Breakpoint

Remove All Breakpoints

¥ foo len

Enable All Breakpoints

Disable All Breakpoints

Reapply All Breakpoints
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15.5.  Python

LusoCAD continuously enhance the integrity and compatibility of
GRX, .NET, and LSP ensuring that users' secondary development
programs run smoothly after migration, thereby reducing the cost of
secondary development migration.

In LusoCAD 2025, we support the use of Python on Windows to
extend the capabilities of the LusoCAD platform. With over 790
commonly used Python interfaces, we cover daily usage scenarios,
such as creating custom commands, custom graphics and entities,
accessing and modifying various drawing data, and implementing

s e

-

custom drawing and analysis algorithms. Users can leverage Python's powerful features for custom development and
automation, significantly expanding GRX functionality. This script-based invocation of GRX interfaces supports cross-platform

development and lowers the learning cost for new developers.
System Environment Requirements

> Python 3.11.8
> Windows 10 and above

15.5.1. Install Python

Download the installation package and install it as administrator, configure the options as below:

£ Python 3.11.8 (64-bit) Setup - X & Python 3.11.8 (64-bit) Setup -
) Install Python 3.11.8 (64-bit) ) Optional Features
Select Install Now to install Python with default settings, or choose @ Documentation
Customize to enable or disable features. nstalls the Python documentation files
- Install Now 8op .
C:\Users\Administrator\AppData\Local\Programs\Python\Python31 nstalls pip. which can download and install other Python packages
Includes IDLE @ td/tk and IDLE
Creal tions stalls tkinter and the IDLE development environment
@ Python test suite
e d Customize installation nstalls the standard hibrary test surte.
Choose location and features 8 py launcher @ for all users (requires admin privileges)
nst global ‘py’ launcher to make it easier to start Pyth
pgth‘()n @ Use admin privileges when installing py.exe pUthfm
. / @ Add python.exe to PATH Cancel . Back Next Cancel
windows windows

= Python 3.11.8 (64-bit) Setup =

) Advanced Options
@ Install Python 3.11 for all users

B Assodiate files with Python (requires the ‘py’ launcher)

@ Create shortcuts for installed applications
@ Add Python to gnvironment variables
@ Precompile standard library

() Download debugging symbols
[ Download debug binaries (requires VS 2017 or later)

Customize install location
C:\Program Files\Python311
python
for
Back Install

windows

Browse

Cancel
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15.5.2.  Import Interface

Use the Import command in the Python file to import the secondary development package:
from pygcad.core import *
from pygcad.pygrx import *
pygcad.core includes Python-specific core interfaces such as the @command decorator;
pygcad.pygrx contains various types and methods corresponding to GRX interfaces.

156.5.3. Register Custom CAD Commands

During development, when a user-defined function is decorated with @command, this function is automatically registered as a
command in LusoCAD, with the function name as the default command name. For example:

pygcad. core.runtime

*

pygcad. pygrx

@command ()

0:

database = gcdbWorkingDatabase()
(status, blockTbl) = database.getBlockTable(GcDb.OpenMode.kForRead)
(status, record) = blockTbl.getAt(GCDB_MODEL_SPACE, GcDb.OpenMode.kForwrite)

blockTbl.close()

line = GeDbLine(GeGePoint3d(e, ©, @), GcGePoint3d(
(status, objIid) = record.appendGcDbEntity(line)
record.close()
line.close()

Exception err:

geedPrompt(

The function pyDrawLine() is decorated with @command(), automatically registering it as the GCAD command PYDRAWLINE.
If you don't want to use the function name as the command name, you can specify it in the decorator function command(). The
@command decorator is defined as follows:

def command(local_name="", global_name="", group_name="", cmd_flags=0):
When local_name is empty, the name of the decorated function is automatically used as local_name. If global_name is empty,
it automatically uses local_name as global_name. If group_name is empty, it selects global _name as group_name. For
example:

@command (local name=

0:
print(

This defines a custom command: PY_MY_CMD.

15.5.4. Load in LusoCAD

For example, we used the secondary development interface to develop our own PYMKENTS command. Python file is: ents.py.
After running the command, the program will draw a line, a circle with a red linetype, and create a layer named
ASDK_MVYLAYER.
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> Open LusoCAD 2025, enter the APPLOAD command, the Load/Unload Applications dialog box will pop up:

@ Load/Unload Applications

Loaded Applications  History List

X

File Path

3DxGst... D:
al_cyl... D:
ai3d. fas D:
aligns... D:
dvit. lsp D:
elitoo... D:
expres... D
gead20. .. D:
goad20. .. D:
gehim. grx D:
godin. grx D:
gcExpe... D:
Overki... D:

b
it
it
b
it
!
b
i
it
b
b
it
it

Close

Unload
[T Add to History

Startup Suite
bl

Contents...

Help

»  Click Load button and select the ents.py file, it will register the command automatically: PYMKENTS

@ Load/Unload Applications

Loaded Applications History List

File

Path

|ems py successfully loaded

Close

X

Load

Unload
[ Add to History

Startup Suite

Contents.

Help

»  Close the dialog box and enter command PYMKENTS, the program automatically runs.

212



Chapter 16 Security

16. Security
16.1.  SECURITY

SECURITY command sets the system security monitoring level, and display or delete the current trusted publisher certificate.
Unnamed VBA project files can be loaded without warning.

@ security X

Security Level | Trusted Publishers

Very High. Only macros installed in trusted locations will be
allowed to run. All ohter signed and unsigned macros are
disabled

O High. Only signed macros from trusted sources will be allowed to
run. Unsigned macros are automatically disabled.

iMedium. You can choose whether or not to run potentialy unsafe
©';'nacm5.

Low {not 1ded). You are not p d from potentially

Ounsafe macros. Use this setting only if you have vinus scanning
software installed, or you have checked the safety of all
documents you open

Cancel

16.2.  Security Options in Save As

Users could add security options for the specified drawing file, those options will have effect when saving the drawing. Anyone

who wants to open the drawing file needs to input the correct password. Do remember the password, otherwise, the drawing
can't be recovered.

@ soe X
Saw @ Security Options X |Miews
Fassword  Digital Signature
Password or phrase to open this drawing - %
| Encrypt drawing properties @ Canfirm Password
AT
= Curent encryption type Reenter password to open this drawing:
Microsoft Base Cryptographic Provider w1.0 ||
[ Options...
\ ) .
E Caution: If you lose or forget the password it can't be
| Advanced Options l e d. t is suggested to keep a list of passwords and
the comesponding drawings name list in a safe place.
- Drawing passwords are not case senstive.
& G
" Cancel | [t
File name: Drawing1.dwg ~ ‘ | Save [
Save as type AutoCAD 2018 Drawing(".dwa) ~ Cancel
Password *
Enter password to open drawing:
C:\Usershows'\Desktop“Drawing1.dwg
oK Cancel
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16.3.  Digital Signature

DIGITALSIGN and SIGVALIDATE command are provided to support attaching and validating digital signatures, which can offer
reliable information, and validate the authenticity and integrity of drawings.

System Variable Description Value Value Description
L The information is not presented if a
Controls whether the Digital Signature 0 , N
, _ file has a valid signature
SIGWARN Contents dialog box is presented when a , o o
- L . The information is presented if a file
file with a valid digital signature is open 1

has a valid signature

Display digital signature information: Located at Logo * Options » Open and Save = File Safety Precautions » Display
digital signature information, has the same effect as the SIGWARN system variable.

@ Options - -
@ Digital Signature Contents X
Current profile: <<Unnamed Profile>> @ Current drawing; Digital signature.dwg
: ‘E\Drawinga\Dig\lal signature.dwg
File  Display | OpenandSave Plotand Publish UserPreferences Draw Selectionset Profiles
: The digital signature is valid
File Save File Open The drawing has not been modified since signed
Saveas El Number of recently-used files Digital ID
AutoGAD 2018 Drawing(* dwg) ~ [ Display full path in‘ite Signed by: Otherfields(0):
- [caD-2023 Subject v
Maintain visual fidelity for annotative objects Application Menu
[“]Maintain drawing size compatibility Values
El Number of recently-used files CAD-2023
Thumbnail Preview Settings.
Serial number
Incremental save percentage Xrefs
Demand load Xrefs:
File Safety Precautions —
nable ~
[] Automatic save EEOiieEns
Minutes between saves (® [~]Retain changes to Xreflayers
Create backup copy with each save @ [7] Allow other users to Refedit current drawing
[CJFuli-ime CRC validation
GRX Applications
[IMaintain a log file
VS Signature date and time: Time service used
File extension for temporary files Proxy images for custom objects: ‘ ‘ ‘
Security Options ECE i AN s [C]skip ref wamnings(S)
| [ Display digital signature information |
Cancel Apply Help
o . . Digital Signature Warning X
If your digital signature has a password, you will need to enter the

password first.

The saved version of this drawing has a digital
signature attached.

Saving a new version will invalidate the signature.

Do you want to continue?

Note: The digital signature will become invalid when:

e Thefile is modified after the digital signature is attached. e
e Thefile is damaged during transmission or when a digital ~ Password
signature is attached.

Enter password to open drawing;

E:\Drawings\Digital signature.dwg

e The digital certificate has been revoked by its certificate |

authority.

Cancel
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16.3.1.  DIGITALSIGN

You can enter DIGITALSIGN command to attach a digital signature to a drawing, which can provide reliable information of the
origin, identity and status on a drawing file. And if an unauthorized change is made or the signed file is corrupted, the digital
signature becomes invalid.

Command :
» Command: DIGITALSIGN

Command :

After execute the DIGITALSIGN command, the Security Options window will pop up, after checking the ‘Attach digital signature
after saving drawings’ option, you are able to select a digital ID and edit signature information (Time stamp and Comments).

Security Options X
@

Password Digital Signature

[i] Atiach digital signature after saving drawing

Digital Signature - Digital ID Not Available X Select a digital ID (certificate).
Issued To Issued By Expiration Date
No Valid digital ID is available on your system.

A digital ID, also known as a digital identity or digital
certificate, is an encrypted file that contains your
personal security information. Digital IDs prove your
identity in electonic transactions, and are included with
digital signature. Time of the Computer (DESKTOP-HG36M2N) M digital signature

Signature information
Gettime stamp from: Comments:

You can obtain a digital certificate from a reputable Successfully contacted time server.

certificate authority(CA).

But, if there is no valid digital certificate in your PC, a warning box will pop up.

Except the DIGITALSIGN command, you can also enter ‘SAVEAS’ command, or click Logo # Save as = Security Options, to
open the ‘Save drawing as’ dialog box and attach a digital signature to the drawing. The Security Options window that is popped
up is the same as DIGITALSIGN command.

Save drawing as x
Saven ‘ Drawings v ‘ < B B] Preview ¥
(P Name - Date modified Type ~  FPrevew:
‘;ﬂ CLIPIT SAMPLE 28/06/2022 16:08 File folder
Demo 16/05/2022 13:41 File folder
Guide 16/05/2022 13:41 File folder
= LISP 29/06/2022 14:16 File folder
Overview 16/05/2022 13:41 File folder
(D ATTIPEDIT.dwg 14/06/2022 15:47 DWG File
| @ BTABLE.dwg 15/06/2022 14:26 DWG File Options...
[ @ BTABLE recover.dwg 27/06/2022 16:22 DWG File
.
(3 CLOSELINE.dwg 14/06/2022 15:37 DWG File
@COMBINELAYOUT‘GWQ 16/05/2022 16:40 DWG File
[P} @ Digital signature.dwg 04/07/2022 10:03 DWG File
@ DWF.dwg 21/06/2022 1438 DWG File
(D DWF2.dwg 29/06/2022 10:58 DWG File
¥ (3 layout drop down button.dwg 29/06/2022 13:38 DWG File
@ @LAYOUTMERGEZ dwg 15/06/2022 14:08 DWG File
(3 LOCKUP.dwg 30/03/2022 13:51 DWG File
(3 NAVCUBE.dwg 14/06/2022 13:01 DWG File N
< >
File name Digital signature dwg -] [ see
Save as lype AutoCAD 2013(LT2013) Drawing(* dwg) ~ Cancel

Note: You can only digitally sign the following file types:
e DWG and DWT files that are compatible with AutoCAD 2000 and later drawing-file formats.
e DWSfiles.
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16.3.2. DWFX Batch Digital Signing Tool

You can find the application digitalsign.exe in the program installation path to signs DWFX, DWG and DWT files in bulk with
digital signatures efficiently.

In the Attach Digital Signatures dialog box:

@Arta(h Digital Signatures - s

. Files to be signed
H

Name Folder Status add Files

++

Search Folders

Eenove

f i R Clear 1ist
MNumber of files to sign: 0

Selectadigital ID (Certificate)

Issued To Issued By Expiration Date
Test Test 2028-12-31

- Signature information

Gettime starmp from: Comment: . .
Biegn Files

(Mo time starmp) ~ <enter description>

frotime stam)

> Files to be signed: Displays a list of files added to be signed with their folders and status(empty, signed, previously
signatures). The number of files you added will also show at the left-bottom of the list.

> Add Files: Pops up the Select File dialog box, and you can select the files you want to attach a digital signature to.

> Search Folders: Pops up the Browse for Folder dialog box, you can select the folder of files you want to attach a digital
signature to and then click OK.

> Remove: Removes the selected files from the list

> Clear List: Empties the whole file list

> Select a Digital ID (Certificate): Select a digital ID to attach to the files you selected in the Files to Be Signed list.

> Get Time Stamp From: Select a time service if you want to add a time stamp to the signed files.

> Comment; Add any extra description to the files you are signing.

> Sign Files: Starts the signing process, it will pop up a

Signing Complete X

Signing Complete dialog box after finishing and display the _— | .
Drawings
Number of files Signed. |\ Number of files signed: 2
. F

> Close: Close the Attach Digital Signatures dialog box.
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If the file you want to sign is read-only, the Read-only File dialog

box will be displayed, you can select according to your needs.

Note: If you choose either a Medium or High-security level when

Digital Signatures - Read-only file

| The following file DWFX_File1.dwfx is marked
" read-only. What do you want to do?

—> Sign this file anyway

—> Sign all read-only files

=> Skip this file

you obtained your digital ID, a message will be displayed each time

you try to attach a digital signature to a file.

Right-Click Menu:

Files to be signed

=> Skip all read-only files

Cancel

Folder Status

DVYFX_File? dhwbx Ll

O G Sign. dhwg Properties
DWW T_Sign.ciwt

Signature information

( Luke\Des._ | Signed ]

CiAlsersiLukelDes...  Signed
CilsersiLukeyDes...  Signed
ChldsersiLuketDes..  Signed

> Delete: deletes the selected file

> Properties: Pop up the system Properties window

> Signature information; Pop up the View the signature details window

DWEFX_File1.dwfx Properties
General Security Details Previous Versions
D ‘ DWFX_FileT.dwhx
Type of file DWFX File (.dwfx)
Opens with: Unknown application Change
Location: C:\Users\Luke\Desktopl
Size 296 KB (304,101 bytes)
Size on disk: 300 KB (307.200 bytes)
Created: Friday. July 28. 2023, 5:14:47 PM
Modified: Friday. August4, 2023, 4:41:54 PM
Accessed: Today, August4, 2023, 5 minutes ago
Aftributes: &%Edfﬁ’."‘x [Hidden Advanced

View the signature details X

Signatures details

The digital signature is valid.
The document has not been modified since it was signed

Certificates

‘Signature valid ‘

Signer by

Certificates

Theme
Issuer
Serial number

Valid from =2023/1/1 0:0: 0
validto =2029/1/1 0:0: 0
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16.3.3.  SIGVALIDATE

You can click the signature validate icon in the Status bar or enter the SIGVALIDATE command to figure out whether the digital

signature attached to a drawing file is valid or invalid. The Validate Digital Signatures dialog box that shows information about
the digital signature is displayed.

El i AT A

(@ Security Options X
password Digital Signature

[] Atach digital signature after saving drawing
Select a digital ID (certificate)

Issued To Issued By Expiration Date

2027-12-31

Signature information

Getfime stamp from Comments:

Time of the Computer (DESKTOP-HGS6M2N) ~ | |digital signature

Successfully contacted ime server.

Cancel Help
After executing the SIGVALIDATE command, the Validate Digital Signature dialog box pops up. When it is valid:

Name: Displays the location and name of the file whose digital signature is being viewed.

Digital Signature Status: Displays a Valid Signature icon if a digital signature is valid, and an Invalid Signature icon if the digital
signature is not valid.

View Base Signature: Displays the Digital Signature Contents dialog box. The option is available only if the digital signature is
valid.

View Xref drawings: Displays the Xref drawings contained in a file’s base drawing. After checking it, a list of Xref drawings will
be showed below as long as there are some Xref drawing contained in the current signed file.

View Xref Signature; Displays the Digital Signature Contents dialog box of the Xref file. It can be clicked only if the Xref file is
selected in the list.

The Digital Signature Contents dialog box includes;

( Digital Signature Contents X

» Name: Displays the location and name of the file whose digital

|E \ Materials\Drawings\ATTIPEDIT.dwg

. . . . The digital signature is valid

signature is being viewed. e e

Digital ID
L. . . . . . . Signed by: Other fields(0):

> Digital Signature Status: Displays a Valid Signature icon if a [ceriate | [Seraiumber <]

digital signature is valid, and an Invalid Signature icon if the e st s o,

WValid to
digital signature is not valid. Serial number

> Signed by: Displays the location and name of the file whose Comment

digital signature
digital signature is being viewed.

> Other fields: Displays the subject, issuer, valid from date, valid to o ] .
ignature date and time: ime service use:

date and Senal number m the Values box |D\SID7!202216:G546W Australia Ste‘ ‘Tlmeﬁom local computer
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Subject: Displays information about the organization or individual who owns the digital ID and attached the digital
signature;

Issuer: Displays the name of the certificate authority that originally issued the digital ID;

Valid from: Displays a day, month, year, and exact time, the digital 1D is valid from that time;

Valid to: Displays a day, month, year, and exact time, the digital ID will be invalid after that time;

Serial numbers: Displays the serial number assigned to the digital ID.

>

>

Values: Displays information about a digital signature based on the item you select in the Other fields drop-down list.
Comment: Displays comments about the digital signature that is attached to the current file.

Signature date and time: Displays the date and time that the digital signature was attached to the current file. The
date and time are based on the time service used when the signature was attached.

Time service used: Displays the time service used to add the time stamp to the current file.
Close: Closes the dialog box.

Help: Opens Online Help system, Home — Commands — S — SIGVALIDATE command.

When the drawing file is not signed:

(3 Validate Digital Signatures X

‘E \Drawings\Digital signature.dwg |

No digital signature o o -
View Base Signature(V)

Xref drawings

[ view Xref drawings(X) View Xref Signature(S)

Name Folder Status
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17. BIM Support

17.1. IFCIMPORT

You can enter IFCIMPORT command or click Ribbon » BIM » Open IFC Files to import an IFC file with complete BIM data.

Home Insert Annotation 3D Surface Mesh Layout View Manage Export BIM Application Help Express Collaboration

n
(TE

a»
Open Open Close Update
IFC Files Structure Panel Structure Panel Structure Panel

IFC

File name: [IFC_filet v | Open |+

Files oftype: IFC file(*.ifc) e Cancel

After opening an IFC file, you can select an entity and go to the Properties Panel to its BIM information.
X Bl rence
I+

L] 3D ¥isualization

Material

Geometry

You can also check and manage the entities using Structure Panel, which displays a tree structure of entities based on BIM data.
You can execute operations by clicking buttons on Ribbon # BIM or entering the following commands.

| |
> STRUCTUREPANEL: Open structure panel » TH
>  STRUCTUREPANELCLOSE: Close structure panel Open Close Update

Structure Panel Structure Panel Structure Panel

»  STRUCTUREPANELUPDATE: Update structure panel s
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Structure Panel Menu: Displays the Structure Panel main menu.

BIM: Displays a BIM entity-based structure.

Configure structure tree: Opens the Configure Structure Tree dialog box, which allows you to set the structure tree

configurations.

> Select Configuration...: Allows you to load Structure Tree Configuration Files (*.gst).

|«

o | IR IFC filel

= Building Element Type
] <Building: None =(204)

Structure Panel right-click menu: It is used to manage the entities, you could
complete operations including show, hide, isolate, zoom, expand all, ® - A p—
collapse all and open the configuration panel.

@ Configure structure tree[bim.gst]
File

Show/Skip Options

+ | General

=77 Spatital Element Type

B+ ¢ Filter

= LB Spatital Element Type
B+ Group

‘ BIM Building

; BIM Story
® s BIM Type
B+ Sort

..+ BIM Name
-7 Building Element Type
a + Filter

I BIM Type
-+ Group
‘ + BIM Building
+ BIM Story
BIM Type
BIM Composition
B+ Sort
+ BIM Name
=77 Entities
+ Filter
B+ Group
[ Entity Type
= ¢ Sort
s Entity Name
"7 Nested blocks

< BIM Building Element Type

bim
Configure structure tree
Select Configuration...

I«

o | Il IFCilet
= Building Element Type

= <Bi )

& Hide
Isolate

: Zoom

Expand All
t Collapse All

Joelho 45 secundé
Joelho 90
Joelho 90
Joelho 90
Joelho 90
Joelho 90
Joelho 90
Joelho 90
Joelho 90
T

Configure structure tree: Allows users to define the tree structure of the
Structural Panel.

> File:

Open...: select to open another *.gst configuration file.

Save: saves the current configuration

Save as: saves the current configuration under a different name
> Group/Sort

Add: Adds a new rule or property

- Select an existing rule, then click the Add or right-click and select Add Rule in
the right-click menu.

- The new rule will be added below the selected rule.

- Right-click the new rule and click Rename in the right-click menu and input a
new name.
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- Select the Filter node of the new rule, then click the Add or right-click and select Add filter property.

- Select the Group node of the new rule, then click the Add or right-click and select Add Grouping Property.

- Select the Sort node of the new rule, then click the Add or right-click and select Add sorting property.

- The Select Property dialog box pops up, select a property, then click.

Delete: deletes the selected rule or property.
Move Up: moves the selected rule or property up.

Move Down: moves the selected rule or property down.

Togale negations: filter properties only

> Show/Skip:

You can pick an option and then select the entity types which you want to follow the option you pick.

> Options:

- The drop-down list is to select what happens in the model space when entities are selected in the Structure Tree.

- The checkboxes are to select what happens in the structure tree when an entity is selected/deselected in the model

space. The following options are checked by default: On entity selection, select in tree; On entity selection, expand parent

in tree; Deselect entities on hide.

@ Configure structure tree[bim.gst]
File

(@) Show all entity types

(") Show only selected entity types:

() Skip selected entity types:

[] 2D Polyline

[] 3D Polyline
[JFace

[] 3D solid

[] Miine

[] Radial Dimension
[] Table

[] Table Style

[] Layout

[] Minsert Block

@ Configure structure tree[bim.gst]
File

Selectentities when selected infree
On entity selection, selectin tree

On entity selection, expand parentin tree
[] On entity deselection, collapse infree

Deselect entities on hide

On the basis of IFC Import, you can now export IFC files and import RVT files with complete BIM data, and STEP/IGES module
will be included in LusoCAD installer, you don't need to install it separately.
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17.2.  IFCEXPORT

On the basis of IFCIMPORT, now you can enter IFCEXPORT command or go to Ribbon # BIM » Export IFC files to export

drawings in IFC format with their complete BIM data.

@ Export Data X
Save in: ‘ Drawings & Files “ ‘ G EIE) View ¥
——
== |
__pycache__ AC20-Institute-Var-2.ifc Villa.ifc
File name: |Drawing1 ifc - | Save
Save as fype IFC4(*.ifc) w Cancel
|FC2x3(".ifc)

Besides, there’s also a newly added system variable for handling IFC files in LusoCAD:

System Variable Description

Value

Value Description

Controls the display and hiding of entities
SHOWALLIFCENTITIES in IFC files that are not associated with
building entities.

Hides entities in the IFC drawing that
are not associated with building
entities.

Displays entities in the IFC drawing
that are not associated with building
entities.

17.3.  RVTIMPORT

You can enter RVTIMPORT command or go to Ribbon * BIM 2 Open RVT files to import drawings in RVT format with their

complete BIM data.
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(& select Files X
Look in: | Drawings & Files v| < JE] View ¥
Preview:
l -
[
== |
_pycache_ fo RVTFILETOVE RVT FILEZ.rvt
Find File...
Locate
@ [RVT FILE vt v Open |+
Files oftype: IRevitFiIe(".r\«“L".rfa] ~ I Cancel

17.4.  STEP/IGES Files Support

STEP (Standard for the Exchange of Product Model Data) is an international standard established by the International Organization
for Standardization (ISO) that defines how product information is represented and exchanged throughout the entire product
lifecycle. The file formats include .step, .stp, and .ste.

IGES (The Initial Graphics Exchange Specification) is a general ANSI information exchange standard based on CAD (Computer-
Aided Design) and CAM (Computer-Aided Manufacturing) systems. The file formats include .igs or .iges.

LusoCAD 2025 supports the import of STEP/IGES files, enhancing our platform's capability for 3D model data.

You can go to LusoCAD logo # Open, or LusoCAD logo = Import # Other Formats, and select STEP/IGES in the drop-down
list of Files of types to open or import STEP/IGES files. Besides, you could also simply enter IMPORT, STPIMPORT or
|GSIMPORT command.
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18. Innovative Features

18.1. Line Enhancement

ANGLE (A) option is added for line command, with this option you can get a fast way to draw a line without assistance of the
polar or a xline. You can directly input the angle valug refers to X axis as well as you can take other line as reference to input the
angle value and even you can input the angle value directly refers to previous line.

Practice example:

To draw the red line in Figure 1-1, the steps as below:

1. Execute line command

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]:a

4. Specify angle [Reference] <0>:35(Software will take the X axis as

reference) X Axis Forward Direction
5. Length of line: 500 IRUREsT

To draw the red line in Figure 1-2, the steps as below:
1. Execute line command

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]:a

4, Specify angle [Reference] <0>:r

5. Select a line object: (Please select the reference line)
6. Specify an angle: 38 7. Length of line: 500

To draw the red line in Figure 1-3, the steps as below:

1. Execute line command (to draw the line 1).

2. Specify first point:

3. Specify next point or [Angle/Length/Undo]: |

4. Specify length: 300

5. Specify next point or [Angle/Length/Undo] (to draw the line 2): a —
6. Specify angle [Reference/reference to Previous/Included angle] <0>: p(Here Figure 1-3
you can try reference to Previous option which will take the extension of the

previous line as reference)

7. Specify an angle: 127

8. Length of line: 500

9. Specify next point or [Angle/Length/Closed/Undo]:a (to draw the line 3)

10. Specify angle [Reference/reference to Previous/Included angle] <0>:1(Try Included angle option)
11. Specify an angle: 37

12. Length of line: 400
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Palvliine
Folyiine

v - |
The ANGLE (A) option in polyline command which its behavior is similar as the one in ling ™) Polyline
command is also added in Polyline. There are still three choices for angle option, you can either .
input angle value which takes X Axis as reference as well as you can input “reference to Previous”
angle or “Included angle”. In CAD software, many objects are consisting of Polyline, for example:
rectangle, polygon and revision cloud, donut. Now these functions are classified under the
Polyline drop down list where you can access them quickly. () Potygon

= =
18.2.  Polyline Enhancement g ‘\D ,// o

F] Rectangle

( Rotated Rectangle

Revision Cloud

o Donut

18.3.  Rectangle Enhancement

OBLIQUE(O) is a new added option to draw an rotate rectangle. The behavior of oblique option is similar as the behavior in line
command. With oblique option, you can locate the angel of bottom line and the length to get a rotate rectangle, you can draw
an oblique rectangle which has specific angle with X axis and horizontal or has random angle refer to any line.

Practice example:

To draw the rotate rectangle in Figure 1-4, the steps as below:

1. Execute RECTANG command and input oblique option or click the rotate

rectangle icon in ribbon panel.

2. Specify first point:

3. Specify next point or [Angle]: a(Input Angle option) ]

4. Specify angle [Reference] <0>:20 X Axis Forward Direction
5. Enter rectangle width: 800
6. Enter rectangle height: 350

Figure 1-4

To draw the rotate rectangle when there is a reference line in Figure 1-5, the steps as below:
1. Execute RECTANFG command and input oblique option or click the rotate
rectangle icon in ribbon panel.

2. Specify first point:

3. Specify next point or [Angle]a

4. Specify angle [Reference] <0>:r

5. Select a line object: (Select the reference line)

6. Specify an angle: 20

7. Enter rectangle width: 800 X Axis Forward Direction
8. Enter rectangle height: 350

ne
rence

Figure 1-5
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18.4.  Circle Enhancement

CONCENTRIC(C) option is new added in circle command, you can input radius several times to create many concentric circle
after specify the circle center, with this new option, you can get concentric circle in a simple way.

Practice example:

To draw the concentric circle in Figure 1-6, the steps as below:

1. Execute circle command and input concentric option or click the
concentric icon in ribbon panel.

2. Specify center point for circle:

3. Specify the radius of circle or [Diameter] <400.0000>:100

4. Specify the radius of circle or [Diameter/Undo] <100.0000>:200
5. Specify the radius of circle or [Diameter/Undo] <200.0000>:300

18.5.  Copy Enhancement

R300

Figure 1-6

There are three options: measure (ED , divide (1> , path (P) options are added in copy command, user can easily finish
the drawing without the assistance of other operations such as divided by segment, by distance, array, or layout bypath in

previous version.

1. Measure (E> When users need to copy objects with same distance and same direction, this option will be very useful.

380

80

I

“/ -

"/

[

;,*. g{._ ';ﬁig-

2. Divide (I> You can copy many objects with same distance in a specified distance.

800

P et

B D) B

)

266.67

7
L
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3.Path (P) Atter select the path option, you can select divide or measure option again to locate the count objects.

18.6. Rotate Enhancement

Multiple copy (M) option is added in rotate command, with this option, you can either copy many objects with different rotate

angles, or you can draw circles array.

When rotate, you can select multiple copy option and input several angle values; the software will rotate and copy the object

according to the value you input. You can try copy and rotate 45, 90,135 degree refers to the original object at a time such as

the following figure.

Practice example:

Rotate and copy objects in Figure1-7, the steps as below:

1. Execute the Command: ROTATE

2. Select object:

3. Specify the base point: (Select the center of the concentric)

4. Specify rotation angle or [Copy/Multiple/Reference] <135>:m
5. Specify rotation angle or [Between/Fill]: 45

6. Specify rotation angle or [Exit/Undo]: 90

7. Specify rotation angle or [Exit/Undo]: 135

If the adjacent object angle is fixed, you can select “angle between object
(B> orfillangle (F)> option, then input the angle and the quantity, this
option can replace circle array.

Rotate and copy objects in Figure1-8, the steps as below:

1. Execute the command: ROTATE

2. Select object: (Select the center of the concentric)

3. Specify the base point:

4. Specify rotation angle or [Copy/Multiple/Reference] <30>:m
5. Specify rotation angle or [Between/Fill]: b

6. Specify rotation angle: 60

7. Specify total number of items: 4

Figure 1-8
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Rotate and copy objects in Figure1-9, the steps as below:

1. Execute the command: ROTATE

2. Specify the base point: (Select the center of the concentric)

3. Specify rotation angle or [Copy/Multiple/Reference] <60>:m
4. Specify rotation angle or [Between/Fill]: f

5. Specify angle to fill<360>:

6. Specify total number of items: 1

Figure 1-9

18.7.  Magnifier

MAGNIFIER (a real alternative to change the habit of viewing details and drafting over the most complex drawing at glance).
This tool helps to view a specific area of your drawing as a magnifier with the capability of snap points without performing zoom
in/out on big drawings like map or survey and also is practical to use and customize. Save time on exploring small details of
your drawing or even drafting in a jungle of intersected objects easy and quickly.

1. Before execute MAGNIFIER command, let’s explain its settings. At the status bar there is a magnifier icon, just right click
mouse and select the option > settings. ..

. @ @ @ T

v Uselcon

bData\Local\Temp\Drawingl 1 0561.sv$

@mLGDL"r‘FE:

2. In the Drafting Settings dialog box, under Magnifier tab, we will see several options. Let’s explain one by one.

r@ Drafting Settings (o |
[ Snap and GRid | Poiar Tracking | Object Snap | Dynamic input | Magnifier | Symmet < | »
["] Enable Magnifier by scroll button
Magnifier Style Magrifier Shape
@ Region _) Square
© Window @ Circle
Magnfier Factor:
6
Magnifier Size(Hal-Width):
128 ]
Fade Control:
® {
ok [ cenca Heb
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Enable Magnifier by Scroll button: If you check this option you can enable/disable the magnifier command by clicking the
scroll wheel of the mouse. Also the shortcut key Ctrl+E is available to activate magnifier.

Magnifier Style

ok

Region: When activating the magnifier, it will magnify the spot you select from your drawing within the magnifier shape. The
cursor only can move in the magnifier shape. You can execute zoom, pan, and draw objects, etc to see the bigger and clearer

details.

Window: When activating the magnifier, it will not only magnify the part you select, but also magnify the whole drawing
according to the magnifier factor you set. With window style, the cursor can move in and out of the magnifier shape. The
operations, for example zoom or draw objects will not be restricted in the shape of magnifier.

Magnifier Shape

Square: If you choose square option, the magnifier will adopt a square shape.
Circle: If you choose circle option, the magnifier will adopt a circle shape.

Magnifier Size: You can adjust the magnifier shape size as you like.

Fade Control: You can adjust the fade effect out of the magnifier shape.

Magnifier Factor: You can adjust the zoom factor within the magnifier shape.

18.8. QR Code

A QR code (quick response code) is a type of bar code that is used
to provide easy access to information through a mobile device like
smart phone or tablet. Comparing with barcode, QR Code can
storage more information and is widely applied in many fields, for
example; product anti-fake, advertising push, web links, data
download, commodity transaction, Positioning/navigation,
electronic documents, business card exchange, etc. Take
advantage of QR Code to make text and block attributes from your

drawing scannable using any mobile phone or tablet with a camera.

All you need is one of many available QR code reader applications
for your device. Type QRCODE to execute the command. The
command line mode -QRCODE also is supported, facilitating the
creation of QR codes via scripts or programs.

@ 2D Code Creator

Input Text:

IGENMAI Lda

Already entered: 20/500 Clear data
Pick Object
2D Code Parameters
Text Block QR Code )
Version: 2 e
Preset Data Error Level:| L (7%) ~
Drawing N Date and Ti
[oraving Name Cos me Code: QRCode b
Name: MR | e [ e~
Copy barcode Save Image Exit
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Parameters of QR Code Creator as below:

Input: In input text area, you can input the text directly or you can pick text data from the drawing, also you can select the preset
data which can display automatically in the input text box.

Already entered:0/500: Displays the entered text number and the maximum Input text number.

Clear: Cleans all data displayed at input text area.

Pick Object: You can select three options to picking objects from your drawing.

Text: Picks text from drawing file, the text will display in input text box automatically after you picked up.

Block: Picks the attribute block from the drawing file, add the tag and value to the input text box. It is always used to pick the
information of the tab.

2D Code: Picks the QR Code from the drawing file to get the information of QR Code

Preset Data: You can preset data, when the data is needed just check the corresponding option. The information will
automatically added to the input text area.

Drawing Name: When check Drawing Name option, the drawing name will display in the input text area.

Date and Time: When check Date and Time option, the current date and time will display in the input text area.

Parameters of Costumed Field as below:

Name > Add/Edit: You can customize field that common used, when the field is needed, click the pull down list to find it out
and display it in input text box.

Customed field ﬁ
No: Input the field number. Customed field
Name: Input the field name. No Name Value Add
Value: Input the field value. -
Add: Add new custom field.
Delete: Delete custom field.
Image: Company logo or others marked pictures can
be added to QR Code. You can also browse pictures
from your computer, JP)G\BMP\PNG\TIF\TGA .etc
formats are supported.
Delete: Delete the picture selected. ==

QR Code Parameters: You can set QR Code image parameters before being inserted.

Version: Creates QR Code according to the data you input. Sets the QR Code version, the version
number will adaptively according to the increase of text.

Error Level: Error level for QR Code data generated.

Size: Set the width of QR Code. H (30%)\Q(25%)\M (15%)\L (7%): the compatibility of correcting
about 15% data error.

[=] A [u]
[=]

2D Code Parameters Code: QR Code system. Currently we support Code93.

verson: |2 ~  Scale: Set the QR Code printing scale, behind the scale option is the scale list. You can choose the
o Lo “ scale needed, meanwhile, the scale list can remind user the QR Code generating is related to the
Code: QRCode ~ Lo . , ,

s 1 |~ printing scale. Finally, it will generate as a block, the scale you set can be the block scale to ensure
. E the QR Code can be printed correctly in different printing scales.
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Copy Barcode: Copies an existing QR Code from your current

drawing. [Z] prawing Name [~] Date and Time s
Save Image: Saves the QR Code as a picture, you can either b = Scale: 1 (u1 v
use the picture to print or insert to other document or to CAD e (o] odete | s 65X 65
drawing. [ copybarcode | [ saveimage | [ msert | [ mat |

Insert: Inserts the generated QR Code to the drawing as a block
Cancel: Cancel the dialog box and save the current settings, when you open the dialog box next time, the setting you saved last
time will be displayed.

18.9. Barcode

Barcode technology has been widely used in a variety of industries. In some design companies, barcode has also been used in
drawing management system, mainly used to corresponding paper documents and electronic drawing file, just by scanning the
bar code in the paper drawing to identify quickly the corresponding part in electronic drawing file.

(3 Bar Code Creator *
Bar Code Parameters Preview
width: | 30 a
Height: | 10 =
scale: |1 Y |y o LusoCAD
- Display
Sze: |3 ¢ M Dats Input
Code: Code93 | ] Seed
Pick Zopy barcode Save Image Insert Exit

Parameters of Bar Code Creator as below:

Width: Set the bar code printing width.

Height: Set the bar code printing height.

Scale: Set the barcode printing scale, behind the scale option is the scale list, you can choose the scale needed, meanwhile,
the scale list can remind user the bar code generating is relate to the printing scale. Finally, barcode will generate as a block,
the scale you set can be the block scale to ensure barcode can be printed correctly in different printing scales.

Display Data: Control whether display the data under the bar code.

Size: If “Display data” option is checked means option is activated, you can set the data height.

Code: Bar code system. Currently we support Code93.

Preview: Displays the bar code image and the data input.

Data input box: You can directly input bar code data, also can click seed to generate barcode.

Seed: Generate barcode data by random algorithm. Click the "seed" button, the barcode data will generate randomly and display
directly to the data input box above.

Length: Set the length of the bar code data. There are two ways: one is control the data length which manually input and random
generated. The other is control the data length that random generated, check the "seed" before activate this setting.

Pick: Pick up text or bar code. If you pick the data, it will only obtain the data displayed, but if you pick the barcode, you will get
the information of barcode width, height and proportion and data

Save Image: Save the barcode to BMP format picture, you can either use the picture to print or insert to other document or to
CAD drawing.

232



Chapter 18 Innovative Features

Insert: Define the barcode generated as a block and take left bottom of the barcode as base point. You can insert the barcode to
the drawing file through the insertion point with the scale set before.

Cancel: Cancel the dialog box and save the current settings, when you open the dialog box next time, the setting you saved last
time will display.

18.10.  Symmetric Draw

No matter it is AEC or MFG industry, there are many symmetric drawing shapes. The usual way to make a symmetric shape is to
draw the first half of the shape and then get another symmetric half by copy or mirror.

@ﬁﬁ — 'ﬁ

() Co e )

It is possible to directly draw symmetrical shapes with Symmetric Draw tool. When drawing the first half you get another half
automatically. The default symmetry axis is X-axis, but user can specify Y-axis or any line in the drawing as symmetry axis
reference.

Users can easily switch on/off this tool by clicking the Symmetric Draw button on the status bar. By the way, Symmetric Draw
tool supports all the drawing commands of LusoCAD.
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Exploring Symmetric Draw Properties

Right-Click the Symmetric Draw button at status bar and select Settings option. The Drafting Settings dialog box will pop up.

Now let’s explore the properties under Symmetric Drawing tab.

Enable Symmetric Draw: Enables the symmetric draw tool if is
checked.

Pick Symmetric Axis: You can pick X, Y, or a custom axis to start
working with.

Supported Objects: Symmetric draw tool supports ling, circle,
rectangle, polygon, ray, polyline, ellipse, arc, xline and spline
objects to be drawn as symmetrical shape.

Select All/ Erase All: You can select or unselect all supported

@ Drafting Settings
9 9

Dynamic Input  Guick Properties  Magnifier  Symmetric Draw  Selection Cycling | * |+

[[] Enable Symmetric Draw

Pick Symmetric Axis

(®) X Axis

Supported Object
Line

Circle
[1Rectangle
[1Palygon
[JRay

(Y Axis

Polyline
[ Blipse
ae

[ #ine
[1Spline

() Custom

objects at once.

Enabled

v Uselcon
Data\Local\Temp\Drawingl 1 ¢
Settings...

Select Al

Clear All

Options...

X

Pick Auis

_OK Cancel Help

#H#fhL GOZXZAL g vTQEA L LEEE

Symmetric Axis Effect

X Axis option: The objects drawn will take the X
coordinate system as invisible axis line. The effect of
X Axis is mirroring the drawn objects up or down
according to X coordinate system origin location.

Y Axis option: The objects drawn will take the Y coordinate system as
invisible axis line. The effect of Y Axis is mirroring the drawn objects
right or left side according to Y coordinate system origin location.

= Custom/Pick Axis option: The objects drawn will take the vector
orientation of a selected object as visible axis line. The effect of
Custom/Pick Axis is mirroring the drawn objects according to a
selected object vector orientation whether inclined, vertical or
horizontal.
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Pick Symmetric Axis: At status bar, besides ] \,—

Symmetric Draw button is located another button Tl o o - Pl __{_
called Pick Symmetric Axis. The functionality of this <

button is as same as Custom and Pick Axis options. X

1 '\ Model (Layoutl {Layout2 /

3, 274.9903, 0.0000

18.11.  Outline Objects

OUTLINE command is another 1:[ Hotih
innovative tool of LusoCAD. This tool

allows extract the outline shape of ,
selected closed objects in a window ]:] Biase
selection method. This outlined
shape is in fact a polyline object
created on the current layer that you

are working with. @ Outline

B\ Mode! (oyoutl Z Cayout? J

For example, use this tool extract the outline shape of a floor plant house to later calculate its total area or to reference draw the
roof of it.

Remark: Other innovative features, such as Break Object, Block Break, Graphic Compare, Pline Boolean, Align tool, Arrange
Tool, AutoXLSTable, CAD Table to Excel, Text Incremental Copy, Statistics Summation, Text on line, LusoCAD Tools, Drawing
Compare, Drawing Lock, Batch Purge, etc. Please refer to the express tool guide.

18.12.  Area Table

The enclosed area and object can be marked number or
area, and the area table can be generated at the same time.
The area data can be exported to a text or table file. The N i — — o
values in the table can be changed automatically when the }{'-’\\ m;m, s | IW -
number or area size is changed. a

Steps to use Area Table

1. Click “Express Tools” > “Area Table” in tumn.

2. Popup "Area Table" dialog box.

3. Click “Pick Point” or “Select Obj” to mark area.

4. Ifthe you checked "Generate Table", you need to determine the table location or the table to be added.

5. Click the available point coordinate to go directly to the next process. Or select the available existing area table to enter
the next process.

6.  After the table is created or selected, the area can be updated automatically by “Pick Point” or “Select Obj”.
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18.13.  Automatically Layer

Predefines the association between object
type and the layer that should be drawn in o *
a drawing. System automatically switches
the current layer while drawing the graph,

and draws the graphic to the set layer. If - |

the specified layer does not exist, the
system will automatically create this layer
based on the settings. !

g

-] 3

About Automatically layer dialog box:

Autolayer list: Display the command name and the corresponding automatic layer settings.

nnnnnnn

Create a layer setting: Create a new layer settings including the command name and the corresponding layer settings.

Delete layer setting: Delete one or more selected automatic layer settings.

Enable Autolayer: After checking this check box, the software can automatically assign the layer based on the settings when

drawing, if not checked, it doesn’t work.
Save Settings: Save your current settings to a text file.

Load Seftings: Read the settings file saved by the user and read the settings into the dialog box.

Clear Settings: Clear all current auto layer settings.

Remark: the current settings only work for the currently edited drawing.

18.14.  Attribute Increment

Attribute Increment can sort and increment the
attribute value of the attribute block of the
same name according to the way you set. The

property value of the attribute block is —_—
modified based on the sort value. For example, - ——
the attribute value of the axis number is ‘ ’

S Owsmnasa

[ -

incremented by the way it is set. 0 Ll el

T

About Attribute Increment dialog box

Auto Increa: All referenced properties of the selected block are automatically incremented, which is copied, inserted, deleted in
the graph, and the attribute number is automatically updated. When "ATTING" is on, as long as the drawing is not closed, when
copying, inserting and deleting the block in the drawing, the property number can be updated automatically.

Increase the select: Only the selected block is processed, and the selected block property is incremented by the order of

creation.
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Select a block:

Click “Select the block” button, and you can pick up a block from the graphics and acquire the name of the block. If there is no
attribute in the block you picked up, then prompt: The selected block has no attributes. And you need to pick up again.

Block: Select a block in block list. If there is no attribute in the block you picked up, then prompt: The selected block has no
attributes. And you need to select again.

Select the attribute to increase;

Select the tags to increase. If the block only has one attribute, then the only attribute will be selected automatically. But if the
block has more than one attribute, then all the attributes will be displayed and you can select one or more attributes to increase.
Parameter:

Increment: The attribute value of the selected block is increased by the increment value.

Add ration: Add the same increment value to the increment number or letter of the attribute value in attribute block.

Increment Mode:

Here are 3 increment modes: Increase every number, Increase the last number and Increase the first number.

Default option is Increase the last number. If there are numbers in the end, these numbers increase as a whole. If you select
Increase the first number, and here are numbers in the first, they also increase as a whole. If you select Increase every number,
gach number in the attribute value is incremented.

Increment Number: The default number is “1”, and you can modify it if needed.

Sort;

Set the sort of increment as the followings: Draw Order, Select Order, Left to Right, Up to Down and The Path of Curve. The
default sort is Draw Order, you can select other sorts.

If you select The Path of Curve, system will prompt you to select a curve. the curve can be a curve or a polyline which intersects
with the selected block, and sort according to the order of the point which is closest to the insertion point of each attribute
block on the curve. If all the points are as the same point, then according to the distance between each insertion point of
attribute block and the curve to sort.

Negative Sequence:

Reverse the order above.

18.15.  Viewport from Model

Creates a viewport on layout space by selecting objects in the model space. And then calculate the viewport size according to
the set ratio and locate the viewport in the layout space. You can quickly create and set a viewport of the graphics.

237



Chapter 18 Innovative Features

Steps to use Viewport from Model:
1. In 2D Drafting space. Click “View” > “Layout Viewport” in turn.

2. Specify the first comer point and the diagonal point.

Extents: Obtain the value of the system variables of EXTMIN and EXTMAX in the model space. When EXTMIN and EXTMAX are
the same or wrong, the "Extents" option is not displayed.

Display: Plot the scope displayed in the Model space currently.

Limits: Obtain the value of the system variables of LIMMIN and LIMMAX in the model space.

When an error scope is obtained, the viewport is not created and shows that "The scope for creating the viewport failed."

3. Please select the layout to create

After you select the scope, the system will prompts you to select the layout to create.

- If the command is executed in the Layout space, the viewport is created directly in the layout space of the command.
- If the command is executed in the Model space, the dialog box pops up for you to select the layout.

4. Specify the insertion point to viewport

- After setting the layout, automatically switch to the selected layout and specify the insertion point of the viewport.
- You can enter coordinates or click a point to set the location of the viewport in a graphical window.

- After setting the location, the computed viewport is generated at the specified location, and the display locked of the viewport
is on.

18.16.  Free Scale

FREESCALE command allows you to scales an object or a group of objects without restrictions under three methods; Non-Uniform,

Rectangle and Free.

Non-uniform scale: The scale of X and Y axis can be input separately.lu
Rect Scale: You can scale a graphic to match a rectangle frame. The rectangle does not need to be drawn, just specify two
diagonal points.
Free Scale: You can move or copy and scale the graphics in a closed quadrilateral frame to another closed quadrilateral frame,
which can be used to generate the pattern of tilting or perspective distortion graphics.

Learn more innovative features from: https://luso-cad.com
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